Avant toute chose merci de (re)prendre connaissance de la charte et de la respecter.
Pour résumer :
- Avant de poser une question, je cherche si la réponse existe
- Je suis poli, courtois et je respecte tout un chacun sur le forum
- Si un post m'agace : je m'en éloigne plutôt que de répondre d'une façon qui pourrait être mal interprétée


Il n'est jamais du luxe que de rappeler des choses simples :
Courtoisie, amabilité, politesse et bonne humeur sont les maîtres mots pour un forum sympathique, bienveillant et accueillant :)

Toute la communauté vous remercie

disparition historique

De l'installation à l'utilisation venez discuter de JEEDOM au quotidien
Répondre
JC Gayon
Timide
Messages : 10
Inscription : 12 janv. 2017, 20:39
Localisation : Poitiers

disparition historique

Message par JC Gayon » 11 juin 2019, 11:52

Bonjour - J'ai un problème d'instabilité de courbes dans l'historique, depuis le passage en 3.3.17 de JEEDOM. Je dois , de temps en temps faire des correction de points sur certaines courbes d'historiques. Jusqu'en V3.2.16 aucun Pb je clique sur le point, je rentre la nouvelle valeur , la courbe se remet à jour et tout est normal. Depuis la V3.3.17, je fais la même chose, mais la courbe corrigée s'affiche quelques secondes, puis disparaît et on voit l'échelle de valeur (axe des Y) se modifier toute seule plusieurs fois, sans affichage du graphique. Si je quitte l'historique et que j'y ré-entre, la courbe s'affiche correctement un temps variable (entre quelques secondes et 1 à 2 minutes) puis disparaît. Ce phénomène ne se produit que sur les courbes qui ont été modifiées. Quelqu'un a-t-il déjà eu ce problème et existe-t-il une solution?

Avatar de l’utilisateur
PrFalKeN
Actif
Messages : 839
Inscription : 27 nov. 2017, 18:51

Re: disparition historique

Message par PrFalKeN » 11 juin 2019, 14:17

'Jour,

Mettre à jour en 3.3.25 déjà, peut être qu'il y a eu des bugs de fixé depuis la 3.3.17...
@+
W.O.P.R

JC Gayon
Timide
Messages : 10
Inscription : 12 janv. 2017, 20:39
Localisation : Poitiers

Re: disparition historique

Message par JC Gayon » 13 juin 2019, 22:56

Merci, mais je suis déjà en 3.3.25.... J'ai remarqué que les courbes problématiques avaient plusieurs décimales. J'ai limité à 3 décimales dans la formule de calcul de la configuration des commandes, mais l'affichage (quand j'arrive à le capter) m'en donne 10. Peut-être est-ce une piste. Autre question ou peut-on trouver les fichiers de l'historique (mon équipement est un JEEDOUINO avec un ESP 8266 avec une entrée compteur).
Merci d'avance pour la réponse

Avatar de l’utilisateur
PrFalKeN
Actif
Messages : 839
Inscription : 27 nov. 2017, 18:51

Re: disparition historique

Message par PrFalKeN » 14 juin 2019, 09:48

Ben désolé mais quand on lit depuis le passage en 3.3.17 on devine difficilement que tu es en 3.3.25 !

C'est vrai que la précision pour la résolution de problème n'aide pas ...
@+
W.O.P.R

JC Gayon
Timide
Messages : 10
Inscription : 12 janv. 2017, 20:39
Localisation : Poitiers

Re: disparition historique

Message par JC Gayon » 14 juin 2019, 10:33

Saurais-tu ou JEEDOM range les fichiers d'historique?
J'ai essayé de regarder en SSH dans le Raspberry Pi , mais pas facile à trouver !

JC Gayon
Timide
Messages : 10
Inscription : 12 janv. 2017, 20:39
Localisation : Poitiers

Re: disparition historique

Message par JC Gayon » 14 juin 2019, 10:41

Petite précision, quand je dis "depuis le passage en 3.3.17", cela veut dire que cela ne se passait pas avant. Toutes les corrections de courbes donnaient des affichages stables. C'est depuis cette mise à jour que le problème est apparu. Ce qui m'étonne c'est, certes la disparition des courbes, mais la modification cyclique de l'échelle sans affichage... On pourrait croire qu'il y a une routine automatique de mise à l'échelle qui s'active ! ! !

JC Gayon
Timide
Messages : 10
Inscription : 12 janv. 2017, 20:39
Localisation : Poitiers

Re: disparition historique

Message par JC Gayon » 17 juin 2019, 11:24

J'ai comme un sentiment de solitude ! Suis-je le seul à avoir ce problème d'utilisation ?
J'ai trouver une solution partielle. Quand la courbe disparait, je coche la case escalier, ce qui fait ré-apparaitre la courbes pour quelques secondes, puis je dé-coche cette même case et la courbe ré-apparait pour un peu plus longtemps. Pour information, seules les courbes qui on reçu des corrections ont ce problème de disparition.

JC Gayon
Timide
Messages : 10
Inscription : 12 janv. 2017, 20:39
Localisation : Poitiers

Re: disparition historique

Message par JC Gayon » 26 juin 2019, 11:01

Depuis hier, une courbe n'ayant jamais eu de correction est affublée de ce problème de disparition. Quelqu'un a-t-il une idée ?

Avatar de l’utilisateur
Fabrice
Actif
Messages : 3058
Inscription : 27 oct. 2016, 22:26
Localisation : Planète terre, IDF, 93

Re: disparition historique

Message par Fabrice » 26 juin 2019, 11:10

L'historique des commandes est placé en base de données, ce ne sont pas des fichiers plats visibles en SSH.
- La table de la base en question port un nom bien explicite.
Usage recommandé uniquement pour ceux qui savent manipuler les bases de données.

Récemment, j'ai eu une commande qui ne voulais plus s'historiser, j'ai vidé la table et tout est repartie en ordre de marche. Mais je l'ai fait en connaissance de cause (perte de 100% des historiques).
Raspberry PI 3 B+ : Jeedom 3.3.27 + 21 plugins
Z-Wave : AEOTEC AEOEZW090-C
RFXCom : RFXtrx433E (FW 1025)
BLEA : Sena UD100-G03 (ant. 8db) & Raspberry PI Zero W + Sena UD100-G03 (ant. 12db)

JC Gayon
Timide
Messages : 10
Inscription : 12 janv. 2017, 20:39
Localisation : Poitiers

Re: disparition historique

Message par JC Gayon » 26 juin 2019, 11:29

Merci pour l'info.
Mon idée de base était de rechercher le fichier historique qui contient mes relevées de conso élect d'ECS et de modifier le nombre de décimales pour revenir à 3... car je crois qu'il y a une influence entre le nombre de décimale "demandée" dans les réglages et le nombre de décimales réellement affichées ... mais peut être que je me trompe ! ! ! !

Niko51
Timide
Messages : 1
Inscription : 27 juin 2019, 11:02

Re: disparition historique

Message par Niko51 » 27 juin 2019, 11:12

Bonjour

Je rencontre le même problème (Jeedom v 3.3.26 sur Raspberry Pi3), la courbe disparait après quelques secondes, mais j'ai remarqué qu'en survolant le graphique, les données s"affichent dans la bulle d'aide (voir PJ)

Bonne journee
Pièces jointes
Jeedom Screenshot 20190627.jpg
Jeedom Screenshot 20190627.jpg (137.53 Kio) Consulté 175 fois

Avatar de l’utilisateur
Fabrice
Actif
Messages : 3058
Inscription : 27 oct. 2016, 22:26
Localisation : Planète terre, IDF, 93

Re: disparition historique

Message par Fabrice » 27 juin 2019, 13:34

Bonjour,

Videz les caches de votre navigateur et testez de nouveau.
N'hésitez pas non plus à faire un CTRL + F5 avant d'aller dans cette page.
Puis, testez avec 1 seul équipement (1 à 1).
Raspberry PI 3 B+ : Jeedom 3.3.27 + 21 plugins
Z-Wave : AEOTEC AEOEZW090-C
RFXCom : RFXtrx433E (FW 1025)
BLEA : Sena UD100-G03 (ant. 8db) & Raspberry PI Zero W + Sena UD100-G03 (ant. 12db)

jc-59
Timide
Messages : 28
Inscription : 11 oct. 2017, 15:38

Re: disparition historique

Message par jc-59 » 02 juil. 2019, 13:31

Bonjour,

Sur Firefox
Même symptôme, mais sur toutes les courbes (quelque soit l'équipement)
Pas d'amélioration après le nettoyage du cache

Sur IE
Même symptôme, mais sur toutes les courbes (quelque soit l'équipement)
Pas d'amélioration après le nettoyage du cache

Sur chrome:
La courbe est visible mais est "rognée" tout doucement sur la gauche, je m'explique au début de l'affichage est de 22h00 à 13h30
puis 5 secondes plus tard l'affichage est entre 23h00 et 13h30
puis 5 secondes plus tard l'affichage est entre 00h00 et 13h30
puis 5 secondes plus tard l'affichage est entre 01h00 et 13h30
puis 5 secondes plus tard l'affichage est entre 02h00 et 13h30
puis 5 secondes plus tard l'affichage est entre 03h00 et 13h30
puis 5 secondes plus tard l'affichage est entre 04h00 et 13h30
puis 5 secondes plus tard l'affichage est entre 04h05 et 13h30 ... et oui le rognage devient moins visible ...
puis 5 secondes plus tard l'affichage est entre 04h10 et 13h30
...

Si je clique sur "Zoom Tous" ... rien ne change je ne reviens pas à la plage complète

Avatar de l’utilisateur
Nibb31
Actif
Messages : 2155
Inscription : 17 févr. 2015, 15:29

Re: disparition historique

Message par Nibb31 » 02 juil. 2019, 14:42

J'ai le même problème. J'utilise exclusivement Firefox. Certaines courbes s'effacent au bout de quelques secondes. Pour ma part, ce sont des températures arrondies à 0,1°C
Jeedom: VM ProxMox sur serveur i7-2760QM, RAM 8Go
Zwave + RFXCom433E + Hue

JC Gayon
Timide
Messages : 10
Inscription : 12 janv. 2017, 20:39
Localisation : Poitiers

Re: disparition historique

Message par JC Gayon » 05 juil. 2019, 10:40

OUI, c'est exactement ce que j'ai. Quand j'affiche 3 courbes, il y en a une qui disparaît, ou 2, ou les 3. La durée d'affichage est variable. Cela se produit quelque soit le navigateur. Si je laisse le problème évoluer (quelques minutes) l'échelle de droite change toute seule toutes les 4 secondes environ en augmentant indéfiniment, mais sans affichage. Le problème s'arrête si je quitte la courbe et que je la reprends... puis ça recommence. Pour mémoire cela ne se passe que dans la fonction historique (menu Analyse - Historique) cela ne se produit pas sur le Dashboard quand on clique sur une valeur affichée. On obtient une seule courbe parfaitement stable.

Un gros merci à ceux qui remontent ce genre de problème, car je commençais à me sentir seul ! ! ! et un énorme merci à celui qui trouvera la solution (pour mémoire le passage en V 3.3.17 n'a rien changé)

Avatar de l’utilisateur
loic
Administrateur
Messages : 13459
Inscription : 01 févr. 2014, 16:21

Re: disparition historique

Message par loic » 05 juil. 2019, 11:28

Bonjour,
Le soucis est connu c'est la mise a jour en temps réel qui fait disparaitre la courbe, par contre avec chrome il ne semble pas avoir de soucis. La prochaine version stable 3.3.28 mettra a jour la lib de graph ça corrigera peut etre
Aide nous à t'aider : mets des logs, détaille ton soucis... Vous n'aurez aucune réponse de ma part si votre demande n'est pas détaillée (log, capture d'écran lisible...) ou si vous ne postez pas dans la bonne section

JC Gayon
Timide
Messages : 10
Inscription : 12 janv. 2017, 20:39
Localisation : Poitiers

Re: disparition historique

Message par JC Gayon » 06 juil. 2019, 11:23

Merci pour cette info. Le problème n'est pas "insupportable" car il y a un moyen de travailler quand même (en sortant de l'historique est en y retournant). Mais c'est plus confortable d'avoir une courbe qui reste en place.

Répondre

Revenir vers « Utilisation »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 4 invités