Ce Forum passera en lecture seule en janvier 2020
Image
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

MySQL Buster

De l'installation à l'utilisation venez discuter de JEEDOM au quotidien
Taldwin
Timide
Messages : 3
Inscription : 03 oct. 2019, 19:52

MySQL Buster

Message par Taldwin » 03 oct. 2019, 20:57

Bonjour,

Tout nouveau ici, je viens m'adresser à la communauté concernant un bug à l'installation qui m'a prit 2 journées déjà.

J'ai déjà utilisé le bouton rechercher :D et ce sujet viewtopic.php?f=152&t=46112&hilit=mysql dans la section raspberry est similaire mais ne réponds pas à mes interrogations.

J'ai téléchargé Debian 10 Buster dans le but de l'installer sur mon précédent PC.
Ce tuto m'a guidé dans l'installation : https://makerhelp.fr/installer-jeedom-sur-debian/

L'installation s'est presque bien passée pour Debian, mais je rencontre un soucis à l'étape 3 de l'installation de Jeedom. Vous trouverez ci-dessou le log d'erreur :
Aucune version du paquet mysql-server n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source
Cependant les paquets suivants le remplacent :
mariadb-server-10.0

E: Le paquet « mysql-client » n'a pas de version susceptible d'être installée
E: Le paquet « mysql-server » n'a pas de version susceptible d'être installée
Ne peut installer mysql-client mysql-common mysql-server - Annulation
La doc officielle traite de Debian 9 mais pas de 10. Pour d'autre l'installation se déroule sans soucis.
Que me conseillez vous? Réinstaller debian 10 à 0? Télécharger Debian 9? ou existe-t-il une technique pour forcer l'installation de Mysql?

Merci à tous

Avatar de l’utilisateur
Poumi
Actif
Messages : 660
Inscription : 21 mars 2019, 22:41

Re: MySQL Buster

Message par Poumi » 03 oct. 2019, 21:03

Si tu suis l’installation de la doc officielle, ça marchera aussi sur buster.
Par contre tous les plugins ne sont pas encore compatibles (c’est pour ça que la version officiellement supportée est stretch)

Tous les plugins officiels sont normalement compatibles.
Pour les autres, ça dépend:
-certains sont compatibles
-certains uniquement sur la version bêta
-et d’autres pas du tout, il faudra attendre que le développeur du plugin le mette à jour.

Sachant ça, c’est à toi de choisir si tu met buster ou stretch.

Taldwin
Timide
Messages : 3
Inscription : 03 oct. 2019, 19:52

Re: MySQL Buster

Message par Taldwin » 05 oct. 2019, 10:55

Bon j'ai réussi à trouver une solution pour valider l'étape 3. Voici ma démarche pour ceux qui sont dans le même cas :

Dés que j'ai eu le bug j'ai décidé de supprimer mysql-common avec la commande :

Code : Tout sélectionner

apt-get purge mysql-common
puis

Code : Tout sélectionner

apt autoremove mysql*
comme cela je repars de zéro avec mysql. Maintenant il faut le réinstaller :

Code : Tout sélectionner

wget https://dev.mysql.com/get/mysql-apt-config_0.8.13-1_all.deb
dpkg -i mysql-apt-config_0.8.13-1_all.deb
puis suivre l'installation
Image
une fois cet écran là ça a buggouillé un peu mais dés que j'ai eu accès à la ligne de commande j'ai tapé :

Code : Tout sélectionner

apt update
apt install mysql-server
et a la fin de l'installation :

Code : Tout sélectionner

systemctl status mysql
je n'ai pas été plus loin car je me suis dit que Jeedom reprendrai la main sur la suite et effectivement c'est passé!

Si cela vous a été utile n'hésitez pas à faire un retour à la communauté

Bon maintenant je bloque à l'étape 5 xD

Répondre

Revenir vers « Utilisation »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 2 invités