Ce Forum passera en lecture seule en janvier 2020
Image
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

Problème installation des dépendances

Retrouvez ici des sujets concernant le protocole Z-Wave et les modules domotiques de type Z-Wave utilisés avec JEEDOM
camusyan
Timide
Messages : 10
Inscription : 30 juin 2019, 13:20

Problème installation des dépendances

Message par camusyan » 30 juin 2019, 13:45

Bonjour,

J'ai installé Jeedom 3.3.26 sur mon raspberry Pi3.
J'ai acheté une clef USB Zwave ZME_UZB1

J'ai installé la version stable du plugin Z-wave depuis le market.
Le statut des dépendances étant à NOK, j'ai cliqué sur le bouton Relancer pour lancer l'installation des dépendances.
Malheureusement, l'installation se termine systématiquement en échec.

Voici les dernières lignes du fichier openzwave_update :

Code : Tout sélectionner

Building Manager.o
Building Msg.o
Building Notification.o
/bin/sh: 1: Syntax error: ")" unexpected
Creating vers.cpp
Building vers.o
/opt/python-openzwave/openzwave/cpp/src/vers.cpp:4:30: error: expected primary-expression before ';' token
 uint16_t ozw_vers_revision = ;
                              ^
/opt/python-openzwave/openzwave/cpp/build/support.mk:130: recipe for target '/opt/python-openzwave/openzwave/.lib/vers.o' failed
make[2]: *** [/opt/python-openzwave/openzwave/.lib/vers.o] Error 1
make[2]: Leaving directory '/opt/python-openzwave/openzwave/cpp/build'
Makefile:20: recipe for target 'all' failed
make[1]: *** [all] Error 2
make[1]: Leaving directory '/opt/python-openzwave/openzwave'
Makefile:272: recipe for target 'openzwave/.lib/' failed
make: *** [openzwave/.lib/] Error 2
sed: can't read /etc/inittab: No such file or directory
Raspberry Pi 3 Detected. If you use a Razberry board you must Disabling Bluetooth
Please add 'dtoverlay=pi3-miniuart-bt' to the end of the file /boot/config.txt
And reboot your Raspberry Pi
Everything is successfully installed!
La version complète du fichier de log est attaché à ce post.

Après lecture de plusieurs posts de personnes qui ont été confrontées à des problèmes d'install des dépendances, je précise que j'ai déjà tenté sans succès les opérations suivantes :

Code : Tout sélectionner

sudo apt-get update
sudo apt-get upgrade
sudo python -m pip install --upgrade pip
sudo pip install --upgrade setuptools
sudo shutdown -r now
Autre remarque, la réinstallation des dépendances se relance automatiquement toutes les 10 minutes mais avec exactement le même résultat final. J'ai donc désactivé le plugin Z-wave pour l'instant.

Je ne suis pourtant pas un débutant en Linux mais là je suis sec... Si quelqu'un a une idée à proposer, je suis preneur.

Merci d'avance pour votre aide,

Yann
Pièces jointes
openzwave_update.log
(13.89 Kio) Téléchargé 15 fois

Rvitch
Actif
Messages : 674
Inscription : 21 juin 2016, 10:31

Re: Problème installation des dépendances

Message par Rvitch » 30 juin 2019, 13:54

Déjà :

Code : Tout sélectionner

Razberry board you must Disabling Bluetooth
Please add 'dtoverlay=pi3-miniuart-bt' to the end of the file /boot/config.txt
Tu peux essayer de faire ce que ton log dit.


Envoyé de mon Mi 9 SE en utilisant Tapatalk


camusyan
Timide
Messages : 10
Inscription : 30 juin 2019, 13:20

Re: Problème installation des dépendances

Message par camusyan » 30 juin 2019, 14:25

Merci pour ta réponse rapide Rvitch mais le problème semble être lié à un problème de compilation qui intervient avant ce message.
Dans le doute, j'ai quand même suivi ton conseil et celui du log ;) . J'ai donc ajouté cette ligne dans le /boot/config.txt, rebooté le Pi et relancé l'install des dépendances mais le résultat est malheureusement le même...

Je joins le dernier fichier de log openzwave_update.
Pièces jointes
openzwave_update.log
(18.62 Kio) Téléchargé 14 fois

Mips2648
Actif
Messages : 932
Inscription : 08 sept. 2018, 17:09

Re: Problème installation des dépendances

Message par Mips2648 » 30 juin 2019, 17:24

Rvitch a écrit :
30 juin 2019, 13:54
Déjà :

Code : Tout sélectionner

Razberry board you must Disabling Bluetooth
Please add 'dtoverlay=pi3-miniuart-bt' to the end of the file /boot/config.txt
Tu peux essayer de faire ce que ton log dit.


Envoyé de mon Mi 9 SE en utilisant Tapatalk
Ce n'est applicable et nécessaire que s'il y a une carte raZberry (avec un Z) qui est une carte zwave pour le raspberry. Par un d'ongle usb donc.

Il n'est pas nécessaire de désactiver le Bluetooth dans d'autres circonstances 😉
Développeur et auteur des plugins suivants, (entre autre Arlo, Solaredge, Design Image, Gotify...) et aidant sur plein d'autres!

Si vous voulez contribuer, un don fait toujours plaisir : https://paypal.me/mips2648

camusyan
Timide
Messages : 10
Inscription : 30 juin 2019, 13:20

Re: Problème installation des dépendances

Message par camusyan » 30 juin 2019, 17:28

Merci Mips2648 pour la précision ;)
Je vais donc pouvoir réactiver mon bluetooth et continuer à chercher une solution à mon problème...

Naboleo
Actif
Messages : 746
Inscription : 20 janv. 2017, 09:57

Re: Problème installation des dépendances

Message par Naboleo » 30 juin 2019, 17:49

camusyan a écrit :
30 juin 2019, 13:45

Merci d'avance pour votre aide,

Yann

A priori c'est le plugin qui n'est pas vraiment propre

Code : Tout sélectionner

Building vers.o
[b]/opt/python-openzwave/openzwave/cpp/src/vers.cpp:4:30: error: expected primary-expression before ‘;’ token[/b]
 uint16_t ozw_vers_revision = ;
Donc la meilleure solution c'est de passer au moins temporairement sur la version beta qui elle se compile bien.

tu peux essayer aussi de faire compléter la mise à jour complète du pi
  • sudo apt-get -y dist-upgrade
    sudo apt-get -y auto-clean
    sudo apt-get -y autoremove
Pi4/4Go +SSD 32Go (Wifi et bluetooth actifs) + Clé USB Z-Wave Everspring + rfxcom (RTS) + Google Home
7 Danfoss LC-13
2 velux module DIO
7 volets RTS
3 Sonoff
IFTTT
Capteur porte, de présence, et prise intelligente...

camusyan
Timide
Messages : 10
Inscription : 30 juin 2019, 13:20

Re: Problème installation des dépendances

Message par camusyan » 30 juin 2019, 22:22

Tu as raison Naboleo, il y a clairement un problème avec ce fichier vers.cpp.
Après vérification, son contenu est corrompu. Le problème est que ce fichier est généré pendant l'installation et à chaque fois avec la même corruption.

Du coup, j'ai trouvé une autre solution. J'ai installé moi même libopenzwave et python-openzwave en clonant le repo git et en lançant l'installation à la main. Dans les grandes lignes, voilà ce que ca donne :

Code : Tout sélectionner

cd /opt
git clone https://github.com/OpenZWave/open-zwave.git
git clone https://github.com/OpenZWave/python-openzwave.git
cd /opt/open-zwave
make all
make install
cd /opt/python-openzwave
vi Makefile
Dans le Makefile, il faut chercher la target install-lib et remplacer --flavor=git par --flavor=shared de façon à ce que python-openzwave utilise la librairie openzwave qu'on vient de compiler et d'installer plutôt que d'en recompiler une.

Voilà ce que ca donne avant :

Code : Tout sélectionner

install-lib:
	${PYTHON_EXEC} setup-lib.py install --flavor=git
et après modification

Code : Tout sélectionner

install-lib:
	${PYTHON_EXEC} setup-lib.py install --flavor=shared
Reste plus qu'à lancer la compile :

Code : Tout sélectionner

make build
make install
Verifier que libopenzwave.so est bien détectée par ldconfig :

Code : Tout sélectionner

ldconfig -v
...
/usr/local/lib:
	libopenzwave.so.1.6 -> libopenzwave.so.1.6
...
si ce n'est pas le cas, il faut ajouter /usr/local/lib au fichier /etc/ld.so.conf et relancer ldconfig

Il ne reste plus qu'à réactiver le module zwave et miracle les dépendances sont OK ainsi que le démon.

Il y a peut être un moyen plus simple de résoudre ce problème mais celui là a le mérite de marcher même si il est assez long car la complie des 2 repos git prend un certain temps sur le pi...

Yann

MaximePrince-67
Timide
Messages : 4
Inscription : 15 févr. 2017, 15:28
Contact :

Re: Problème installation des dépendances

Message par MaximePrince-67 » 05 juil. 2019, 17:54

Je confirme qu'il y a effectivement un problème sur l'installation des dépendances par le plugin, et ce quelque soit le support.

En revanche, en prenant ce qui à été donné précédemment, ça fonctionne, enfin presque.

Dans mon cas, j'ai du laisser le Makefile comme il était au départ.

Ensuite, j'ai dû lancer ces deux commandes afin de satisfaire les dépendances Python :

setuptools :

Code : Tout sélectionner

pip install setuptools
pip3 install setuptools
Cython :

Code : Tout sélectionner

pip install cython
pip3 install cython
Etant sur une installation custom basée sur Debian, j'ai également du lancer cette commande pour installer les dépendances :

Code : Tout sélectionner

apt-get install libudev-dev
En espérant que le plugin soit corrigé,
Bonne journée,
MaximePrince-67

benoit.rigoult
Timide
Messages : 5
Inscription : 10 juil. 2019, 20:31

Re: Problème installation des dépendances

Message par benoit.rigoult » 10 juil. 2019, 20:34

Bonjour à tous,

Suite a une fresh install sur un NAS Synology avec une debian 10 j'ai aussi des problèmes pour les dépendances...

Si qqn peut m'aider ???

Code : Tout sélectionner

Lancement de l'installation/mise à jour des dépendances openzwave
Atteint :1 http://security.debian.org/debian-security buster/updates InRelease
Atteint :2 http://ftp.fr.debian.org/debian buster InRelease
Atteint :3 http://ftp.fr.debian.org/debian buster-updates InRelease
Lecture des listes de paquets…

Installation des dependances
Lecture des listes de paquets…
Construction de l'arbre des dépendances…
Lecture des informations d'état…
build-essential est déjà la version la plus récente (12.6).
g++ est déjà la version la plus récente (4:8.3.0-1).
gcc est déjà la version la plus récente (4:8.3.0-1).
git est déjà la version la plus récente (1:2.20.1-2).
libjpeg-dev est déjà la version la plus récente (1:1.5.2-2).
python-louie est déjà la version la plus récente (1.1-4).
python-lxml est déjà la version la plus récente (4.3.2-1).
make est déjà la version la plus récente (4.2.1-1.2).
python-serial est déjà la version la plus récente (3.4-4).
python-dev est déjà la version la plus récente (2.7.16-1).
python-pip est déjà la version la plus récente (18.1-5).
python-setuptools est déjà la version la plus récente (40.8.0-1).
python-pyudev est déjà la version la plus récente (0.21.0-1).
python-requests est déjà la version la plus récente (2.21.0-1).
libudev-dev est déjà la version la plus récente (241-5).
unzip est déjà la version la plus récente (6.0-23).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Installation des dependances Python
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.
Requirement already satisfied: urwid in /usr/local/lib/python2.7/dist-packages (2.0.1)
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.
Requirement already satisfied: louie in /usr/lib/python2.7/dist-packages (1.1)
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.
Requirement already satisfied: six in /usr/lib/python2.7/dist-packages (1.12.0)
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.
Requirement already satisfied: tornado in /usr/local/lib/python2.7/dist-packages (5.1.1)
Requirement already satisfied: backports-abc>=0.4 in /usr/local/lib/python2.7/dist-packages (from tornado) (0.5)
Requirement already satisfied: singledispatch in /usr/local/lib/python2.7/dist-packages (from tornado) (3.4.0.3)
Requirement already satisfied: futures in /usr/local/lib/python2.7/dist-packages (from tornado) (3.2.0)
Requirement already satisfied: six in /usr/lib/python2.7/dist-packages (from singledispatch->tornado) (1.12.0)
mkdir: impossible de créer le répertoire « /opt »: Le fichier existe
Désinstallation de la version précédente
Installation de Python-OpenZwave
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.
ERROR: Cannot uninstall 'Cython'. It is a distutils installed project and thus we cannot accurately determine which files belong to it which would lead to only a partial uninstall.
apt-get install --force-yes -y cython
Lecture des listes de paquets…
Construction de l'arbre des dépendances…
Lecture des informations d'état…
cython est déjà la version la plus récente (0.29.2-2).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
W: --force-yes est obsolète, veuillez plutôt utiliser l'une des options commençant par --allow.
Installing dependencies for python : 2 7 16
apt-get install --force-yes -y python-pip python-dev python-docutils python-setuptools python-louie
Lecture des listes de paquets…
Construction de l'arbre des dépendances…
Lecture des informations d'état…
python-louie est déjà la version la plus récente (1.1-4).
python-dev est déjà la version la plus récente (2.7.16-1).
python-docutils est déjà la version la plus récente (0.14+dfsg-4).
python-pip est déjà la version la plus récente (18.1-5).
python-setuptools est déjà la version la plus récente (40.8.0-1).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
W: --force-yes est obsolète, veuillez plutôt utiliser l'une des options commençant par --allow.
apt-get install --force-yes -y build-essential libudev-dev g++
Lecture des listes de paquets…
Construction de l'arbre des dépendances…
Lecture des informations d'état…
build-essential est déjà la version la plus récente (12.6).
g++ est déjà la version la plus récente (4:8.3.0-1).
libudev-dev est déjà la version la plus récente (241-5).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
W: --force-yes est obsolète, veuillez plutôt utiliser l'une des options commençant par --allow.
apt-get install --force-yes -y cython
Lecture des listes de paquets…
Construction de l'arbre des dépendances…
Lecture des informations d'état…
cython est déjà la version la plus récente (0.29.2-2).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
W: --force-yes est obsolète, veuillez plutôt utiliser l'une des options commençant par --allow.
pip install nose-html
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.
Requirement already satisfied: nose-html in /usr/local/lib/python2.7/dist-packages (1.1)
Requirement already satisfied: nose>=0.11.1 in /usr/lib/python2.7/dist-packages (from nose-html) (1.3.7)
pip install nose-progressive
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.
Requirement already satisfied: nose-progressive in /usr/local/lib/python2.7/dist-packages (1.5.2)
Requirement already satisfied: blessings<2.0,>=1.3 in /usr/local/lib/python2.7/dist-packages (from nose-progressive) (1.7)
Requirement already satisfied: nose>=1.2.1 in /usr/lib/python2.7/dist-packages (from nose-progressive) (1.3.7)
Requirement already satisfied: six in /usr/lib/python2.7/dist-packages (from blessings<2.0,>=1.3->nose-progressive) (1.12.0)
pip install coverage
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.
Requirement already satisfied: coverage in /usr/local/lib/python2.7/dist-packages (4.5.3)
pip install nose
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.
Requirement already satisfied: nose in /usr/lib/python2.7/dist-packages (1.3.7)
pip install pylint
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.
Requirement already satisfied: pylint in /usr/local/lib/python2.7/dist-packages (1.9.4)
Requirement already satisfied: singledispatch; python_version < "3.4" in /usr/local/lib/python2.7/dist-packages (from pylint) (3.4.0.3)
Requirement already satisfied: mccabe in /usr/local/lib/python2.7/dist-packages (from pylint) (0.6.1)
Requirement already satisfied: configparser; python_version == "2.7" in /usr/lib/python2.7/dist-packages (from pylint) (3.5.0b2)
Requirement already satisfied: isort>=4.2.5 in /usr/local/lib/python2.7/dist-packages (from pylint) (4.3.21)
Requirement already satisfied: six in /usr/lib/python2.7/dist-packages (from pylint) (1.12.0)
Requirement already satisfied: astroid<2.0,>=1.6 in /usr/local/lib/python2.7/dist-packages (from pylint) (1.6.6)
Requirement already satisfied: backports.functools-lru-cache; python_version == "2.7" in /usr/lib/python2.7/dist-packages (from pylint) (1.5)
Requirement already satisfied: futures; python_version < "3.2" in /usr/local/lib/python2.7/dist-packages (from isort>=4.2.5->pylint) (3.2.0)
Requirement already satisfied: wrapt in /usr/local/lib/python2.7/dist-packages (from astroid<2.0,>=1.6->pylint) (1.11.2)
Requirement already satisfied: enum34>=1.1.3; python_version < "3.4" in /usr/lib/python2.7/dist-packages (from astroid<2.0,>=1.6->pylint) (1.1.6)
Requirement already satisfied: lazy-object-proxy in /usr/local/lib/python2.7/dist-packages (from astroid<2.0,>=1.6->pylint) (1.4.1)
#pip install docutils
#pip install setuptools
#The following line crashes with a core dump
#pip install "Cython==0.22"

Dependencies for users installed (python 2 7 16)
sed -i -e '253s/.*//' openzwave/cpp/src/value_classes/ValueID.h
cd openzwave && make
make[1] : on entre dans le répertoire « /opt/python-openzwave/openzwave »
CPPFLAGS= make -C /opt/python-openzwave/openzwave/cpp/build/ -w 
make[2] : on entre dans le répertoire « /opt/python-openzwave/openzwave/cpp/build »
Building OpenZWave Version 1.4.-1
Building tinystr.o
Building tinyxmlerror.o
Building tinyxml.o
Building tinyxmlparser.o
Building hid.o
Building aeskey.o
Building aescrypt.o
Building aestab.o
Building aes_modes.o
Building SensorAlarm.o
Building Proprietary.o
Building BarrierOperator.o
Building SensorBinary.o
Building Language.o
Building WakeUp.o
Building Color.o
Building ZWavePlusInfo.o
Building SoundSwitch.o
Building MeterPulse.o
Building DeviceResetLocally.o
Building ThermostatFanMode.o
Building ClimateControlSchedule.o
Building Configuration.o
Building Battery.o
Building SwitchToggleBinary.o
Building ThermostatMode.o
Building NoOperation.o
Building CentralScene.o
Building UserCode.o
Building Indicator.o
Building TimeParameters.o
Building ManufacturerSpecific.o
Building ThermostatSetpoint.o
Building ApplicationStatus.o
Building SwitchToggleMultilevel.o
Building NodeNaming.o
Building DoorLockLogging.o
/opt/python-openzwave/openzwave/cpp/src/command_classes/DoorLockLogging.cpp: In member function ‘virtual bool OpenZWave::DoorLockLogging::HandleMsg(const uint8*, uint32, uint32)’:
/opt/python-openzwave/openzwave/cpp/src/command_classes/DoorLockLogging.cpp:312:15: error: passing argument 1 to restrict-qualified parameter aliases with argument 4 [-Werror=restrict]
      snprintf(usercode, sizeof(usercode), "%s %d", usercode, (int)_data[12+i]);
               ^~~~~~~~                             ~~~~~~~~
cc1plus: all warnings being treated as errors
make[2]: *** [/opt/python-openzwave/openzwave/cpp/build/support.mk:136: /opt/python-openzwave/openzwave/.lib/DoorLockLogging.o] Error 1
make[2] : on quitte le répertoire « /opt/python-openzwave/openzwave/cpp/build »
make[1]: *** [Makefile:20: all] Error 2
make[1] : on quitte le répertoire « /opt/python-openzwave/openzwave »
make: *** [Makefile:273: openzwave/.lib/] Error 2
Everything is successfully installed!

schouf26
Timide
Messages : 7
Inscription : 23 mars 2018, 01:42

Re: Problème installation des dépendances

Message par schouf26 » 12 juil. 2019, 02:38

Salut Benoit,
oui ils peuvent t'aider....ils ont indiqué ce qu'il fallait faire, une compilation maison....
je suis entrain d'essayer....
bon courage

alttrash
Timide
Messages : 9
Inscription : 12 juil. 2019, 16:56

Re: Problème installation des dépendances

Message par alttrash » 12 juil. 2019, 17:04

camusyan a écrit :
30 juin 2019, 22:22
Tu as raison Naboleo, il y a clairement un problème avec ce fichier vers.cpp.
Après vérification, son contenu est corrompu. Le problème est que ce fichier est généré pendant l'installation et à chaque fois avec la même corruption.

Du coup, j'ai trouvé une autre solution. J'ai installé moi même libopenzwave et python-openzwave en clonant le repo git et en lançant l'installation à la main. Dans les grandes lignes, voilà ce que ca donne :

Code : Tout sélectionner

cd /opt
git clone https://github.com/OpenZWave/open-zwave.git
git clone https://github.com/OpenZWave/python-openzwave.git
cd /opt/open-zwave
make all
make install
cd /opt/python-openzwave
vi Makefile
Dans le Makefile, il faut chercher la target install-lib et remplacer --flavor=git par --flavor=shared de façon à ce que python-openzwave utilise la librairie openzwave qu'on vient de compiler et d'installer plutôt que d'en recompiler une.

Voilà ce que ca donne avant :

Code : Tout sélectionner

install-lib:
	${PYTHON_EXEC} setup-lib.py install --flavor=git
et après modification

Code : Tout sélectionner

install-lib:
	${PYTHON_EXEC} setup-lib.py install --flavor=shared
Reste plus qu'à lancer la compile :

Code : Tout sélectionner

make build
make install
Verifier que libopenzwave.so est bien détectée par ldconfig :

Code : Tout sélectionner

ldconfig -v
...
/usr/local/lib:
	libopenzwave.so.1.6 -> libopenzwave.so.1.6
...
si ce n'est pas le cas, il faut ajouter /usr/local/lib au fichier /etc/ld.so.conf et relancer ldconfig

Il ne reste plus qu'à réactiver le module zwave et miracle les dépendances sont OK ainsi que le démon.

Il y a peut être un moyen plus simple de résoudre ce problème mais celui là a le mérite de marcher même si il est assez long car la complie des 2 repos git prend un certain temps sur le pi...

Yann
Bonjour Yann. J'ai bien rebuildé libopenzwave et je confirme que la lib dynamique (.so) est bien detectée par ldconfig comme indiqué. Cependant à la réactivation du module zwave, en relancant l installation des dépendances, jeedom cherche à rebuilder la lib (avec ses propres options de compil qui foutent la merde) au lieu d'utiliser celle qu on vient de builder (et qui se trouve dans `/usr/local/lib`). Une idée ? merci

camusyan
Timide
Messages : 10
Inscription : 30 juin 2019, 13:20

Re: Problème installation des dépendances

Message par camusyan » 12 juil. 2019, 17:18

Hello,
En fait il ne faut pas relancer la réinstallation des dépendances depuis l’interface Jeedom.
Une fois que tu as compilé toi même libopenzwave et python-openzwave, il suffit normalement de relancer le plugin zwave dans Jeedom mais surtout pas relancer l’install des dépendances.
Si la relance du plugin ne suffit pas, tente un reboot du pi et vérifie bien après le reboot que libopenzwave est toujours bien détectée par ldconfig.
Yann

alttrash
Timide
Messages : 9
Inscription : 12 juil. 2019, 16:56

Re: Problème installation des dépendances

Message par alttrash » 12 juil. 2019, 17:28

Je précise que c'est ma TOUTE PREMIERE utilisation (et installation) de Jeedom... donc je n'ai jamais eu par le passé de module zwave operationnel ! qd je reboot le Pi, jeedom, sur la page du module z-wave, me précise que le status "dependances" est NOK. Est ce normal puisqu'on a pas utilisé son install mais la notre ?? ca ne veut pas dire que le module ne fonctionne pas ?

camusyan
Timide
Messages : 10
Inscription : 30 juin 2019, 13:20

Re: Problème installation des dépendances

Message par camusyan » 12 juil. 2019, 17:48

Rassure toi, avant d’avoir été confronté à ce problème je n’avais jamais installé le plugin zwave non plus mais c’est souvent dans la galère qu’on apprend le plus de choses 😊.
Si après reboot, les dépendances sont toujours à NOK c’est effectivement qu’il y a un problème.
Après avoir relancé l’installation des dépendances depuis Jeedom, est-ce que tu as relancé la compile manuelle de python-openzwave car la reinstall depuis Jeedom à certainement écrasé le résultat de ta compile manuelle dans le répertoire /opt/python-openzwave. Donc à ta place, j’effacerais ce repertoire, je reclonerais le repo git dans /opt/python-openzwave, je remodifierais le Makefile comme expliqué dans mon post et je relancerais la compile. Une fois la compile terminée, tu relances le plugin zwave et tu croises les doigts pour que les dépendances passent OK 😊

alttrash
Timide
Messages : 9
Inscription : 12 juil. 2019, 16:56

Re: Problème installation des dépendances

Message par alttrash » 12 juil. 2019, 21:23

Definitivement non ça ne marche pas, apres avoir recompilé et bien verifié que la lib dynamique est referencée par ldconfig, quand je relance le plugin zwave, il me dit qu il y a un probleme avec les dépendances, j ai meme l impression que jeedom relance d'office l'install des dépendances. Je n'arrive pas bien à voir dans le log du plugin ce qui ne lui plait pas. Y'a moyen de configurer jeedom pour qu il n'installe pas les dependances tout seul "automatiquement" ? et pour voir, sans qu'il ne cherche à regler le probleme par lui même, ce qui ne lui va pas ?

camusyan
Timide
Messages : 10
Inscription : 30 juin 2019, 13:20

Re: Problème installation des dépendances

Message par camusyan » 12 juil. 2019, 21:58

Alors là, je suis désolé mais je ne vois pas. Chez moi, il ne lance pas l’install des dépendances automatiquement...

alttrash
Timide
Messages : 9
Inscription : 12 juil. 2019, 16:56

Re: Problème installation des dépendances

Message par alttrash » 12 juil. 2019, 22:05

Jeedom passe son temps a me désinstaller ce qui à pris 1h a compiler/installer :_(

```mkdir: cannot create directory ‘/opt’: File exists
Désinstallation de la version précédente
Installation de Python-OpenZwave``` <- ARGH

alttrash
Timide
Messages : 9
Inscription : 12 juil. 2019, 16:56

Re: Problème installation des dépendances

Message par alttrash » 12 juil. 2019, 22:10

Yann tu es sur une beta (de jeedom ou du module zwave) ?

camusyan
Timide
Messages : 10
Inscription : 30 juin 2019, 13:20

Re: Problème installation des dépendances

Message par camusyan » 12 juil. 2019, 23:14

Non, je suis sur la version stable de Jeedom et du plug-in Zwave

alttrash
Timide
Messages : 9
Inscription : 12 juil. 2019, 16:56

Re: Problème installation des dépendances

Message par alttrash » 13 juil. 2019, 06:30

Bon ben tant pis, je vais devoir attendre la version officielle supportant Buster :cry:

Répondre

Revenir vers « [Plugin Officiel] Z-Wave »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité