Ce Forum passera en lecture seule en janvier 2020
Image
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

Impossible d'installer Dépendance Z-WAVE

Retrouvez ici des sujets concernant le protocole Z-Wave et les modules domotiques de type Z-Wave utilisés avec JEEDOM
Sebgsx01
Timide
Messages : 10
Inscription : 28 nov. 2018, 19:22

Impossible d'installer Dépendance Z-WAVE

Message par Sebgsx01 » 22 déc. 2018, 22:38

Bonjour à tous.

J'aurai besoin de votre aide, j'ai beau fouiner de partout, je n'arrive pas à solutionner mon problème....

Je suis en train de faire des tests pour déployer JEEDOM chez moi.
Matériel: Raspberry Pi3 avec les dernières mise à jour firmware et softs (Linux raspberrypi 4.14.86-v7+ #1175 SMP Thu Dec 6 14:04:38 GMT 2018 armv7l GNU/Linux [9.6])
J'utilise plusieurs protocole:
-Rflink
-Zigate
et dernièrement j'ai fait l'acquisition d'une carte Razberry pour passer sur du Z-WAVE.
Jeedom est installé sur ce même Raspberry.

Avant d'installer ma Razberry2, mon système (très basique: 1sonde Xiaomi, 2 récépteurs 433mhz...) répondait parfaitement aux différents test.

J'ai suivi la procédure décrite par Z-WAVE, j'ai réussi à me connecter 1 seul fois à Z-Way (depuis impossible....)
Je n'ai pas modifié le port du serveur que j'ai laissé par défaut à 8083.

J'ai installé, sur JEEDOM qui est en version 3.3.7, le plugin Z-WAVE
Je précise que j'ai les plugin suivant: ABEILLE, RFLINK, et JEEDOUINO, dès fois qu'il y ai un conflit....
La configuration est la suivante:
_Port cléf Z-Wave> rasperry pi(/dev/ttyAMAO)
_Port du serveur> 8083

Lorsque je lance l'installation des Dépendances, après 45% j'ai une erreur et le statut reste en NOK. Egalement il me met "impossible de contacter le serveur Z-WAVE"
Je vous mets les logs.

  • [2018-12-22 19:47:46][DEBUG] : Lancement de : /var/www/html/core/class/../../core/php/jeePlugin.php plugin_id=openzwave function=remove callInstallFunction=1
    [2018-12-22 19:53:59][INFO] : Début d'activation du plugin
    [2018-12-22 19:54:00][INFO] : Info sur le démon : Array ( [state] => nok [launchable] => nok [launchable_message] => Gestion automatique désactivée [log] => [auto] => 0 [last_launch] => Inconnue )
    [2018-12-22 19:54:00][DEBUG] : Lancement de : /var/www/html/core/class/../../core/php/jeePlugin.php plugin_id=openzwave function=install callInstallFunction=1
    [2018-12-22 21:31:26][DEBUG] : Lancement de : /var/www/html/core/class/../../core/php/jeePlugin.php plugin_id=openzwave function=remove callInstallFunction=1
    [2018-12-22 21:31:30][INFO] : Début d'activation du plugin
    [2018-12-22 21:31:31][INFO] : Info sur le démon : Array ( [launchable_message] => [launchable] => nok [state] => nok [log] => nok [auto] => 0 )
    [2018-12-22 21:31:31][DEBUG] : Lancement de : /var/www/html/core/class/../../core/php/jeePlugin.php plugin_id=openzwave function=install callInstallFunction=1
[/i]
  • Lancement de l'installation/mise à jour des dépendances openzwave
    Atteint:1 http://raspbian.raspberrypi.org/raspbian stretch InRelease
    Atteint:2 http://archive.raspberrypi.org/debian stretch InRelease
    Atteint:3 https://deb.nodesource.com/node_8.x stretch InRelease
    Atteint:4 https://repo.mosquitto.org/debian stretch InRelease
    Lecture des listes de paquets…
    Installation des dependances
    Lecture des listes de paquets…
    Construction de l'arbre des dépendances…
    Lecture des informations d'état…
    build-essential is already the newest version (12.3).
    g++ is already the newest version (4:6.3.0-4).
    gcc is already the newest version (4:6.3.0-4).
    git is already the newest version (1:2.11.0-3+deb9u4).
    libjpeg-dev is already the newest version (1:1.5.1-2).
    libudev-dev is already the newest version (232-25+deb9u6).
    make is already the newest version (4.1-9.1).
    python-dev is already the newest version (2.7.13-2).
    python-louie is already the newest version (1.1-2.1).
    python-lxml is already the newest version (3.7.1-1).
    python-pyudev is already the newest version (0.21.0-1).
    python-requests is already the newest version (2.12.4-1).
    python-serial is already the newest version (3.2.1-1).
    python-setuptools is already the newest version (33.1.1-1).
    unzip is already the newest version (6.0-21).
    python-pip is already the newest version (9.0.1-2+rpt2).
    0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
    Installation des dependances Python
    Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
    Requirement already satisfied: urwid in /usr/local/lib/python3.5/dist-packages (2.0.1)
    Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
    Collecting louie
    Using cached https://files.pythonhosted.org/packages ... 1.1.tar.gz
    Complete output from command python setup.py egg_info:
    Traceback (most recent call last):
    File "<string>", line 1, in <module>
    File "/tmp/pip-install-ujddxm8f/louie/setup.py", line 8, in <module>
    from louie import version
    File "/tmp/pip-install-ujddxm8f/louie/louie/__init__.py", line 33, in <module>
    import louie.dispatcher, louie.error, louie.plugin, louie.robustapply, \
    File "/tmp/pip-install-ujddxm8f/louie/louie/dispatcher.py", line 454
    except Exception, err:
    ^
    SyntaxError: invalid syntax

    ----------------------------------------
    Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-install-ujddxm8f/louie/
    could not install - abort


J'aurai aimé aller vérifier les paramètre dans le raZberry pour être sur que le port est bon, mais impossible de me reconnecter.
Je rentre bien ID/admin> 127510/admin
et le mot de passe (que j'ai défini) mais cela ne fonctionne plus. (je me demande s'il a bien été enregistré).
Le mot de passe de base vous le connaissez?

Mais même si la raZberry n'était pas bien configurée, je devrais pouvoir installer les dépendances? seul des Demons auraient un statut NOK?


Si vous pouviez m'aiguiller, ça serait sympa...

Si non je vais tenté une ré-installation total....

Sebgsx01
Timide
Messages : 10
Inscription : 28 nov. 2018, 19:22

Re: Impossible d'installer Dépendance Z-WAVE

Message par Sebgsx01 » 23 déc. 2018, 18:36

Hello à tous, j'ai solutionné mon problème.....

Ré-installation total du raspberry, puis jeedom, puis les passerelles 1 par 1.....

Ca fait 2 fois que je solutionne des défaillances de cette façon, un début de faiblesse de la carte SD??

Fredtje
Timide
Messages : 21
Inscription : 08 oct. 2018, 22:11

Re: Impossible d'installer Dépendance Z-WAVE

Message par Fredtje » 06 janv. 2019, 21:48

Salut
J’ai d mon coté un zigate avec le plugin zigate et jeedouino qui pilote les gpio de pi. J’avais essayé avant cela d’utiliser un arduino en usb toujours avec jeedouino mais même problème : lorsque les sorties commutent j’ai parfois la connection à la zigate qui est perdue. ceci m’oblige de manuellement stopper le demon et de le relancer. La gestion auto n’y fait rien. Le demon est OK mais il n’y a en fait plus aucune com avec mes sondes de températures.
As-tu eu ce genre de soucis avec jeedouino?
J’ai remarqué en inspectant les log que la com saute lorsque jeedom utilise son demon USB. Qu’il utilise aussi pour piloter les GPIO du PI !?

Sebgsx01
Timide
Messages : 10
Inscription : 28 nov. 2018, 19:22

Re: Impossible d'installer Dépendance Z-WAVE

Message par Sebgsx01 » 07 janv. 2019, 13:22

Fredtje a écrit :
06 janv. 2019, 21:48
Salut
J’ai d mon coté un zigate avec le plugin zigate et jeedouino qui pilote les gpio de pi. J’avais essayé avant cela d’utiliser un arduino en usb toujours avec jeedouino mais même problème : lorsque les sorties commutent j’ai parfois la connection à la zigate qui est perdue. ceci m’oblige de manuellement stopper le demon et de le relancer. La gestion auto n’y fait rien. Le demon est OK mais il n’y a en fait plus aucune com avec mes sondes de températures.
As-tu eu ce genre de soucis avec jeedouino?
J’ai remarqué en inspectant les log que la com saute lorsque jeedom utilise son demon USB. Qu’il utilise aussi pour piloter les GPIO du PI !?
Salut Fredtje,

Je n'utilise que la carte Razberry2 qui est pluggée sur les ports GPIO du raspberry pi3.
Je n'utilise pas le Pi pour piloter des Gpio donc je ne suis pas dans la même config que toi.

Par contre j'avais, au début, des soucis de connexion/déconnexion qui étaient dû à une mauvaise installation depuis le ssh du raspberry.
Il a fallu tout que je re-installe (debian, JEEDOM, les plugin... et depuis plus aucun soucis avec Mon réseau Z-wave.

Je suis débutant dans le domaine et je ne pourrais pas trop t'aider....

Désolé.

Répondre

Revenir vers « [Plugin Officiel] Z-Wave »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 6 invités