Avant toute chose merci de (re)prendre connaissance de la charte et de la respecter.
Pour résumer :
- Avant de poser une question, je cherche si la réponse existe
- Je suis poli, courtois et je respecte tout un chacun sur le forum
- Si un post m'agace : je m'en éloigne plutôt que de répondre d'une façon qui pourrait être mal interprétée


Il n'est jamais du luxe que de rappeler des choses simples :
Courtoisie, amabilité, politesse et bonne humeur sont les maîtres mots pour un forum sympathique, bienveillant et accueillant :)

Le groupe des Helpers est present pour vous aidez, n'hésitez pas à poser des questions ;)

Toute la communauté vous remercie

/!\ L’ancien forum passera en lecture seule en janvier 2020 (Si community a bien pris le relais) puis nous le fermerons définitivement en janvier 2021./!\
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

Impossible de lancer le démon openzwave

Retrouvez ici des sujets concernant le protocole Z-Wave et les modules domotiques de type Z-Wave utilisés avec JEEDOM
Répondre
Zzo
Timide
Messages : 12
Inscription : 24 févr. 2019, 20:54

Impossible de lancer le démon openzwave

Message par Zzo » 24 févr. 2019, 21:07

Bonjour,

Depuis hier, le plugin Z-wave a cessé de fonctionner sur mon Jeedom tournant sur un Pi 3+.
Voici l'erreur, je l'ai passé en mode debug, mais il n'y a pas plus d'info après un redémarrage :

Code : Tout sélectionner

[2019-02-24 20:50:34][ERROR] : Impossible de lancer le démon openzwave, relancer le démon en debug et vérifiez la log
[2019-02-24 20:55:05][INFO] : Lancement démon openzwave : /usr/bin/python /var/www/html/plugins/openzwave/core/class/../../resources/openzwaved/openzwaved.py  --device auto --loglevel debug --port 8083 --config_folder /var/www/html/plugins/openzwave/core/class/../../resources/openzwaved/config --data_folder /var/www/html/plugins/openzwave/core/class/../../data --callback http://127.0.0.1:81/plugins/openzwave/core/php/jeeZwave.php --apikey xxxxxxxxxxx --suppressRefresh 0 --cycle 0.3 --pid /tmp/jeedom/openzwave/deamon.pid
J'ai fait une mise à jour complète du Pi via la commande suivante, tout s'est déroulé sans problème :

Code : Tout sélectionner

sudo apt-get update && sudo apt-get upgrade -y && sudo apt-get dist-upgrade -y && sudo rpi-update
Ma version de Jeedom est déjà à jour 3.2.16 et celle du plugin est 2019-02-05 02:09:16
Par contre dans la log Openzwave_update je vois ceci :
Je n'ai aucune idée de ce que c'est...

Code : Tout sélectionner

Installation des dependances Python
/var/www/html/plugins/openzwave/core/class/../../resources/install_apt.sh: line 35:  3152 Illegal instruction     sudo pip install "$@"
could not install  - abort
J'ai aussi tenté de relancer l'installation des dépendances du plugin, il va jusque 40% puis passe en OK directement.

Voilà, je ne suis pas un pro de Jeedom et je cale sur ce problème.
Dire que tout allait parfaitement depuis des mois... :-/

Merci,

Z

Avatar de l’utilisateur
Fabrice
Modérateur
Messages : 3381
Inscription : 27 oct. 2016, 22:26
Localisation : Planète terre, IDF, 93

Re: Impossible de lancer le démon openzwave

Message par Fabrice » 25 févr. 2019, 07:31

Bonjour,

Questions :
- Vous avez fait la mise à jour du PI, ce qui a entrainé cette erreur ?
- ou vous avez mis à jour le PI après ?
Pour information : la mise à jour du PI de cette fin 02/2019 est une GROSSE mises à jour, avec un nouveau noyau Linux (passage de 4.14 à 4.19).

L'idéale, serait de placer ici la log complète : openzwave_update
Helper Officiel Jeedom
- Jeedom : 3.3.32
- Protocole : Z-Wave / RFXcom / BLEA
- Raspberry Pi : Pi 3 B+ / Pi 3 B / Pi Zero W

Zzo
Timide
Messages : 12
Inscription : 24 févr. 2019, 20:54

Re: Impossible de lancer le démon openzwave

Message par Zzo » 25 févr. 2019, 08:01

Bonjour,

J'ai fait la Maj du Pi après avoir constaté que mon Z-wave ne fonctionnait plus.
J'ai vu dans ce forum que ça avait résolu le problème pour un autre module.

Voilà la log openzwave_update, c'est la dernière ligne qui pose problème.

Code : Tout sélectionner

Lancement de l'installation/mise à jour des dépendances openzwave
Hit:1 http://raspbian.raspberrypi.org/raspbian stretch InRelease
Hit:2 http://archive.raspberrypi.org/debian stretch InRelease
Hit:3 https://deb.nodesource.com/node_8.x stretch InRelease
Reading package lists...
Installation des dependances
Reading package lists...
Building dependency tree...
Reading state information...
build-essential is already the newest version (12.3).
g++ is already the newest version (4:6.3.0-4).
gcc is already the newest version (4:6.3.0-4).
git is already the newest version (1:2.11.0-3+deb9u4).
libjpeg-dev is already the newest version (1:1.5.1-2).
libudev-dev is already the newest version (232-25+deb9u9).
make is already the newest version (4.1-9.1).
python-dev is already the newest version (2.7.13-2).
python-louie is already the newest version (1.1-2.1).
python-lxml is already the newest version (3.7.1-1).
python-pyudev is already the newest version (0.21.0-1).
python-requests is already the newest version (2.12.4-1).
python-serial is already the newest version (3.2.1-1).
python-setuptools is already the newest version (33.1.1-1).
unzip is already the newest version (6.0-21).
python-pip is already the newest version (9.0.1-2+rpt2).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Installation des dependances Python
/var/www/html/plugins/openzwave/core/class/../../resources/install_apt.sh: line 35: 19494 Illegal instruction     sudo pip install "$@"
could not install  - abort
J'ai bien trouvé le script install_apt.sh en ssh sur le Pi et la ligne 35 est bien le sudo pip install "$@" dans cette fonction.

Code : Tout sélectionner

function pip_install {
  sudo pip install "$@"
  if [ $? -ne 0 ]; then
    echo "could not install $p - abort"
    rm ${PROGRESS_FILE}
    exit 1
  fi
}
Est-ce que je peux revenir à une version précédente du plugin?

Merci,

Z

Avatar de l’utilisateur
Fabrice
Modérateur
Messages : 3381
Inscription : 27 oct. 2016, 22:26
Localisation : Planète terre, IDF, 93

Re: Impossible de lancer le démon openzwave

Message par Fabrice » 25 févr. 2019, 08:21

Non ce n'est pas possible via l'interface. Surtout si vous indiquez ne rien avoir fait. Je ne suis pas certain que cela soit utile.
J'ai cette même ligne 35 et je viens de relancer l'installation des dépendances sur une machine de test et cela ne pose pas de problème.

Vous pouvez revenir en arrière en effectuant une restauration de Jeedom. Mais est-ce bien utile dans votre cas je ne sais pas .

A tenter, installez Raspbian sur une autre carte micro SD et réinstallez Jeedom dessus.
Puis restaurez votre sauvegarde pour voir ce que cela donne.

En principe,après la restauration, l'installation des dépendances est automatique.
Helper Officiel Jeedom
- Jeedom : 3.3.32
- Protocole : Z-Wave / RFXcom / BLEA
- Raspberry Pi : Pi 3 B+ / Pi 3 B / Pi Zero W

Avatar de l’utilisateur
PrFalKeN
Actif
Messages : 892
Inscription : 27 nov. 2017, 18:51

Re: Impossible de lancer le démon openzwave

Message par PrFalKeN » 25 févr. 2019, 08:31

'Jour,

En SSH tu peux essayer ceci : (si tu n'es pas root met sudo devant les commaneds)

pip install --upgrade setuptools
python -m pip install --upgrade pip
python3 -m pip install --upgrade pip

Et ensuite tu relances l'installation des dépendances dans le config du plugin zwave.
@+
W.O.P.R

Zzo
Timide
Messages : 12
Inscription : 24 févr. 2019, 20:54

Re: Impossible de lancer le démon openzwave

Message par Zzo » 25 févr. 2019, 09:24

Ok Fabrice, je vais essayer de refaire une installation sur une autre SD pour voir ce que ça donne.
J'espère avoir juste un bon backup que part :-)

PrFalKeN, ces commandes ne donnent rien de mon côté.

Code : Tout sélectionner

pi@jeedom:/var/www/html/plugins/openzwave/resources $ sudo pip install --upgrade setuptools
Instruction non permise
pi@jeedom:/var/www/html/plugins/openzwave/resources $ sudo python -m pip install --upgrade pip
Instruction non permise
pi@jeedom:/var/www/html/plugins/openzwave/resources $ sudo python3 -m pip install --upgrade pip
/usr/bin/python3: No module named pip

Avatar de l’utilisateur
Fabrice
Modérateur
Messages : 3381
Inscription : 27 oct. 2016, 22:26
Localisation : Planète terre, IDF, 93

Re: Impossible de lancer le démon openzwave

Message par Fabrice » 25 févr. 2019, 18:42

Il faut saisir les commandes de PrFalKeN telle que,
- sans mettre ce que vous avez mis avant.

Juste :
sudo pip install --upgrade setuptools

Ect...
Helper Officiel Jeedom
- Jeedom : 3.3.32
- Protocole : Z-Wave / RFXcom / BLEA
- Raspberry Pi : Pi 3 B+ / Pi 3 B / Pi Zero W

Zzo
Timide
Messages : 12
Inscription : 24 févr. 2019, 20:54

Re: Impossible de lancer le démon openzwave

Message par Zzo » 26 févr. 2019, 21:17

C’est just le prompt du chemin dans lequel je me trouvais.
Ça ne change rien de le lancer depuis le root "/" , même erreur :-/

Code : Tout sélectionner

pi@jeedom:/ $ sudo pip install --upgrade setuptools
Instruction non permise
pi@jeedom:/ $ sudo python -m pip install --upgrade pip
Instruction non permise
pi@jeedom:/ $ sudo python3 -m pip install --upgrade pip
/usr/bin/python3: No module named pip
A quoi sert la commande "pip"?

Code : Tout sélectionner

pi@jeedom:/ $ pip
Instruction non permise
pi@jeedom:/ $ sudo pip
Instruction non permise
Merci

Zzo
Timide
Messages : 12
Inscription : 24 févr. 2019, 20:54

Re: Impossible de lancer le démon openzwave

Message par Zzo » 26 févr. 2019, 21:29

D'après ce que j'ai trouvé ca viendrait des packages pythons qui ne sont pas compatibles avec le Pi3+.
Mais comment cela est-tel arrivé d'un coup?

Zzo
Timide
Messages : 12
Inscription : 24 févr. 2019, 20:54

Re: Impossible de lancer le démon openzwave

Message par Zzo » 01 mars 2019, 16:59

Bonjour,

J'ai fait une installation complète de Jeedom dans mon Docker de test qui tournat en 3.2.8.
Tout fonctionnait très bien jusqu'à ce que je mette à jour Jeedom en 3.2.16.
Maintenant le z-wave ne fonctionne plus, même après une installation des dépendances.

Code : Tout sélectionner

Echec de la requête http : http://127.0.0.1:8083/node?node_id=6&instance_id=1&cc_id=37&index=0&type=setvalue&value=0&apikey=xxxxxxxxxxxxxxxxx Curl error : Failed to connect to 127.0.0.1 port 8083: Connection refused
Comment retourner à une version stable de Jeedom?

Merci

Avatar de l’utilisateur
Fabrice
Modérateur
Messages : 3381
Inscription : 27 oct. 2016, 22:26
Localisation : Planète terre, IDF, 93

Re: Impossible de lancer le démon openzwave

Message par Fabrice » 01 mars 2019, 18:13

Bonjour,

Débranchez complètement votre clé Z-wave, au moins 30 minutes. Puis testez de nouveau.

Veillez aussi, à ce que la page SANTE de Jeedom n'ai pas de rouge, s'il y en as, corrigez la situation.
Helper Officiel Jeedom
- Jeedom : 3.3.32
- Protocole : Z-Wave / RFXcom / BLEA
- Raspberry Pi : Pi 3 B+ / Pi 3 B / Pi Zero W

Zzo
Timide
Messages : 12
Inscription : 24 févr. 2019, 20:54

Re: Impossible de lancer le démon openzwave

Message par Zzo » 02 mars 2019, 08:45

J'ai essayé pendant plus d'une demi journée sans la clé, mais rien en rouge et les commandes pip ne fonctionnent toujours pas.
Finalement j'ai réinstallé complètement le Pi depuis une image 2018-11-13-raspbian-stretch-lite.img et restauré mon backup Jeedom.
Tout fonctionne à nouveau ainsi que les commandes pip en ssh.

Il me reste maintenant à trouver comment faire pour que Alexa ouvre les volets quand je dir "ouvre" et pas "ferme", elle inverse les 2 commandes :-/

aureil6
Timide
Messages : 18
Inscription : 28 janv. 2018, 19:26

Re: Impossible de lancer le démon openzwave

Message par aureil6 » 05 mars 2019, 22:42

Bonjour,
Pour ma part, je viens d'installer le plugin Zwave et impossible de démarrer le démon. Dans la log, erreur ligne 205 de web.py.
Je suis sur docker/Synology. Après avoir cherché un long moment, j'ai remplacé le package tornado préinstallé en 6.0.1 par la version 3.2.1, et je peux maintenant démarrer le démon.
La procédure :
Aller en ssh root sur le conteneur jeedom
Aller dans le répertoire /usr/local/lib/python2.7/dist-packages
Supprimer les deux répertoires tornado
Puis faire :
pip install tornado==3.2.1

En fait, la version installée (6.0.1) n'est pas compatible, il suffit de la désinstaller et de mettre le 3.2.1 à la place.

Si ça peut aider quelqu'un…

Bonne soirée,

Aurélien

gil_p
Timide
Messages : 79
Inscription : 10 févr. 2018, 12:47
Localisation : Drancy

Re: Impossible de lancer le démon openzwave

Message par gil_p » 13 mars 2019, 17:18

aureil6 a écrit :
05 mars 2019, 22:42
Bonjour,
Pour ma part, je viens d'installer le plugin Zwave et impossible de démarrer le démon. Dans la log, erreur ligne 205 de web.py.
Je suis sur docker/Synology. Après avoir cherché un long moment, j'ai remplacé le package tornado préinstallé en 6.0.1 par la version 3.2.1, et je peux maintenant démarrer le démon.
La procédure :
Aller en ssh root sur le conteneur jeedom
Aller dans le répertoire /usr/local/lib/python2.7/dist-packages
Supprimer les deux répertoires tornado
Puis faire :
pip install tornado==3.2.1

En fait, la version installée (6.0.1) n'est pas compatible, il suffit de la désinstaller et de mettre le 3.2.1 à la place.

Si ça peut aider quelqu'un…

Bonne soirée,

Aurélien
Bonjour

J'ai le même probleme
openzwave.txt
(1.68 Kio) Téléchargé 25 fois
Mais le ssh je ne sais pas faire

Peux tu m'expliquer

un grand merci

gp
jeedom smart zwave + rfplayer // Delta Dore X2D > Alarme (contact+mouv) + chauffage (Tybox 310) + Récepteur TYXIA 610 // X10 (cpl + RF ) // Blys // Modules zwave //
Oregon Sientific // D.O (mouv + contact) // Philips pronto RU950

exotycs
Timide
Messages : 3
Inscription : 04 janv. 2018, 12:35

Re: Impossible de lancer le démon openzwave

Message par exotycs » 10 avr. 2019, 22:48

aureil6 a écrit :
05 mars 2019, 22:42
Bonjour,
Pour ma part, je viens d'installer le plugin Zwave et impossible de démarrer le démon. Dans la log, erreur ligne 205 de web.py.
Je suis sur docker/Synology. Après avoir cherché un long moment, j'ai remplacé le package tornado préinstallé en 6.0.1 par la version 3.2.1, et je peux maintenant démarrer le démon.
La procédure :
Aller en ssh root sur le conteneur jeedom
Aller dans le répertoire /usr/local/lib/python2.7/dist-packages
Supprimer les deux répertoires tornado
Puis faire :
pip install tornado==3.2.1

En fait, la version installée (6.0.1) n'est pas compatible, il suffit de la désinstaller et de mettre le 3.2.1 à la place.

Si ça peut aider quelqu'un…

Bonne soirée,

Aurélien
Aurélien je te bénis !! J'avais exactement le même problème que toi et en suivant ton modop cela fonctionnement parfaitement désormais.
Un grand MERCI

Pour répondre à Gil :
Je t'invite à chercher rapidement sur google ce qu'est le SSH pour comprendre son fonctionnement. Mais en gros tu auras besoin d'un terminal comme "Putty" par exemple pour pouvoir te connecter à ton NAS en SSH sur le port défini dans ton docker. Ensuite tu tape login/mdp et tu suis le tuto de notre cher sauveur Aurélien :)

Répondre

Revenir vers « [Plugin Officiel] Z-Wave »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 3 invités