Ce Forum passera en lecture seule en janvier 2020
Image
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

z-stick gen5 et Zwave, impossible d'installer les dépendances

Retrouvez ici des sujets concernant le protocole Z-Wave et les modules domotiques de type Z-Wave utilisés avec JEEDOM
freetronic
Timide
Messages : 44
Inscription : 20 mai 2018, 19:14

z-stick gen5 et Zwave, impossible d'installer les dépendances

Message par freetronic » 05 avr. 2019, 17:36

Hello,

Je viens de recevoir ma z-stick gen5, je la connecte à mon pi3, elle clignote de 3 couleurs successives, j'installe le plugin Zwave, puis je lance l'install des dépendances et là c'est le drame, ça bloque à 45% et ça revient à 0 comme si je n'avais pas lancé l'install..

http://img110.xooimage.com/files/1/9/a/ ... 5fe3e9.jpg

http://img110.xooimage.com/files/e/c/4/ ... 5fe3ef.jpg

http://img110.xooimage.com/files/6/3/1/ ... 5fe3f3.jpg

J'ai zappé quoi?

Merci :)

Avatar de l’utilisateur
Darkeyes
Actif
Messages : 1286
Inscription : 02 avr. 2015, 08:37

Re: z-stick gen5 et Zwave, impossible d'installer les dépendances

Message par Darkeyes » 05 avr. 2019, 17:54

Salut, il faut fournir les logs d’installation des dépendances du plugin sinon personne pourra t’aider
Développement script:
- ssh_commande.php
- ip_public.sh
- BackupSamba.sh

freetronic
Timide
Messages : 44
Inscription : 20 mai 2018, 19:14

Re: z-stick gen5 et Zwave, impossible d'installer les dépendances

Message par freetronic » 05 avr. 2019, 18:06

Re,

Oups je pensais l'avoir fait, merci

Code : Tout sélectionner

Lancement de l'installation/mise à jour des dépendances openzwave
Atteint:1 https://deb.nodesource.com/node_8.x stretch InRelease
Atteint:2 http://archive.raspberrypi.org/debian stretch InRelease
Atteint:3 http://raspbian.raspberrypi.org/raspbian stretch InRelease
Lecture des listes de paquets…
Installation des dependances
Lecture des listes de paquets…
Construction de l'arbre des dépendances…
Lecture des informations d'état…
build-essential is already the newest version (12.3).
g++ is already the newest version (4:6.3.0-4).
gcc is already the newest version (4:6.3.0-4).
git is already the newest version (1:2.11.0-3+deb9u4).
libjpeg-dev is already the newest version (1:1.5.1-2).
libudev-dev is already the newest version (232-25+deb9u9).
make is already the newest version (4.1-9.1).
python-dev is already the newest version (2.7.13-2).
python-louie is already the newest version (1.1-2.1).
python-lxml is already the newest version (3.7.1-1).
python-pyudev is already the newest version (0.21.0-1).
python-requests is already the newest version (2.12.4-1).
python-serial is already the newest version (3.2.1-1).
python-setuptools is already the newest version (33.1.1-1).
unzip is already the newest version (6.0-21).
python-pip is already the newest version (9.0.1-2+rpt2).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 141 non mis à jour.
Installation des dependances Python
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Requirement already satisfied: urwid in /usr/local/lib/python3.5/dist-packages (2.0.1)
You are using pip version 18.1, however version 19.0.3 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Collecting louie
Using cached https://files.pythonhosted.org/packages/be/c5/4bc02697ffd990fb4e4750c7ddf5694c247054c031366d5ffe65b67f46bc/Louie-1.1.tar.gz
Complete output from command python setup.py egg_info:
Traceback (most recent call last):
File "<string>", line 1, in <module>
File "/tmp/pip-install-gy9_iz9i/louie/setup.py", line 8, in <module>
from louie import version
File "/tmp/pip-install-gy9_iz9i/louie/louie/__init__.py", line 33, in <module>
import louie.dispatcher, louie.error, louie.plugin, louie.robustapply, \
File "/tmp/pip-install-gy9_iz9i/louie/louie/dispatcher.py", line 454
except Exception, err:
^
SyntaxError: invalid syntax
----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-install-gy9_iz9i/louie/
You are using pip version 18.1, however version 19.0.3 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.
could not install  - abort

freetronic
Timide
Messages : 44
Inscription : 20 mai 2018, 19:14

Re: z-stick gen5 et Zwave, impossible d'installer les dépendances

Message par freetronic » 08 avr. 2019, 13:23

Re,

Personne n'a une petite piste? merci

Avatar de l’utilisateur
kiboost
Actif
Messages : 1433
Inscription : 19 déc. 2017, 15:02
Localisation : France, Bretagne

Re: z-stick gen5 et Zwave, impossible d'installer les dépendances

Message par kiboost » 08 avr. 2019, 14:58


Prod : Jeedom Stable sur Smart | Z-wave
Synology DS1512+|Rpis Kodi|Netatmo|SNIPS-Tips|Market
JeedomV4Tips

Avatar de l’utilisateur
bronche
Modérateur
Messages : 973
Inscription : 07 janv. 2016, 19:29
Localisation : Du côté de Issy les Moulineaux la semaine et de Péronne le week-end...

Re: z-stick gen5 et Zwave, impossible d'installer les dépendances

Message par bronche » 08 avr. 2019, 15:14

Bonjour,, tes logs réclament la dernière version.
Tente un :

Code : Tout sélectionner

sudo pip install requests
Phil
Helper Officiel Jeedom
Des images non officielles jeedom maintenues et hébergées par mes soins :
https://queen.useed.fr/SB1268/owncloud/ ... mA9xeSgBgx

freetronic
Timide
Messages : 44
Inscription : 20 mai 2018, 19:14

Re: z-stick gen5 et Zwave, impossible d'installer les dépendances

Message par freetronic » 14 avr. 2019, 11:49

Re,

Désolé pour mon temps de réponse long, j'ai eu une semaine chargée...

Bon j'ai tenté une update de pip, mais je tombe sur une erreur de user

Image

serait-il possible d'avoir la liste des commandes complète? à mon avis un soucis de droits mais je ne suis pas forcément au fait sur le pi. J'ai déjà planté une fois mon install, et du tout refaire malgré des sauvegardes régulières, donc je n'ai pas envie de le replanter, car si ça arrive, il retournera dans son carton n'ayant pas le temps de m'en occuper...

Merci d'avance :)

Avatar de l’utilisateur
bronche
Modérateur
Messages : 973
Inscription : 07 janv. 2016, 19:29
Localisation : Du côté de Issy les Moulineaux la semaine et de Péronne le week-end...

Re: z-stick gen5 et Zwave, impossible d'installer les dépendances

Message par bronche » 14 avr. 2019, 12:25

Bonjour,
Avec les droits sudo ça ira mieux...

Code : Tout sélectionner

sudo pip install --upgrade pip
Phil
Helper Officiel Jeedom
Des images non officielles jeedom maintenues et hébergées par mes soins :
https://queen.useed.fr/SB1268/owncloud/ ... mA9xeSgBgx

freetronic
Timide
Messages : 44
Inscription : 20 mai 2018, 19:14

Re: z-stick gen5 et Zwave, impossible d'installer les dépendances

Message par freetronic » 14 avr. 2019, 13:16

Re,

Mon dieu, cette erreur de nul... Je suis fatigué moi (j'ai fais un copier/coller sans réfléchir en validant), Merci

freetronic
Timide
Messages : 44
Inscription : 20 mai 2018, 19:14

Re: z-stick gen5 et Zwave, impossible d'installer les dépendances

Message par freetronic » 14 avr. 2019, 13:30

Donc effectivement ça fonctionne bien mieux avec sudo ...

Image

mais la suite se passe moins bien

Code : Tout sélectionner

Lancement de l'installation/mise à jour des dépendances openzwave
Hit:1 https://deb.nodesource.com/node_8.x stretch InRelease
Hit:2 http://raspbian.raspberrypi.org/raspbian stretch InRelease
Hit:3 http://archive.raspberrypi.org/debian stretch InRelease
Reading package lists...
Installation des dependances
Reading package lists...
Building dependency tree...
Reading state information...
build-essential is already the newest version (12.3).
g++ is already the newest version (4:6.3.0-4).
gcc is already the newest version (4:6.3.0-4).
git is already the newest version (1:2.11.0-3+deb9u4).
libjpeg-dev is already the newest version (1:1.5.1-2).
libudev-dev is already the newest version (232-25+deb9u11).
make is already the newest version (4.1-9.1).
python-dev is already the newest version (2.7.13-2).
python-louie is already the newest version (1.1-2.1).
python-lxml is already the newest version (3.7.1-1).
python-pyudev is already the newest version (0.21.0-1).
python-requests is already the newest version (2.12.4-1).
python-serial is already the newest version (3.2.1-1).
python-setuptools is already the newest version (33.1.1-1).
unzip is already the newest version (6.0-21).
python-pip is already the newest version (9.0.1-2+rpt2).
0 upgraded, 0 newly installed, 0 to remove and 143 not upgraded.
Installation des dependances Python
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Requirement already satisfied: urwid in /usr/local/lib/python3.5/dist-packages (2.0.1)
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Collecting louie
Using cached https://files.pythonhosted.org/packages/be/c5/4bc02697ffd990fb4e4750c7ddf5694c247054c031366d5ffe65b67f46bc/Louie-1.1.tar.gz
Complete output from command python setup.py egg_info:
Traceback (most recent call last):
File "<string>", line 1, in <module>
File "/tmp/pip-install-v602vzbv/louie/setup.py", line 8, in <module>
from louie import version
File "/tmp/pip-install-v602vzbv/louie/louie/__init__.py", line 33, in <module>
import louie.dispatcher, louie.error, louie.plugin, louie.robustapply, \
File "/tmp/pip-install-v602vzbv/louie/louie/dispatcher.py", line 454
except Exception, err:
^
SyntaxError: invalid syntax
----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-install-v602vzbv/louie/
could not install  - abort
J'ai redémarré le pi dans le doute avant de tenter une nouvelle install des dépendances mais cela n'a rien résolu
Dernière édition par freetronic le 15 avr. 2019, 20:10, édité 1 fois.

Avatar de l’utilisateur
bronche
Modérateur
Messages : 973
Inscription : 07 janv. 2016, 19:29
Localisation : Du côté de Issy les Moulineaux la semaine et de Péronne le week-end...

Re: z-stick gen5 et Zwave, impossible d'installer les dépendances

Message par bronche » 14 avr. 2019, 18:47

Bonsoir
Fais un

Code : Tout sélectionner

sudo pip install -U setuptools
Pour mettre à jour l'installateur.
Phil
Helper Officiel Jeedom
Des images non officielles jeedom maintenues et hébergées par mes soins :
https://queen.useed.fr/SB1268/owncloud/ ... mA9xeSgBgx

freetronic
Timide
Messages : 44
Inscription : 20 mai 2018, 19:14

Re: z-stick gen5 et Zwave, impossible d'installer les dépendances

Message par freetronic » 15 avr. 2019, 20:08

Re,

Image

Fait, après avoir redémarré le pi et relancé l'install des dépendances

Code : Tout sélectionner

Lancement de l'installation/mise à jour des dépendances openzwave
Hit:1 https://deb.nodesource.com/node_8.x stretch InRelease
Hit:2 http://raspbian.raspberrypi.org/raspbian stretch InRelease
Hit:3 http://archive.raspberrypi.org/debian stretch InRelease
Reading package lists...
Installation des dependances
Reading package lists...
Building dependency tree...
Reading state information...
build-essential is already the newest version (12.3).
g++ is already the newest version (4:6.3.0-4).
gcc is already the newest version (4:6.3.0-4).
git is already the newest version (1:2.11.0-3+deb9u4).
libjpeg-dev is already the newest version (1:1.5.1-2).
libudev-dev is already the newest version (232-25+deb9u11).
make is already the newest version (4.1-9.1).
python-dev is already the newest version (2.7.13-2).
python-louie is already the newest version (1.1-2.1).
python-lxml is already the newest version (3.7.1-1).
python-pyudev is already the newest version (0.21.0-1).
python-requests is already the newest version (2.12.4-1).
python-serial is already the newest version (3.2.1-1).
python-setuptools is already the newest version (33.1.1-1).
unzip is already the newest version (6.0-21).
python-pip is already the newest version (9.0.1-2+rpt2).
0 upgraded, 0 newly installed, 0 to remove and 143 not upgraded.
Installation des dependances Python
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Requirement already satisfied: urwid in /usr/local/lib/python3.5/dist-packages (2.0.1)
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Collecting louie
Using cached https://files.pythonhosted.org/packages/be/c5/4bc02697ffd990fb4e4750c7ddf5694c247054c031366d5ffe65b67f46bc/Louie-1.1.tar.gz
Complete output from command python setup.py egg_info:
Traceback (most recent call last):
File "<string>", line 1, in <module>
File "/tmp/pip-install-usx2n7d_/louie/setup.py", line 8, in <module>
from louie import version
File "/tmp/pip-install-usx2n7d_/louie/louie/__init__.py", line 33, in <module>
import louie.dispatcher, louie.error, louie.plugin, louie.robustapply, \
File "/tmp/pip-install-usx2n7d_/louie/louie/dispatcher.py", line 454
except Exception, err:
^
SyntaxError: invalid syntax
----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-install-usx2n7d_/louie/
could not install  - abort
Grand merci pour le coup de main en attendant ;)

Avatar de l’utilisateur
bronche
Modérateur
Messages : 973
Inscription : 07 janv. 2016, 19:29
Localisation : Du côté de Issy les Moulineaux la semaine et de Péronne le week-end...

Re: z-stick gen5 et Zwave, impossible d'installer les dépendances

Message par bronche » 16 avr. 2019, 08:39

Ok, tu as bien la dernière version de l'installateur.
Mais tu as relancé une installation ?

Code : Tout sélectionner

sudo pip install requests
Phil
Helper Officiel Jeedom
Des images non officielles jeedom maintenues et hébergées par mes soins :
https://queen.useed.fr/SB1268/owncloud/ ... mA9xeSgBgx

freetronic
Timide
Messages : 44
Inscription : 20 mai 2018, 19:14

Re: z-stick gen5 et Zwave, impossible d'installer les dépendances

Message par freetronic » 16 avr. 2019, 18:58

Re,

Vu qu'il ne m'installe rien de plus, je pense que oui

Image

Edit, par contre quelle est cette adresse 192.168.1.5 sur l'image, ce n'est pas l'adresse ip de mon pi

Edit 2 bon c'était l'adresse du pc duquel je lançais putty... donc aucun rapport

Avatar de l’utilisateur
Jeandhom
Actif
Messages : 1373
Inscription : 20 oct. 2015, 17:32

Re: z-stick gen5 et Zwave, impossible d'installer les dépendances

Message par Jeandhom » 16 avr. 2019, 20:51

Je ne sais pas si cela te fera avancer mais tu as aussi 143 paquets qui ne sont pas à jour.

Avatar de l’utilisateur
bronche
Modérateur
Messages : 973
Inscription : 07 janv. 2016, 19:29
Localisation : Du côté de Issy les Moulineaux la semaine et de Péronne le week-end...

Re: z-stick gen5 et Zwave, impossible d'installer les dépendances

Message par bronche » 17 avr. 2019, 10:15

Bonjour,
J'ai creusé et j'ai comparé avec mon Pi + Zwave de production. Il tourne sur Python 2.7

Donc je pense que le zwave ne fonctionne que sous python 2.
En fait tu avais la bonne réponse quelques lignes plus haut.
Fais un

Code : Tout sélectionner

sudo rm /usr/local/bin/pip
sudo ln -s /usr/bin/pip2 /usr/local/bin/pip
Cela va recréer le lien vers la bonne version.

Relance tes dépendances, ça va également recompiler. Ce sera très très long !

Et dis nous quoi.

Phil
Helper Officiel Jeedom
Des images non officielles jeedom maintenues et hébergées par mes soins :
https://queen.useed.fr/SB1268/owncloud/ ... mA9xeSgBgx

freetronic
Timide
Messages : 44
Inscription : 20 mai 2018, 19:14

Re: z-stick gen5 et Zwave, impossible d'installer les dépendances

Message par freetronic » 17 avr. 2019, 18:35

Hello,
Jeandhom a écrit :
16 avr. 2019, 20:51
Je ne sais pas si cela te fera avancer mais tu as aussi 143 paquets qui ne sont pas à jour.
Pour ma culture personnelle, tu vois ça comment?
bronche a écrit :
17 avr. 2019, 10:15
Bonjour,
J'ai creusé et j'ai comparé avec mon Pi + Zwave de production. Il tourne sur Python 2.7

Donc je pense que le zwave ne fonctionne que sous python 2.
En fait tu avais la bonne réponse quelques lignes plus haut.
Fais un

Code : Tout sélectionner

sudo rm /usr/local/bin/pip
sudo ln -s /usr/bin/pip2 /usr/local/bin/pip
Cela va recréer le lien vers la bonne version.

Relance tes dépendances, ça va également recompiler. Ce sera très très long !

Et dis nous quoi.

Phil
Merci, je ferais ça ce week end, et je tiendrais le forum au jus sans soucis :)

Avatar de l’utilisateur
Jeandhom
Actif
Messages : 1373
Inscription : 20 oct. 2015, 17:32

Re: z-stick gen5 et Zwave, impossible d'installer les dépendances

Message par Jeandhom » 17 avr. 2019, 19:51

freetronic a écrit :
17 avr. 2019, 18:35
Hello,
Jeandhom a écrit :
16 avr. 2019, 20:51
Je ne sais pas si cela te fera avancer mais tu as aussi 143 paquets qui ne sont pas à jour.
Pour ma culture personnelle, tu vois ça comment?
freetronic a écrit :
15 avr. 2019, 20:08

Code : Tout sélectionner

0 upgraded, 0 newly installed, 0 to remove and 143 not upgraded.

sudo apt-get update && sudo apt-get upgrade

freetronic
Timide
Messages : 44
Inscription : 20 mai 2018, 19:14

Re: z-stick gen5 et Zwave, impossible d'installer les dépendances

Message par freetronic » 18 avr. 2019, 20:56

Re,

Bon j'ai craqué et lancé ça ce soir

Image vu que j'ai passé le s 45% fatidiques, c'est bon signe :)
Jeandhom a écrit :
17 avr. 2019, 19:51
freetronic a écrit :
17 avr. 2019, 18:35
Hello,
Jeandhom a écrit :
16 avr. 2019, 20:51
Je ne sais pas si cela te fera avancer mais tu as aussi 143 paquets qui ne sont pas à jour.
Pour ma culture personnelle, tu vois ça comment?
freetronic a écrit :
15 avr. 2019, 20:08

Code : Tout sélectionner

0 upgraded, 0 newly installed, 0 to remove and 143 not upgraded.

sudo apt-get update && sudo apt-get upgrade
pas encore analysé ça, je verrai pour la suite (bien que je lance régulièrement ( de mémoire en tout cas ) des update/upgrade, merci en tout cas :)

freetronic
Timide
Messages : 44
Inscription : 20 mai 2018, 19:14

Re: z-stick gen5 et Zwave, impossible d'installer les dépendances

Message par freetronic » 18 avr. 2019, 21:13

re,

Je n'irais pas plus loin ce soir, mais un grand merci à tous les participants ;) ça se débloque à priori :)

Image

Je donnerais suite pour le reste

Répondre

Revenir vers « [Plugin Officiel] Z-Wave »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 11 invités