Ce Forum passera en lecture seule en janvier 2020
Image
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

Erreur de communication TMS:FAIL:DIS

Retrouvez ici des sujets concernant le protocole mySensors et les modules domotiques de type mySensors utilisés avec JEEDOM
/!\ Plugin mySensors non officiel
LestatSan
Timide
Messages : 15
Inscription : 14 juil. 2019, 16:49

Erreur de communication TMS:FAIL:DIS

Message par LestatSan » 03 août 2019, 11:29

Bonjour tout le monde,

Je suis commence à faire mes capteurs MySensors et je rencontre quelques problèmes de comm... J'ai prévu de faire une passerelle sur un Wemos Mini+NRF2401 avec antenne déportée et un capteur sur un arduino mini sans antenne déportée. J'ai mis les condo de 47uF entre le 3V3 et le GND de l'antenne. Pour commencer simplement, j'ai pris les exemples présents dans la bibliothèque.

J'ai mis Jeedom en mode inclusion (au cas où...)

Ci dessous le log de la gateway

Code : Tout sélectionner

11:11:59.957 -> 0;255;3;0;9;0 MCO:BGN:INIT GW,CP=RNNGA---,REL=255,VER=2.3.1
11:11:59.957 -> 0;255;3;0;9;5 TSM:INIT
11:11:59.957 -> 0;255;3;0;9;7 TSF:WUR:MS=0
11:11:59.957 -> 0;255;3;0;9;14 TSM:INIT:TSP OK
11:11:59.957 -> 0;255;3;0;9;17 TSM:INIT:GW MODE
11:11:59.957 -> 0;255;3;0;9;20 TSM:READY:ID=0,PAR=0,DIS=0
11:11:59.957 -> 0;255;3;0;9;24 MCO:REG:NOT NEEDED
11:11:59.957 -> 0;255;3;0;14;Gateway startup complete.
11:11:59.991 -> 0;255;0;0;18;2.3.1
11:11:59.991 -> 0;255;3;0;9;28 MCO:BGN:STP
11:11:59.991 -> 0;255;3;0;9;34 MCO:BGN:INIT OK,TSP=1
11:11:59.991 -> 0;255;3;0;9;37 TSM:READY:NWD REQ
11:12:00.026 -> 0;255;3;0;9;76 TSF:MSG:SEND,0-0-255-255,s=255,c=3,t=20,pt=0,l=0,sg=0,ft=0,st=OK:
Celui du noeud :

Code : Tout sélectionner

11:13:26.312 -> 16 MCO:BGN:INIT NODE,CP=RNNNA---,REL=255,VER=2.3.1
11:13:26.346 -> 26 TSM:INIT
11:13:26.346 -> 27 TSF:WUR:MS=0
11:13:26.346 -> 33 !TSM:INIT:TSP FAIL
11:13:26.346 -> 35 TSM:FAIL:CNT=1
11:13:26.346 -> 37 TSM:FAIL:DIS
11:13:26.346 -> 38 TSF:TDI:TSL
Le sketch de la gateway

Code : Tout sélectionner

/*
   The MySensors Arduino library handles the wireless radio link and protocol
   between your home built sensors/actuators and HA controller of choice.
   The sensors forms a self healing radio network with optional repeaters. Each
   repeater and gateway builds a routing tables in EEPROM which keeps track of the
   network topology allowing messages to be routed to nodes.

   Created by Henrik Ekblad <henrik.ekblad@mysensors.org>
   Copyright (C) 2013-2018 Sensnology AB
   Full contributor list: https://github.com/mysensors/MySensors/graphs/contributors

   Documentation: http://www.mysensors.org
   Support Forum: http://forum.mysensors.org

   This program is free software; you can redistribute it and/or
   modify it under the terms of the GNU General Public License
   version 2 as published by the Free Software Foundation.

 *******************************

   REVISION HISTORY
   Version 1.0 - Henrik EKblad
   Contribution by a-lurker and Anticimex,
   Contribution by Norbert Truchsess <norbert.truchsess@t-online.de>
   Contribution by Ivo Pullens (ESP8266 support)

   DESCRIPTION
   The EthernetGateway sends data received from sensors to the WiFi link.
   The gateway also accepts input on ethernet interface, which is then sent out to the radio network.

   VERA CONFIGURATION:
   Enter "ip-number:port" in the ip-field of the Arduino GW device. This will temporarily override any serial configuration for the Vera plugin.
   E.g. If you want to use the default values in this sketch enter: 192.168.178.66:5003

   LED purposes:
   - To use the feature, uncomment any of the MY_DEFAULT_xx_LED_PINs in your sketch, only the LEDs that is defined is used.
   - RX (green) - blink fast on radio message received. In inclusion mode will blink fast only on presentation received
   - TX (yellow) - blink fast on radio message transmitted. In inclusion mode will blink slowly
   - ERR (red) - fast blink on error during transmission error or receive crc error

   See https://www.mysensors.org/build/connect_radio for wiring instructions.

   If you are using a "barebone" ESP8266, see
   https://www.mysensors.org/build/esp8266_gateway#wiring-for-barebone-esp8266

   Inclusion mode button:
   - Connect GPIO5 (=D1) via switch to GND ('inclusion switch')

   Hardware SHA204 signing is currently not supported!

   Make sure to fill in your ssid and WiFi password below for ssid & pass.
*/

// Enable debug prints to serial monitor
#define MY_DEBUG

// Use a bit lower baudrate for serial prints on ESP8266 than default in MyConfig.h
#define MY_BAUD_RATE 9600

// Enables and select radio type (if attached)
#define MY_RADIO_RF24
//#define MY_RADIO_RFM69
//#define MY_RADIO_RFM95

#define MY_GATEWAY_ESP8266

#define MY_WIFI_SSID " xxxxx "
#define MY_WIFI_PASSWORD "xxxxxx"

// Enable UDP communication
//#define MY_USE_UDP  // If using UDP you need to set MY_CONTROLLER_IP_ADDRESS below

// Set the hostname for the WiFi Client. This is the hostname
// it will pass to the DHCP server if not static.
#define MY_HOSTNAME "Mysensor"

// Enable MY_IP_ADDRESS here if you want a static ip address (no DHCP)
//#define MY_IP_ADDRESS XXX XXX XXX XXX

// If using static ip you can define Gateway and Subnet address as well
//#define MY_IP_GATEWAY_ADDRESS XXX XXX XXX XXX
//#define MY_IP_SUBNET_ADDRESS XXX XXX XXX XXX

// The port to keep open on node server mode
#define MY_PORT 5003

// How many clients should be able to connect to this gateway (default 1)
#define MY_GATEWAY_MAX_CLIENTS 10

// Controller ip address. Enables client mode (default is "server" mode).
// Also enable this if MY_USE_UDP is used and you want sensor data sent somewhere.
//#define MY_CONTROLLER_IP_ADDRESS 192, 168, 178, 68

// Enable inclusion mode
//#define MY_INCLUSION_MODE_FEATURE

// Enable Inclusion mode button on gateway
//#define MY_INCLUSION_BUTTON_FEATURE
// Set inclusion mode duration (in seconds)
//#define MY_INCLUSION_MODE_DURATION 60
// Digital pin used for inclusion mode button
//#define MY_INCLUSION_MODE_BUTTON_PIN D1

// Set blinking period
//#define MY_DEFAULT_LED_BLINK_PERIOD 300

// Flash leds on rx/tx/err
// Led pins used if blinking feature is enabled above
//#define MY_DEFAULT_ERR_LED_PIN 16  // Error led pin
//#define MY_DEFAULT_RX_LED_PIN  16  // Receive led pin
//#define MY_DEFAULT_TX_LED_PIN  16  // the PCB, on board LED

#if defined(MY_USE_UDP)
#include <WiFiUdp.h>
#endif

#include <ESP8266WiFi.h>
#include <MySensors.h>

void setup()
{
  // Setup locally attached sensors
}

void presentation()
{
  // Present locally attached sensors here
}

void loop()
{
  // Send locally attached sensors data here
}
Celui du noeud :

Code : Tout sélectionner

/**
 * The MySensors Arduino library handles the wireless radio link and protocol
 * between your home built sensors/actuators and HA controller of choice.
 * The sensors forms a self healing radio network with optional repeaters. Each
 * repeater and gateway builds a routing tables in EEPROM which keeps track of the
 * network topology allowing messages to be routed to nodes.
 *
 * Created by Henrik Ekblad <henrik.ekblad@mysensors.org>
 * Copyright (C) 2013-2015 Sensnology AB
 * Full contributor list: https://github.com/mysensors/Arduino/graphs/contributors
 *
 * Documentation: http://www.mysensors.org
 * Support Forum: http://forum.mysensors.org
 *
 * This program is free software; you can redistribute it and/or
 * modify it under the terms of the GNU General Public License
 * version 2 as published by the Free Software Foundation.
 *
 *******************************
 *
 * REVISION HISTORY
 * Version 1.0: Henrik EKblad
 * Version 1.1 - 2016-07-20: Converted to MySensors v2.0 and added various improvements - Torben Woltjen (mozzbozz)
 * 
 * DESCRIPTION
 * This sketch provides an example of how to implement a humidity/temperature
 * sensor using a DHT11/DHT-22.
 *  
 * For more information, please visit:
 * http://www.mysensors.org/build/humidity
 * 
 */

// Enable debug prints
#define MY_DEBUG

// Enable and select radio type attached 
#define MY_RADIO_RF24
//#define MY_RADIO_RFM69
//#define MY_RS485

#define MY_NODE_ID 1
 
#include <SPI.h>
#include <MySensors.h>  
#include <DHT.h>

// Set this to the pin you connected the DHT's data pin to
#define DHT_DATA_PIN 3

// Set this offset if the sensor has a permanent small offset to the real temperatures.
// In Celsius degrees (as measured by the device)
#define SENSOR_TEMP_OFFSET 0

// Sleep time between sensor updates (in milliseconds)
// Must be >1000ms for DHT22 and >2000ms for DHT11
static const uint64_t UPDATE_INTERVAL = 6000;

// Force sending an update of the temperature after n sensor reads, so a controller showing the
// timestamp of the last update doesn't show something like 3 hours in the unlikely case, that
// the value didn't change since;
// i.e. the sensor would force sending an update every UPDATE_INTERVAL*FORCE_UPDATE_N_READS [ms]
static const uint8_t FORCE_UPDATE_N_READS = 10;

#define CHILD_ID_HUM 0
#define CHILD_ID_TEMP 1

float lastTemp;
float lastHum;
uint8_t nNoUpdatesTemp;
uint8_t nNoUpdatesHum;
bool metric = true;

MyMessage msgHum(CHILD_ID_HUM, V_HUM);
MyMessage msgTemp(CHILD_ID_TEMP, V_TEMP);
DHT dht (DHT_DATA_PIN, DHT22);


void presentation()  
{ 
  // Send the sketch version information to the gateway
  sendSketchInfo("TemperatureAndHumidity", "1.1");
  
  // Register all sensors to gw (they will be created as child devices)
  present(CHILD_ID_HUM, S_HUM);
  present(CHILD_ID_TEMP, S_TEMP);
  
  metric = getControllerConfig().isMetric;
}


void setup()
{
/*  dht.setup(DHT_DATA_PIN); // set data pin of DHT sensor
  if (UPDATE_INTERVAL <= dht.getMinimumSamplingPeriod()) {
    Serial.println("Warning: UPDATE_INTERVAL is smaller than supported by the sensor!");
  }
  // Sleep for the time of the minimum sampling period to give the sensor time to power up
  // (otherwise, timeout errors might occure for the first reading)
  sleep(dht.getMinimumSamplingPeriod());
*/
}


void loop()      
{  
  // Force reading sensor, so it works also after sleep()
/*
  dht.readSensor(true);
  */
  // Get temperature from DHT library
  float temperature = dht.readTemperature();
  if (isnan(temperature)) {
    Serial.println("Failed reading temperature from DHT!");
  } else if (temperature != lastTemp || nNoUpdatesTemp == FORCE_UPDATE_N_READS) {
    // Only send temperature if it changed since the last measurement or if we didn't send an update for n times
    lastTemp = temperature;

    // apply the offset before converting to something different than Celsius degrees
    temperature += SENSOR_TEMP_OFFSET;
/*
    if (!metric) {
      temperature = dht.toFahrenheit(temperature);
    }
    */
    // Reset no updates counter
    nNoUpdatesTemp = 0;
    send(msgTemp.set(temperature, 1));

    #ifdef MY_DEBUG
    Serial.print("T: ");
    Serial.println(temperature);
    #endif
  } else {
    // Increase no update counter if the temperature stayed the same
    nNoUpdatesTemp++;
  }

  // Get humidity from DHT library
  float humidity = dht.readHumidity();
  if (isnan(humidity)) {
    Serial.println("Failed reading humidity from DHT");
  } else if (humidity != lastHum || nNoUpdatesHum == FORCE_UPDATE_N_READS) {
    // Only send humidity if it changed since the last measurement or if we didn't send an update for n times
    lastHum = humidity;
    // Reset no updates counter
    nNoUpdatesHum = 0;
    send(msgHum.set(humidity, 1));
    
    #ifdef MY_DEBUG
    Serial.print("H: ");
    Serial.println(humidity);
    #endif
  } else {
    // Increase no update counter if the humidity stayed the same
    nNoUpdatesHum++;
  }

  // Sleep for a while to save energy
  sleep(UPDATE_INTERVAL); 
}
Mes essais :
1 - GW Wemos + NRF24 antenne déportée : TSM ok
2 - GW Wemos + NRF24 : TSM ok
3 - GW Arduino Uno + NRF24 : TSM ok

-> J'en déduis donc les deux antennes comme ok (exact ?)

4 - Noeud Arduino mini + NRF24 antenne déportée : TSM FAIL
5 - Noeud Arduino mini + NRF24 : TSM FAIL
6 - Noeud Arduino Uno + NRF : TSM FAIL

-> J'en déduis que le problème ne vient pas du mini, car le Uno avec la même antenne fonctionne en GW et pas en noeud.

J'ai vérifié plusieurs fois les câblages et changé les câbles duponts sur les platines.
J'ai aussi suivi la procédure de débug trouvé sur le site MySensor que je mets en PJ au cas où ca intéresse quelqu'un.
MySensor-debug.jpg
My sensor debug
MySensor-debug.jpg (237 Kio) Consulté 557 fois
Avec tout ca, je ne vois que trois problèmes :
A - Il y a un problème de sketch. Mais vu que j'ai pris les exemples des bibliothèques, je ne pense pas
B - Il y a un gros problème entre la chaise et le clavier -> Fort probable que j'ai raté un manip' ou pas compris un truc
C - Autre ?


Là, je sèche... Est ce que quelqu'un a une idée ?

Merci !

totoff974
Helper
Messages : 573
Inscription : 15 juil. 2016, 08:08
Localisation : Île de La Réunion

Re: Erreur de communication TMS:FAIL:DIS

Message par totoff974 » 03 août 2019, 18:00

Bonsoir,
Pour ma part le plugin mysensors n'est plus opérationnel chez moi. Comme mentionné dans le sujet viewtopic.php?f=35&t=12117&start=1160
Tu peux éventuellement essayer les différentes manips évoquées dans ce sujet mais chez moi plus rien ne fonctionne en l'état.

J'ai commencé à développer un nouveau plugin qui est quasi terminé.
Helper Officiel Jeedom
Plugin JeeOrangeTv, JeeMySensors, JeePlcBus et JeeRss
Un petit don pour m'aider à développer : Faire un don

LestatSan
Timide
Messages : 15
Inscription : 14 juil. 2019, 16:49

Re: Erreur de communication TMS:FAIL:DIS

Message par LestatSan » 04 août 2019, 15:05

Bonjour,

Merci de ton retour. Cela viendrai donc uniquement du fait que le plugin (mon controleur ?) ne fonctionne pas ?

totoff974
Helper
Messages : 573
Inscription : 15 juil. 2016, 08:08
Localisation : Île de La Réunion

Re: Erreur de communication TMS:FAIL:DIS

Message par totoff974 » 04 août 2019, 15:36

Je ne peux pas garantir, mais dans mon cas sur deux serveurs jeedom différents et deux controleurs / node différents je n'ai pu réussir à refaire fonctionner mon reséeau mysensors.
cependant tu peux lever les doutes en te connectant en série sur le logiciel arduino et regarder ce qu'il se passe en tapant les commandes direct dans le moniteur série.
Helper Officiel Jeedom
Plugin JeeOrangeTv, JeeMySensors, JeePlcBus et JeeRss
Un petit don pour m'aider à développer : Faire un don

Avatar de l’utilisateur
lunarok
Actif
Messages : 6695
Inscription : 08 août 2014, 12:48
Localisation : Anjou

Re: Erreur de communication TMS:FAIL:DIS

Message par lunarok » 04 août 2019, 16:12

Plus de 400 installations, 0 ticket depuis plus de 2 ans.
On arrête la les medisances non fondées. Surtout venant d'un développeur, balancer que le plugin ne marche pas 'mais je sais pas pourquoi' c'est grossier
Mon Blog | Xiaomi Home
Pour contribuer au développement des plugins (don ou achat de matériel) : Paypal
Aides nous à t'aider : les logs, détails du soucis, la doc, recherche sur le forum ...
PS : pas de support par MP, je ne répondrais pas

totoff974
Helper
Messages : 573
Inscription : 15 juil. 2016, 08:08
Localisation : Île de La Réunion

Re: Erreur de communication TMS:FAIL:DIS

Message par totoff974 » 04 août 2019, 16:25

lunarok a écrit :
04 août 2019, 16:12
On arrête la les medisances non fondées. Surtout venant d'un développeur
BONSOIR Lunarok, je ne suis pas médisant ! d'ailleurs je lui propose de regarder le flux 'officiel' où il y a des pistes pour résoudre son problème ! ... non ?
Il est où le mal ? D'ailleurs j'ai aussi préciser que je ne pas "garantir" que c'est lié à ton plugin ... je n'aurai pas cette prétention !

... mais bon bref !

Sur le sujet viewtopic.php?f=35&t=12117&start=1160 il y a des pistes pour résoudre certains problèmes (désolé tout n'est pas parfait dans cette vie)...

Certains n'ont pas envie de faire des tickets, certains préfèrent le forum pour échanger dans la courtoisie ... chacun est libre.

Bonne soirée :)
Helper Officiel Jeedom
Plugin JeeOrangeTv, JeeMySensors, JeePlcBus et JeeRss
Un petit don pour m'aider à développer : Faire un don

rol-rider
Actif
Messages : 5092
Inscription : 10 août 2014, 23:50

Re: Erreur de communication TMS:FAIL:DIS

Message par rol-rider » 04 août 2019, 20:22

Ceci dit...... ça fonctionne toujours chez moi depuis le tout début de Mysensors sur jeedom.

Envoyé de mon Redmi Note 6 Pro en utilisant Tapatalk

RPI3 avec mSATA
RFXcom; RFLink; Z-Wave; Mysensors; ESPEasy
Noeuds MySensors-téléinfo-Température-Distance-Baromètre-relais
Noeuds ESPEasy-open-garage-relais-PIR-Station Météo

Avatar de l’utilisateur
yogui
Actif
Messages : 797
Inscription : 11 févr. 2015, 21:52
Localisation : Alsace

Re: Erreur de communication TMS:FAIL:DIS

Message par yogui » 05 août 2019, 14:17

rol-rider a écrit :Ceci dit...... ça fonctionne toujours chez moi depuis le tout début de Mysensors sur jeedom.

Envoyé de mon Redmi Note 6 Pro en utilisant Tapatalk
Pareil depuis 4ans avec gateway réseau

Envoyé de mon STF-L09 en utilisant Tapatalk

Raspberry PI 2 , Razberry Zwave +
Fibaro FGRM-222
Qubino ZMNHCA2
Fibaro FGS-222
Qubino ZMNHBA2
Everspring AN180-6
Everspring Z-WAVE SP-103
Raspberry Pi 2 + touch 3.5" en Squeezebox
Modules Mysensors

Dev. Librairie Arduino pour Somfy RTS

totoff974
Helper
Messages : 573
Inscription : 15 juil. 2016, 08:08
Localisation : Île de La Réunion

Re: Erreur de communication TMS:FAIL:DIS

Message par totoff974 » 05 août 2019, 14:35

Bonjour,
Le sujet initial est quand même d'aider LestatSan, sachant que je suppose (attention le mot supposer signifie poser à titre d'hypothèse) que vos installations qui fonctionnent tournent depuis un moment.. car moi cela à commencer à dysfonctionner dès l'ajout d'un nouveau node et/ou à partir d'un gateway nouveau. Qui semble être le cas de LestatSan également, et ayant eu les mêmes symptômes ... d'où la redirection vers le sujet principal du forum mysensors qui me semble plus alimenté en solutions (qui n'ont pas fonctionné pour ma part aie).
Helper Officiel Jeedom
Plugin JeeOrangeTv, JeeMySensors, JeePlcBus et JeeRss
Un petit don pour m'aider à développer : Faire un don

rol-rider
Actif
Messages : 5092
Inscription : 10 août 2014, 23:50

Re: Erreur de communication TMS:FAIL:DIS

Message par rol-rider » 06 août 2019, 01:21

C'est vrai que ça ne fait pas avancer le sujet !
Mais, y a pas de raison que ça ne fonctionne pas, puisque chez certains ça fonctionne !
Et même si la config est ancienne, les mises à jour sont..... à jour et ça fonctionne.
Sur le premier post, les logs? D'où ils viennent ? De jeedom ? Ou du moniteur série ?
Comment sont les logs des dépendances du plugin ? As tu testé la gateway et le nœud sur MYSController? Avec ça tu seras d'où vient le problème.
Et....la config jeedom? C'est sur quoi ?

Envoyé de mon Redmi Note 6 Pro en utilisant Tapatalk


RPI3 avec mSATA
RFXcom; RFLink; Z-Wave; Mysensors; ESPEasy
Noeuds MySensors-téléinfo-Température-Distance-Baromètre-relais
Noeuds ESPEasy-open-garage-relais-PIR-Station Météo

Avatar de l’utilisateur
yogui
Actif
Messages : 797
Inscription : 11 févr. 2015, 21:52
Localisation : Alsace

Re: Erreur de communication TMS:FAIL:DIS

Message par yogui » 06 août 2019, 07:16

Question bête je suppose que les xxx dans le code de la gateway c fait exprès pour pa donner ton ip

Autres question qui aiderait notre boulle de cristal ta config du plugin

Envoyé de mon STF-L09 en utilisant Tapatalk


Raspberry PI 2 , Razberry Zwave +
Fibaro FGRM-222
Qubino ZMNHCA2
Fibaro FGS-222
Qubino ZMNHBA2
Everspring AN180-6
Everspring Z-WAVE SP-103
Raspberry Pi 2 + touch 3.5" en Squeezebox
Modules Mysensors

Dev. Librairie Arduino pour Somfy RTS

LestatSan
Timide
Messages : 15
Inscription : 14 juil. 2019, 16:49

Re: Erreur de communication TMS:FAIL:DIS

Message par LestatSan » 07 août 2019, 22:10

Bonjour,

@Rol-Rider Sur le premier post, l'ensemble des log viennent du moniteur série.

Je met ci dessous le log des dépendances dans jeedom :

Code : Tout sélectionner

Début de l'installation
--2019-07-30 22:16:07--  https://raw.githubusercontent.com/lunarok/jeedom_nodejs/master/nodejs.sh
Resolving raw.githubusercontent.com (raw.githubusercontent.com)... 151.101.120.133
Connecting to raw.githubusercontent.com (raw.githubusercontent.com)|151.101.120.133|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1489 (1.5K) [text/plain]
Saving to: 'dependencies.sh'
0K .                                                     100% 19.1M=0s
2019-07-30 22:16:07 (19.1 MB/s) - 'dependencies.sh' saved [1489/1489]
dependencies.sh: 3: [: mySensors: unexpected operator
Version actuelle : 8
Hit:1 https://deb.nodesource.com/node_8.x stretch InRelease
Hit:2 http://raspbian.raspberrypi.org/raspbian stretch InRelease
Get:3 http://archive.raspberrypi.org/debian stretch InRelease [25.4 kB]
Fetched 25.4 kB in 18min 1s (23 B/s)
Reading package lists...
Reading package lists...
Building dependency tree...
Reading state information...
lsb-release is already the newest version (9.20161125+rpi1).
The following package was automatically installed and is no longer required:
realpath
Use 'sudo apt autoremove' to remove it.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Ok, version suffisante
> @serialport/bindings@2.0.8 install /var/www/html/plugins/mySensors/resources/node_modules/@serialport/bindings
> prebuild-install --tag-prefix @serialport/bindings@ || node-gyp rebuild
prebuild-install WARN install No prebuilt binaries found (target=8.16.0 runtime=node arch=arm libc= platform=linux)
make: Entering directory '/var/www/html/plugins/mySensors/resources/node_modules/@serialport/bindings/build'
CXX(target) Release/obj.target/bindings/src/serialport.o
CXX(target) Release/obj.target/bindings/src/serialport_unix.o
CXX(target) Release/obj.target/bindings/src/poller.o
CXX(target) Release/obj.target/bindings/src/serialport_linux.o
SOLINK_MODULE(target) Release/obj.target/bindings.node
COPY Release/bindings.node
make: Leaving directory '/var/www/html/plugins/mySensors/resources/node_modules/@serialport/bindings/build'
npm notice created a lockfile as package-lock.json. You should commit this file.
added 125 packages from 100 contributors and audited 206 packages in 54.594s
found 0 vulnerabilities
Fin de l'installation
Au cas où, le log "mysensor_Node"

Code : Tout sélectionner

Wed Aug 07 2019 22:02:07 GMT+0200 (CEST) - Jeedom url : http://127.0.0.1:80/plugins/mySensors/core/api/jeeSensors.php?apikey=yyyyyyyyyyyyygateway=192.168.1.40, gwAddress : 192.168.1.40:5003
Connection type network
Wed Aug 07 2019 22:02:07 GMT+0200 (CEST) - server bound on 8019
Wed Aug 07 2019 22:02:07 GMT+0200 (CEST) - connected to network gateway at 192.168.1.40:5003:network
Wed Aug 07 2019 22:02:07 GMT+0200 (CEST) : 0;255;3;0;14;Gateway startup complete.
Wed Aug 07 2019 22:02:07 GMT+0200 (CEST) : 0;255;0;0;18;2.3.1
Le paramétrage du plugin :
Réseau Client
IP : 192.168.1.40:5003

Je ne connaissais pas MYSControler, je vais me trouver un windows et tester ca.

Mon jeedom tourne sur un Rpi3B+, avec un core en 3.3.29

Merci pour votre aide !

Avatar de l’utilisateur
yogui
Actif
Messages : 797
Inscription : 11 févr. 2015, 21:52
Localisation : Alsace

Re: Erreur de communication TMS:FAIL:DIS

Message par yogui » 07 août 2019, 22:42

LestatSan a écrit :Bonjour,

@Rol-Rider Sur le premier post, l'ensemble des log viennent du moniteur série.

Je met ci dessous le log des dépendances dans jeedom :

Code : Tout sélectionner

Début de l'installation
--2019-07-30 22:16:07--  https://raw.githubusercontent.com/lunarok/jeedom_nodejs/master/nodejs.sh
Resolving raw.githubusercontent.com (raw.githubusercontent.com)... 151.101.120.133
Connecting to raw.githubusercontent.com (raw.githubusercontent.com)|151.101.120.133|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1489 (1.5K) [text/plain]
Saving to: 'dependencies.sh'
0K .                                                     100% 19.1M=0s
2019-07-30 22:16:07 (19.1 MB/s) - 'dependencies.sh' saved [1489/1489]
dependencies.sh: 3: [: mySensors: unexpected operator
Version actuelle : 8
Hit:1 https://deb.nodesource.com/node_8.x stretch InRelease
Hit:2 http://raspbian.raspberrypi.org/raspbian stretch InRelease
Get:3 http://archive.raspberrypi.org/debian stretch InRelease [25.4 kB]
Fetched 25.4 kB in 18min 1s (23 B/s)
Reading package lists...
Reading package lists...
Building dependency tree...
Reading state information...
lsb-release is already the newest version (9.20161125+rpi1).
The following package was automatically installed and is no longer required:
realpath
Use 'sudo apt autoremove' to remove it.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Ok, version suffisante
> @serialport/bindings@2.0.8 install /var/www/html/plugins/mySensors/resources/node_modules/@serialport/bindings
> prebuild-install --tag-prefix @serialport/bindings@ || node-gyp rebuild
prebuild-install WARN install No prebuilt binaries found (target=8.16.0 runtime=node arch=arm libc= platform=linux)
make: Entering directory '/var/www/html/plugins/mySensors/resources/node_modules/@serialport/bindings/build'
CXX(target) Release/obj.target/bindings/src/serialport.o
CXX(target) Release/obj.target/bindings/src/serialport_unix.o
CXX(target) Release/obj.target/bindings/src/poller.o
CXX(target) Release/obj.target/bindings/src/serialport_linux.o
SOLINK_MODULE(target) Release/obj.target/bindings.node
COPY Release/bindings.node
make: Leaving directory '/var/www/html/plugins/mySensors/resources/node_modules/@serialport/bindings/build'
npm notice created a lockfile as package-lock.json. You should commit this file.
added 125 packages from 100 contributors and audited 206 packages in 54.594s
found 0 vulnerabilities
Fin de l'installation
Au cas où, le log "mysensor_Node"

Code : Tout sélectionner

Wed Aug 07 2019 22:02:07 GMT+0200 (CEST) - Jeedom url : http://127.0.0.1:80/plugins/mySensors/core/api/jeeSensors.php?apikey=yyyyyyyyyyyyygateway=192.168.1.40, gwAddress : 192.168.1.40:5003
Connection type network
Wed Aug 07 2019 22:02:07 GMT+0200 (CEST) - server bound on 8019
Wed Aug 07 2019 22:02:07 GMT+0200 (CEST) - connected to network gateway at 192.168.1.40:5003:network
Wed Aug 07 2019 22:02:07 GMT+0200 (CEST) : 0;255;3;0;14;Gateway startup complete.
Wed Aug 07 2019 22:02:07 GMT+0200 (CEST) : 0;255;0;0;18;2.3.1
Le paramétrage du plugin :
Réseau Client
IP : 192.168.1.40:5003

Je ne connaissais pas MYSControler, je vais me trouver un windows et tester ca.

Mon jeedom tourne sur un Rpi3B+, avec un core en 3.3.29

Merci pour votre aide !
Tes logs ont l'air ok ça vient probablement du code de la gateway

Envoyé de mon STF-L09 en utilisant Tapatalk

Raspberry PI 2 , Razberry Zwave +
Fibaro FGRM-222
Qubino ZMNHCA2
Fibaro FGS-222
Qubino ZMNHBA2
Everspring AN180-6
Everspring Z-WAVE SP-103
Raspberry Pi 2 + touch 3.5" en Squeezebox
Modules Mysensors

Dev. Librairie Arduino pour Somfy RTS

rol-rider
Actif
Messages : 5092
Inscription : 10 août 2014, 23:50

Re: Erreur de communication TMS:FAIL:DIS

Message par rol-rider » 08 août 2019, 00:03

moi, je partirais plutôt sur un problème de communication du nœud !
surtout que c'est le moniteur série qui te le dit et la gateway semble bien reconnu par le plugin.
ou problème de NRF sur l'un des deux...bref ça communique pas.
RPI3 avec mSATA
RFXcom; RFLink; Z-Wave; Mysensors; ESPEasy
Noeuds MySensors-téléinfo-Température-Distance-Baromètre-relais
Noeuds ESPEasy-open-garage-relais-PIR-Station Météo

LestatSan
Timide
Messages : 15
Inscription : 14 juil. 2019, 16:49

Re: Erreur de communication TMS:FAIL:DIS

Message par LestatSan » 08 août 2019, 06:31

J'ai pu essayer MYSControler. J'ai pas réussi à extraire les log, mais il ne trouve que ma passerelle et semble pas me donner de messages d'erreurs.

Je vais refaire quelques essais en inversant les antennes et les arduino. Sinon je commanderai chez les fournisseurs recommandés sur le site de mysensor. Ça éliminera le côté matériel.

Envoyé de mon H8416 en utilisant Tapatalk


Avatar de l’utilisateur
yogui
Actif
Messages : 797
Inscription : 11 févr. 2015, 21:52
Localisation : Alsace

Re: Erreur de communication TMS:FAIL:DIS

Message par yogui » 08 août 2019, 06:48

LestatSan a écrit :J'ai pu essayer MYSControler. J'ai pas réussi à extraire les log, mais il ne trouve que ma passerelle et semble pas me donner de messages d'erreurs.

Je vais refaire quelques essais en inversant les antennes et les arduino. Sinon je commanderai chez les fournisseurs recommandés sur le site de mysensor. Ça éliminera le côté matériel.

Envoyé de mon H8416 en utilisant Tapatalk
Ce qui discrédite la thèse que le plugin fonctionne pas !
Tu peux faire une photo de tes montage ?

Envoyé de mon STF-L09 en utilisant Tapatalk


Raspberry PI 2 , Razberry Zwave +
Fibaro FGRM-222
Qubino ZMNHCA2
Fibaro FGS-222
Qubino ZMNHBA2
Everspring AN180-6
Everspring Z-WAVE SP-103
Raspberry Pi 2 + touch 3.5" en Squeezebox
Modules Mysensors

Dev. Librairie Arduino pour Somfy RTS

Avatar de l’utilisateur
yogui
Actif
Messages : 797
Inscription : 11 févr. 2015, 21:52
Localisation : Alsace

Re: Erreur de communication TMS:FAIL:DIS

Message par yogui » 08 août 2019, 06:55

rol-rider a écrit :moi, je partirais plutôt sur un problème de communication du nœud !
surtout que c'est le moniteur série qui te le dit et la gateway semble bien reconnu par le plugin.
ou problème de NRF sur l'un des deux...bref ça communique pas.
Par code gateway je pensais au noeud et ça communication
Moi ce qui me choc c'est que le numéro de noeud de la gateway est 255 de mémoire c'est 0
C'est en tout cas ce que dit le log parser de mysensors

Envoyé de mon STF-L09 en utilisant Tapatalk


Raspberry PI 2 , Razberry Zwave +
Fibaro FGRM-222
Qubino ZMNHCA2
Fibaro FGS-222
Qubino ZMNHBA2
Everspring AN180-6
Everspring Z-WAVE SP-103
Raspberry Pi 2 + touch 3.5" en Squeezebox
Modules Mysensors

Dev. Librairie Arduino pour Somfy RTS

LestatSan
Timide
Messages : 15
Inscription : 14 juil. 2019, 16:49

Re: Erreur de communication TMS:FAIL:DIS

Message par LestatSan » 08 août 2019, 21:26

J'ai fait une photo des montages, mais... c'est pas exploitable il faudrai que je prenne au moins 4/5 photos (ce qui peut toujours se faire). c'est un vrai sac de noeuds, même si j'ai pris les câbles les plus courts possible... Pour l'instant, tout est sur breadboard avec câbles duponts. Et alimentés par l'USB (ordinateur pour le noeud et alim externe pour la GW)

J'ai fait les schémas de câblage à la main.

La gateway
GW.jpg
GW.jpg (705.27 Kio) Consulté 330 fois
Le noeud
Sensor.jpg
Sensor.jpg (676.88 Kio) Consulté 330 fois
Dans MYSControler, la GW est reconnue avec une adresse à "0"

Pour info/rappel/précision, les codes utilisés sont ceux des bibliothèques. J'ai uniquement changé le nombre de noeuds max dans le code de la GW et forcél'ID dans le noeud (j'avais vu sur un forum que ca pouvait faciliter la comm et résolu des pb chez certains).

rol-rider
Actif
Messages : 5092
Inscription : 10 août 2014, 23:50

Re: Erreur de communication TMS:FAIL:DIS

Message par rol-rider » 08 août 2019, 23:32

Ya un truc qui me chagrine !
sur tes log (moniteur série) de ta gateway ? on ne voit pas la connexion à ta box (internet).
est-ce parce que tu n'as pas tout mis ? ou c'est tout ce que tu as reçu ?
je vois dans le sketch gateway

Code : Tout sélectionner

//#define MY_IP_ADDRESS XXX XXX XXX XXX
normalement il faut décocher (enlever les //) et rajouter ton IP à la place de XXXX

j'ai testé (ya longtemps) une gateway sur Wemos et j'ai retrouvé les log (moniteur série)
par contre je ne sais plus quelle sketch que j'avais utilisé.
mais la connexion à ma freebox apparait sur le log.
Capture02.PNG
Capture02.PNG (61.04 Kio) Consulté 319 fois

PS:
Dans MYSControler, la GW est reconnue avec une adresse à "0"
c'est normal (0 et 255) sont réservé 0 pour la gateway et 255 c'est un nœud qui n'a pas été reconnu par la gateway...(il me semble !)
RPI3 avec mSATA
RFXcom; RFLink; Z-Wave; Mysensors; ESPEasy
Noeuds MySensors-téléinfo-Température-Distance-Baromètre-relais
Noeuds ESPEasy-open-garage-relais-PIR-Station Météo

LestatSan
Timide
Messages : 15
Inscription : 14 juil. 2019, 16:49

Re: Erreur de communication TMS:FAIL:DIS

Message par LestatSan » 09 août 2019, 19:01

Ya un truc qui me chagrine !
sur tes log (moniteur série) de ta gateway ? on ne voit pas la connexion à ta box (internet).
est-ce parce que tu n'as pas tout mis ? ou c'est tout ce que tu as reçu ?
je vois dans le sketch gateway
Je t'avoue que je ne sais plus. J'ai refais une copie ci dessous du log réalisé à l'instant. J'ai allégé le log avec des "...", car à la place j'avais une dizaine de "GWT:TIN:CONNECTING..."

Code : Tout sélectionner

18:43:24.126 -> 106 TSF:LRT:OK
18:43:24.194 -> 122 TSM:INIT
18:43:24.194 -> 135 TSF:WUR:MS=0
18:43:24.194 -> 159 TSM:INIT:TSP OK
18:43:24.229 -> scandone
18:43:24.229 -> state: 0 -> 2 (b0)
18:43:24.262 -> state: 2 -> 3 (0)
18:43:24.295 -> state: 3 -> 5 (10)
18:43:24.295 -> add 0
18:43:24.295 -> aid 1
18:43:24.295 -> cnt 
18:43:24.332 -> 
18:43:24.332 -> connected with [SSID], channel 6
18:43:24.332 -> dhcp client start...
18:43:24.367 -> 337 TSM:INIT:GW MODE
18:43:24.367 -> 359 TSM:READY:ID=0,PAR=0,DIS=0
18:43:24.401 -> 392 MCO:REG:NOT NEEDED
18:43:24.550 -> 483 TSM:READY:NWD REQ
18:43:24.584 -> 542 TSF:MSG:SEND,0-0-255-255,s=255,c=3,t=20,pt=0,l=0,sg=0,ft=0,st=OK:
18:43:25.051 -> 983 GWT:TIN:CONNECTING...
18:43:25.585 -> 1510 GWT:TIN:CONNECTING...
18:43:26.102 -> 2038 GWT:TIN:CONNECTING...
18:43:26.644 -> 2566 GWT:TIN:CONNECTING...
18:43:26.889 -> scandone
18:43:27.167 -> 3094 GWT:TIN:CONNECTING...
...
18:43:34.030 -> 9958 GWT:TIN:CONNECTING...
18:43:34.236 -> pm open,type:2 0
18:43:34.552 -> 10486 GWT:TIN:CONNECTING...
....
18:44:16.870 -> 52806 GWT:TIN:CONNECTING...
18:44:16.870 -> 52835 TSF:MSG:READ,1-1-255,s=255,c=3,t=7,pt=0,l=0,sg=0:
18:44:16.937 -> 52894 TSF:MSG:BC
18:44:16.975 -> 52912 TSF:MSG:FPAR REQ,ID=1
18:44:17.010 -> 52941 TSF:PNG:SEND,TO=0
18:44:17.010 -> 52966 TSF:CKU:OK
18:44:17.045 -> 52984 TSF:MSG:GWL OK
18:44:17.892 -> 53824 !TSF:MSG:SEND,0-0-1-1,s=255,c=3,t=8,pt=1,l=1,sg=0,ft=0,st=NACK:0
18:44:17.960 -> 53898 GWT:TIN:CONNECTING...
Je viens de tester avec une autre NRF non amplifée sur la GW, j'ai ca :

Code : Tout sélectionner

18:55:20.410 -> 106 TSF:LRT:OK
18:55:20.446 -> 121 TSM:INIT
18:55:20.446 -> 135 TSF:WUR:MS=0
18:55:20.446 -> 159 TSM:INIT:TSP OK
18:55:20.481 -> scandone
18:55:20.481 -> state: 0 -> 2 (b0)
18:55:20.515 -> 209 TSM:INIT:GW MODE
18:55:20.549 -> state: 2 -> 3 (0)
18:55:20.549 -> state: 3 -> 5 (10)
18:55:20.582 -> add 0
18:55:20.582 -> aid 1
18:55:20.582 -> cnt 
18:55:20.582 -> 
18:55:20.582 -> connected with SSID, channel 6
18:55:20.649 -> dhcp client start...
18:55:20.649 -> ip:192.168.1.40,mask:255.255.255.0,gw:192.168.1.1
18:55:20.716 -> 411 TSM:READY:ID=0,PAR=0,DIS=0
18:55:20.750 -> 444 MCO:REG:NOT NEEDED
18:55:20.852 -> 539 TSM:READY:NWD REQ
18:55:20.920 -> 597 TSF:MSG:SEND,0-0-255-255,s=255,c=3,t=20,pt=0,l=0,sg=0,ft=0,st=OK:
18:55:21.370 -> 1036 GWT:TIN:CONNECTING...
18:55:21.907 -> 1564 GWT:TIN:CONNECTING...
18:55:22.402 -> 2092 GWT:TIN:CONNECTING...
18:55:22.938 -> 2620 GWT:TIN:CONNECTING...
18:55:23.219 -> scandone
18:55:23.444 -> 3148 GWT:TIN:CONNECTING...
18:55:23.444 -> 3176 GWT:TIN:IP: 192.168.1.40
18:55:23.480 -> 3208 MCO:BGN:STP
18:55:23.516 -> 3226 MCO:BGN:INIT OK,TSP=1
18:55:30.522 -> pm open,type:2 0
18:55:39.545 -> 19244 TSF:MSG:READ,1-1-255,s=255,c=3,t=7,pt=0,l=0,sg=0:
18:55:39.583 -> 19302 TSF:MSG:BC
18:55:39.619 -> 19320 TSF:MSG:FPAR REQ,ID=1
18:55:39.653 -> 19350 TSF:PNG:SEND,TO=0
18:55:39.653 -> 19375 TSF:CKU:OK
18:55:39.691 -> 19393 TSF:MSG:GWL OK
18:55:40.710 -> 20400 TSF:MSG:SEND,0-0-1-1,s=255,c=3,t=8,pt=1,l=1,sg=0,ft=0,st=OK:0
18:55:41.617 -> 21294 TSF:MSG:READ,1-1-0,s=255,c=3,t=24,pt=1,l=1,sg=0:1
18:55:41.654 -> 21353 TSF:MSG:PINGED,ID=1,HP=1
18:55:41.691 -> 21392 TSF:MSG:SEND,0-0-1-1,s=255,c=3,t=25,pt=1,l=1,sg=0,ft=0,st=OK:1
18:55:41.758 -> 21464 TSF:MSG:READ,1-1-0,s=255,c=3,t=15,pt=6,l=2,sg=0:0100
18:55:41.824 -> 21528 TSF:MSG:SEND,0-0-1-1,s=255,c=3,t=15,pt=6,l=2,sg=0,ft=0,st=OK:0100
18:55:41.862 -> 21603 TSF:MSG:READ,1-1-0,s=255,c=0,t=17,pt=0,l=5,sg=0:2.3.1
18:55:41.933 -> 21666 TSF:MSG:READ,1-1-0,s=255,c=3,t=6,pt=1,l=1,sg=0:0
18:55:43.860 -> 23552 TSF:MSG:READ,1-1-0,s=255,c=3,t=11,pt=0,l=22,sg=0:TemperatureAndHumidity
18:55:43.930 -> 23634 TSF:MSG:READ,1-1-0,s=255,c=3,t=12,pt=0,l=3,sg=0:1.1
18:55:44.002 -> 23695 TSF:MSG:READ,1-1-0,s=0,c=0,t=7,pt=0,l=0,sg=0:
18:55:44.040 -> 23750 TSF:MSG:READ,1-1-0,s=1,c=0,t=6,pt=0,l=0,sg=0:
18:55:45.938 -> 25632 TSF:MSG:READ,1-1-0,s=255,c=3,t=26,pt=1,l=1,sg=0:2
18:55:45.973 -> 25697 TSF:MSG:SEND,0-0-1-1,s=255,c=3,t=27,pt=1,l=1,sg=0,ft=0,st=OK:1
Si je comprends bien, ma GW voit ma sonde DHT22 ?

Si oui, j'ai deux NRF HS (dont celui avec l'antenne externe) sur les 4 que j'ai...

Pour l'adresse IP, c'est parce que je suis actuellement en DHCP. Pour l'instant je laisse ma box gérer, je verrais par la suite.

EDIT : Je viens de trouver ca une page sur le site qui permet d'aider à interpréter les log https://www.mysensors.org/build/parser
d'après le log du noeud, il voit bien la GW
Dernière édition par LestatSan le 09 août 2019, 19:37, édité 1 fois.

Répondre

Revenir vers « [Plugin Tiers] MySensors »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité