Ce Forum passera en lecture seule en janvier 2020
Image
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

Nouveau protocole rfxcom pour MCZ

Retrouvez ici des sujets concernant le protocole RFXcom et les modules domotiques compatibles RFXcom (Chacon, DI-O, Oregon, Blyss, etc...) utilisés avec JEEDOM
spud
Timide
Messages : 93
Inscription : 05 août 2016, 14:09

Re: Nouveau protocole rfxcom pour MCZ

Message par spud » 15 janv. 2019, 22:56

Essaye de t’inspirer du scénario de gidom en page 8 j’avais le même style de problème il fallait que je remette les slider du poêle à une certaine position pour ne plus avoir d’erreur dans le log du rfxcom et par la suite j’ai remplacé les slider par des boutons et depuis plus de problème

bosquo342
Timide
Messages : 43
Inscription : 13 avr. 2016, 09:33

Re: Nouveau protocole rfxcom pour MCZ

Message par bosquo342 » 15 janv. 2019, 23:36

l' ensemble est identique à Gidom déja c'était nikel et d un coup paffff des erreurs et plus rien ne fonctionne...
Dernière édition par bosquo342 le 15 janv. 2019, 23:51, édité 1 fois.

GiDom
Actif
Messages : 513
Inscription : 26 oct. 2016, 18:52
Localisation : Haute Saône (70)

Re: Nouveau protocole rfxcom pour MCZ

Message par GiDom » 15 janv. 2019, 23:42

Bonsoir, essayez de tout mettre à 3 flamme & fan après la commande auto avec des pauses de 2s entre chaque.

Je suis en bip off tout le temps.

J'ai pas le xl et un poêle 2 ventilos mais depuis que je fais ça j'ai plus de problème. Avant j'en avait comme vous avec des non démarrages, c'était pas WAF :)
NUC sous EXSI et Jeedom 3.2.11 sur VM Debian9 / Zwave / MySensors / Remora / RFXCOM433E / Xiaomi Home / Volets sous ESPEASY / Squeezebox / ZoneMinder

bosquo342
Timide
Messages : 43
Inscription : 13 avr. 2016, 09:33

Re: Nouveau protocole rfxcom pour MCZ

Message par bosquo342 » 15 janv. 2019, 23:46

Voici le code du scenario :

Code : Tout sélectionner

- Nom du scénario : Mode auto 2
- Objet parent : Salon
- Mode du scénario : provoke



    
    ACTION
     #[Salon][Pellet][Flamme]# - Options : {"enable":"1","background":"0","slider":"3"}
     (sleep) Pause de  : 5
     #[Salon][Pellet][Ventilateur]# - Options : {"enable":"1","background":"0","slider":"3"}
     (sleep) Pause de  : 5
     #[Salon][Pellet][Ventilateur 2]# - Options : {"enable":"1","background":"0","slider":"3"}
         
        DANS 15
        FAIRE
         (scenario) activate de [Salon][Mode auto 3]
         (scenario) deactivate de [Salon][Mode auto 2]

GiDom
Actif
Messages : 513
Inscription : 26 oct. 2016, 18:52
Localisation : Haute Saône (70)

Re: Nouveau protocole rfxcom pour MCZ

Message par GiDom » 16 janv. 2019, 00:29

C'est peut être un soucis sur le xl ou alors à cause des 3 ventilos ?

Vous êtes bien en version stable du plugin jeedom?
NUC sous EXSI et Jeedom 3.2.11 sur VM Debian9 / Zwave / MySensors / Remora / RFXCOM433E / Xiaomi Home / Volets sous ESPEASY / Squeezebox / ZoneMinder

bosquo342
Timide
Messages : 43
Inscription : 13 avr. 2016, 09:33

Re: Nouveau protocole rfxcom pour MCZ

Message par bosquo342 » 16 janv. 2019, 00:34

Oui je suis en version stable et tout fonctionnait très bien :(

Envoyé de mon SM-G950F en utilisant Tapatalk


Lodge
Timide
Messages : 67
Inscription : 04 janv. 2019, 16:58

Re: Nouveau protocole rfxcom pour MCZ

Message par Lodge » 16 janv. 2019, 07:54

Le firmware du XL peut-être?
Certains ont eu des anomalies avec le XL en firmware récent (postérieur à la version du plugin). Perso, j'ai la version 1028.

bosquo342
Timide
Messages : 43
Inscription : 13 avr. 2016, 09:33

Re: Nouveau protocole rfxcom pour MCZ

Message par bosquo342 » 18 janv. 2019, 07:48

Alors petit retour, après un retour du support j ai réinstallé l ensemble du plugin rfxcom et j ai changé le cable usb par un nouveau de meilleur qualité. J avais encore des erreurs mais le rfxcom fonctionnait de temps à autre. J ai ensuite placé un hub USB auto-alimenté et depuis les deux changement je n ai plus d erreur de transmission. Peut être que le xl demande plus d énergie que le normale et que la box ne parvient pas à lui donner. Cela fait maintenant 1 jours que il tourne très bien . Firmware version 1030. Je ne met pas à jour je vais essayer de garder cette configuration.

Envoyé de mon SM-G950F en utilisant Tapatalk


GiDom
Actif
Messages : 513
Inscription : 26 oct. 2016, 18:52
Localisation : Haute Saône (70)

Re: Nouveau protocole rfxcom pour MCZ

Message par GiDom » 18 janv. 2019, 18:13

bosquo342 a écrit :
18 janv. 2019, 07:48
Alors petit retour, après un retour du support j ai réinstallé l ensemble du plugin rfxcom et j ai changé le cable usb par un nouveau de meilleur qualité. J avais encore des erreurs mais le rfxcom fonctionnait de temps à autre. J ai ensuite placé un hub USB auto-alimenté et depuis les deux changement je n ai plus d erreur de transmission. Peut être que le xl demande plus d énergie que le normale et que la box ne parvient pas à lui donner. Cela fait maintenant 1 jours que il tourne très bien . Firmware version 1030. Je ne met pas à jour je vais essayer de garder cette configuration.

Envoyé de mon SM-G950F en utilisant Tapatalk
Super, merci pour ton retour qui pourra servir à d'autres.
NUC sous EXSI et Jeedom 3.2.11 sur VM Debian9 / Zwave / MySensors / Remora / RFXCOM433E / Xiaomi Home / Volets sous ESPEASY / Squeezebox / ZoneMinder

misterbebel
Timide
Messages : 16
Inscription : 27 févr. 2017, 22:19

Re: Nouveau protocole rfxcom pour MCZ

Message par misterbebel » 19 janv. 2019, 18:07

Hello

Moi c'est tjs la galère... même une simple commande auto pour le démarrage ne passe pas, pourtant le rfxcom est à 3m (+1 cloison placo) du poêle....

Scénario :
1.png
1.png (426.62 Kio) Consulté 583 fois
Log du scénario :

Code : Tout sélectionner

------------------------------------
[2019-01-19 18:00:54][SCENARIO] Start : Scenario lance manuellement.
[2019-01-19 18:00:54][SCENARIO] Exécution du sous-élément de type [action] : action
[2019-01-19 18:00:54][SCENARIO] Exécution de la commande [Séjour][Poele][Auto]
[2019-01-19 18:00:54][SCENARIO] Exécution d'un bloc élément : 173
[2019-01-19 18:00:54][SCENARIO] Tâche : 173 programmé à : 2019-01-19 18:10:54 (+ 10 min)
[2019-01-19 18:00:54][SCENARIO] Fin correcte du scénario
Log du rfxcom :

Code : Tout sélectionner

[2019-01-19 18:00:54][DEBUG] : Special function execCmd143 return  : 0C430202456302010102020200
[2019-01-19 17:00:54][DEBUG] : Client connected to [127.0.0.1:38186]
[2019-01-19 17:00:54][DEBUG] : Message read from socket: {"apikey":"m1CYwOpLd8wZnfZ9P3PleGKKwp1B7sI6","cmd":"send","data":["0C430202456302010102020200"]}
[2019-01-19 17:00:54][DEBUG] : Client disconnected from [127.0.0.1:38186]
[2019-01-19 17:00:54][DEBUG] : Message received in socket JEEDOM_SOCKET_MESSAGE
[2019-01-19 17:00:54][DEBUG] : Test message: 0C430202456302010102020200
[2019-01-19 17:00:54][DEBUG] : flushOutput serial port
[2019-01-19 17:00:54][DEBUG] : flushInput serial port
[2019-01-19 17:00:54][DEBUG] : Write message to serial port
[2019-01-19 17:00:54][DEBUG] : Write data to serial port : 0C 43 02 02 45 63 02 01 01 02 02 02 00
[2019-01-19 17:00:54][DEBUG] : Write message ok : 0C 43 02 02 45 63 02 01 01 02 02 02 00
[2019-01-19 17:00:54][DEBUG] : Decode message
[2019-01-19 17:00:54][DEBUG] : Decode : 0C 43 02 02 45 63 02 01 01 02 02 02 00
[2019-01-19 17:00:54][DEBUG] : Test message: 0C 43 02 02 45 63 02 01 01 02 02 02 00
[2019-01-19 17:00:54][DEBUG] : PacketType: 43
[2019-01-19 17:00:54][DEBUG] : SubType: 02
[2019-01-19 17:00:54][DEBUG] : SeqNbr: 02
[2019-01-19 17:00:54][DEBUG] : Id1: 45
[2019-01-19 17:00:54][DEBUG] : Id2: 63
[2019-01-19 17:00:54][DEBUG] : Decode data : {'subtype': '02', 'packettype': '43', 'raw': '0C430202456302010102020200'}
[2019-01-19 17:00:54][DEBUG] : Message: 14 01 FF 02 45 53 19 08 8C 3F 00 01 03 1C 03 52 69 58 43 4F 4D
[2019-01-19 17:00:54][DEBUG] : Decode : 14 01 FF 02 45 53 19 08 8C 3F 00 01 03 1C 03 52 69 58 43 4F 4D
[2019-01-19 17:00:54][DEBUG] : Test message: 14 01 FF 02 45 53 19 08 8C 3F 00 01 03 1C 03 52 69 58 43 4F 4D
[2019-01-19 17:00:54][DEBUG] : PacketType: 01
[2019-01-19 17:00:54][DEBUG] : SubType: FF
[2019-01-19 17:00:54][DEBUG] : SeqNbr: 02
[2019-01-19 17:00:54][DEBUG] : Id1: 45
[2019-01-19 17:00:54][DEBUG] : Id2: 53
[2019-01-19 17:00:54][DEBUG] : Subtype			= Unknown type (01)
[2019-01-19 17:00:54][DEBUG] : Sequence nbr		= 02
[2019-01-19 17:00:54][ERROR] : Error: unrecognizable packet (14 01 FF 02 45 53 19 08 8C 3F 00 01 03 1C 03 52 69 58 43 4F 4D) : '45'
Je me demande si les sondes oregon ne viennent pas foutre le binz en même temps...

GiDom
Actif
Messages : 513
Inscription : 26 oct. 2016, 18:52
Localisation : Haute Saône (70)

Re: Nouveau protocole rfxcom pour MCZ

Message par GiDom » 20 janv. 2019, 13:05

Salut essaye de désactiver tous les protocoles. Est ce que ça fonctionne en passant par le rfxcom seul ?
NUC sous EXSI et Jeedom 3.2.11 sur VM Debian9 / Zwave / MySensors / Remora / RFXCOM433E / Xiaomi Home / Volets sous ESPEASY / Squeezebox / ZoneMinder

spud
Timide
Messages : 93
Inscription : 05 août 2016, 14:09

Re: Nouveau protocole rfxcom pour MCZ

Message par spud » 20 janv. 2019, 13:14

Et une commande ECO car moi la commande AUTO me mettait une erreur mais en ECO le poêle démarre

Lodge
Timide
Messages : 67
Inscription : 04 janv. 2019, 16:58

Re: Nouveau protocole rfxcom pour MCZ

Message par Lodge » 20 janv. 2019, 13:22

On dirait qu'il y a plusieurs transmissions dans la même seconde.

bosquo342
Timide
Messages : 43
Inscription : 13 avr. 2016, 09:33

Re: Nouveau protocole rfxcom pour MCZ

Message par bosquo342 » 20 janv. 2019, 15:47

Peut être une pause de 5 s entre chaque commandes ?

Envoyé de mon SM-G950F en utilisant Tapatalk


spud
Timide
Messages : 93
Inscription : 05 août 2016, 14:09

Re: Nouveau protocole rfxcom pour MCZ

Message par spud » 20 janv. 2019, 18:10

De plus le scénario qui est en photo ce n'est pas le scénario de commande mais le scénario qui active le scénario de commandes.

Mon scénario de démarrage qui fonctionne très bien même si maintenant je pourrai retirer le bip car il ne fonctionne plus sur mon poêle (mon poêle à presque 10 ans)
démarrage.jpg
démarrage.jpg (222.07 Kio) Consulté 541 fois

misterbebel
Timide
Messages : 16
Inscription : 27 févr. 2017, 22:19

Re: Nouveau protocole rfxcom pour MCZ

Message par misterbebel » 20 janv. 2019, 21:35

Merci pour tous vos conseils, je vais faire les modifs conseillées et je reviens vers vous ;)

bosquo342
Timide
Messages : 43
Inscription : 13 avr. 2016, 09:33

Re: Nouveau protocole rfxcom pour MCZ

Message par bosquo342 » 09 févr. 2019, 09:50

Bonjour , Pourrait on connaître la sortie de la maj pour mcz avec 3 fans car je possède un mcz et j aimerais exploiter les 3 fans. Passer en plugin bêta je ne suis pas trop chaud ... ou alors comment envoyer la commande pour le fan 3 avec le plugin stable ? Merci

Envoyé de mon SM-G950F en utilisant Tapatalk


Petit_Malin
Timide
Messages : 4
Inscription : 06 mars 2019, 13:51

Re: Nouveau protocole rfxcom pour MCZ

Message par Petit_Malin » 06 mars 2019, 13:57

Bonjour à tous,

Quelqu'un a-t-il réussi à configurer un MCZ EGO/STAR qui utilise ce type de télécommande :

Image

Je n'ai malheureusement pas la télécommande pour afficher la tram dans RfxCom
J'ai testé avec une télécommande affichage LCD d'un ami mais elle n'utilise pas la même tram :(

Merci d'avance pour vos retour

bosquo342
Timide
Messages : 43
Inscription : 13 avr. 2016, 09:33

Re: Nouveau protocole rfxcom pour MCZ

Message par bosquo342 » 09 mars 2019, 19:35

A mon avis votre télécommande ressemble à une télécommande infrarouge et pas une commande rf.
Y a t il un genre de petite led transparente ou noir à l avant de la télécommande ?


Envoyé de mon SM-G950F en utilisant Tapatalk


bosquo342
Timide
Messages : 43
Inscription : 13 avr. 2016, 09:33

Re: Nouveau protocole rfxcom pour MCZ

Message par bosquo342 » 10 mars 2019, 19:44

Bon bah voila je viens de retester le version beta avec mon rfxcom XL et mon feu mcz 3 fans.
Le feu ne reçoit rien. Dans les logs j'ai :

Code : Tout sélectionner

[2019-03-10 17:45:04][ERROR] : Invalid message from socket.
[2019-03-10 17:45:05][ERROR] : Invalid message from socket.
[2019-03-10 17:45:05][ERROR] : Invalid message from socket.
[2019-03-10 17:45:05][ERROR] : Invalid message from socket.
[2019-03-10 18:24:27][ERROR] : Invalid message from socket.
[2019-03-10 18:24:27][ERROR] : Invalid message from socket.
[2019-03-10 18:24:27][ERROR] : Invalid message from socket.
[2019-03-10 18:24:27][ERROR] : Invalid message from socket.
[2019-03-10 18:24:28][ERROR] : Invalid message from socket.
[2019-03-10 18:24:33][ERROR] : Invalid message from socket.
[2019-03-10 18:24:37][ERROR] : Invalid message from socket.
[2019-03-10 18:24:37][ERROR] : Invalid message from socket.
[2019-03-10 18:24:37][ERROR] : Invalid message from socket.
[2019-03-10 18:24:38][ERROR] : Invalid message from socket.
[2019-03-10 18:24:38][ERROR] : Invalid message from socket.
[2019-03-10 18:24:43][ERROR] : Invalid message from socket.
[2019-03-10 18:24:49][ERROR] : Invalid message from socket.
[2019-03-10 18:24:49][ERROR] : Invalid message from socket.
[2019-03-10 18:24:49][ERROR] : Invalid message from socket.
[2019-03-10 18:24:49][ERROR] : Invalid message from socket.
[2019-03-10 18:24:50][ERROR] : Invalid message from socket.
[2019-03-10 18:24:55][ERROR] : Invalid message from socket.
[2019-03-10 18:25:00][ERROR] : Invalid message from socket.
[2019-03-10 18:25:03][ERROR] : Invalid message from socket.
[2019-03-10 18:25:03][ERROR] : Invalid message from socket.
[2019-03-10 18:25:03][ERROR] : Invalid message from socket.
[2019-03-10 18:25:03][ERROR] : Invalid message from socket.
[2019-03-10 18:25:05][ERROR] : Invalid message from socket.
[2019-03-10 18:31:44][ERROR] : Invalid message from socket.
[2019-03-10 18:33:01][ERROR] : Invalid message from socket.
Avec un décalage de une heure par rapport au log de la version stable.
En stable avec le rfxcom Xl et le feu configuré en 2 fans je n'ai aucun problèmes de fonctionnement.
Je ne sais pas si je peux aider autrement ? ( loic ? :p )

Cela me serait bien utile que le troisième fan soit activé :) surtout en cette période

Merci d'avance a tous pour le travail réalisé

Répondre

Revenir vers « [Plugin Officiel] RFXcom »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité