Avant toute chose merci de (re)prendre connaissance de la charte et de la respecter.
Pour résumer :
- Avant de poser une question, je cherche si la réponse existe
- Je suis poli, courtois et je respecte tout un chacun sur le forum
- Si un post m'agace : je m'en éloigne plutôt que de répondre d'une façon qui pourrait être mal interprétée


Il n'est jamais du luxe que de rappeler des choses simples :
Courtoisie, amabilité, politesse et bonne humeur sont les maîtres mots pour un forum sympathique, bienveillant et accueillant :)

Le groupe des Helpers est present pour vous aidez, n'hésitez pas à poser des questions ;)

Toute la communauté vous remercie

/!\ L’ancien forum passera en lecture seule en janvier 2020 (Si community a bien pris le relais) puis nous le fermerons définitivement en janvier 2021./!\
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

Détecteur d'ouverture SUNLIT TECH SL-WD507

Retrouvez ici des sujets concernant le protocole RFXcom et les modules domotiques compatibles RFXcom (Chacon, DI-O, Oregon, Blyss, etc...) utilisés avec JEEDOM
JeanPierre33
Timide
Messages : 6
Inscription : 24 oct. 2018, 00:24

Détecteur d'ouverture SUNLIT TECH SL-WD507

Message par JeanPierre33 » 24 oct. 2018, 12:59

Bonjour,
Je tente d'intégrer ces détecteurs qui présentent l'avantage d'avoir des états ouverts et fermés différents.
Dans RFXCom le détecteur est immédiatement reconnu, aussi bien en mode insertion que manuellement.
Voici les Logs :

A la fermeture :

[2018-10-23 23:41:08][DEBUG] : Message: 08 20 00 30 0D B1 00 04 70
[2018-10-23 23:41:08][DEBUG] : Decode : 08 20 00 30 0D B1 00 04 70
[2018-10-23 23:41:08][DEBUG] : Test message: 08 20 00 30 0D B1 00 04 70
[2018-10-23 23:41:08][DEBUG] : PacketType: 20
[2018-10-23 23:41:08][DEBUG] : SubType: 00
[2018-10-23 23:41:08][DEBUG] : SeqNbr: 30
[2018-10-23 23:41:08][DEBUG] : Id1: 0D
[2018-10-23 23:41:08][DEBUG] : Id2: B1
[2018-10-23 23:41:08][DEBUG] : Decode data : {'status': 'Motion', 'raw': '082000300DB1000470', 'battery': '0', 'signal': '7', 'subtype': '00', 'packettype': '20', 'id': '0DB100'}
[2018-10-23 23:41:08][DEBUG] : Send to jeedom : {'devices': {'0DB10020': {'status': 'Motion', 'raw': '082000300DB1000470', 'battery': '0', 'signal': '7', 'subtype': '00', 'packettype': '20', 'id': '0DB100'}}}
[2018-10-23 23:41:08][DEBUG] : Starting new HTTP connection (1): 127.0.0.1
[2018-10-23 23:41:10][DEBUG] : http://127.0.0.1:80 "POST /plugins/rfxcom/core/php/jeeRfxcom.php?apikey=TjWu6w1Sig3fnfxq0Cd88x0CaLBBTh2l HTTP/1.1" 200 0

A l'ouverture :

[2018-10-23 23:41:12][DEBUG] : Message: 08 20 00 31 0D B1 00 02 70
[2018-10-23 23:41:12][DEBUG] : Decode : 08 20 00 31 0D B1 00 02 70
[2018-10-23 23:41:12][DEBUG] : Test message: 08 20 00 31 0D B1 00 02 70
[2018-10-23 23:41:12][DEBUG] : PacketType: 20
[2018-10-23 23:41:12][DEBUG] : SubType: 00
[2018-10-23 23:41:12][DEBUG] : SeqNbr: 31
[2018-10-23 23:41:12][DEBUG] : Id1: 0D
[2018-10-23 23:41:12][DEBUG] : Id2: B1
[2018-10-23 23:41:12][DEBUG] : Decode data : {'status': 'Alarm', 'raw': '082000310DB1000270', 'battery': '0', 'signal': '7', 'subtype': '00', 'packettype': '20', 'id': '0DB100'}
[2018-10-23 23:41:12][DEBUG] : Send to jeedom : {'devices': {'0DB10020': {'status': 'Alarm', 'raw': '082000310DB1000270', 'battery': '0', 'signal': '7', 'subtype': '00', 'packettype': '20', 'id': '0DB100'}}}
[2018-10-23 23:41:12][DEBUG] : Starting new HTTP connection (1): 127.0.0.1
[2018-10-23 23:41:13][DEBUG] : http://127.0.0.1:80 "POST /plugins/rfxcom/core/php/jeeRfxcom.php?apikey=TjWu6w1Sig3fnfxq0Cd88x0CaLBBTh2l HTTP/1.1" 200 0

L'état est la valeur de "status" : "Motion" pour la fermeture et "Alarm" pour l'ouverture, donc à ce niveau tout va bien !

Le problème apparait au niveau au niveau de l'équipement car quelque soit le mouvement, la valeur retournée est 1, pourtant c'est bien "status" qui est pris en compte et la variable est bien alphanumérique (String)
Commande_Rfxcom .png
Commandes associées à l'équipement
Commande_Rfxcom .png (29.96 Kio) Consulté 160 fois
Configuration_Rfxcom.png
Configuration de la commande "position"
Configuration_Rfxcom.png (50.03 Kio) Consulté 160 fois
Avez-vous une idée de la façon dont je pourrai récupérer la valeur émise par le module ?

Merci d'avance

Pascal67
Timide
Messages : 4
Inscription : 21 août 2018, 15:50

Re: Détecteur d'ouverture SUNLIT TECH SL-WD507

Message par Pascal67 » 17 mars 2019, 12:00

Bonjour,

J'ai le même problème.
Impossible d'avoir un retour "Alarm" ou "Motion", la valeur reste également à 1.

En analysant le raw, j'ai vu que :
à la fermeture "Motion" correspond à : 082000300DB1000470 (ou 04 ?)
à l'ouverture "Alarm" correspond à 082000310DB1000270 (ou 02?)
Pour plus se facilité, j'ai repris vos raw, mais chez moi c'est la même chose.

Mais je suis également bloqué à ce stade.
Avez-vous trouvé une solutions ?

Merci pour votre aide,

Répondre

Revenir vers « [Plugin Officiel] RFXcom »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité