Ce Forum passera en lecture seule en janvier 2020
Image
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

(résolu) demon nook encore et encore!!

Retrouvez ici des sujets concernant le protocole RFXcom et les modules domotiques compatibles RFXcom (Chacon, DI-O, Oregon, Blyss, etc...) utilisés avec JEEDOM
dln35
Timide
Messages : 33
Inscription : 16 avr. 2019, 17:02

(résolu) demon nook encore et encore!!

Message par dln35 » 05 sept. 2019, 16:14

bonjour à tous,

Voilà je m'en remet à vous car là je sèche avec ce rfxcom!

je suis sous jeedom 3.3.30 dockerisé.

toute mon install fonctionne au poil (zwave....) et comme j'ai 2 volet somfy je me suis offert le rfxcom pour compléter mon installation.

mon rfxcom est bien reconnu par mon syno en ttyUSB1, la clé zwave étant en ttyUSB0.

j'installe le plugin (en 3.1), je l'active, les dépendances OK et vous l'aurez compris demon NOOK.

voici le log en mode debug:

Code : Tout sélectionner

[2019-09-05 15:49:33][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consecutivement
[2019-09-05 13:50:03][ERROR] : Timeout waiting status 
[2019-09-05 15:51:17][INFO] : Lancement démon rfxcomd : /usr/bin/python /var/www/html/plugins/rfxcom/resources/rfxcomd/rfxcomd.py --device /dev/ttyUSB1 --loglevel debug --socketport 55000 --serialrate 38400 --protocol 12,13,18,20,21,22,23 --callback http://127.0.0.1:80/plugins/rfxcom/core/php/jeeRfxcom.php --apikey TDBNHFNeC2ZvGF658aJFhaxZ6RXY9ebK --cycle 0.3 --pid /tmp/jeedom/rfxcom/deamon.pid
[2019-09-05 13:51:17][INFO] : Start rfxcomd
[2019-09-05 13:51:17][INFO] : Log level : debug
[2019-09-05 13:51:17][INFO] : Socket port : 55000
[2019-09-05 13:51:17][INFO] : Socket host : 127.0.0.1
[2019-09-05 13:51:17][INFO] : PID file : /tmp/jeedom/rfxcom/deamon.pid
[2019-09-05 13:51:17][INFO] : Device : /dev/ttyUSB1
[2019-09-05 13:51:17][INFO] : Apikey : TDBNHFNeC2ZvGF658aJFhaxZ6RXY9ebK
[2019-09-05 13:51:17][INFO] : Callback : http://127.0.0.1:80/plugins/rfxcom/core/php/jeeRfxcom.php
[2019-09-05 13:51:17][INFO] : Cycle : 0.3
[2019-09-05 13:51:17][INFO] : Serial rate : 38400
[2019-09-05 13:51:17][INFO] : Serial timeout : 9
[2019-09-05 13:51:17][INFO] : Protocol : 12,13,18,20,21,22,23
[2019-09-05 13:51:17][DEBUG] : Writing PID 2995 to /tmp/jeedom/rfxcom/deamon.pid
[2019-09-05 13:51:17][DEBUG] : Init request module v2.12.4
[2019-09-05 13:51:17][DEBUG] : Starting new HTTP connection (1): 127.0.0.1
[2019-09-05 13:51:17][DEBUG] : http://127.0.0.1:80 "GET /plugins/rfxcom/core/php/jeeRfxcom.php?apikey=TDBNHFNeC2ZvGF658aJFhaxZ6RXY9ebK HTTP/1.1" 200 0
[2019-09-05 13:51:17][DEBUG] : Init serial module v3.2.1
[2019-09-05 13:51:17][DEBUG] : Start listening...
[2019-09-05 13:51:17][DEBUG] : Socket interface started
[2019-09-05 13:51:17][DEBUG] : LoopNetServer Thread started
[2019-09-05 13:51:17][DEBUG] : Open serial port on device: /dev/ttyUSB1, rate 38400, timeout : 9
[2019-09-05 13:51:17][DEBUG] : Listening on: [127.0.0.1:55000]
[2019-09-05 13:51:17][DEBUG] : Open Serialport
[2019-09-05 13:51:17][DEBUG] : flushOutput serial port 
[2019-09-05 13:51:17][DEBUG] : flushInput serial port 
[2019-09-05 13:51:17][DEBUG] : flushOutput serial port 
[2019-09-05 13:51:17][DEBUG] : flushInput serial port 
[2019-09-05 13:51:17][DEBUG] : Read Socket Thread Launched
[2019-09-05 13:51:17][DEBUG] : Read Device Thread Launched
[2019-09-05 13:51:18][DEBUG] : Send rfxcomd_reset
[2019-09-05 13:51:18][DEBUG] : Write data to serial port : 0D 00 00 00 00 00 00 00 00 00 00 00 00 00
[2019-09-05 13:51:18][DEBUG] : Sleep 1 sec
[2019-09-05 13:51:19][DEBUG] : flushInput serial port 
[2019-09-05 13:51:19][DEBUG] : Send get status test
[2019-09-05 13:51:19][DEBUG] : Write data to serial port : 0D 00 00 01 02 00 00 00 00 00 00 00 00 00
[2019-09-05 13:51:20][DEBUG] : Client connected to [127.0.0.1:39095]
[2019-09-05 13:51:20][DEBUG] : Message read from socket: {"apikey":"TDBNHFNeC2ZvGF658aJFhaxZ6RXY9ebK","cmd":"add","device":{"id":"0D6F1F"}}
[2019-09-05 13:51:20][DEBUG] : Client disconnected from [127.0.0.1:39095]
[2019-09-05 15:51:20][INFO] : Démon RFXcom lancé
[2019-09-05 13:51:20][DEBUG] : Message received in socket JEEDOM_SOCKET_MESSAGE
[2019-09-05 13:51:20][DEBUG] : Add device : {u'id': u'0D6F1F'}
[2019-09-05 13:51:31][DEBUG] : Message: 06 84 31 0F 04 FE 06
[2019-09-05 13:51:31][DEBUG] : Decode : 06 84 31 0F 04 FE 06
[2019-09-05 13:51:31][DEBUG] : Test message: 06 84 31 0F 04 FE 06
[2019-09-05 13:51:31][DEBUG] : PacketType: 84
[2019-09-05 13:51:31][DEBUG] : SubType: 31
[2019-09-05 13:51:31][DEBUG] : SeqNbr: 0F
[2019-09-05 13:51:31][DEBUG] : Id1: 04
[2019-09-05 13:51:31][DEBUG] : Id2: FE
[2019-09-05 13:51:31][DEBUG] : Decode data : {'subtype': '31', 'packettype': '84', 'raw': '0684310F04FE06'}
[2019-09-05 13:51:46][ERROR] : Timeout waiting status 
[2019-09-05 13:51:46][DEBUG] : Shutdown
[2019-09-05 13:51:46][DEBUG] : Removing PID file /tmp/jeedom/rfxcom/deamon.pid
[2019-09-05 13:51:47][DEBUG] : LoopNetServer Thread stopped
[2019-09-05 13:51:47][DEBUG] : Close serial port
[2019-09-05 13:51:47][DEBUG] : Serial port closed
[2019-09-05 13:51:47][DEBUG] : Exit 0
Peut-être un conflit entre ma clé et le rfx car un dmesg sur le syno me sort les 2 comme "cp210" où un truc dans le genre enfin je sais pas trop si il y a un lien!
je suis pas spécialiste en log mais bon la seul erreur que je vois c'est le "Timeout waiting status" seulement quant à savoir pourquoi, je vois pas!

si une ame charitable à déjà rencontré ce problème.
Dernière édition par dln35 le 13 sept. 2019, 14:52, édité 1 fois.

Avatar de l’utilisateur
loic
Administrateur
Messages : 14865
Inscription : 01 févr. 2014, 16:21

Re: demon nook encore et encore!!

Message par loic » 05 sept. 2019, 16:17

A mon avis la le firmware du rfxcom est pas a jour.

Hésites pas a consulter la documentation du plugin car ton erreur est documenté ainsi que sa résolution...
Aide nous à t'aider : mets des logs, détaille ton soucis... Vous n'aurez aucune réponse de ma part si votre demande n'est pas détaillée (log, capture d'écran lisible...) ou si vous ne postez pas dans la bonne section

dln35
Timide
Messages : 33
Inscription : 16 avr. 2019, 17:02

Re: demon nook encore et encore!!

Message par dln35 » 05 sept. 2019, 17:43

merci loic je regarde cela, effectivement j'ai lu dans d'autre post que cela pouvait être du au firmware!

dln35
Timide
Messages : 33
Inscription : 16 avr. 2019, 17:02

Re: demon nook encore et encore!!

Message par dln35 » 05 sept. 2019, 19:05

bon cela n'a rien changé! mise à jour en 10.41 et toujours pareil!
redémarré le nas, jeedom, relancé les dependances, le demon rien n'y fait!

un défaut du rfxcom?

Avatar de l’utilisateur
loic
Administrateur
Messages : 14865
Inscription : 01 févr. 2014, 16:21

Re: demon nook encore et encore!!

Message par loic » 05 sept. 2019, 19:13

Je sais pas en tout cas il répond pas comme attendu ça peut être aussi du a Docker... On a jamais testé dessus
Aide nous à t'aider : mets des logs, détaille ton soucis... Vous n'aurez aucune réponse de ma part si votre demande n'est pas détaillée (log, capture d'écran lisible...) ou si vous ne postez pas dans la bonne section

dln35
Timide
Messages : 33
Inscription : 16 avr. 2019, 17:02

Re: (résolu) demon nook encore et encore!!

Message par dln35 » 13 sept. 2019, 14:55


Répondre

Revenir vers « [Plugin Officiel] RFXcom »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 8 invités