Ce Forum passera en lecture seule en janvier 2020
Image
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

Installation Onocean - le mode inclusion ne fonctionne pas

Retrouvez ici des sujets concernant le protocole EnOcean et les modules domotiques de type EnOcean utilisés avec JEEDOM

Modérateur : Patrick

Répondre
gilles666
Timide
Messages : 12
Inscription : 21 janv. 2016, 12:07

Installation Onocean - le mode inclusion ne fonctionne pas

Message par gilles666 » 29 mars 2019, 19:41

Bonjour
Le plugin EnOcean démarre et s'installe mais le click sur "Mode inclusion" ou "Mode Exclusion" ne donne rien.

J'ai installé le plugin EnOcean depuis le market en version 2019-02-28 15:57:26 et ma jeedom est en version 3.3.19
Ces versions sont-elles compatibles?
Sinon comme faire?

Merci

Avatar de l’utilisateur
Patrick
Helper
Messages : 1007
Inscription : 29 août 2014, 15:21
Localisation : Savoie

Re: Installation Onocean - le mode inclusion ne fonctionne pas

Message par Patrick » 29 mars 2019, 20:22

Si tu ne donne pas de logs ni d'autres précisions, je vais attendre que madame Irma me dise ce qu'elle voit dans sa boule de cristal...
Et si elle me répond, promis, je te le dirai... :-)
ßêta-Testeur / Développeur plugin / Modérateur du Forum EnOcean

En domotique ou en informatique, il n'y a pas de problème, mais seulement des solutions à trouver...
Pour contribuer au développement des plugins et tutos : Paypal

gilles666
Timide
Messages : 12
Inscription : 21 janv. 2016, 12:07

Re: Installation Onocean - le mode inclusion ne fonctionne pas

Message par gilles666 » 29 mars 2019, 20:30

Voici les logs du plugin en démarrage ci-dessous



[2019-03-29 19:27:45][DEBUG] : Lancement de : /var/www/html/core/class/../../core/php/jeePlugin.php plugin_id=openenocean function=remove callInstallFunction=1
[2019-03-29 19:29:22][INFO] : Début d'activation du plugin
[2019-03-29 19:29:23][INFO] : Info sur le démon : Array ( [log] => openenocean [state] => nok [launchable] => nok [launchable_message] => Gestion automatique désactivée [auto] => 0 [last_launch] => Inconnue )
[2019-03-29 19:29:23][DEBUG] : Lancement de : /var/www/html/core/class/../../core/php/jeePlugin.php plugin_id=openenocean function=install callInstallFunction=1
[2019-03-29 19:29:55][INFO] : Lancement démon openenocean : /usr/bin/python /var/www/html/plugins/openenocean/resources/openenoceand/openenoceand.py --device auto --loglevel info --socketport 55006 --callback http://127.0.0.1:80/plugins/openenocean ... nOcean.php --apikey pMtI4t6hiHw2uLgVWPqxPs5faBubRb67 --cycle 0.3 --pid /tmp/jeedom/openenocean/deamon.pid
[2019-03-29 18:29:57][INFO] : Start openenoceand
[2019-03-29 18:29:57][INFO] : Log level : info
[2019-03-29 18:29:57][INFO] : Socket port : 55006
[2019-03-29 18:29:57][INFO] : Socket host : 127.0.0.1
[2019-03-29 18:29:57][INFO] : PID file : /tmp/jeedom/openenocean/deamon.pid
[2019-03-29 18:29:57][INFO] : Apikey : pMtI4t6hiHw2uLgVWPqxPs5faBubRb67
[2019-03-29 18:29:57][INFO] : Callback : http://127.0.0.1:80/plugins/openenocean ... nOcean.php
[2019-03-29 18:29:57][INFO] : Cycle : 0.3
[2019-03-29 18:29:57][INFO] : Find device : /dev/ttyUSB0
[2019-03-29 18:29:57][INFO] : Loading profile file : D2-01-0B.xml
[2019-03-29 18:29:57][INFO] : Loading profile file : D2-01-06.xml
[2019-03-29 18:29:57][INFO] : Loading profile file : D2-01-11.xml
[2019-03-29 18:29:57][INFO] : Loading profile file : D2-01-05.xml
[2019-03-29 18:29:57][INFO] : Loading profile file : D2-01-12.xml
[2019-03-29 18:29:57][INFO] : Loading profile file : D2-01-04.xml
[2019-03-29 18:29:58][INFO] : Loading profile file : D2-01-03.xml
[2019-03-29 18:29:58][INFO] : Loading profile file : D2-01-09.xml
[2019-03-29 18:29:58][INFO] : Loading profile file : D2-01-08.xml
[2019-03-29 18:29:58][INFO] : Loading profile file : D2-01-0A.xml
[2019-03-29 18:29:58][INFO] : Loading profile file : D2-01-0F.xml
[2019-03-29 18:29:58][INFO] : Loading profile file : D2-01-10.xml
[2019-03-29 18:29:58][INFO] : Loading profile file : D2-01-0C.xml
[2019-03-29 18:29:58][INFO] : Loading profile file : D2-01-00.xml
[2019-03-29 18:29:59][INFO] : Loading profile file : D2-01-01.xml
[2019-03-29 18:29:59][INFO] : Loading profile file : D2-01-02.xml
[2019-03-29 18:29:59][INFO] : Loading profile file : D2-01-07.xml
[2019-03-29 18:29:59][INFO] : Loading profile file : D2-01-0E.xml
[2019-03-29 18:29:59][INFO] : Loading profile file : D2-01-0D.xml
[2019-03-29 18:29:59][INFO] : Loading profile file : D2-03-0A.xml
[2019-03-29 18:29:59][INFO] : Loading profile file : D2-14-30.xml
[2019-03-29 18:29:59][INFO] : Loading profile file : D2-05-00.xml
[2019-03-29 18:29:59][INFO] : Loading profile file : D2-06-01.xml
[2019-03-29 18:29:59][INFO] : Loading profile file : D2-32-01.xml
[2019-03-29 18:29:59][INFO] : Loading profile file : D2-32-00.xml
[2019-03-29 18:29:59][INFO] : Loading profile file : D2-32-02.xml
[2019-03-29 18:29:59][INFO] : Loading profile file : D2-04-08.xml
[2019-03-29 18:29:59][INFO] : Loading profile file : A5-30-01.xml
[2019-03-29 18:29:59][INFO] : Loading profile file : A5-3F-7F.xml
[2019-03-29 18:29:59][INFO] : Loading profile file : A5-06-01.xml
[2019-03-29 18:29:59][INFO] : Loading profile file : A5-06-02.xml
[2019-03-29 18:29:59][INFO] : Loading profile file : A5-06-03.xml
[2019-03-29 18:29:59][INFO] : Loading profile file : A5-09-07.xml
[2019-03-29 18:29:59][INFO] : Loading profile file : A5-09-05.xml
[2019-03-29 18:29:59][INFO] : Loading profile file : A5-09-04.xml
[2019-03-29 18:29:59][INFO] : Loading profile file : A5-09-06.xml
[2019-03-29 18:29:59][INFO] : Loading profile file : A5-12-10.xml
[2019-03-29 18:29:59][INFO] : Loading profile file : A5-12-00.xml
[2019-03-29 18:29:59][INFO] : Loading profile file : A5-12-01.xml
[2019-03-29 18:29:59][INFO] : Loading profile file : A5-04-03.xml
[2019-03-29 18:29:59][INFO] : Loading profile file : A5-04-01.xml
[2019-03-29 18:29:59][INFO] : Loading profile file : A5-04-02.xml
[2019-03-29 18:29:59][INFO] : Loading profile file : A5-02-30.xml
[2019-03-29 18:29:59][INFO] : Loading profile file : A5-02-10.xml
[2019-03-29 18:29:59][INFO] : Loading profile file : A5-02-18.xml
[2019-03-29 18:29:59][INFO] : Loading profile file : A5-02-07.xml
[2019-03-29 18:29:59][INFO] : Loading profile file : A5-02-17.xml
[2019-03-29 18:29:59][INFO] : Loading profile file : A5-02-1B.xml
[2019-03-29 18:29:59][INFO] : Loading profile file : A5-02-09.xml
[2019-03-29 18:29:59][INFO] : Loading profile file : A5-02-16.xml
[2019-03-29 18:29:59][INFO] : Loading profile file : A5-02-12.xml
[2019-03-29 18:29:59][INFO] : Loading profile file : A5-02-11.xml
[2019-03-29 18:30:00][INFO] : Loading profile file : A5-02-20.xml
[2019-03-29 18:30:00][INFO] : Loading profile file : A5-02-0A.xml
[2019-03-29 18:30:00][INFO] : Loading profile file : A5-02-14.xml
[2019-03-29 18:30:00][INFO] : Loading profile file : A5-02-02.xml
[2019-03-29 18:30:00][INFO] : Loading profile file : A5-02-19.xml
[2019-03-29 18:30:00][INFO] : Loading profile file : A5-02-01.xml
[2019-03-29 18:30:00][INFO] : Loading profile file : A5-02-05.xml
[2019-03-29 18:30:00][INFO] : Loading profile file : A5-02-1A.xml
[2019-03-29 18:30:00][INFO] : Loading profile file : A5-02-04.xml
[2019-03-29 18:30:00][INFO] : Loading profile file : A5-02-08.xml
[2019-03-29 18:30:00][INFO] : Loading profile file : A5-02-0B.xml
[2019-03-29 18:30:00][INFO] : Loading profile file : A5-02-03.xml
[2019-03-29 18:30:00][INFO] : Loading profile file : A5-02-06.xml
[2019-03-29 18:30:00][INFO] : Loading profile file : A5-02-15.xml
[2019-03-29 18:30:00][INFO] : Loading profile file : A5-02-13.xml
[2019-03-29 18:30:00][INFO] : Loading profile file : A5-11-02.xml
[2019-03-29 18:30:00][INFO] : Loading profile file : A5-38-08.xml
[2019-03-29 18:30:00][INFO] : Loading profile file : A5-07-01.xml
[2019-03-29 18:30:00][INFO] : Loading profile file : A5-07-03.xml
[2019-03-29 18:30:00][INFO] : Loading profile file : A5-20-01.xml
[2019-03-29 18:30:00][INFO] : Loading profile file : A5-14-01.xml
[2019-03-29 18:30:00][INFO] : Loading profile file : A5-14-05.xml
[2019-03-29 18:30:00][INFO] : Loading profile file : A5-10-06.xml
[2019-03-29 18:30:00][INFO] : Loading profile file : A5-10-03.xml
[2019-03-29 18:30:00][INFO] : Loading profile file : A5-10-04.xml
[2019-03-29 18:30:00][INFO] : Loading profile file : A5-10-01.xml
[2019-03-29 18:30:00][INFO] : Loading profile file : D5-00-01.xml
[2019-03-29 18:30:00][INFO] : Loading profile file : F6-02-03.xml
[2019-03-29 18:30:00][INFO] : Loading profile file : F6-02-04.xml
[2019-03-29 18:30:00][INFO] : Loading profile file : F6-02-01.xml
[2019-03-29 18:30:00][INFO] : Loading profile file : F6-02-02.xml
[2019-03-29 18:30:00][INFO] : Loading profile file : F6-05-01.xml
[2019-03-29 18:30:00][INFO] : Loading profile file : F6-04-01.xml
[2019-03-29 18:30:00][INFO] : Loading profile file : F6-10-00.xml
[2019-03-29 18:30:00][INFO] : Loading profile file : F6-03-01.xml
[2019-03-29 18:30:00][INFO] : Successfully loaded 87 profiles !
[2019-03-29 18:30:00][INFO] : SerialCommunicator started
[2019-03-29 18:30:00][INFO] : Sending packet
[2019-03-29 18:30:00][INFO] : Sending packet
[2019-03-29 18:30:00][INFO] : Sending packet
[2019-03-29 18:30:00][INFO] : The Base ID of your controler is FFB23980.
[2019-03-29 18:30:00][INFO] : Sending packet
[2019-03-29 18:30:00][INFO] : Sending packet
[2019-03-29 18:30:00][INFO] : Sending packet

Avatar de l’utilisateur
Patrick
Helper
Messages : 1007
Inscription : 29 août 2014, 15:21
Localisation : Savoie

Re: Installation Onocean - le mode inclusion ne fonctionne pas

Message par Patrick » 30 mars 2019, 07:40

okay, ben je ne vois rien d'anormal...

Je ne comprend pas ce qui te fait dire que l'inclusion ne fonctionne pas en V3.3.19 !


Tu es certain que le problème ne vient pas de ton module ou de ta manière de faire l'inclusion ?

quand tu dis :
Le plugin EnOcean démarre et s'installe mais le click sur "Mode inclusion" ou "Mode Exclusion" ne donne rien.
Tu t'attends à quoi au juste ?

Décris nous ton process d'inclusion...
ßêta-Testeur / Développeur plugin / Modérateur du Forum EnOcean

En domotique ou en informatique, il n'y a pas de problème, mais seulement des solutions à trouver...
Pour contribuer au développement des plugins et tutos : Paypal

gilles666
Timide
Messages : 12
Inscription : 21 janv. 2016, 12:07

Re: Installation Onocean - le mode inclusion ne fonctionne pas

Message par gilles666 » 30 mars 2019, 10:17

Quand je suis sur l'écran de gestion du plugin Enocean,
PluginEnocean.JPG
PluginEnocean.JPG (21.4 Kio) Consulté 396 fois
quand je clique sur le bouton "Mode inclusion" ou "Mode exclusion" ou "Santé" rien ne se passe.
Aucun message apparait pour débuter l'inclusion. Je m'attends à avoir le processus similaire au plugin zWave qui lui fonctionne très bien
Seul le bouton "Configuration" affiche le paramétrage du plugin.

En controlant les versions plugin et jeedom, est-ce que le module EnOcean en version 3.2.12 fonctionne sur la version Jeedom 3.3.19?
PluginEnocean.JPG
PluginEnocean.JPG (21.4 Kio) Consulté 396 fois
Merci
Pièces jointes
version.png
version.png (79.66 Kio) Consulté 396 fois

gilles666
Timide
Messages : 12
Inscription : 21 janv. 2016, 12:07

Re: Installation Onocean - le mode inclusion ne fonctionne pas

Message par gilles666 » 30 mars 2019, 12:50

Le clic sur le "Mode inclusion" ne fait aucune action mais si j'active l'inclusion sur un capteur EnOcean, la trace debug donne.

[2019-03-30 11:47:41][DEBUG] : [85, 0, 10, 7, 1, 235, 165, 8, 40, 70, 128, 1, 138, 69, 151, 0, 1, 255, 255, 255, 255, 73, 0, 248]
[2019-03-30 11:47:41][DEBUG] : learn received, EEP detected, RORG: 0xA5, FUNC: 0x02, TYPE: 0x05, Manufacturer: 0x46
[2019-03-30 11:47:41][DEBUG] : 01:8A:45:97->FF:FF:FF:FF (-73 dBm): 0x01 ['0xa5', '0x8', '0x28', '0x46', '0x80', '0x1', '0x8a', '0x45', '0x97', '0x0'] ['0x1', '0xff', '0xff', '0xff', '0xff', '0x49', '0x0'] OrderedDict()
[2019-03-30 11:47:41][DEBUG] : Message is repeated 0 times
[2019-03-30 11:47:41][DEBUG] : Not decode because it's an unknown device or I'am not in learn mode

Comment activer ce "learn mode"?

gilles666
Timide
Messages : 12
Inscription : 21 janv. 2016, 12:07

Re: Installation Onocean - le mode inclusion ne fonctionne pas

Message par gilles666 » 30 mars 2019, 14:36

C’est résolu!!! Cela fonctionne en Chrome ou Edge
Mais pas sous Ie11!!!

Fil
Timide
Messages : 113
Inscription : 18 nov. 2014, 08:46

Re: Installation Onocean - le mode inclusion ne fonctionne pas

Message par Fil » 12 août 2019, 22:10

Bonsoir,

J'ai le même soucis sous debian 9 et Jeedom 3.3.29 après une réinstallation et remise d'un backup. Demon OK et port OK
Voici le log

[2019-08-12 22:05:22][DEBUG] : Client connected to [127.0.0.1:52136]
[2019-08-12 22:05:22][DEBUG] : Message read from socket: {"apikey":"*****************************","cmd":"learnin"}
[2019-08-12 22:05:22][DEBUG] : Client disconnected from [127.0.0.1:52136]
[2019-08-12 22:05:22][DEBUG] : Message received in socket JEEDOM_SOCKET_MESSAGE
[2019-08-12 22:05:22][DEBUG] : Received command from jeedom : learnin
[2019-08-12 22:05:22][DEBUG] : Enter in learn mode
[2019-08-12 22:05:22][DEBUG] : Send to jeedom : {'learn_mode': 1}
[2019-08-12 22:05:22][DEBUG] : Starting new HTTP connection (1): 127.0.0.1
[2019-08-12 22:05:22][DEBUG] : http://127.0.0.1:80 "POST /plugins/openenocean/core/php/jeeOpenEnOcean.php?apikey=**********************HTTP/1.1" 200 0
[2019-08-12 22:05:36][DEBUG] : [85, 0, 7, 7, 1, 122, 213, 8, 1, 140, 82, 161, 0, 1, 255, 255, 255, 255, 77, 0, 185]
[2019-08-12 22:05:36][DEBUG] : 01:8C:52:A1->FF:FF:FF:FF (-77 dBm): 0x01 ['0xd5', '0x8', '0x1', '0x8c', '0x52', '0xa1', '0x0'] ['0x1', '0xff', '0xff', '0xff', '0xff', '0x4d', '0x0'] OrderedDict()
[2019-08-12 22:05:36][DEBUG] : Message is repeated 0 times
[2019-08-12 22:05:36][DEBUG] : Not decode because it's an unknown device or I'am not in learn mode
[2019-08-12 22:07:20][DEBUG] : [85, 0, 7, 7, 1, 122, 213, 9, 1, 140, 82, 161, 0, 1, 255, 255, 255, 255, 79, 0, 7]
[2019-08-12 22:07:20][DEBUG] : 01:8C:52:A1->FF:FF:FF:FF (-79 dBm): 0x01 ['0xd5', '0x9', '0x1', '0x8c', '0x52', '0xa1', '0x0'] ['0x1', '0xff', '0xff', '0xff', '0xff', '0x4f', '0x0'] OrderedDict()
[2019-08-12 22:07:20][DEBUG] : Message is repeated 0 times
[2019-08-12 22:07:20][DEBUG] : Not decode because it's an unknown device or I'am not in learn mode
[2019-08-12 22:07:44][DEBUG] : Client connected to [127.0.0.1:52210]
[2019-08-12 22:07:44][DEBUG] : Message read from socket: {"apikey":******************************j","cmd":"learnout"}
[2019-08-12 22:07:44][DEBUG] : Client disconnected from [127.0.0.1:52210]
[2019-08-12 22:07:44][DEBUG] : Message received in socket JEEDOM_SOCKET_MESSAGE
[2019-08-12 22:07:44][DEBUG] : Received command from jeedom : learnout
[2019-08-12 22:07:44][DEBUG] : Leave learn mode
[2019-08-12 22:07:44][DEBUG] : Send to jeedom : {'learn_mode': 0}
[2019-08-12 22:07:44][DEBUG] : Starting new HTTP connection (1): 127.0.0.1
[2019-08-12 22:07:44][DEBUG] : http://127.0.0.1:80 "POST /plugins/openenocean/core/php/jeeOpenEnOcean.php?apikey=************************ HTTP/1.1" 200 0



Acune inclusion possible.
gilles666, comment as-tu résolu le problème ?

Merci

Gilles
Dernière édition par Fil le 13 août 2019, 08:17, édité 1 fois.

Avatar de l’utilisateur
Patrick
Helper
Messages : 1007
Inscription : 29 août 2014, 15:21
Localisation : Savoie

Re: Installation Onocean - le mode inclusion ne fonctionne pas

Message par Patrick » 13 août 2019, 07:18

As-tu essayé avec un autre navigateur (c'est ce qu'a fait Gilles66) ?
Et évite de laisser ton apikey dans les logs sur les forums par sécurité... ;-)
ßêta-Testeur / Développeur plugin / Modérateur du Forum EnOcean

En domotique ou en informatique, il n'y a pas de problème, mais seulement des solutions à trouver...
Pour contribuer au développement des plugins et tutos : Paypal

Avatar de l’utilisateur
Patrick
Helper
Messages : 1007
Inscription : 29 août 2014, 15:21
Localisation : Savoie

Re: Installation Onocean - le mode inclusion ne fonctionne pas

Message par Patrick » 13 août 2019, 11:01

Quels sont les derniers plugins que tu as installé (pour voir si cela pourrait être un effet de bord) ?
ßêta-Testeur / Développeur plugin / Modérateur du Forum EnOcean

En domotique ou en informatique, il n'y a pas de problème, mais seulement des solutions à trouver...
Pour contribuer au développement des plugins et tutos : Paypal

Avatar de l’utilisateur
Patrick
Helper
Messages : 1007
Inscription : 29 août 2014, 15:21
Localisation : Savoie

Re: Installation Onocean - le mode inclusion ne fonctionne pas

Message par Patrick » 13 août 2019, 11:51

Après vérification, le problème doit venir de la façon dont tu fais l'inclusion de ton module...
Décris nous ton process STP...
ßêta-Testeur / Développeur plugin / Modérateur du Forum EnOcean

En domotique ou en informatique, il n'y a pas de problème, mais seulement des solutions à trouver...
Pour contribuer au développement des plugins et tutos : Paypal

Répondre

Revenir vers « [Plugin Officiel] EnOcean »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 6 invités