Avant toute chose merci de (re)prendre connaissance de la charte et de la respecter.
Pour résumer :
- Avant de poser une question, je cherche si la réponse existe
- Je suis poli, courtois et je respecte tout un chacun sur le forum
- Si un post m'agace : je m'en éloigne plutôt que de répondre d'une façon qui pourrait être mal interprétée


Il n'est jamais du luxe que de rappeler des choses simples :
Courtoisie, amabilité, politesse et bonne humeur sont les maîtres mots pour un forum sympathique, bienveillant et accueillant :)

Toute la communauté vous remercie

Hager TS101 USB - Démon OK, mais bus muet [clos]

Retrouvez ici des sujets concernant le protocole KNX et les modules domotiques de type KNX utilisés avec JEEDOM
/!\ Plugin KNX non officiel
salbrecht
Timide
Messages : 29
Inscription : 19 févr. 2018, 10:57
Contact :

Re: Hager TS101 USB - Démon OK, mais bus muet

Message par salbrecht » 19 févr. 2018, 19:51

j'ai pas compris le dernier message. ajouter le port USB ?
Jeedom-PI3-250Go, Rfxcom, Zwave, Téléinfo, Relais IP, Station Météo HP1000, Syno DS217j, UPS, Routeur Asus RT-AC68UF Merlin, Google Home, Yeelight.

Avatar de l’utilisateur
poluket
Actif
Messages : 834
Inscription : 19 août 2017, 17:02
Localisation : Chastre - Belgique
Contact :

Re: Hager TS101 USB - Démon OK, mais bus muet

Message par poluket » 19 févr. 2018, 20:02

bcuaddrtab -w0 usb:1:4:1:0:0 && eibd -d -D -S -T -i -e 15.15.255 usb:1:4:1:0:0
Installation KNX + Sonos + Xiaomi Yeelight + Jeedom sur VM Proxmox + wifi unifi avec contrôleur + NAS DS1513+ + UPS + PFsense FW

salbrecht
Timide
Messages : 29
Inscription : 19 févr. 2018, 10:57
Contact :

Re: Hager TS101 USB - Démon OK, mais bus muet

Message par salbrecht » 19 févr. 2018, 20:06

mais pas de différence.

root@jeedom:~# bcuaddrtab -w0 usb:1:4:1:0:0 && eibd -d -D -S -T -i -e 15.15.255 usb:1:4:1:0:0
Size 0 written
Erreur de segmentation
root@jeedom:~# vbusmonitor1 ip:localhost
Open failed: Connection refused
root@jeedom:~#
Jeedom-PI3-250Go, Rfxcom, Zwave, Téléinfo, Relais IP, Station Météo HP1000, Syno DS217j, UPS, Routeur Asus RT-AC68UF Merlin, Google Home, Yeelight.

Avatar de l’utilisateur
poluket
Actif
Messages : 834
Inscription : 19 août 2017, 17:02
Localisation : Chastre - Belgique
Contact :

Re: Hager TS101 USB - Démon OK, mais bus muet

Message par poluket » 19 févr. 2018, 20:21

Rien a voir. Je pars sur une autre piste. Dans la config du plugin, il faut pas donner une adresse Knx a la passerelle USB? Par ce que, dans sa config, rien n'est donné. Je sais que en IP c'est pas nécessaire mais pour l'usb, je sais pas. Mais cela me semblerait logique d'en mettre une.

C'est avec quelle commande que tu as eu ce retour:
Layer 2(009B4BA8,5A8B1446) Recv L_Data low from 0.1.2 to 2/0/3 hops: 06 T_DATA_XXX_REQ A_GroupValue_Write 00

Parce que a ce moment, ta config était bonne
Installation KNX + Sonos + Xiaomi Yeelight + Jeedom sur VM Proxmox + wifi unifi avec contrôleur + NAS DS1513+ + UPS + PFsense FW

salbrecht
Timide
Messages : 29
Inscription : 19 févr. 2018, 10:57
Contact :

Re: Hager TS101 USB - Démon OK, mais bus muet

Message par salbrecht » 19 févr. 2018, 20:41

tu m'avais demandé de lancer :

eibd -S -T -i -e 15.15.255 -t65535 usb:1:4:1:0:0

il a causé et attendait les évènements. J'ai appuyé sur des touches physiques de l'installation qui ouvrent et ferment un volet.
j'ai eu des blocs et j'ai sorti cette ligne.
Jeedom-PI3-250Go, Rfxcom, Zwave, Téléinfo, Relais IP, Station Météo HP1000, Syno DS217j, UPS, Routeur Asus RT-AC68UF Merlin, Google Home, Yeelight.

salbrecht
Timide
Messages : 29
Inscription : 19 févr. 2018, 10:57
Contact :

Re: Hager TS101 USB - Démon OK, mais bus muet

Message par salbrecht » 19 févr. 2018, 20:43

un appui donne:

Layer 10(01884020,5A8B28A6) LoopProcess
Layer 10(01884020,5A8B28A6) LoopEnd
Layer 10(01884020,5A8B28A6) LoopBegin
Layer 10(01884020,5A8B28A6) LoopWait
Layer 0(018A4B78,5A8B28A6) RecvComplete 64
Layer 0(018A4B78,5A8B28A6) RecvUSB(064): 01 13 12 00 08 00 0A 01 01 00 00 49 BC 01 02 10 03 E2 00 80 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
Layer 0(018A4B78,5A8B28A6) StartRecv
Layer 1(018A4B78,5A8B28A6) Recv(064): 01 13 12 00 08 00 0A 01 01 00 00 49 BC 01 02 10 03 E2 00 80 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
Layer 0(018A4C40,5A8B28A6) RecvEMI(010): 49 BC 01 02 10 03 E2 00 80 00
Layer 2(018A5BA8,5A8B28A6) Recv L_Data low from 0.1.2 to 2/0/3 hops: 06 T_DATA_XXX_REQ A_GroupValue_Write 00
Layer 2(018A5BA8,5A8B28A6) Recv L_Data low from 0.1.2 to 2/0/3 hops: 06 T_DATA_XXX_REQ A_GroupValue_Write 00
Layer 3(018A5F38,5A8B28A6) Recv L_Data low from 0.1.2 to 2/0/3 hops: 06 T_DATA_XXX_REQ A_GroupValue_Write 00
Jeedom-PI3-250Go, Rfxcom, Zwave, Téléinfo, Relais IP, Station Météo HP1000, Syno DS217j, UPS, Routeur Asus RT-AC68UF Merlin, Google Home, Yeelight.

Avatar de l’utilisateur
poluket
Actif
Messages : 834
Inscription : 19 août 2017, 17:02
Localisation : Chastre - Belgique
Contact :

Re: Hager TS101 USB - Démon OK, mais bus muet

Message par poluket » 19 févr. 2018, 21:19

Tu saurais mettre un screenshot de ta config du plugin Knx. Parce que pour moi, eidb est bien installé et fonctionnel.
Installation KNX + Sonos + Xiaomi Yeelight + Jeedom sur VM Proxmox + wifi unifi avec contrôleur + NAS DS1513+ + UPS + PFsense FW

salbrecht
Timide
Messages : 29
Inscription : 19 févr. 2018, 10:57
Contact :

Re: Hager TS101 USB - Démon OK, mais bus muet

Message par salbrecht » 19 févr. 2018, 21:37

Jeedom-PI3-250Go, Rfxcom, Zwave, Téléinfo, Relais IP, Station Météo HP1000, Syno DS217j, UPS, Routeur Asus RT-AC68UF Merlin, Google Home, Yeelight.

Avatar de l’utilisateur
poluket
Actif
Messages : 834
Inscription : 19 août 2017, 17:02
Localisation : Chastre - Belgique
Contact :

Re: Hager TS101 USB - Démon OK, mais bus muet

Message par poluket » 19 févr. 2018, 21:52

Essaye de mettre 15.15.255 comme adresse a la place de 0.0.0 et redémarre le démon si nécessaire.
Installation KNX + Sonos + Xiaomi Yeelight + Jeedom sur VM Proxmox + wifi unifi avec contrôleur + NAS DS1513+ + UPS + PFsense FW

salbrecht
Timide
Messages : 29
Inscription : 19 févr. 2018, 10:57
Contact :

Re: Hager TS101 USB - Démon OK, mais bus muet

Message par salbrecht » 19 févr. 2018, 22:00

pas de changement... mais maintenant que je peux voir des adresses, je vais creuser de ce côté.
Jeedom-PI3-250Go, Rfxcom, Zwave, Téléinfo, Relais IP, Station Météo HP1000, Syno DS217j, UPS, Routeur Asus RT-AC68UF Merlin, Google Home, Yeelight.

Avatar de l’utilisateur
poluket
Actif
Messages : 834
Inscription : 19 août 2017, 17:02
Localisation : Chastre - Belgique
Contact :

Re: Hager TS101 USB - Démon OK, mais bus muet

Message par poluket » 19 févr. 2018, 22:11

Tu vois des évents dans le moniteur de bus de jeedom?

L'adresse que je t'ai demandé de mettre est une adresse par défaut. Normalement, tu devrais mettre une adresse en 0.1.x il faut prendre un x qui n'est pas encore utilisé dans ta config. Sans ets ou la config c'est difficile a savoir. Mais si tu te mets dans les 200 (par exemple 0.1.210) tu devrais pas avoir de problème de conflit avec une adresse déjà existante.
Installation KNX + Sonos + Xiaomi Yeelight + Jeedom sur VM Proxmox + wifi unifi avec contrôleur + NAS DS1513+ + UPS + PFsense FW

salbrecht
Timide
Messages : 29
Inscription : 19 févr. 2018, 10:57
Contact :

Re: Hager TS101 USB - Démon OK, mais bus muet

Message par salbrecht » 20 févr. 2018, 13:37

non toujours rien dans le moniteur. j'étudie les adresses dans le terminal.

à quoi sert le deuxième champ dans "adressage des connexions" ?

http://www.madeinalbrecht.fr/screen/screen1.png
Jeedom-PI3-250Go, Rfxcom, Zwave, Téléinfo, Relais IP, Station Météo HP1000, Syno DS217j, UPS, Routeur Asus RT-AC68UF Merlin, Google Home, Yeelight.

Avatar de l’utilisateur
mika-nt28
Actif
Messages : 5833
Inscription : 05 août 2014, 08:58
Localisation : Dreux - France

Re: Hager TS101 USB - Démon OK, mais bus muet

Message par mika-nt28 » 20 févr. 2018, 14:00

Avec cette instruction eibd -S -T -i -e 15.15.255 -t65535 usb:1:4:1:0:0 tu vois des event passé mais pas sur jeedom c'est bien ca

Essaye avec
eibd --daemon=/var/log/knx.log --pid-file=/var/run/knx.pid --eibaddr=15.15.255 -t65535 -D -T -S --listen-tcp=6720 usb:1:4:1:0:0


Ce parametre -t65535 je ne le connais pas

salbrecht
Timide
Messages : 29
Inscription : 19 févr. 2018, 10:57
Contact :

Re: Hager TS101 USB - Démon OK, mais bus muet

Message par salbrecht » 20 févr. 2018, 14:18

apparemment, -t correspond à "-t, --trace=LEVEL set trace level"

voilà le retour de la commande :

root@jeedom:~# eibd --daemon=/var/log/knx.log --pid-file=/var/run/knx.pid --eibaddr=15.15.255 -t65535 -D -T -S --listen-tcp=6720 usb:1:4:1:0:0
Layer 7(00000000,5A8C1F25) EIBD should not run as root
W00000001: EIBD should not run as root


root@jeedom:~# cat /var/log/knx.log

Layer 10(00426020,5A8C1F25) USBLoop-Create
Layer 1(00446B78,5A8C1F25) Detect
Layer 1(00446B78,5A8C1F25) Using 1:4:1:0:0 (2:129)
Layer 1(00446B78,5A8C1F25) Open
Layer 1(00446B78,5A8C1F25) Claimed
Layer 1(00446B78,5A8C1F25) Opened
Layer 1(00446B78,5A8C1F25) Send(064): 01 13 09 00 08 00 01 0F 01 00 00 01 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
Layer 10(00426020,5A8C1F25) LoopStart
Layer 10(00426020,5A8C1F25) LoopBegin
Layer 10(00426020,5A8C1F25) LoopWait
Layer 0(00446B78,5A8C1F25) StartRecv
Layer 0(00446B78,5A8C1F25) Send(064): 01 13 09 00 08 00 01 0F 01 00 00 01 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
Layer 0(00446B78,5A8C1F25) StartSend
Layer 10(00426020,5A8C1F25) LoopProcess
Layer 10(00426020,5A8C1F25) LoopEnd
Layer 10(00426020,5A8C1F25) LoopBegin
Layer 10(00426020,5A8C1F25) LoopWait
Layer 0(00446B78,5A8C1F25) SendComplete 64
Layer 10(00426020,5A8C1F25) LoopProcess
Layer 10(00426020,5A8C1F25) LoopEnd
Layer 10(00426020,5A8C1F25) LoopBegin
Layer 10(00426020,5A8C1F25) LoopWait
Layer 0(00446B78,5A8C1F25) RecvComplete 64
Layer 0(00446B78,5A8C1F25) RecvUSB(064): 01 13 0B 00 08 00 03 0F 02 00 00 01 00 01 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
Layer 0(00446B78,5A8C1F25) StartRecv
Layer 1(00446B78,5A8C1F25) Recv(064): 01 13 0B 00 08 00 03 0F 02 00 00 01 00 01 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
Layer 1(00446B78,5A8C1F25) Send(064): 01 13 0A 00 08 00 02 0F 03 00 00 05 01 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
Layer 0(00446B78,5A8C1F25) Send(064): 01 13 0A 00 08 00 02 0F 03 00 00 05 01 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
Layer 0(00446B78,5A8C1F25) StartSend
Layer 1(00446C40,5A8C1F25) EMI1
Layer 2(00447BA8,5A8C1F25) Open
Layer 2(00447BA8,5A8C1F25) Opened
Layer 3(00447F38,5A8C1F25) Open
Layer 2(00447BA8,5A8C1F25) OpenL2
Layer 0(00446C40,5A8C1F25) Send-EMI(005): 46 01 00 60 12
Layer 1(00446B78,5A8C1F25) Send(064): 01 13 0D 00 08 00 05 01 01 00 00 46 01 00 60 12 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
Layer 10(00426020,5A8C1F25) LoopProcess
Layer 10(00426020,5A8C1F25) LoopEnd
Layer 10(00426020,5A8C1F25) LoopBegin
Layer 10(00426020,5A8C1F25) LoopWait
Layer 0(00446B78,5A8C1F25) SendComplete 64
Layer 0(00446B78,5A8C1F25) Send(064): 01 13 0D 00 08 00 05 01 01 00 00 46 01 00 60 12 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
Layer 0(00446B78,5A8C1F25) StartSend
Layer 10(00426020,5A8C1F25) LoopProcess
Layer 10(00426020,5A8C1F25) LoopEnd
Layer 10(00426020,5A8C1F25) LoopBegin
Layer 10(00426020,5A8C1F25) LoopWait
Layer 0(00446B78,5A8C1F25) SendComplete 64
Layer 8(00447230,5A8C1F25) OpenInetSocket 6720
Layer 8(00447230,5A8C1F25) InetSocket opened
Layer 8(00447AE8,5A8C1F25) Open
Layer 0(00447FB8,5A8C1F25) Open
Layer 0(00447FB8,5A8C1F25) Openend
Layer 3(00447F38,5A8C1F25) registerBroadcast 00447AE8
Layer 3(00447F38,5A8C1F25) registerBroadcast 00447AE8 = 1
Layer 3(00447F38,5A8C1F25) registerGroup 00447AE8
Layer 3(00447F38,5A8C1F25) registerGroup 00447AE8 = 1
Layer 3(00447F38,5A8C1F25) registerIndividual 00447AE8 0
Layer 3(00447F38,5A8C1F25) registerIndividual 00447AE8 = 1
Layer 8(00447AE8,5A8C1F25) Opened
Layer 4(004491C0,5A8C1F25) GroupCacheInit
Layer 10(00426020,5A8C1F43) LoopProcess
Layer 10(00426020,5A8C1F43) LoopEnd
Layer 10(00426020,5A8C1F43) LoopBegin
Layer 10(00426020,5A8C1F43) LoopWait
Layer 10(00426020,5A8C1F43) LoopProcess
Layer 10(00426020,5A8C1F43) LoopEnd
Layer 10(00426020,5A8C1F43) LoopBegin
Layer 10(00426020,5A8C1F43) LoopWait
Layer 0(00446B78,5A8C1F43) RecvError 2
Layer 0(00446B78,5A8C1F43) StartRecv
root@jeedom:~#


J'ai aussi trouvé sur git, le paramètre automatique qui n'est plus d'actualité :

https://jeedom.github.io/documentation/ ... index.html partie 2.2
Jeedom-PI3-250Go, Rfxcom, Zwave, Téléinfo, Relais IP, Station Météo HP1000, Syno DS217j, UPS, Routeur Asus RT-AC68UF Merlin, Google Home, Yeelight.

Avatar de l’utilisateur
mika-nt28
Actif
Messages : 5833
Inscription : 05 août 2014, 08:58
Localisation : Dreux - France

Re: Hager TS101 USB - Démon OK, mais bus muet

Message par mika-nt28 » 20 févr. 2018, 14:45

Je vais mettre a jours la documentation car effectivement ce point n'a pas du etre mise a jours depuis un moment

salbrecht
Timide
Messages : 29
Inscription : 19 févr. 2018, 10:57
Contact :

Re: Hager TS101 USB - Démon OK, mais bus muet

Message par salbrecht » 20 févr. 2018, 19:29

et par rapport à l'instruction que tu m'as demandé de tester, tu vois un truc qui cloche ?

j'en profite pour redemander à quoi sert le deuxième champ dans "adressage des connexions" ?

Merci pour vos réponses.
Jeedom-PI3-250Go, Rfxcom, Zwave, Téléinfo, Relais IP, Station Météo HP1000, Syno DS217j, UPS, Routeur Asus RT-AC68UF Merlin, Google Home, Yeelight.

Avatar de l’utilisateur
poluket
Actif
Messages : 834
Inscription : 19 août 2017, 17:02
Localisation : Chastre - Belgique
Contact :

Re: Hager TS101 USB - Démon OK, mais bus muet

Message par poluket » 20 févr. 2018, 20:11

adressage des connexions, c'est l'adresse que tu va donner a ta passerelle knx coté KNX. avec une passerelle ip, cette fonction ne sert a rien parce que l'adresse est configurée dessus, un peu comme son IP par contre en usb ou serial, il est necessaire de la donner pour se mettre dans le bon adressage. et normalement l'adresse 0.0.0 ne peut pas etre utilisée, elle est réservée. et l'adresse 15.15.255 est l'adresse par defaut de tout module KNX avant config. comme cela tu sais tout :)

le -t65535, c'est le mode debug version tres bavard.

et si tu fais cette commande:
eibd --trace=1 -d -D -S -T -i -e 15.15.255 usb:1:4:1:0:0

cela marche? (vérifie juste avant qu'il n'y a pas d'autres services eidb qui tournent)
et si cela tourne, cette commande pour monitorer (puis appuyer sur des boutons physiques):
vbusmonitor1 ip:localhost
Installation KNX + Sonos + Xiaomi Yeelight + Jeedom sur VM Proxmox + wifi unifi avec contrôleur + NAS DS1513+ + UPS + PFsense FW

salbrecht
Timide
Messages : 29
Inscription : 19 févr. 2018, 10:57
Contact :

Re: Hager TS101 USB - Démon OK, mais bus muet [clos]-[partiellement résolu]

Message par salbrecht » 22 févr. 2018, 06:53

Au final :

- le démon se lance
- le monitor et le log du plugin reste désespérément vide, malgré des modules qui fonctionnent.

J'ait récupéré les adresses des sources et groupes de mon installation à l'aide de la commande :

eibd --trace=1 -d -D -S -T -i -e 15.15.255 usb:1:4:1:0:0

- les modules ont été créés manuellement

Merci pour votre aide.
Jeedom-PI3-250Go, Rfxcom, Zwave, Téléinfo, Relais IP, Station Météo HP1000, Syno DS217j, UPS, Routeur Asus RT-AC68UF Merlin, Google Home, Yeelight.

Avatar de l’utilisateur
mika-nt28
Actif
Messages : 5833
Inscription : 05 août 2014, 08:58
Localisation : Dreux - France

Re: Hager TS101 USB - Démon OK, mais bus muet

Message par mika-nt28 » 22 févr. 2018, 08:06

Les module que tu as cree se mette a jours?

salbrecht
Timide
Messages : 29
Inscription : 19 févr. 2018, 10:57
Contact :

Re: Hager TS101 USB - Démon OK, mais bus muet

Message par salbrecht » 22 févr. 2018, 19:22

j'ai créé des équipements qui activent mes volets, quelque soit la valeur, ils montent. :-) J'ai laissé tombé le moniteur muet.
Je tâtonne pour trouver les bons codes. Le plus amusant, c'est que je bosses avec des techniciens de chez Hager à Saverne (domotique KNX), mais leur structure logiciel n'est pas Jeedom ! ;-)
Jeedom-PI3-250Go, Rfxcom, Zwave, Téléinfo, Relais IP, Station Météo HP1000, Syno DS217j, UPS, Routeur Asus RT-AC68UF Merlin, Google Home, Yeelight.

Répondre

Revenir vers « [Plugin Tiers] KNX »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité