Ce Forum passera en lecture seule en janvier 2020
Image
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

Tuto - netinstall sur Mini + (Solidrun humingboard) via script officiel

Venez discuter de la box JEEDOM MINI et MINI+
crazyfrog
Timide
Messages : 63
Inscription : 01 juil. 2015, 00:29

Re: Tuto - netinstall sur Mini + (Solidrun humingboard) via script officiel

Message par crazyfrog » 09 nov. 2017, 20:53

euh... question conne, je vais faire mon boulet :) . Le disque SSD doit être formaté avant l'opération?

Avatar de l’utilisateur
bronche
Modérateur
Messages : 973
Inscription : 07 janv. 2016, 19:29
Localisation : Du côté de Issy les Moulineaux la semaine et de Péronne le week-end...

Re: Tuto - netinstall sur Mini + (Solidrun humingboard) via script officiel

Message par bronche » 09 nov. 2017, 21:14

Non
Aucune importance.
Phil
Helper Officiel Jeedom
Des images non officielles jeedom maintenues et hébergées par mes soins :
https://queen.useed.fr/SB1268/owncloud/ ... mA9xeSgBgx

crazyfrog
Timide
Messages : 63
Inscription : 01 juil. 2015, 00:29

Re: Tuto - netinstall sur Mini + (Solidrun humingboard) via script officiel

Message par crazyfrog » 12 nov. 2017, 19:45

Je viens de refaire la manipulation de la première page du poste, depuis le début, nouvel échec:
- une erreur au début de l'installation jeedom, mais l'installation a continué :

W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://repo.solid-build.xyz ./ Release: The following signatures were invalid: KEYEXPIRED 1508672008

- Ca s'est terminé avec une autre erreur
...
171112 17:49:09 [Note] /usr/sbin/mysqld (mysqld 5.5.58-0+deb8u1) starting as process 3284 ...
Setting up libhtml-template-perl (2.95-1) ...
Setting up mysql-client (5.5.58-0+deb8u1) ...
Setting up mysql-server (5.5.58-0+deb8u1) ...
Processing triggers for libc-bin (2.19-18+deb8u10) ...
/sbin/ldconfig.real: file /usr/lib/arm-linux-gnueabihf/libssl.so.1.0.0 is truncated

Processing triggers for systemd (215-17+deb8u7) ...
Errors were encountered while processing:
ssl-cert
E: Sub-process /usr/bin/dpkg returned an error code (1)
Could not install mysql-client mysql-common mysql-server - abort

Visiblement cette erreur semble récente, c'est un pb lié à l'image de IMX6/Debian qui n'est plus à jour. Je vais aussi télécharger la dernière version de imx6, la release note indique un correctif sur la clé ( https://images.solid-build.xyz/IMX6/Debian/?C=M;O=D )

Debian Releases for i.MX6

08/11/2017, 09/11/2017: Jessie

includes all updates as of that date
includes renewed apt key
31/10/2017: Jessie

includes all updates as of today
removed legacy dtb symlinks in /boot: u-boot searches there first, and falls back to /boot/dtb-dir/.
(apt-get remove kernel-3.14.y-fslc-imx6-sr dtb-subfolder-compat)

Avatar de l’utilisateur
bronche
Modérateur
Messages : 973
Inscription : 07 janv. 2016, 19:29
Localisation : Du côté de Issy les Moulineaux la semaine et de Péronne le week-end...

Re: Tuto - netinstall sur Mini + (Solidrun humingboard) via script officiel

Message par bronche » 12 nov. 2017, 21:03

Oui
tout à fait possible
Prend la dernière image et tiens moi au courant
https://images.solid-build.xyz/IMX6/Deb ... 108.img.xz
Je modifierai la doc et le tuto
Phil
Helper Officiel Jeedom
Des images non officielles jeedom maintenues et hébergées par mes soins :
https://queen.useed.fr/SB1268/owncloud/ ... mA9xeSgBgx

Avatar de l’utilisateur
bronche
Modérateur
Messages : 973
Inscription : 07 janv. 2016, 19:29
Localisation : Du côté de Issy les Moulineaux la semaine et de Péronne le week-end...

Re: Tuto - netinstall sur Mini + (Solidrun humingboard) via script officiel

Message par bronche » 12 nov. 2017, 22:47

Bonsoir
Bon c'est bien ça.
je viens de tester avec la dernière image solidrun.
Ça passe comme une lettre à la poste, je trouve même l'installation de jeedom beaucoup plus rapide.
Je mets à jour le tuto et la doc.
Bonne soirée
Phil
Helper Officiel Jeedom
Des images non officielles jeedom maintenues et hébergées par mes soins :
https://queen.useed.fr/SB1268/owncloud/ ... mA9xeSgBgx

crazyfrog
Timide
Messages : 63
Inscription : 01 juil. 2015, 00:29

Re: Tuto - netinstall sur Mini + (Solidrun humingboard) via script officiel

Message par crazyfrog » 15 nov. 2017, 23:22

Je confirme, ca fonctionne....... enfin :) . J'avoue que j'ai pas mal galéré pendant trois semaines à faire marcher le bouzin, à faire des tests dans tous les sens. Ca peut vite devenir touchy et je n'ai pas eu de chance. J'avais donc deux problèmes:
- deux cartes SD neuves défaillantes! Mon ancienne carte de 32Go qui contenait la version 1.9 de JEEDOM fonctionne à merveille.
- ce pb de clé qui n'était pas à jour depuis le début du mois, je n'avait pas bien regardé les messages d'erreur au départ..

La prochaine étape, je vais retenter de basculer la config sur la SSD que j'ai acheté.

Je m'interroge quant même sur la qualité des cartes SD, il y a un post qui en parle? Ce serait pas mal de recenser les cartes défaillantes pour essayer de voir s'il y a des séries à pb. Et merci pour le tuto!

Je rajoute que je n'ai jamais réussi à faire le swap du premier coup, même avec la carte SD qui fonctionne. J'ai toujours procédé en deux temps.

Avatar de l’utilisateur
bronche
Modérateur
Messages : 973
Inscription : 07 janv. 2016, 19:29
Localisation : Du côté de Issy les Moulineaux la semaine et de Péronne le week-end...

Re: Tuto - netinstall sur Mini + (Solidrun humingboard) via script officiel

Message par bronche » 16 nov. 2017, 18:14

Bonsoir
Oui pour le swap. Deux manipulations mais sans sortir, il suffit de relancer...
Mystère et boules de gum...
Phil
Helper Officiel Jeedom
Des images non officielles jeedom maintenues et hébergées par mes soins :
https://queen.useed.fr/SB1268/owncloud/ ... mA9xeSgBgx

PHDB
Timide
Messages : 298
Inscription : 01 mars 2016, 13:42

Re: Tuto - netinstall sur Mini + (Solidrun humingboard) via script officiel

Message par PHDB » 20 nov. 2017, 21:28

Bonjour,

j'ai un peu souci avec mes Dash button du coup j'ai voulu faire un "sudo apt-get update", mais sans succès.

Code : Tout sélectionner

debian@linux:~$ sudo apt-get update
[sudo] password for debian:
Get:1 http://security.debian.org jessie/updates InRelease [63.1 kB]
Ign http://http.us.debian.org jessie InRelease
Ign http://httpredir.debian.org jessie InRelease
Hit https://deb.nodesource.com jessie InRelease
Get:2 http://httpredir.debian.org jessie-updates InRelease [145 kB]
Hit http://httpredir.debian.org jessie Release.gpg
Hit http://http.us.debian.org jessie Release.gpg
Get:3 https://repo.solid-build.xyz ./ InRelease [354 B]
Hit http://httpredir.debian.org jessie Release
Ign https://repo.solid-build.xyz ./ InRelease
Hit http://http.us.debian.org jessie Release
Get:4 https://repo.solid-build.xyz ./ Release.gpg [481 B]
Get:5 https://repo.solid-build.xyz ./ Release
Get:6 https://repo.solid-build.xyz ./ Release [982 B]
Get:7 http://security.debian.org jessie/updates/main armhf Packages [479 kB]
Get:8 https://deb.nodesource.com jessie/main Sources [764 B]
Hit http://security.debian.org jessie/updates/main Sources
Get:9 https://deb.nodesource.com jessie/main armhf Packages [968 B]
Get:10 https://deb.nodesource.com jessie/main Translation-en_US [162 B]
Get:11 https://deb.nodesource.com jessie/main Translation-en [162 B]
Hit http://security.debian.org jessie/updates/main Translation-en
Get:12 https://deb.nodesource.com jessie/main Translation-en_US [162 B]
Get:13 https://deb.nodesource.com jessie/main Translation-en [162 B]
Get:14 http://httpredir.debian.org jessie-updates/main Sources [17.2 kB]
Get:15 https://deb.nodesource.com jessie/main Translation-en_US [162 B]
Get:16 https://deb.nodesource.com jessie/main Translation-en [162 B]
Get:17 http://httpredir.debian.org jessie-updates/main armhf Packages/DiffIndex [9,376 B]
Get:18 http://httpredir.debian.org jessie-updates/main Translation-en/DiffIndex [3,688 B]
Get:19 https://deb.nodesource.com jessie/main Translation-en_US [162 B]
Get:20 https://deb.nodesource.com jessie/main Translation-en [162 B]
Get:21 https://deb.nodesource.com jessie/main Translation-en_US [162 B]
Ign https://deb.nodesource.com jessie/main Translation-en_US
Get:22 https://deb.nodesource.com jessie/main Translation-en [162 B]
Ign https://deb.nodesource.com jessie/main Translation-en
Hit http://httpredir.debian.org jessie/main Sources
Hit http://httpredir.debian.org jessie/main armhf Packages
Hit http://httpredir.debian.org jessie/main Translation-en
Err https://repo.solid-build.xyz ./ Release

Hit http://http.us.debian.org jessie/non-free armhf Packages
Hit http://http.us.debian.org jessie/non-free Translation-en
Fetched 703 kB in 26s (26.4 kB/s)
Reading package lists... Done
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://repo.solid-build.xyz ./ Release: The following signatures were invalid: KEYEXPIRED 1508672008

W: Failed to fetch https://repo.solid-build.xyz/debian/jessie/bsp-imx6/./Release

W: Some index files failed to download. They have been ignored, or old ones used instead.
et des erreurs etranges aussi en essyant "sudo apt-get install npm"

Code : Tout sélectionner

debian@linux:~$ sudo apt-get install npm
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 npm : Depends: nodejs but it is not going to be installed
       Depends: node-abbrev (>= 1.0.4) but it is not going to be installed
       Depends: node-ansi (>= 0.3.0-2) but it is not going to be installed
       Depends: node-ansi-color-table but it is not going to be installed
       Depends: node-archy but it is not going to be installed
       Depends: node-block-stream but it is not going to be installed
       Depends: node-fstream (>= 0.1.22) but it is not going to be installed
       Depends: node-fstream-ignore but it is not going to be installed
       Depends: node-github-url-from-git but it is not going to be installed
       Depends: node-glob (>= 3.1.21) but it is not going to be installed
       Depends: node-graceful-fs (>= 2.0.0) but it is not going to be installed
       Depends: node-inherits but it is not going to be installed
       Depends: node-ini (>= 1.1.0) but it is not going to be installed
       Depends: node-lockfile but it is not going to be installed
       Depends: node-lru-cache (>= 2.3.0) but it is not going to be installed
       Depends: node-minimatch (>= 0.2.11) but it is not going to be installed
       Depends: node-mkdirp (>= 0.3.3) but it is not going to be installed
       Depends: node-gyp (>= 0.10.9) but it is not going to be installed
       Depends: node-nopt (>= 3.0.1) but it is not going to be installed
       Depends: node-npmlog but it is not going to be installed
       Depends: node-once but it is not going to be installed
       Depends: node-osenv but it is not going to be installed
       Depends: node-read but it is not going to be installed
       Depends: node-read-package-json (>= 1.1.0) but it is not going to be installed
       Depends: node-request (>= 2.25.0) but it is not going to be installed
       Depends: node-retry but it is not going to be installed
       Depends: node-rimraf (>= 2.2.2) but it is not going to be installed
       Depends: node-semver (>= 2.1.0) but it is not going to be installed
       Depends: node-sha but it is not going to be installed
       Depends: node-slide but it is not going to be installed
       Depends: node-tar (>= 0.1.18) but it is not going to be installed
       Depends: node-underscore but it is not going to be installed
       Depends: node-which but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
debian@linux:~$ sudo apt-get install nodejs
Reading package lists... Done
Building dependency tree
Reading state information... Done
nodejs is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 55 not upgraded.
debian@linux:~$ sudo apt-get install node-abbrev
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
  node-abbrev
0 upgraded, 1 newly installed, 0 to remove and 55 not upgraded.
Need to get 3,540 B of archives.
After this operation, 37.9 kB of additional disk space will be used.
Get:1 http://httpredir.debian.org/debian/ jessie/main node-abbrev all 1.0.5-2 [3,540 B]
Fetched 3,540 B in 0s (10.9 kB/s)
Selecting previously unselected package node-abbrev.
(Reading database ... 57284 files and directories currently installed.)
Preparing to unpack .../node-abbrev_1.0.5-2_all.deb ...
Unpacking node-abbrev (1.0.5-2) ...
Setting up node-abbrev (1.0.5-2) ...
debian@linux:~$ sudo apt-get install npm
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 npm : Depends: nodejs but it is not going to be installed
       Depends: node-abbrev (>= 1.0.4) but it is not going to be installed
       Depends: node-ansi (>= 0.3.0-2) but it is not going to be installed
       Depends: node-ansi-color-table but it is not going to be installed
       Depends: node-archy but it is not going to be installed
       Depends: node-block-stream but it is not going to be installed
       Depends: node-fstream (>= 0.1.22) but it is not going to be installed
       Depends: node-fstream-ignore but it is not going to be installed
       Depends: node-github-url-from-git but it is not going to be installed
       Depends: node-glob (>= 3.1.21) but it is not going to be installed
       Depends: node-graceful-fs (>= 2.0.0) but it is not going to be installed
       Depends: node-inherits but it is not going to be installed
       Depends: node-ini (>= 1.1.0) but it is not going to be installed
       Depends: node-lockfile but it is not going to be installed
       Depends: node-lru-cache (>= 2.3.0) but it is not going to be installed
       Depends: node-minimatch (>= 0.2.11) but it is not going to be installed
       Depends: node-mkdirp (>= 0.3.3) but it is not going to be installed
       Depends: node-gyp (>= 0.10.9) but it is not going to be installed
       Depends: node-nopt (>= 3.0.1) but it is not going to be installed
       Depends: node-npmlog but it is not going to be installed
       Depends: node-once but it is not going to be installed
       Depends: node-osenv but it is not going to be installed
       Depends: node-read but it is not going to be installed
       Depends: node-read-package-json (>= 1.1.0) but it is not going to be installed
       Depends: node-request (>= 2.25.0) but it is not going to be installed
       Depends: node-retry but it is not going to be installed
       Depends: node-rimraf (>= 2.2.2) but it is not going to be installed
       Depends: node-semver (>= 2.1.0) but it is not going to be installed
       Depends: node-sha but it is not going to be installed
       Depends: node-slide but it is not going to be installed
       Depends: node-tar (>= 0.1.18) but it is not going to be installed
       Depends: node-underscore but it is not going to be installed
       Depends: node-which but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Une idée de si ca peut venir de ton image (et si oui de comment resoudre ce souci)?
Je suis parti de ton image 3.0.11 puis restore de ma sauvegarde 2.4.6 puis upgrade en 3.1.7

Sur google on trouve des references mais vu que je ne comprends pas les solutions je ne suis pas chaud pour tenter le diable aveuglement

http://www.omgubuntu.co.uk/2017/08/fix- ... tory-error

Code : Tout sélectionner

wget -q -O - https://dl.google.com/linux/linux_signing_key.pub | sudo apt-key add -
https://ubuntuforums.org/showthread.php?t=2364912

Code : Tout sélectionner

Code:
sudo apt-get clean
sudo mv /var/lib/apt/lists /tmp
sudo mkdir -p /var/lib/apt/lists/partial
sudo apt-get clean
sudo apt-get update


https://forum.openmediavault.org/index. ... ification/

Code : Tout sélectionner

sudo apt-key adv --recv-keys --keyserver keys.gnupg.net D62E4F5B041390BC

Avatar de l’utilisateur
bronche
Modérateur
Messages : 973
Inscription : 07 janv. 2016, 19:29
Localisation : Du côté de Issy les Moulineaux la semaine et de Péronne le week-end...

Re: Tuto - netinstall sur Mini + (Solidrun humingboard) via script officiel

Message par bronche » 21 nov. 2017, 18:17

Houla... :oops:
Halte au feu !
C'est juste un problème de clé lié à la nouvelle release de novembre.
Changes
08/11/2017, 09/11/2017: Jessie
includes all updates as of that date
includes renewed apt key
La tu pars sur des choses dangereuses. En plus tu vas mettre le souk dans tous tes plugins avec npm...

Le sudo apt-get install npm n'est donc pas une bonne idée...

Tu vas juste faire :
un

Code : Tout sélectionner

su - 
pour passer en root
Puis tu vas récupérer la bonne clé et la réinjecter

Code : Tout sélectionner

curl https://repo.solid-build.xyz/debian/jessie/bsp-imx6/Release.key | sudo apt-key add -
Et c'est tout...
Phil
Helper Officiel Jeedom
Des images non officielles jeedom maintenues et hébergées par mes soins :
https://queen.useed.fr/SB1268/owncloud/ ... mA9xeSgBgx

PHDB
Timide
Messages : 298
Inscription : 01 mars 2016, 13:42

Re: Tuto - netinstall sur Mini + (Solidrun humingboard) via script officiel

Message par PHDB » 21 nov. 2017, 22:43

Le sudo apt-get install npm est suggéré dans le sujet Dash button en fait, pour resoudre l'erreur

Code : Tout sélectionner

module.js:341
throw err;
^
Error: Cannot find module 'node-dash-button'
at Function.Module._resolveFilename (module.js:339:15)
at Function.Module._load (module.js:290:25)
at Module.require (module.js:367:17)
at require (internal/module.js:20:19)
at Object.<anonymous> (/var/www/html/plugins/dashbutton/node/dashbutton.js:1:81)
at Module._compile (module.js:413:34)
at Object.Module._extensions..js (module.js:422:10)
at Module.load (module.js:357:32)
at Function.Module._load (module.js:314:12)
at Function.Module.runMain (module.js:447:10)
module.js:341
throw err;
^
Error: Cannot find module 'node-dash-button'
at Function.Module._resolveFilename (module.js:339:15)
at Function.Module._load (module.js:290:25)
at Module.require (module.js:367:17)
at require (internal/module.js:20:19)
at Object.<anonymous> (/var/www/html/plugins/dashbutton/node/dashbutton.js:1:81)
at Module._compile (module.js:413:34)
at Object.Module._extensions..js (module.js:422:10)
at Module.load (module.js:357:32)
at Function.Module._load (module.js:314:12)
at Function.Module.runMain (module.js:447:10)
Pourquoi npm met le bazar dans mes plugins?!

Question bête quand je fais su et que je tape debian, il me repond

Code : Tout sélectionner

su: Authentication failure
Alors que le même mot de passe avec sudo marche
Du coup j'ai fait

Code : Tout sélectionner

debian@linux:~$ sudo curl https://repo.solid-build.xyz/debian/jessie/bsp-imx6/Release.key | sudo apt-key add -
[sudo] password for debian: [sudo] password for debian:
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  1068  100  1068    0     0   1924      0 --:--:-- --:--:-- --:--:--  1924
OK
Souci de Dash button mis a part, ca peut toujours valoir de coup de faire un petit "sudo apt-get update" (puis "sudo apt-get upgrade" ?) histoire de me mettre a jour non?

Avatar de l’utilisateur
bronche
Modérateur
Messages : 973
Inscription : 07 janv. 2016, 19:29
Localisation : Du côté de Issy les Moulineaux la semaine et de Péronne le week-end...

Re: Tuto - netinstall sur Mini + (Solidrun humingboard) via script officiel

Message par bronche » 21 nov. 2017, 23:21

Bonsoir
J'ai écrit su - pas su
C'est nécessaire pour passer root. Sudo fait ça aussi très bien, mais pour passer ma commande c'est plus simple.

Pour Npm, il y a des soucis avec les plugins qui utilisent NodeJs et qui n'ont pas les mêmes exigences de version. J'ai eu de gros soucis avec ça. Je ne sais pas si le problème perdure.
Va faire un tour ici : https://nodejs.org/en/download/releases/ tu verras la liste des versions.

Pour ta mise à jour, pourquoi pas. La question est : tu en as besoin ?

Phil
Helper Officiel Jeedom
Des images non officielles jeedom maintenues et hébergées par mes soins :
https://queen.useed.fr/SB1268/owncloud/ ... mA9xeSgBgx

PHDB
Timide
Messages : 298
Inscription : 01 mars 2016, 13:42

Re: Tuto - netinstall sur Mini + (Solidrun humingboard) via script officiel

Message par PHDB » 21 nov. 2017, 23:29

Oui oui pardon "su -" me renvoie "su: Authentication failure". Etrange.
Avec sudo ca a l'air d'avoir marché.

Je n'ai pas forcément besoin d'un update en soi, juste je voudrais bien résoudre mon souci de Dash button. D'ou npm et comme l'install de npm me renvoie des choses bizarres, que je n'arrive pas à expliquer...

Code : Tout sélectionner

debian@linux:~$ sudo apt-get install npm
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 npm : Depends: nodejs but it is not going to be installed
       Depends: node-abbrev (>= 1.0.4) but it is not going to be installed
       Depends: node-ansi (>= 0.3.0-2) but it is not going to be installed
       Depends: node-ansi-color-table but it is not going to be installed
       Depends: node-archy but it is not going to be installed
       Depends: node-block-stream but it is not going to be installed
       Depends: node-fstream (>= 0.1.22) but it is not going to be installed
       Depends: node-fstream-ignore but it is not going to be installed
       Depends: node-github-url-from-git but it is not going to be installed
       Depends: node-glob (>= 3.1.21) but it is not going to be installed
       Depends: node-graceful-fs (>= 2.0.0) but it is not going to be installed
       Depends: node-inherits but it is not going to be installed
       Depends: node-ini (>= 1.1.0) but it is not going to be installed
       Depends: node-lockfile but it is not going to be installed
       Depends: node-lru-cache (>= 2.3.0) but it is not going to be installed
       Depends: node-minimatch (>= 0.2.11) but it is not going to be installed
       Depends: node-mkdirp (>= 0.3.3) but it is not going to be installed
       Depends: node-gyp (>= 0.10.9) but it is not going to be installed
       Depends: node-nopt (>= 3.0.1) but it is not going to be installed
       Depends: node-npmlog but it is not going to be installed
       Depends: node-once but it is not going to be installed
       Depends: node-osenv but it is not going to be installed
       Depends: node-read but it is not going to be installed
       Depends: node-read-package-json (>= 1.1.0) but it is not going to be installed
       Depends: node-request (>= 2.25.0) but it is not going to be installed
       Depends: node-retry but it is not going to be installed
       Depends: node-rimraf (>= 2.2.2) but it is not going to be installed
       Depends: node-semver (>= 2.1.0) but it is not going to be installed
       Depends: node-sha but it is not going to be installed
       Depends: node-slide but it is not going to be installed
       Depends: node-tar (>= 0.1.18) but it is not going to be installed
       Depends: node-underscore but it is not going to be installed
       Depends: node-which but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Avatar de l’utilisateur
bronche
Modérateur
Messages : 973
Inscription : 07 janv. 2016, 19:29
Localisation : Du côté de Issy les Moulineaux la semaine et de Péronne le week-end...

Re: Tuto - netinstall sur Mini + (Solidrun humingboard) via script officiel

Message par bronche » 21 nov. 2017, 23:37

Su - fonctionne chez moi. Bizarre. (su espace -)
Pour Dash, je ne connais pas ce plugin.
Je vais regarder sur une mini + de test et tenter de l'installer par curiosité.
C'est quoi ta version debian imx 6 ?

Code : Tout sélectionner

lsb_release -idrc
Phil
Helper Officiel Jeedom
Des images non officielles jeedom maintenues et hébergées par mes soins :
https://queen.useed.fr/SB1268/owncloud/ ... mA9xeSgBgx

PHDB
Timide
Messages : 298
Inscription : 01 mars 2016, 13:42

Re: Tuto - netinstall sur Mini + (Solidrun humingboard) via script officiel

Message par PHDB » 21 nov. 2017, 23:40

Code : Tout sélectionner

debian@linux:~$ lsb_release -idrc
Distributor ID: Debian
Description:    Debian GNU/Linux 8.9 (jessie)
Release:        8.9
Codename:       jessie

Avatar de l’utilisateur
bronche
Modérateur
Messages : 973
Inscription : 07 janv. 2016, 19:29
Localisation : Du côté de Issy les Moulineaux la semaine et de Péronne le week-end...

Re: Tuto - netinstall sur Mini + (Solidrun humingboard) via script officiel

Message par bronche » 22 nov. 2017, 16:10

bonjour,
il n'y a rien d'étrange...
C'est un problème de version. On va dire pour faire court que tu es à cheval sur ... deux chevaux. Certaines de tes dépendances sont introuvables.

Pour commencer que donne un

Code : Tout sélectionner

cat  /etc/apt/sources.list
Phil
Helper Officiel Jeedom
Des images non officielles jeedom maintenues et hébergées par mes soins :
https://queen.useed.fr/SB1268/owncloud/ ... mA9xeSgBgx

PHDB
Timide
Messages : 298
Inscription : 01 mars 2016, 13:42

Re: Tuto - netinstall sur Mini + (Solidrun humingboard) via script officiel

Message par PHDB » 22 nov. 2017, 18:49

Et voila
Verdict?

Code : Tout sélectionner

debian@linux:~$ cat  /etc/apt/sources.list
deb http://httpredir.debian.org/debian jessie main
deb-src http://httpredir.debian.org/debian jessie main
deb http://httpredir.debian.org/debian jessie-updates main
deb-src http://httpredir.debian.org/debian jessie-updates main
deb http://security.debian.org/ jessie/updates main
deb-src http://security.debian.org/ jessie/updates main
deb http://http.us.debian.org/debian/ jessie non-free

Avatar de l’utilisateur
bronche
Modérateur
Messages : 973
Inscription : 07 janv. 2016, 19:29
Localisation : Du côté de Issy les Moulineaux la semaine et de Péronne le week-end...

Re: Tuto - netinstall sur Mini + (Solidrun humingboard) via script officiel

Message par bronche » 24 nov. 2017, 10:32

PHDB a écrit :Et voila
Verdict?

Code : Tout sélectionner

debian@linux:~$ cat  /etc/apt/sources.list
deb http://httpredir.debian.org/debian jessie main
deb-src http://httpredir.debian.org/debian jessie main
deb http://httpredir.debian.org/debian jessie-updates main
deb-src http://httpredir.debian.org/debian jessie-updates main
deb http://security.debian.org/ jessie/updates main
deb-src http://security.debian.org/ jessie/updates main
deb http://http.us.debian.org/debian/ jessie non-free
Verdict, je reproduis ce souci avec une configuration identique... paquet non dispo sur cette distribution.
Je pense que l'on va devoir appeler une source non officielle.
Je regarde.
Phil

Envoyé de mon PLK-L01 en utilisant Tapatalk

Helper Officiel Jeedom
Des images non officielles jeedom maintenues et hébergées par mes soins :
https://queen.useed.fr/SB1268/owncloud/ ... mA9xeSgBgx

PHDB
Timide
Messages : 298
Inscription : 01 mars 2016, 13:42

Re: Tuto - netinstall sur Mini + (Solidrun humingboard) via script officiel

Message par PHDB » 01 déc. 2017, 13:31

qu'est ce que tu appelles une source non officielle?

Avatar de l’utilisateur
bronche
Modérateur
Messages : 973
Inscription : 07 janv. 2016, 19:29
Localisation : Du côté de Issy les Moulineaux la semaine et de Péronne le week-end...

Re: Tuto - netinstall sur Mini + (Solidrun humingboard) via script officiel

Message par bronche » 02 déc. 2017, 08:56

Bonjour,
Un autre dépôt.
Regarde ça :
https://doc.ubuntu-fr.org/depots
Il faut que je me penche la dessus, mais en ce moment un peu noyé...
Phil
Helper Officiel Jeedom
Des images non officielles jeedom maintenues et hébergées par mes soins :
https://queen.useed.fr/SB1268/owncloud/ ... mA9xeSgBgx

Fab38
Timide
Messages : 9
Inscription : 11 déc. 2015, 16:10
Localisation : Bourgoin Jallieu

Re: Tuto - netinstall sur Mini + (Solidrun humingboard) via script officiel

Message par Fab38 » 06 déc. 2017, 20:36

Bonjour bronche,

Je tente une réinstallation suite crash de ma SD originale.
Je n'arrive pas à installer le Swap (malgré mes nombreux essais) ?
J'ai ce message en sortant de imx6-config
W: Not using locking for read only lock file /var/lib/dpkg/lock
E: Unable to write to /var/cache/apt/
E: The package lists or status file could not be parsed or opened.
sed: couldn't open temporary file /etc/sed1DQHPu: Read-only file system
debian@linux:~$
Peux tu m'informer des possibilités pour activer le swap autre que de réessayer l'installation ?
Merci d'avance pour votre aide

Répondre

Revenir vers « La box JEEDOM MINI+ »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 3 invités