Ce Forum passera en lecture seule en janvier 2020
Image
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

zigbee2mqtt, passerelle low cost

Pour parler de tout, et surtout de rien !
arnox
Timide
Messages : 93
Inscription : 09 sept. 2018, 00:10

Re: zigbee2mqtt, passerelle low cost

Message par arnox » 02 déc. 2019, 17:10

yoco9 a écrit :
02 déc. 2019, 12:34
Pour illustrer mon problème:
Meme probleme de mon cote, je pense que c'est un souci suite a la derniere mise a jour du plugin. Domotruc est super reactif habituellement, il va nous resoudre ca sans probleme ;)

kwet
Timide
Messages : 78
Inscription : 01 oct. 2019, 07:26

Re: zigbee2mqtt, passerelle low cost

Message par kwet » 02 déc. 2019, 17:53

Il faut aller sur le nouveau forum pour lui signaler..

kbaretti
Timide
Messages : 10
Inscription : 26 déc. 2018, 17:05

Re: zigbee2mqtt, passerelle low cost

Message par kbaretti » 02 déc. 2019, 22:54

Bonjour, malgré de nombreuses tentatives de résolution de ce soucis avec les différentes choses que j'ai trouvé sur internet, impossible de réussir.
Pouvez vous m'aider ?

> zigbee2mqtt@1.6.0 start /opt/zigbee2mqtt
> node index.js

internal/modules/cjs/loader.js:638
throw err;
^

Error: Cannot find module 'zigbee-herdsman/dist/deprecated/ziee'
at Function.Module._resolveFilename (internal/modules/cjs/loader.js:636:15)
at Function.Module._load (internal/modules/cjs/loader.js:562:25)
at Module.require (internal/modules/cjs/loader.js:692:17)
at require (internal/modules/cjs/helpers.js:25:18)
at Object.<anonymous> (/opt/zigbee2mqtt/lib/zapp/cie.js:6:14)
at Module._compile (internal/modules/cjs/loader.js:778:30)
at Object.Module._extensions..js (internal/modules/cjs/loader.js:789:10)
at Module.load (internal/modules/cjs/loader.js:653:32)
at tryModuleLoad (internal/modules/cjs/loader.js:593:12)
at Function.Module._load (internal/modules/cjs/loader.js:585:3)
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! zigbee2mqtt@1.6.0 start: `node index.js`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the zigbee2mqtt@1.6.0 start script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR! /home/pi/.npm/_logs/2019-12-02T21_52_36_635Z-debug.log

kbaretti
Timide
Messages : 10
Inscription : 26 déc. 2018, 17:05

Re: zigbee2mqtt, passerelle low cost

Message par kbaretti » 03 déc. 2019, 01:20

kbaretti a écrit :
02 déc. 2019, 22:54
Bonjour, malgré de nombreuses tentatives de résolution de ce soucis avec les différentes choses que j'ai trouvé sur internet, impossible de réussir.
Pouvez vous m'aider ?

> zigbee2mqtt@1.6.0 start /opt/zigbee2mqtt
> node index.js

internal/modules/cjs/loader.js:638
throw err;
^

Error: Cannot find module 'zigbee-herdsman/dist/deprecated/ziee'
at Function.Module._resolveFilename (internal/modules/cjs/loader.js:636:15)
at Function.Module._load (internal/modules/cjs/loader.js:562:25)
at Module.require (internal/modules/cjs/loader.js:692:17)
at require (internal/modules/cjs/helpers.js:25:18)
at Object.<anonymous> (/opt/zigbee2mqtt/lib/zapp/cie.js:6:14)
at Module._compile (internal/modules/cjs/loader.js:778:30)
at Object.Module._extensions..js (internal/modules/cjs/loader.js:789:10)
at Module.load (internal/modules/cjs/loader.js:653:32)
at tryModuleLoad (internal/modules/cjs/loader.js:593:12)
at Function.Module._load (internal/modules/cjs/loader.js:585:3)
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! zigbee2mqtt@1.6.0 start: `node index.js`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the zigbee2mqtt@1.6.0 start script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR! /home/pi/.npm/_logs/2019-12-02T21_52_36_635Z-debug.log
Après mise à jour de Zigbee2Mqtt en version 1.7.1 j'ai résolu le problème ci-dessus.
Mais désormais je suis embêté avec la version de Node entre mon RfLink et ma clé Zigbee2Mqtt.

Si je laisse Node avec la version de l'installation des dépendances du RFLink j'ai ce message quand je fais un Npm Start :

Code : Tout sélectionner

pi@raspberrypi:/opt/zigbee2mqtt $ npm start

> zigbee2mqtt@1.7.1 start /opt/zigbee2mqtt
> node index.js

		Zigbee2mqtt requires node version 10, you are running v12.13.1!

zigbee2mqtt:info  2019-12-03T00:11:15: Logging to directory: '/opt/zigbee2mqtt/data/log/2019-12-03.00-11-11'
(node:31079) UnhandledPromiseRejectionWarning: Error: ENOENT: no such file or directory, stat '/opt/zigbee2mqtt/data/log/2019-11-16.00-46-01'
    at Object.statSync (fs.js:915:3)
    at /opt/zigbee2mqtt/lib/util/logger.js:70:40
    at Array.map (<anonymous>)
    at DerivedLogger.cleanup (/opt/zigbee2mqtt/lib/util/logger.js:68:57)
    at Controller.start (/opt/zigbee2mqtt/lib/controller.js:86:16)
    at Object.<anonymous> (/opt/zigbee2mqtt/index.js:11:12)
    at Module._compile (internal/modules/cjs/loader.js:959:30)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:995:10)
    at Module.load (internal/modules/cjs/loader.js:815:32)
    at Function.Module._load (internal/modules/cjs/loader.js:727:14)
(node:31079) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). (rejection id: 1)
(node:31079) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will terminate the Node.js process with a non-zero exit code.
Si je downgrade Node pour convenir à ce que demande Zigbee2Mqtt j'ai un soucis avec RFLink et je n'arrive pas à re compilé comme demandé :

Code : Tout sélectionner

Error: The module '/var/www/html/plugins/rflink/resources/node_modules/@serialport/bindings/build/Release/bindings.node'
was compiled against a different Node.js version using
NODE_MODULE_VERSION 72. This version of Node.js requires
NODE_MODULE_VERSION 64. Please try re-compiling or re-installing
the module (for instance, using `npm rebuild` or `npm install`).
at Object.Module._extensions..node (internal/modules/cjs/loader.js:807:18)
at Module.load (internal/modules/cjs/loader.js:653:32)
at tryModuleLoad (internal/modules/cjs/loader.js:593:12)
at Function.Module._load (internal/modules/cjs/loader.js:585:3)
at Module.require (internal/modules/cjs/loader.js:692:17)
at require (internal/modules/cjs/helpers.js:25:18)
at bindings (/var/www/html/plugins/rflink/resources/node_modules/bindings/bindings.js:112:48)
at Object.<anonymous> (/var/www/html/plugins/rflink/resources/node_modules/@serialport/bindings/lib/linux.js:2:36)
at Module._compile (internal/modules/cjs/loader.js:778:30)
at Object.Module._extensions..js (internal/modules/cjs/loader.js:789:10)
at Module.load (internal/modules/cjs/loader.js:653:32)
at tryModuleLoad (internal/modules/cjs/loader.js:593:12)
at Function.Module._load (internal/modules/cjs/loader.js:585:3)
at Module.require (internal/modules/cjs/loader.js:692:17)
at require (internal/modules/cjs/helpers.js:25:18)
at Object.<anonymous> (/var/www/html/plugins/rflink/resources/node_modules/@serialport/bindings/lib/index.js:14:22)
Est ce quelqu'un utilise un RFLink avec une clé Zigbee2Mqtt et pourrait m'aider ?

Merci d'avance.

Bonne nuit ;)

Avatar de l’utilisateur
cadavor
Actif
Messages : 1282
Inscription : 21 juin 2015, 22:00
Localisation : 34

Re: zigbee2mqtt, passerelle low cost

Message par cadavor » 03 déc. 2019, 15:42

kbaretti a écrit :
03 déc. 2019, 01:20
kbaretti a écrit :
02 déc. 2019, 22:54
Bonjour, malgré de nombreuses tentatives de résolution de ce soucis avec les différentes choses que j'ai trouvé sur internet, impossible de réussir.
Pouvez vous m'aider ?

> zigbee2mqtt@1.6.0 start /opt/zigbee2mqtt
> node index.js

internal/modules/cjs/loader.js:638
throw err;
^

Error: Cannot find module 'zigbee-herdsman/dist/deprecated/ziee'
at Function.Module._resolveFilename (internal/modules/cjs/loader.js:636:15)
at Function.Module._load (internal/modules/cjs/loader.js:562:25)
at Module.require (internal/modules/cjs/loader.js:692:17)
at require (internal/modules/cjs/helpers.js:25:18)
at Object.<anonymous> (/opt/zigbee2mqtt/lib/zapp/cie.js:6:14)
at Module._compile (internal/modules/cjs/loader.js:778:30)
at Object.Module._extensions..js (internal/modules/cjs/loader.js:789:10)
at Module.load (internal/modules/cjs/loader.js:653:32)
at tryModuleLoad (internal/modules/cjs/loader.js:593:12)
at Function.Module._load (internal/modules/cjs/loader.js:585:3)
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! zigbee2mqtt@1.6.0 start: `node index.js`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the zigbee2mqtt@1.6.0 start script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR! /home/pi/.npm/_logs/2019-12-02T21_52_36_635Z-debug.log
Après mise à jour de Zigbee2Mqtt en version 1.7.1 j'ai résolu le problème ci-dessus.
Mais désormais je suis embêté avec la version de Node entre mon RfLink et ma clé Zigbee2Mqtt.

Si je laisse Node avec la version de l'installation des dépendances du RFLink j'ai ce message quand je fais un Npm Start :

Code : Tout sélectionner

pi@raspberrypi:/opt/zigbee2mqtt $ npm start

> zigbee2mqtt@1.7.1 start /opt/zigbee2mqtt
> node index.js

		Zigbee2mqtt requires node version 10, you are running v12.13.1!

zigbee2mqtt:info  2019-12-03T00:11:15: Logging to directory: '/opt/zigbee2mqtt/data/log/2019-12-03.00-11-11'
(node:31079) UnhandledPromiseRejectionWarning: Error: ENOENT: no such file or directory, stat '/opt/zigbee2mqtt/data/log/2019-11-16.00-46-01'
    at Object.statSync (fs.js:915:3)
    at /opt/zigbee2mqtt/lib/util/logger.js:70:40
    at Array.map (<anonymous>)
    at DerivedLogger.cleanup (/opt/zigbee2mqtt/lib/util/logger.js:68:57)
    at Controller.start (/opt/zigbee2mqtt/lib/controller.js:86:16)
    at Object.<anonymous> (/opt/zigbee2mqtt/index.js:11:12)
    at Module._compile (internal/modules/cjs/loader.js:959:30)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:995:10)
    at Module.load (internal/modules/cjs/loader.js:815:32)
    at Function.Module._load (internal/modules/cjs/loader.js:727:14)
(node:31079) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). (rejection id: 1)
(node:31079) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will terminate the Node.js process with a non-zero exit code.
Si je downgrade Node pour convenir à ce que demande Zigbee2Mqtt j'ai un soucis avec RFLink et je n'arrive pas à re compilé comme demandé :

Code : Tout sélectionner

Error: The module '/var/www/html/plugins/rflink/resources/node_modules/@serialport/bindings/build/Release/bindings.node'
was compiled against a different Node.js version using
NODE_MODULE_VERSION 72. This version of Node.js requires
NODE_MODULE_VERSION 64. Please try re-compiling or re-installing
the module (for instance, using `npm rebuild` or `npm install`).
at Object.Module._extensions..node (internal/modules/cjs/loader.js:807:18)
at Module.load (internal/modules/cjs/loader.js:653:32)
at tryModuleLoad (internal/modules/cjs/loader.js:593:12)
at Function.Module._load (internal/modules/cjs/loader.js:585:3)
at Module.require (internal/modules/cjs/loader.js:692:17)
at require (internal/modules/cjs/helpers.js:25:18)
at bindings (/var/www/html/plugins/rflink/resources/node_modules/bindings/bindings.js:112:48)
at Object.<anonymous> (/var/www/html/plugins/rflink/resources/node_modules/@serialport/bindings/lib/linux.js:2:36)
at Module._compile (internal/modules/cjs/loader.js:778:30)
at Object.Module._extensions..js (internal/modules/cjs/loader.js:789:10)
at Module.load (internal/modules/cjs/loader.js:653:32)
at tryModuleLoad (internal/modules/cjs/loader.js:593:12)
at Function.Module._load (internal/modules/cjs/loader.js:585:3)
at Module.require (internal/modules/cjs/loader.js:692:17)
at require (internal/modules/cjs/helpers.js:25:18)
at Object.<anonymous> (/var/www/html/plugins/rflink/resources/node_modules/@serialport/bindings/lib/index.js:14:22)
Est ce quelqu'un utilise un RFLink avec une clé Zigbee2Mqtt et pourrait m'aider ?

Merci d'avance.

Bonne nuit ;)
Je t'ai répondu sur ton autre sujet.
Jeedom Stable 3.3
NUC Z83 + Aeotec Z-Stick Gen5
Z-Wave FGR + FGMS + FGDS + FGFS + FGK + FGWPE + ZW062 + ZW080
GH Mini + Orvibo AllOne + Playbulb + Miband2

Avatar de l’utilisateur
cadavor
Actif
Messages : 1282
Inscription : 21 juin 2015, 22:00
Localisation : 34

Re: zigbee2mqtt, passerelle low cost

Message par cadavor » 03 déc. 2019, 15:48

kwet a écrit :
02 déc. 2019, 17:53
Il faut aller sur le nouveau forum pour lui signaler..
https://community.jeedom.com/t/probleme ... ement/9807
Jeedom Stable 3.3
NUC Z83 + Aeotec Z-Stick Gen5
Z-Wave FGR + FGMS + FGDS + FGFS + FGK + FGWPE + ZW062 + ZW080
GH Mini + Orvibo AllOne + Playbulb + Miband2

kbaretti
Timide
Messages : 10
Inscription : 26 déc. 2018, 17:05

Re: zigbee2mqtt, passerelle low cost

Message par kbaretti » 04 déc. 2019, 10:04

Si je veux installer Zigbee2Mqtt via Docker, est ce que Jeedom doit être également installé dans un container ? Où est ce possible de laissé ma config actuelle Jeedom et seulement installer Docker et faire un container pour Zigbee2mqtt ?

Répondre

Revenir vers « Discussions Générales »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 2 invités