Ce Forum passera en lecture seule en janvier 2020
Image
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

Google Home (ou Amazon Echo) avec Ha-Bridge (Réponse immédiate aux ordres sans IFTTT)

Pour parler de tout, et surtout de rien !
baptou60
Timide
Messages : 75
Inscription : 01 mars 2015, 14:27

Re: Google Home (ou Amazon Echo) avec Ha-Bridge (Réponse immédiate aux ordres sans IFTTT)

Message par baptou60 » 27 juil. 2018, 18:09

bonjour à tous,

Voila maintenant quelques heures que je galère et je viens de comprendre qu'il fallait passer le port Ha-Bridge en 80 et le port jeedom sur autre chose.
Jusque la, ça parait simple, seulement, vous êtes tous en apache2 et moi en nginx (Jeedom Mini+), du coup, je ne trouve pas le fichier ports.
J'ai bien trouvé dans "/etc/nginx-site-enable/default" la possibilité de mettre listen 81 (par exemple). Je reboot pour être sur, et là, je n'ai plus du tout accès à mon interface Jeedom sur le port 81 bien sur ;) . Si j'enlève l'ajout de la ligne, ça fonctionne correctement sur le port 80.

Avez vous une piste, car je pense ne pas être très loin mais sans ça, je ne peux pas aller plus loin...

Merci d'avance.

baptou60
Timide
Messages : 75
Inscription : 01 mars 2015, 14:27

Re: Google Home (ou Amazon Echo) avec Ha-Bridge (Réponse immédiate aux ordres sans IFTTT)

Message par baptou60 » 27 juil. 2018, 21:28

Bon, je me répond à moi même, peut être que la solution servira à d'autre...

Pour l'écoute du serveur web, (j'ai honte), j'avais oublié le ; à la fin de la ligne.. ( ajout de listen : "numérodeport"; le fichier a modifier se trouve dans /etc/nginx/site-enable/default)

Avatar de l’utilisateur
NonoM45
Timide
Messages : 195
Inscription : 25 août 2014, 19:07

Re: Google Home (ou Amazon Echo) avec Ha-Bridge (Réponse immédiate aux ordres sans IFTTT)

Message par NonoM45 » 31 juil. 2018, 20:46

Bonjour Baptou
baptou60 a écrit :
27 juil. 2018, 21:28
Bon, je me répond à moi même, peut être que la solution servira à d'autre...
Pour l'écoute du serveur web, (j'ai honte), j'avais oublié le ; à la fin de la ligne.. ( ajout de listen : "numérodeport"; le fichier a modifier se trouve dans /etc/nginx/site-enable/default)
Merci de donner une réponse, mais il faudrait préciser sur quelle plateforme tu es et quelle version tu as
Sur RPi le dossier que tu définis n'existe pas ;)

De plus je trouve que mettre le port d'écoute sur 81 ralenti considérablement Jeedom dans les accès aux commandes, je ne sais pas si c'est normal ?
Raspberry Pi 3 avec une raZberry
Linux raspberrypi 4.9.41-v7+ #1023 - armv7l GNU/Linux [9.1]
PHP : 7.0.19-1 - Jeedom : 3.2.16
Version database : 10.1.23-MariaDB-9+deb9u1

Avatar de l’utilisateur
NonoM45
Timide
Messages : 195
Inscription : 25 août 2014, 19:07

Re: Google Home (ou Amazon Echo) avec Ha-Bridge (Réponse immédiate aux ordres sans IFTTT)

Message par NonoM45 » 13 oct. 2018, 19:43

Bonsoir à tous,

Est-ce que quelqu'un à réussi à mettre HA bridge sur un autre port que 80 ?

J'ai essayé 8081, mais ça n'a pas l'air de fonctionner.

J'aimerais pouvoir accéder à Jeedom de l'extérieur et la seule possibilité est de le laisser sur le port 80

A+
Raspberry Pi 3 avec une raZberry
Linux raspberrypi 4.9.41-v7+ #1023 - armv7l GNU/Linux [9.1]
PHP : 7.0.19-1 - Jeedom : 3.2.16
Version database : 10.1.23-MariaDB-9+deb9u1

bertrand
Timide
Messages : 101
Inscription : 15 janv. 2017, 07:41
Localisation : Marseille

Re: Google Home (ou Amazon Echo) avec Ha-Bridge (Réponse immédiate aux ordres sans IFTTT)

Message par bertrand » 14 oct. 2018, 08:55

Bonjour !

Oui pas de souci pour moi il est sur le port 8080
J'ai suivi pas à pas la doc sans RIEN omettre....

Bon Dimanche !!!!!!!!

Avatar de l’utilisateur
NonoM45
Timide
Messages : 195
Inscription : 25 août 2014, 19:07

Re: Google Home (ou Amazon Echo) avec Ha-Bridge (Réponse immédiate aux ordres sans IFTTT)

Message par NonoM45 » 14 oct. 2018, 09:17

Bonjour Bertrand et merci pour la réponse ;-)

J'en ai fait de même... mais ça ne fonctionne pas pour moi, tant pis :-(

Bon dimanche
Raspberry Pi 3 avec une raZberry
Linux raspberrypi 4.9.41-v7+ #1023 - armv7l GNU/Linux [9.1]
PHP : 7.0.19-1 - Jeedom : 3.2.16
Version database : 10.1.23-MariaDB-9+deb9u1

LowRunX
Timide
Messages : 3
Inscription : 30 oct. 2018, 22:02

Re: Google Home (ou Amazon Echo) avec Ha-Bridge (Réponse immédiate aux ordres sans IFTTT)

Message par LowRunX » 30 oct. 2018, 22:10

bonjour, j'ai le même souci que vous.
j'ai bien la page ha-bridge qui interagie avec l'équipement que j'ai créer (une prise qui gère une lampe)
mais impossible d'éffectuer le lien avec alexa.

j'ai suivi ce tuto:
https://www.pasteck.com/alexa-echo-avec ... #comment-2


j'ai une erreur apache2
elle est lié au fichier: nano /etc/apache2/sites-available/000-default.conf
voici mon ficier:

Code : Tout sélectionner

<VirtualHost *:80>
        ServerAdmin webmaster@localhost
        DocumentRoot /var/www/html
        ErrorLog /var/www/html/log/http.error
</VirtualHost>
<VirtualHost *:8088>
ProxyPass /api http://localhost:8088/api nocanon retry=0
ProxyPassReverse /api http://localhost:8088/api
ProxyRequests Off
AllowEncodedSlashes NoDecode

Local reverse proxy authorization override
Most unix distribution deny proxy by default (ie /etc/apache2/mods-enabled/proxy.conf in Ubuntu)
<Proxy http://localhost:8088/api*>
Order deny,allow
#Allow from all
deny from all
allow from 192.168.2.0/24
</Proxy>
</VirtualHost>

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet

voici mon erreur:
Job for apache2.service failed because the control process exited with error code.
See "systemctl status apache2.service" and "journalctl -xe" for details.

Code : Tout sélectionner

root@jeedom:/etc/apache2# systemctl status apache2.service
● apache2.service - The Apache HTTP Server
   Loaded: loaded (/lib/systemd/system/apache2.service; enabled; vendor preset: enabled)
  Drop-In: /etc/systemd/system/apache2.service.d
           └─privatetmp.conf
   Active: failed (Result: exit-code) since Tue 2018-10-30 21:07:01 UTC; 47s ago
  Process: 9579 ExecStart=/usr/sbin/apachectl start (code=exited, status=1/FAILURE)
 Main PID: 4752 (code=exited, status=0/SUCCESS)

Oct 30 21:07:01 jeedom systemd[1]: Starting The Apache HTTP Server...
Oct 30 21:07:01 jeedom apachectl[9579]: AH00526: Syntax error on line 12 of /etc/apache2/sites-enabled/000-default.conf:
Oct 30 21:07:01 jeedom apachectl[9579]: Invalid command 'Local', perhaps misspelled or defined by a module not included in the server configuration
Oct 30 21:07:01 jeedom apachectl[9579]: Action 'start' failed.
Oct 30 21:07:01 jeedom apachectl[9579]: The Apache error log may have more information.
Oct 30 21:07:01 jeedom systemd[1]: apache2.service: Control process exited, code=exited status=1
Oct 30 21:07:01 jeedom systemd[1]: Failed to start The Apache HTTP Server.
Oct 30 21:07:01 jeedom systemd[1]: apache2.service: Unit entered failed state.
Oct 30 21:07:01 jeedom systemd[1]: apache2.service: Failed with result 'exit-code'.

Je ne parvient pas à trouver de solution.

Peu être quelqu'un peu m'aider ici.

bertrand
Timide
Messages : 101
Inscription : 15 janv. 2017, 07:41
Localisation : Marseille

Re: Google Home (ou Amazon Echo) avec Ha-Bridge (Réponse immédiate aux ordres sans IFTTT)

Message par bertrand » 31 oct. 2018, 10:07

Bonjour !

Ton fichier log apache dit je ne comprends pas "local" à la ligne 12 de ton fichier de config 000-defaut.conf

Il manque des # pour les lignes de commentaires
Comme ca :

# Local reverse proxy authorization override
# Most unix distribution deny proxy by default (ie /etc/apache2/mods-enabled/proxy.conf in Ubuntu)
<Proxy http://localhost:8080/api*>
Order deny,allow
Allow from all
</Proxy>
</VirtualHost>

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet

Bien sur il te fait redémarrer le serveur apache pour prendre ceci en compte

LowRunX
Timide
Messages : 3
Inscription : 30 oct. 2018, 22:02

Re: Google Home (ou Amazon Echo) avec Ha-Bridge (Réponse immédiate aux ordres sans IFTTT)

Message par LowRunX » 31 oct. 2018, 11:13

@ bertrand merci

je n'est pu d'erreur
mais ca ne fonctionne tjr pas impossible d'associer mon equipement à alexa

pourtant j'ai bien un equipement sur ha-bridge

http://ip_jedom:8080/api/devices
[{"id":"1","uniqueid":"00:17:88:5E:D3:01-01","name":"Allogène","mapId":"21","offUrl":"[{\"item\":\"https://7cbac508.dns4.jeedom.com/core/a ... ation/json\"}]","onUrl":"[{\"item\":\"https://7cbac508.dns4.jeedom.com/core/a ... ation/json\"}]","inactive":false,"noState":false,"offState":false,"description":"Allogène","comments":"Allogène","deviceState":{"on":true,"bri":254,"alert":"none","reachable":true},"onFirstDim":false}]



-------------------------------------------------

[EDIT]

aller dans les log jeedom quand vous voulez faire votre association. http.error.
si vous avez un souci de ce genre
[Wed Oct 31 10:16:41.639194 2018] [proxy:error] [pid 5431] (111)Connection refused: AH00957: HTTP: attempt to connect to 127.0.0.1:8080 (localhost) failed
[Wed Oct 31 10:16:41.639444 2018] [proxy_http:error] [pid 5431] [client 192.168.0.46:46432] AH01114: HTTP: failed to make connection to backend: localhost
remplacer votre localhost par votre adresse ip jeedom dans votre fichier de config (de redirection de port)
pour mon cas ce fichier: nano /etc/apache2/sites-available/000-default.conf

ca fontionne ;)

bertrand
Timide
Messages : 101
Inscription : 15 janv. 2017, 07:41
Localisation : Marseille

Re: Google Home (ou Amazon Echo) avec Ha-Bridge (Réponse immédiate aux ordres sans IFTTT)

Message par bertrand » 31 oct. 2018, 13:56

Cool tu vas voir c'est top ha-bridge
Une fois qu'on a compris le principe c'est un jouet !

Un truc que je n'ai pas pigé tout de suite c'est que les appels depuis ha bridge peuvent se faire vers jeedom (bien sur) mais aussi vers tout autre appareil ayant des API publiques.

Je te "signale" aussi que c'est à sens unique, impossible avec ha-bridge de faire des remontées depuis Jeedom vers Alexa.
Là il te fait le plugin jeedom sur l'écho...

Pour moi c'est complémentaire et j’apprécie les deux !

LowRunX
Timide
Messages : 3
Inscription : 30 oct. 2018, 22:02

Re: Google Home (ou Amazon Echo) avec Ha-Bridge (Réponse immédiate aux ordres sans IFTTT)

Message par LowRunX » 31 oct. 2018, 16:10

en effet. avant j'avais ma alexa sur ma lifedomus, mais le zwave est mal maitriser. donc j'ai tout basculer sur jeedom, ca marche mieux. et surtout alexa prend en compte les "scénario", plusieurs commande en une seul parole. c'est cool.

lefoimpeur
Timide
Messages : 10
Inscription : 21 mars 2017, 19:42

Re: Google Home (ou Amazon Echo) avec Ha-Bridge (Réponse immédiate aux ordres sans IFTTT)

Message par lefoimpeur » 16 déc. 2018, 15:45

Bonjour,

C'est puissant Ha-Bridge !
Franchement, ça s'installe rapidement et c'est vraiment simple à configurer :)
Mon alexa peut désormais piloter mes volets.
Merci pour les informations de chacun.
NUC / Proxmox / Stick Gen 5 / Fibaro module FGR-222

jcarlosj
Timide
Messages : 5
Inscription : 13 nov. 2018, 12:12

Re: Google Home (ou Amazon Echo) avec Ha-Bridge (Réponse immédiate aux ordres sans IFTTT)

Message par jcarlosj » 19 déc. 2018, 17:11

Bon après-midi à tous. Je lance enfin mon Ha_Bridge, je l’ai localisée dans le port par défaut (80) alors que ma JEEDOM est exécutée sur le port 8080.

Les commandes On et Off fonctionnent parfaitement avec mon script afin qu'Alexa me dise de bonnes choses.

Cependant, je me suis impliqué dans mon projet et je n’ai pas la clé pour exécuter les commandes Dimmer (% ou Byte).

La question du sujet est que je voudrais pouvoir changer le Température cible de ma chaudière en disant à Alexa.

Cette chaudière communique en Modbus avec mon Jeedom grâce au plugin correspondant.

Je ne sais pas si ma stratégie ou mon plan sera correct, à savoir:

L'idée est de dire à alexa de mettre mon mot Température cible à 25 (25ºC) et que cette clôture directement à mon objet qui écrit dans le registre modbus de ma chaudière le mot de passe actuel. Mais je n'ai pas réussi; J'ai essayé d'apporter la valeur du% dimmer à une variable virtuelle à l'aide du plugin virtuel mais je n'ai rien réalisé.

Quelqu'un pourrait me conseiller comment configurer mon appareil dans Ha-Bridge afin qu'il m'envoie la valeur en% à un lieu de danger où je peux le voir ....


Je quitte la capture de mon tableau de bord pour qu'ils puissent voir ce que j'ai déjà fait. Au fait, mon HA-Bridge est la vers 5.2.1

Eternellement reconnaissant je serais. Merci à tous, joyeux Noël
Pièces jointes
2222222222.JPG
2222222222.JPG (156.31 Kio) Consulté 438 fois

Avatar de l’utilisateur
tom74
Actif
Messages : 1798
Inscription : 16 juil. 2014, 09:16
Localisation : Annecy (74)

Re: Google Home (ou Amazon Echo) avec Ha-Bridge (Réponse immédiate aux ordres sans IFTTT)

Message par tom74 » 29 déc. 2018, 14:45

Salut à tous,
Je test actuellemnt HA bridge pour piloter JEEDOM depuis une télécommande Harmony.
J'ai réussi à configurer une lampe, le ON et le OFF fonctionnent mais pas la variation...
Dans la case DIM URL, j'ai mis http://#IP_JEEDOM#/core/api/jeeApi.php?apikey=#APIKEY#&type=cmd&id=5110&slider=

mais je pense qu'il manque un truc à la fin... car si je vais voir l'URL de la commande depuis JEEDOM, il me met slider=50 à la fin...
Une idée de quoi mettre après slider= ? j'ai essayé value, slider .... mais pas moyen.

Avatar de l’utilisateur
tom74
Actif
Messages : 1798
Inscription : 16 juil. 2014, 09:16
Localisation : Annecy (74)

Re: Google Home (ou Amazon Echo) avec Ha-Bridge (Réponse immédiate aux ordres sans IFTTT)

Message par tom74 » 29 déc. 2018, 15:14

Bon en fait j'ai trouvé, c'était sous mes yeux... il faut mettre ${intensity.percent} à la fin

jeannotmer
Timide
Messages : 261
Inscription : 30 mars 2018, 20:36
Contact :

Re: Google Home (ou Amazon Echo) avec Ha-Bridge (Réponse immédiate aux ordres sans IFTTT)

Message par jeannotmer » 07 juil. 2019, 23:04

Didier3L a écrit :
16 juin 2018, 22:42
Merci 8-)
On peut aussi modifier le type d'affichage
2018-06-16_22-38-20.png

Par contre quelqu'un a t'il pu reussi à faire la découverte de l'echo avec un autre port que 80 :?:
Car j'ai installé le conteneur https://hub.docker.com/r/aptalca/home-a ... on-bridge/ sur mon Synology et donc le port 80 c'est celui du syno :!: :oops:
Salut Didier as tu réussi finalement ?

Si oui comment ?
Pour suivre mes avancées dans le monde de la domotique Présentation

jeannotmer
Timide
Messages : 261
Inscription : 30 mars 2018, 20:36
Contact :

Re: Google Home (ou Amazon Echo) avec Ha-Bridge (Réponse immédiate aux ordres sans IFTTT)

Message par jeannotmer » 08 juil. 2019, 00:43

J'ai finalement trouvé

J'ai ajouter dans la conf nginx
sous
:/usr/local/etc/nginx/conf.d
un fichier
www.habridge.conf
(le format doit être www.xxxx.conf)



Code : Tout sélectionner

location ^~   /api {
            proxy_pass http://127.0.0.1:8080/api;
}


nb
(a la place de 127.0.0.1 l'ip de mon nas)
Pour suivre mes avancées dans le monde de la domotique Présentation

Répondre

Revenir vers « Discussions Générales »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 11 invités