Page 16 sur 23

Re: Smart Led Messenger

Publié : 29 nov. 2018, 22:27
par drs
christlep a écrit :
29 nov. 2018, 21:40
salut,

Ton adaptateur 220v-5v ne doit pas delivrer assez de courant.
Lors du demarrage, les matrices et le wemos demandent pas mal de courant, le port usb de ton pc peut facilement le supporter. L'adaptateur ne doit pas le supporter et du coup sa tension s'ecroule, surtout si c'est un adaptateur pas cher et de mauvaise qualité.
Essaye avec un adaptateur de tel portable assez recent, tu devrais plus avoir ce probleme.
Sinon, il te reste la solution de demonter ton SmartLedMesenger, pour deplacer l'alimentation des matrice sur la broche 5v du wemos.

a+
J’ai essayé plusieurs adaptateurs, de 1 à 3a (récents) et la matrice est bien alimentée en 5v, j’ai déjà ouvert le slm pour le modifier. Du coup je ne comprends pas...

Re: Smart Led Messenger

Publié : 29 nov. 2018, 23:02
par rol-rider
sur le mien ça fait pareil, je crois pas que ça viens de l'adaptateur.
c'est plutôt un problème d'initialisation je pense, au démarrage toutes les led s'allument ,ce qui doit surcharger l'alim et peut être bloquer le bon déroulement du sketch.
moi, je n'utilise pas le reset, mais je coupe et rallume, ça fonctionne.
je testerais demain sur une alim ou je peux limiter l'ampérage pour voir.

Re: Smart Led Messenger

Publié : 29 nov. 2018, 23:11
par christlep
Essaye de changer de cable usb, on sait jamais.
Apres, je n'ai pas d'autres idées.

Sauf, qu'il m'est arrivé d'avoir ce bug avec un wemos et une matrice, tout deux arrivés récemment de chine. Mais c'etait un faux bug dû à un mauvais contact dans la nappe de fil (nappe fournie avec les matrices), car en changeant de nappe le bug disparaisait. Du coup je me suis fais une petite plaque en test pour ne plus avoir de fils entre le wemos et la matrice, et depuis plus de problemes.

Si cela intéresse du monde, il est possible de faire fabriquer une petite série de plaques pour pas trop cher en chine.

A+
chris

Re: Smart Led Messenger

Publié : 30 nov. 2018, 10:24
par drs
Salut

J'ai changé de cable USB, changé toute la nappe, et le problème est le même. Je n'y comprends rien.

PS: j'ai tenté de brancher la matrice sur un wemos en espeasy. Il s'allume, mais je n'arrive pas à afficher dessus. De plus, dans la dernière version d'espeasy, j'ai l'impression qu'ils l'ont retiré... je sais que ce n'est pas le sujet, mais une idée?

Re: Smart Led Messenger

Publié : 30 nov. 2018, 11:55
par rol-rider
j'ai testé avec un condensateur (entre +5v et gnd) de 220µF c'est beaucoup mieux.

Re: Smart Led Messenger

Publié : 30 nov. 2018, 15:13
par Idaho947
Super pour la mise à jour !
Est ce que quelqu'un sait comment inséré un DHT22 dans le smartled ? Merci d'avance pour votre aide.

Re: Smart Led Messenger

Publié : 30 nov. 2018, 18:44
par Sabato
Merci pour la commande rafraîchir dans la nouvelle mise à jour @Lunarok !!

Re: Smart Led Messenger

Publié : 30 nov. 2018, 19:15
par drs
Bonjour

J'ai trouvé!!!!!

J'ai fini par réussir à extraire le wemos de son logement (en faisant attention), et j'ai découvert que les pins non utilisées (comme par ex. le 5V) n'étaient pas soudées!!! Donc un coup ça fonctionnait, et l'autre coup non!
J'ai remis un coup de soudure sur toutes les pinoches et maintenant ça fonctionne!

Re: Smart Led Messenger

Publié : 30 nov. 2018, 23:09
par christlep
Cool, tu n'auras plus de soucis maintenant ;)

Re: Smart Led Messenger

Publié : 01 déc. 2018, 01:18
par Jeandhom
Pour que l'option time=5 fonctionne, il faut que je modifie le code comme :

Code : Tout sélectionner

		//if (isset($options['time']) && is_int($options['time']) && ($options['time'] > 0))	{
          if (isset($options['time']) && ($options['time'] > 0))	{
			//log::add('smartledmessenger', 'debug', 'Time set : ' . $_options['time']);
            log::add('smartledmessenger', 'debug', 'Time set : ' . $options['time']);
			$this->setConfiguration('messActive',$options['time']);
			$this->save();
		}
is_int($options['time']) semble toujours être faux.

Pour le log : $_options['time'] -> $options['time'] ?

Re: Smart Led Messenger

Publié : 01 déc. 2018, 12:53
par Sabato
Bonjour @Lunarok,

j'ai un petit problème avec la nouvelle version. Depuis que je l'ai installé j'ai les erreurs suivantes qui remontent dans le log alors que l'affichage se fait bien sur la smart led.

Code : Tout sélectionner

Erreur sur la fonction cron du plugin : Echec de la requête HTTP : http://192.168.1.12/?message=12%3A22+-+Le+garage+est+ouvert+%21%21%21%21&intensity=0&speed=50&local=1&static=0 cURL error : Operation timed out after 2001 milliseconds with 0 bytes received	
2018-12-01 09:20:10	smartledmessenger	Erreur sur la fonction cron du plugin : Echec de la requête HTTP : http://192.168.1.12/?message=09%3A20+-+Le+garage+est+ouvert+%21%21%21%21&intensity=0&speed=50&local=1&static=0 cURL error : Operation timed out after 2000 milliseconds with 0 bytes received	
2018-12-01 09:05:18	smartledmessenger	Erreur exécution de la commande [Salon][Smart Led salon][Rafraichir] : Echec de la requête HTTP : http://192.168.1.12/?message=09%3A05&intensity=0&speed=50&local=1&static=1 cURL error : Connection timed out after 2001 milliseconds	
2018-12-01 09:05:10	smartledmessenger	Erreur sur la fonction cron du plugin : Echec de la requête HTTP : http://192.168.1.12/?message=09%3A05+-+GH+Salon+%3A+Hit+Sale+%28feat.+Rom%C3%A9o+Elvis%29+-+Therapie+TAXI&intensity=0&speed=50&local=1&static=0 cURL error : Operation timed out after 2000 milliseconds with 0 bytes received	
2018-12-01 09:04:49	smartledmessenger	Erreur exécution de la commande [Salon][Smart Led salon][Rafraichir] : Echec de la requête HTTP : http://192.168.1.12/?message=09%3A04+-+GH+Salon+%3A+Hit+Sale+%28feat.+Rom%C3%A9o+Elvis%29+-+Therapie+TAXI&intensity=0&speed=50&local=1&static=0 cURL error : Operation timed out after 2001 milliseconds with 0 bytes received	
2018-11-30 20:32:10	smartledmessenger	Erreur sur la fonction cron du plugin : Echec de la requête HTTP : http://192.168.1.12/?message=20%3A32+-+Aimy+devra+mettre+la+table+la+prochaine+fois.&intensity=0&speed=50&local=1&static=0 cURL error : Operation timed out after 2001 milliseconds with 0 bytes received	
2018-11-30 20:31:10	smartledmessenger	Erreur sur la fonction cron du plugin : Echec de la requête HTTP : http://192.168.1.12/?message=20%3A31+-+Aimy+devra+mettre+la+table+la+prochaine+fois.&intensity=0&speed=50&local=1&static=0 cURL error : Operation timed out after 2000 milliseconds with 0 bytes received	
2018-11-30 20:30:20	smartledmessenger	Erreur exécution de la commande [Salon][Smart Led salon][Rafraichir] : Echec de la requête HTTP : http://192.168.1.12/?message=20%3A30+-+Aimy+devra+mettre+la+table+la+prochaine+fois.&intensity=0&speed=50&local=1&static=0 cURL error : Operation timed out after 2000 milliseconds with 0 bytes received	
2018-11-30 20:30:11	smartledmessenger	Erreur sur la fonction cron du plugin : Echec de la requête HTTP : http://192.168.1.12/?message=20%3A30+-+Est-ce+que+Evan+a+mis+la+table+%3F&intensity=0&speed=50&local=1&static=0 cURL error : Operation timed out after 2001 milliseconds with 0 bytes received
Voici comment est configuré mon équipement :
config.png
config.png (137.51 Kio) Consulté 546 fois
Et un exemple de comment je l'utilise dans mes scénario :
exemple de code.png
exemple de code.png (13.39 Kio) Consulté 546 fois
Je fais ainsi pour que quand pas de message à afficher l'heure s'affiche en fixe et sinon heure + message.

Re: Smart Led Messenger

Publié : 01 déc. 2018, 13:19
par Jez
Je suis dans le même cas que toi mais je n'osais me manifester pensant que le problème venait de chez moi. Le rafraîchissement de l'affichage se fait mais pas régulièrement.

Re: Smart Led Messenger

Publié : 01 déc. 2018, 13:26
par patmtp35
meme probléme aussi depuis la maj
Erreur sur la fonction cron du plugin : Echec de la requête HTTP : http://192.168.xxx.xxx/?message=+++++&i ... 1&static=1 cURL error : Operation timed out after 2006 milliseconds with 0 bytes received

Re: Smart Led Messenger

Publié : 01 déc. 2018, 13:35
par benoit74
+1 idem ici

Re: Smart Led Messenger

Publié : 01 déc. 2018, 17:20
par drs
Bonjour

Après l'écran OLED, je vous présente le Smart Led Messenger Edition Spéciale :)

Image

Image

Image

Re: Smart Led Messenger

Publié : 02 déc. 2018, 08:56
par Idaho947
Fun.
Même problème pour moi pour les messages.

Re: Smart Led Messenger

Publié : 02 déc. 2018, 11:15
par Jez
Merci Lunarok pour la mise à jour. Je n'ai plus de de pb de requête http maintenant.

Re: Smart Led Messenger

Publié : 02 déc. 2018, 11:35
par Idaho947
Idem nickel pour moi. Par contre si je laisse le champ message vide je n'ai plus l'heure par défaut. J'ai ratté un truc ?

Re: Smart Led Messenger

Publié : 02 déc. 2018, 13:36
par samidcs
Pareil pour moi, plus d'heure par defaut :(

Re: Smart Led Messenger

Publié : 02 déc. 2018, 14:16
par Jeandhom
samidcs a écrit :
02 déc. 2018, 13:36
Pareil pour moi, plus d'heure par defaut :(

Code : Tout sélectionner

date('H:i')