Avant toute chose merci de (re)prendre connaissance de la charte et de la respecter.
Pour résumer :
- Avant de poser une question, je cherche si la réponse existe
- Je suis poli, courtois et je respecte tout un chacun sur le forum
- Si un post m'agace : je m'en éloigne plutôt que de répondre d'une façon qui pourrait être mal interprétée


Il n'est jamais du luxe que de rappeler des choses simples :
Courtoisie, amabilité, politesse et bonne humeur sont les maîtres mots pour un forum sympathique, bienveillant et accueillant :)

Toute la communauté vous remercie

Connexion impossible depuis passage en HTTPS

Venez partager sur les applications Jeedom pour appareils IOS, Android et Windows Phone
Répondre
Avatar de l’utilisateur
carlierd
Timide
Messages : 253
Inscription : 20 mai 2015, 22:51

Connexion impossible depuis passage en HTTPS

Message par carlierd » 04 mai 2018, 21:35

Hello,

Pour pouvoir utiliser Telegram j'ai passé mon JEEDOM en HTTPS.
J'avoue avoir bien galérer en faisant le gros boulet mais j'ai finalement réussi.

J'ai donc tout au vert (accès interne et externe, https) sur mon Jeedom.

Néanmoins depuis (enfin il me semble) je n'ai plus accès à l'application mobile sur Android.
Cela me marque "Impossible de récupérer la configuration de votre Jeedom" ...

J'ai testé la configuration manuelle et par QRcode mais rien n'y fait.
J'ai aussi essayé de réinitialiser l'application mais c'est pareil.

Pas grand chose dans les logs mais suffisamment pour dire que l'application se connecte :
[2018-05-04 21:32:29][DEBUG] : Appel API Mobile > sync
[2018-05-04 21:32:29][DEBUG] : Demande du RDK
[2018-05-04 21:32:30][DEBUG] : Appel API Mobile > sync
[2018-05-04 21:32:30][DEBUG] : Demande du RDK
Des idées de ce que je pourrais faire de plus ?

David.

arguaon
Timide
Messages : 2
Inscription : 31 mars 2018, 13:36

Re: Connexion impossible depuis passage en HTTPS

Message par arguaon » 06 mai 2018, 22:18

bonjour

j ai le même soucis que toi l application en réussis pas a récupérer les informations de versions
.
je n avais pas encore configurer l application. as tu réussis a résoudre le soucis

Avatar de l’utilisateur
carlierd
Timide
Messages : 253
Inscription : 20 mai 2015, 22:51

Re: Connexion impossible depuis passage en HTTPS

Message par carlierd » 06 mai 2018, 22:52

Non rien du tout.
Et je ne sais pas quoi faire de plus.

David.

Djal94
Actif
Messages : 1148
Inscription : 09 août 2016, 09:21

Re: Connexion impossible depuis passage en HTTPS

Message par Djal94 » 06 mai 2018, 23:14

Tu as bien changé ta configuration réseau dans la configuration de Jeedom?

Puis tu "régénère la conjuration" depuis le plugin.
Puis tu mets en HTTPS dans l'application mobile, tu la relance,ca devrait fonctionner.
Jeedom 3.2.8 sur NUC Intel (Debian 8)
Zwave - BLEA - Wifi
Trucs et Astuces

Avatar de l’utilisateur
carlierd
Timide
Messages : 253
Inscription : 20 mai 2015, 22:51

Re: Connexion impossible depuis passage en HTTPS

Message par carlierd » 07 mai 2018, 08:34

Déjà fait.

Tout semble bon avec ma config. réseau car tout est vert, j'ai accès depuis l'extérieur et l'intérieur via le web et j'arrive à faire fonctionner Telegram ...

C'est la configuration qui semble ne pas se faire. Rien de plus dans les logs que ce que j'ai mis dans le premier message.

J'ai vérifié que j'avais bien la dernière version de l'application (c'est bien le cas) et dans les nouveautés il y a "Grosse modification de la synchronisation". C'est peut-être ça mon problème et pas le passage en HTTPS ...

David.

Agone
Timide
Messages : 4
Inscription : 08 mai 2018, 16:37

Re: Connexion impossible depuis passage en HTTPS

Message par Agone » 08 mai 2018, 16:39

Bonjour !
Même problème.
Sur l'app mobile : "Impossible de récupérer la configuration de votre Jeedom" ... (sur android)
Si qqn a une petite idée
Merci ;-)

Avatar de l’utilisateur
rocket13011
Actif
Messages : 573
Inscription : 07 sept. 2014, 21:29
Localisation : Lyon

Re: Connexion impossible depuis passage en HTTPS

Message par rocket13011 » 09 mai 2018, 11:35

vérifier dans la configuration de votre Jeedom si il y a bien l'api JSONRPC qui est Activé
Équipe développement JEEDOM
Développeur Mobile JEEDOM / Responsable relation partenaire

Dev des plugins :
Mobile, Lifx

Agone
Timide
Messages : 4
Inscription : 08 mai 2018, 16:37

Re: Connexion impossible depuis passage en HTTPS

Message par Agone » 09 mai 2018, 12:17

Oui Jsonrpc est bien activé

Avatar de l’utilisateur
carlierd
Timide
Messages : 253
Inscription : 20 mai 2015, 22:51

Re: Connexion impossible depuis passage en HTTPS

Message par carlierd » 09 mai 2018, 14:13

Tout pareil, c'est bien activé.

David.

Avatar de l’utilisateur
rocket13011
Actif
Messages : 573
Inscription : 07 sept. 2014, 21:29
Localisation : Lyon

Re: Connexion impossible depuis passage en HTTPS

Message par rocket13011 » 09 mai 2018, 14:23

quand vous allez sur votre mobile dans le plugin mobile et que vous cliquez sur le bouton bleu clair en haut a droite "infos envoyés à l'app" vous avez un message d'erreur ?
Équipe développement JEEDOM
Développeur Mobile JEEDOM / Responsable relation partenaire

Dev des plugins :
Mobile, Lifx

Agone
Timide
Messages : 4
Inscription : 08 mai 2018, 16:37

Re: Connexion impossible depuis passage en HTTPS

Message par Agone » 09 mai 2018, 16:13

Oui effectivement voici le message d'erreur:
[MySQL] Error code : 42000 (1064). You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near ') AND `generic_type` IS NOT NULL ORDER BY `order`,`name`' at line 3

Avatar de l’utilisateur
rocket13011
Actif
Messages : 573
Inscription : 07 sept. 2014, 21:29
Localisation : Lyon

Re: Connexion impossible depuis passage en HTTPS

Message par rocket13011 » 09 mai 2018, 22:04

c'est qu'il n'y a aucun plugin qui envoi un generic_type a l'app.

il faut activer les bon les plugin et mettre en place les generic_type voir la doc du plugin mobile, j'ai normalement tout marqué dessus. ;)

Merci
Équipe développement JEEDOM
Développeur Mobile JEEDOM / Responsable relation partenaire

Dev des plugins :
Mobile, Lifx

Avatar de l’utilisateur
carlierd
Timide
Messages : 253
Inscription : 20 mai 2015, 22:51

Re: Connexion impossible depuis passage en HTTPS

Message par carlierd » 10 mai 2018, 16:05

rocket13011 a écrit :
09 mai 2018, 14:23
quand vous allez sur votre mobile dans le plugin mobile et que vous cliquez sur le bouton bleu clair en haut a droite "infos envoyés à l'app" vous avez un message d'erreur ?
Pas de souci pour moi, y'a pas mal de choses déjà.
Surtout tout fonctionnait bien avant, c'est soit depuis le passage en HTTPS soit depuis la dernière mise à jour. Cela c'est passé à peu près en même temps et je n'arrive pas à me rappeler le déclencheur ...

David.

Avatar de l’utilisateur
rocket13011
Actif
Messages : 573
Inscription : 07 sept. 2014, 21:29
Localisation : Lyon

Re: Connexion impossible depuis passage en HTTPS

Message par rocket13011 » 11 mai 2018, 10:54

carlierd a écrit :
10 mai 2018, 16:05
rocket13011 a écrit :
09 mai 2018, 14:23
quand vous allez sur votre mobile dans le plugin mobile et que vous cliquez sur le bouton bleu clair en haut a droite "infos envoyés à l'app" vous avez un message d'erreur ?
Pas de souci pour moi, y'a pas mal de choses déjà.
Surtout tout fonctionnait bien avant, c'est soit depuis le passage en HTTPS soit depuis la dernière mise à jour. Cela c'est passé à peu près en même temps et je n'arrive pas à me rappeler le déclencheur ...

David.
Peux tu me faire un accès support sur ta jeedom (configuration, utilisateur, activer accès support en haut a droite) et juste me donner ton nom d'utilisateur market ^^ en mp si tu veux

Merci ;)
Équipe développement JEEDOM
Développeur Mobile JEEDOM / Responsable relation partenaire

Dev des plugins :
Mobile, Lifx

Avatar de l’utilisateur
carlierd
Timide
Messages : 253
Inscription : 20 mai 2015, 22:51

Re: Connexion impossible depuis passage en HTTPS

Message par carlierd » 11 mai 2018, 14:48

C'est fait.

Merci !

David.

Avatar de l’utilisateur
carlierd
Timide
Messages : 253
Inscription : 20 mai 2015, 22:51

Re: Connexion impossible depuis passage en HTTPS

Message par carlierd » 15 mai 2018, 10:49

Hello,

Tu as pu regarder ? Car mon accès est toujours ouvert ...

Merci.

David.
rocket13011 a écrit :
11 mai 2018, 10:54
carlierd a écrit :
10 mai 2018, 16:05
rocket13011 a écrit :
09 mai 2018, 14:23
quand vous allez sur votre mobile dans le plugin mobile et que vous cliquez sur le bouton bleu clair en haut a droite "infos envoyés à l'app" vous avez un message d'erreur ?
Pas de souci pour moi, y'a pas mal de choses déjà.
Surtout tout fonctionnait bien avant, c'est soit depuis le passage en HTTPS soit depuis la dernière mise à jour. Cela c'est passé à peu près en même temps et je n'arrive pas à me rappeler le déclencheur ...

David.
Peux tu me faire un accès support sur ta jeedom (configuration, utilisateur, activer accès support en haut a droite) et juste me donner ton nom d'utilisateur market ^^ en mp si tu veux

Merci ;)

Avatar de l’utilisateur
carlierd
Timide
Messages : 253
Inscription : 20 mai 2015, 22:51

Re: Connexion impossible depuis passage en HTTPS

Message par carlierd » 23 mai 2018, 06:19

Hello,

Pour le moment je n'ai plus de problème d'accès car j'ai activé l'accès support dans Jeedom.
Si je le désactive je n'ai de nouveau plus accès ... L'application mobile n'arrivant pas à se synchroniser.

David.

jefa
Timide
Messages : 5
Inscription : 18 févr. 2015, 14:20

Re: Connexion impossible depuis passage en HTTPS

Message par jefa » 24 août 2018, 13:34

Hello,
Du nouveau sur cette problématique de connexion à l'application depuis passage en https de jeedom ?
Merci

Avatar de l’utilisateur
carlierd
Timide
Messages : 253
Inscription : 20 mai 2015, 22:51

Re: Connexion impossible depuis passage en HTTPS

Message par carlierd » 24 août 2018, 16:19

Non c'est toujours pareil. Ne fonctionne que si je laisse ouvert le support Jeedom ...

David.

Cygnus
Timide
Messages : 11
Inscription : 24 août 2017, 13:32

Re: Connexion impossible depuis passage en HTTPS

Message par Cygnus » 08 oct. 2018, 11:56

Bonjour,
j'ai le meme probleme en http, meme logs ..
Pas de soucis mysql quand je clique sur infos envoyées a l'app.
Mon jeedom est sous docker mais les acces internes et externes fonctionnent bien, et pareil en activant l'acces support ca fonctionne donc definitivement probleme coté jeedom.
Quelqu'un a pu regler ce probleme ?

Répondre

Revenir vers « [Plugin officiel] App mobile »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité