Ce Forum passera en lecture seule en janvier 2020
Image
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

502 Bad Gateway

Hier wird über Plugin's, Widget's, Scripts und dere Entwicklung diskutiert
Répondre
Schorsch
Timide
Messages : 333
Inscription : 04 févr. 2015, 10:09

502 Bad Gateway

Message par Schorsch » 02 févr. 2016, 17:44

Hallo,

ich hatte am Montag versucht ein Update mit Jeedom zu machen. Dazu habe ich im Menü auf "Centre de mise à jour"->"mise à jour"->mise à jour IOS geklickt. Jeedom hat dann begonnen das Update durchzuführen. Auf der rechten Seite konnte man sehen was gerade herrunter geladen wurde und was nach und nach installiert wurde. Die Liste wurde immer länger, man konnte schön zugucken. Auf einmal blieb die Liste stehen nichts wurde mehr installiert. Ich glaube die Liste war irgendwo bei etwas mit Mysql stehen geblieben. Eine weile habe ich gewartet. Ich dachte, vielleicht braucht Jeedom an dieser Stelle etwas länger zum installieren. Irgendwann habe ich dann die Seite im Firefox neu geöffnet und habe dann die Fehlermeldung "502 Bad Gateway nginx/1.6.2" bekommen. Ich habe auch den Router nach Jeedom durchsucht ohne Erfolg. Ich habe dann versucht das Jeedomboard direkt anzusprechen, aber ohne Erfolg. Ich habe an dem Board immer eine Funktastatur und als Display mein TV angeschlossen. Aber wenn ich etwas eingeben möchte tut sich nichts. Auf dem Board leuchtet eine rote LED und eine grüne LED blinkt immer. Nun weiss ich nicht was ich machen soll. Einfach den Stecker aus der Steckdose ziehen, eine gewisse Zeit warten und dann wieder reinstecken? :?: :?: :?: :?: :?:

Danke
Meine Server Hardware
Jeedomboard + Z-Wave Modul und OpenZwave-Plugin

Windows PC/Firefox

Avatar de l’utilisateur
yogui
Actif
Messages : 797
Inscription : 11 févr. 2015, 21:52
Localisation : Alsace

Re: 502 Bad Gateway

Message par yogui » 02 févr. 2016, 18:29

Hallo hort sich scheisse an.hoffe das du ein backup hast von deine einstellungen. Ich habe zwar kein jeedomboard aber mit mein pi wurde uch jetzt abstecken und die officielle image neu instalieren.

Ps nachste dienstag steht jeedon v2 zu verfugung
Raspberry PI 2 , Razberry Zwave +
Fibaro FGRM-222
Qubino ZMNHCA2
Fibaro FGS-222
Qubino ZMNHBA2
Everspring AN180-6
Everspring Z-WAVE SP-103
Raspberry Pi 2 + touch 3.5" en Squeezebox
Modules Mysensors

Dev. Librairie Arduino pour Somfy RTS

Schorsch
Timide
Messages : 333
Inscription : 04 févr. 2015, 10:09

Re: 502 Bad Gateway

Message par Schorsch » 03 févr. 2016, 16:45

Bonjour,

ich glaube ich habe noch einmal glück gehabt. Heute habe ich mal das Board vom Strom getrennt. Anschließend habe ich es wieder angeschlossen. Auf meinem TV habe ich zwar kein Signal gefunden, aber auf meinem PC kann ich wieder auf Jeedom zugreifen. Ich habe mal bei den Protokollen gesucht und das Update Protokoll angeschaut. Da kann man sehen wo das Update nicht mehr weiter wollte oder war es vielleicht schon fertig. Ich habe da keine Ahnung, aber müßte nicht eine Meldung kommen das das Update erfolgreich war. Wie ich schon geschrieben hatte kamm ja diese Fehlermeldung.
update.txt
(24.75 Kio) Téléchargé 23 fois
Meine Server Hardware
Jeedomboard + Z-Wave Modul und OpenZwave-Plugin

Windows PC/Firefox

Schorsch
Timide
Messages : 333
Inscription : 04 févr. 2015, 10:09

Re: 502 Bad Gateway

Message par Schorsch » 09 févr. 2016, 13:48

Hallo,

Ich wollte heute versuchen die V2 aufzuspielen. Ohne Erfolg. Ich habe erst einmal auf "Tout forcer" geklickt. Als Jeedom damit fertig war, mußte ich erst einmal ein paar Plugins updaten. Außer das "openzwave", das läßt sich nicht updaten. Es kommt dann immer die folgende Meldung.
09-02-2016 13:30:37 | update | [START UPDATE]
09-02-2016 13:30:37 | update | Starten der Aktualisierung :openzwave<br/>
09-02-2016 13:30:37 | update | Téléchargement de openzwave...
09-02-2016 13:30:38 | update | OK
09-02-2016 13:30:38 | update | Aktion vor dem Update
09-02-2016 13:30:38 | update | OK
09-02-2016 13:30:38 | update | Décompression du zip...
09-02-2016 13:30:38 | update | Impossible de décompresser le zip : /usr/share/nginx/www/jeedom/core/class/../../tmp/openzwave.zip. Erreur : Ceci n\'est pas une archive zip.. Avez vous acheté le plugin ?
09-02-2016 13:30:38 | update | [FEHLER UPDATE ENDE]

Ich habe auf dem Markt nachgeschaut und es erscheint auch nicht mehr das openzwave Plugin. Nur das Z-Way ist vorhanden aber es ist veralter.
protokolle.png
protokolle.png (136 Kio) Consulté 1271 fois
Danach habe ich noch einmal versucht auf "Mettre à jour l'OS" zu klicken. Das war ja die Aktion, die ich schon am 02 Feb 2016 gestartet hatte, wo dann erst einmal die Meldung mit "502 Bad Gateway" kam. Dieses mal ging es ohne diese Meldung. Aber es kamm folgende Meldung.

19 added, 18 removed; done.
Running hooks in /etc/ca-certificates/update.d....done.
Errors were encountered while processing:
php5-mysql
php5-cli
php5-fpm
Error on fix previous update
[END UPDATE ERROR]
Wie kann ich diesen Fehler Korigieren?
Meine Server Hardware
Jeedomboard + Z-Wave Modul und OpenZwave-Plugin

Windows PC/Firefox

Schorsch
Timide
Messages : 333
Inscription : 04 févr. 2015, 10:09

Re: 502 Bad Gateway

Message par Schorsch » 09 févr. 2016, 14:59

Update v2 hab ich auf mein Jeedomboard bekommen. Und das eine Plugin habe ich im anschluß auch aktualisiert.
Ist nur noch die Frage mit den php Dateien.
Meine Server Hardware
Jeedomboard + Z-Wave Modul und OpenZwave-Plugin

Windows PC/Firefox

Avatar de l’utilisateur
marie
Actif
Messages : 1119
Inscription : 20 févr. 2014, 19:39
Localisation : Lyon (ou presque)

Re: 502 Bad Gateway

Message par marie » 13 févr. 2016, 09:15

Cool für die Update und das Plugin :)
Ich werde fur die php dataein fragen

Schorsch
Timide
Messages : 333
Inscription : 04 févr. 2015, 10:09

Re: 502 Bad Gateway

Message par Schorsch » 13 févr. 2016, 10:12

Marie,

du brauchst dich nicht mehr bemühen, ich habe diese Dateien mit SSh-Zugriff installieren können. Sorry, das ich nicht gleich geschrieben habe, das es erledigt ist.

Gruß Schorsch
Meine Server Hardware
Jeedomboard + Z-Wave Modul und OpenZwave-Plugin

Windows PC/Firefox

kouaw
Actif
Messages : 5986
Inscription : 25 janv. 2015, 22:15
Localisation : Belgium
Contact :

Re: 502 Bad Gateway

Message par kouaw » 13 févr. 2016, 10:19

sudo apt update and sudo apt upgrade.

launch php via sudo service php5-fgm restart and try again update for Jeedom.

Envoyé de mon GT-I9300 en utilisant Tapatalk

Schorsch
Timide
Messages : 333
Inscription : 04 févr. 2015, 10:09

Re: 502 Bad Gateway

Message par Schorsch » 13 févr. 2016, 10:24

Marie,

wie ich schon geschrieben habe, ist soweit alles gut gegangen bei der Umstellung auf V2 und nun V2.01. . Ich habe nur noch bei den Netzwerkeinstellungen "NOK". Siehe Bild
Gesundheit NOK.png
Gesundheit NOK.png (51.77 Kio) Consulté 1224 fois
Ich habe mal die Seite mit den Netzwerkeinstellungen kopiert.
Netzwerkkonfiguration.png
Netzwerkkonfiguration.png (43.23 Kio) Consulté 1224 fois
Vielleicht kann mann dieses Problem noch lösen.

Danke Schorsch
Meine Server Hardware
Jeedomboard + Z-Wave Modul und OpenZwave-Plugin

Windows PC/Firefox

Schorsch
Timide
Messages : 333
Inscription : 04 févr. 2015, 10:09

Re: 502 Bad Gateway

Message par Schorsch » 13 févr. 2016, 10:36

Ich Habe auch mal im log-Menü geschaut. Im log nginx.error habe ich noch solche Fehlermeldungen bekommen. Das ist mal die letzte Zeile (die client IP habe ich mal mit XXX geändert). Was hat diese Meldung zu sagen und was kann ich dagegen machen.

2016/02/13 10:05:27 [error] 18195#0: *55499 FastCGI sent in stderr: "Primary script unknown" while reading response header from upstream, client: 192.XXX.XXX.XX, server: , request: "GET /plugins/widget/core/template/dashboard/cmd.action.slider.DanfosIMGbutton/index.php?v=d& HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock:", host: "jeedom.fritz.box", referrer: "http://jeedom.fritz.box/index.php?v=d&p ... bject_id=5"
Meine Server Hardware
Jeedomboard + Z-Wave Modul und OpenZwave-Plugin

Windows PC/Firefox

Schorsch
Timide
Messages : 333
Inscription : 04 févr. 2015, 10:09

Re: 502 Bad Gateway

Message par Schorsch » 13 févr. 2016, 12:19

kouaw,

das was du geschrieben hast, habe ich gemacht. 2 Dateien wurden noch aktualisiert (php-pear und php-dev).
Nur bei der letzten Anweisung bekamm ich eine Fehlermeldung "sudo service php5-fgm restart"-> "Failed to restart php-fgm.service: Unit php5-fgm.service failed to load: No such file or directory."
Es scheint so als ob die Datei nicht installiert ist.
Ich habe schon versucht es nach zu installieren mit "sudo apt php5-fgm" , ohne Erfolg.
Meine Server Hardware
Jeedomboard + Z-Wave Modul und OpenZwave-Plugin

Windows PC/Firefox

kouaw
Actif
Messages : 5986
Inscription : 25 janv. 2015, 22:15
Localisation : Belgium
Contact :

Re: 502 Bad Gateway

Message par kouaw » 13 févr. 2016, 13:57

a command exact is

sudo apt install php5-fgm

;)

Envoyé de mon GT-I9300 en utilisant Tapatalk

Schorsch
Timide
Messages : 333
Inscription : 04 févr. 2015, 10:09

Re: 502 Bad Gateway

Message par Schorsch » 13 févr. 2016, 14:31

Ich glaube es giebt einen Fehler. :?: :?: :?:
ssh.png
ssh.png (5.05 Kio) Consulté 1205 fois
Oder ist es php5-fpm???
Meine Server Hardware
Jeedomboard + Z-Wave Modul und OpenZwave-Plugin

Windows PC/Firefox

Répondre

Revenir vers « Software & Plugins »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 3 invités