Ce Forum passera en lecture seule en janvier 2020
Image
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

Problème de configuration après reinstallation

(anciennement dénommé plugin OpenZwave)

Modérateur : nechry

ehovaere
Timide
Messages : 55
Inscription : 21 déc. 2014, 19:35

Re: Problème de configuration après reinstallation

Message par ehovaere » 10 déc. 2015, 20:59

Le terminal ne me retourne rien donc je dirais que la commande passe. Mais toujours pas de vert.
Health.sh renvoie la même chose.

Par ailleurs, peut être pas un indice pour toi mais j'ai l'erreur JS suivante quand je vais sur ma page jeedom:
http://192.168.1.111/socket.io/socket.io.js?1.2.1 Failed to load resource: the server responded with a status of 502 (Bad Gateway)

kouaw
Actif
Messages : 5986
Inscription : 25 janv. 2015, 22:15
Localisation : Belgium
Contact :

Re: Problème de configuration après reinstallation

Message par kouaw » 10 déc. 2015, 21:28

mhhh il y a bien un soucis sur le nodejs mais j'avoue que la je ne comprend pas pourquoi :/

ehovaere
Timide
Messages : 55
Inscription : 21 déc. 2014, 19:35

Re: Problème de configuration après reinstallation

Message par ehovaere » 10 déc. 2015, 21:55

ah nononnonononon ça ne va pas du tout ça :)

ehovaere
Timide
Messages : 55
Inscription : 21 déc. 2014, 19:35

Re: Problème de configuration après reinstallation

Message par ehovaere » 10 déc. 2015, 22:03

Un peu + d'info.. même si ça ne fait que confirmer:
systemctl status jeedom.service
me donne
● jeedom.service - Service jeedom nodejs
Loaded: loaded (/etc/systemd/system/jeedom.service; enabled)
Active: failed (Result: start-limit) since jeu. 2015-12-10 22:01:29 CET; 19s ago
Process: 5238 ExecStart=/usr/bin/nodejs /usr/share/nginx/www/jeedom/core/nodeJS/server.js (code=exited, status=203/EXEC)
Main PID: 5238 (code=exited, status=203/EXEC)

déc. 10 22:01:28 Jeedom systemd[1]: Unit jeedom.service entered failed state.
déc. 10 22:01:29 Jeedom systemd[1]: jeedom.service holdoff time over, sche...t.
déc. 10 22:01:29 Jeedom systemd[1]: Stopping Service jeedom nodejs...
déc. 10 22:01:29 Jeedom systemd[1]: Starting Service jeedom nodejs...
déc. 10 22:01:29 Jeedom systemd[1]: jeedom.service start request repeated ...t.
déc. 10 22:01:29 Jeedom systemd[1]: Failed to start Service jeedom nodejs.
déc. 10 22:01:29 Jeedom systemd[1]: Unit jeedom.service entered failed state.
déc. 10 22:01:32 Jeedom systemd[1]: Starting Service jeedom nodejs...
déc. 10 22:01:32 Jeedom systemd[1]: jeedom.service start request repeated ...t.
déc. 10 22:01:32 Jeedom systemd[1]: Failed to start Service jeedom nodejs.
Hint: Some lines were ellipsized, use -l to show in full.
Du coup j'ai essayé
/usr/bin/nodejs /usr/share/nginx/www/jeedom/core/nodeJS/server.js

et là ben il connait pas /usr/bin/nodejs...

alors j'essaie à la main

nodejs /usr/share/nginx/www/jeedom/core/nodeJS/server.js

lais là c'est le path nodeJS/server.js qui n'existe pas.. mais c'est normal car j'ai fait ça, c'est la manip de la doc:
rm -rf /usr/share/nginx/www/jeedom/core/nodeJS

qui le recréer ce dossier??

ehovaere
Timide
Messages : 55
Inscription : 21 déc. 2014, 19:35

Re: Problème de configuration après reinstallation

Message par ehovaere » 10 déc. 2015, 22:44

En forçant la mise à jour de jeedom, le dossier est recréé. En lançant nodejs /usr/share/nginx/www/jeedom/core/nodeJS/server.js à la main, le nodeJS devient vert.:)
Me reste plus que cette histoire /usr/bin/nodejs .. ou à modifer le script du service

ehovaere
Timide
Messages : 55
Inscription : 21 déc. 2014, 19:35

Re: Problème de configuration après reinstallation

Message par ehovaere » 10 déc. 2015, 22:52

ok, donc j'ai modifé /etc/systemd/system/jeedom.service pour utiliser /usr/local/bin/nodejs
(bon en 1er temps j'avais fait un lien symbolique mais pas vérifié si ça marche car j'avais alors oublié de faire un systemctl daemon-reload avant de démarrer mon service).

Bref, mon voyant est vert et mon interface se met enfin à jour dynamiquement, je vais pouvoir inclure mes modules, ouf!!

Merci beaucoup à tous!

kouaw
Actif
Messages : 5986
Inscription : 25 janv. 2015, 22:15
Localisation : Belgium
Contact :

Re: Problème de configuration après reinstallation

Message par kouaw » 10 déc. 2015, 23:00

de rien monsieur :)

fabreg
Timide
Messages : 7
Inscription : 12 déc. 2015, 08:23

Re: Problème de configuration après reinstallation

Message par fabreg » 12 déc. 2015, 08:34

Bonjour, pour ma part je viens d'installer Jeedom sur un rasberry pi B+, et je n'ai pas d'actualisation non plus. (node js en gris)

Comme le préconise la doc j'ai donc supprimé le dossier, forcé la mise à jour, un reboot et toujours rien ....

quand je lance un health, nodejs est noté : NOK, try to restart ...

J'ai tenté un : nodejs /usr/share/nginx/www/jeedom/core/nodeJS/server.js
Ce qui me retourne : erreur de segmentation

si vous avez des idées je prend ...

fabreg
Timide
Messages : 7
Inscription : 12 déc. 2015, 08:23

Re: Problème de configuration après reinstallation

Message par fabreg » 12 déc. 2015, 08:46

Je viens de trouver ça :

Code : Tout sélectionner

sudo apt-get remove --purge nodejs
sudo rm /etc/apt/sources.list.d/nodesource.list
sudo apt-get update
cd /tmp
wget http://conoroneill.net.s3.amazonaws.com/wp-content/uploads/2015/09/node-v0.12.7-linux-arm-v6.tar.gz
mkdir /tmp/nodetemp
tar -zxvf node-v0.12.7-linux-arm-v6.tar.gz -C /tmp/nodetemp
sudo cp -R /tmp/nodetemp/* /usr/local/
sudo reboot
Puis

Code : Tout sélectionner

sudo rm /usr/bin/node
sudo rm /usr/bin/nodejs

sudo ln -s /usr/local/bin/nodejs /usr/bin/nodejs
sudo ln -s /usr/local/bin/node /usr/bin/node
sudo service jeedom start
Et cela fonctionne !
Merci à fmetz qui a remercié Slyos qui a lui même remercié matmatdv. Fichtre !

Bonne journée à tous.

Répondre

Revenir vers « Plugin Z-Wave »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 2 invités