Avant toute chose merci de (re)prendre connaissance de la charte et de la respecter.
Pour résumer :
- Avant de poser une question, je cherche si la réponse existe
- Je suis poli, courtois et je respecte tout un chacun sur le forum
- Si un post m'agace : je m'en éloigne plutôt que de répondre d'une façon qui pourrait être mal interprétée


Il n'est jamais du luxe que de rappeler des choses simples :
Courtoisie, amabilité, politesse et bonne humeur sont les maîtres mots pour un forum sympathique, bienveillant et accueillant :)

Le groupe des Helpers est present pour vous aidez, n'hésitez pas à poser des questions ;)

Toute la communauté vous remercie

installer les dépendances

(anciennement dénommé plugin OpenZwave)

Modérateur : nechry

Yves
Timide
Messages : 23
Inscription : 24 mars 2015, 13:05
Localisation : La Rochelle (17)

installer les dépendances

Message par Yves » 12 févr. 2016, 08:42

Bonjour
voilà je n'ai que des NOK dans les dépendances vpn et zwave
Voici la log:
Lancement de l'installation/mise à jour des dépendances openzwave
Hit http://archive.raspberrypi.org jessie InRelease
Hit http://mirrordirector.raspbian.org jessie InRelease
Hit http://archive.raspberrypi.org jessie/main armhf Packages
Hit http://mirrordirector.raspbian.org jessie/main armhf Packages
Hit http://mirrordirector.raspbian.org jessie/non-free armhf Packages
Ign http://archive.raspberrypi.org jessie/main Translation-en
Ign http://mirrordirector.raspbian.org jessie/main Translation-en
Ign http://mirrordirector.raspbian.org jessie/non-free Translation-en
Reading package lists...
Installation des dependances
Reading package lists...
Building dependency tree...
Reading state information...
build-essential is already the newest version.
g++ is already the newest version.
gcc is already the newest version.
git is already the newest version.
libudev-dev is already the newest version.
make is already the newest version.
mercurial is already the newest version.
python-dev is already the newest version.
python-louie is already the newest version.
python-lxml is already the newest version.
python-pip is already the newest version.
python-setuptools is already the newest version.
python-sphinx is already the newest version.
unzip is already the newest version.
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
libjpeg-dev : Depends: libjpeg62-turbo-dev (>= 1:1.3.1-12) but it is not going to be installed
php5-cli : Depends: php5-common (= 5.6.17+dfsg-0+deb8u1) but 5.6.13+dfsg-0+deb8u1 is to be installed
php5-curl : Depends: php5-common (= 5.6.17+dfsg-0+deb8u1) but 5.6.13+dfsg-0+deb8u1 is to be installed
php5-fpm : Depends: php5-common (= 5.6.17+dfsg-0+deb8u1) but 5.6.13+dfsg-0+deb8u1 is to be installed
php5-ldap : Depends: php5-common (= 5.6.17+dfsg-0+deb8u1) but 5.6.13+dfsg-0+deb8u1 is to be installed
php5-mysql : Depends: php5-common (= 5.6.17+dfsg-0+deb8u1) but 5.6.13+dfsg-0+deb8u1 is to be installed
php5-readline : Depends: php5-common (= 5.6.17+dfsg-0+deb8u1) but 5.6.13+dfsg-0+deb8u1 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
could not install mercurial - abort

Que dois-je faire pour remédier à ce problème?
par avance merci
Yves

Santé de Jeedom
Résultat
Conseil
Système à jour OK
Lancement des crons OK
Cron actif OK
Scénario actif OK
Démarré OK
Date système OK
Authentification par défaut OK
Droits sudo OK
Version Jeedom 2.0.1
Version PHP 5.6.13-0+deb8u1
Espace disque libre 83 %
Configuration réseaux interne OK
Configuration réseaux externe NOK Allez sur Administration -> Configuration puis configurez correctement la partie réseaux
Commande info en non evènement seulement 0

Santé Monitoring
Résultat
Conseil
Dépendance OK

Santé Openvpn
Résultat
Conseil
Dépendance NOK

Santé RFXcom
Résultat
Conseil
Configuration démon OK
Status démon OK

Santé SMS
Résultat
Conseil
Configuration démon OK
Status démon OK

Santé Z-Wave
Résultat
Conseil
Dépendance NOK
Configuration démon NOK Dépendances non installées
Status démon OK

Avatar de l’utilisateur
Sshafi
Actif
Messages : 3891
Inscription : 01 juil. 2014, 16:08
Localisation : Albi

Re: installer les dépendances

Message par Sshafi » 12 févr. 2016, 08:55

Déjà je tenterai de faire ce qu'il te dis de faire, en ssh :

Code : Tout sélectionner

sudo apt-get -f install
et avant de re-lancer l'install des dépendances :

Code : Tout sélectionner

sudo apt-get update
sudo apt-get upgrade
??? Menfin ...
VM ESXi # Aeon Lab Gen5 | RFXtrx433E | ...
Trucs & Astuces

Yves
Timide
Messages : 23
Inscription : 24 mars 2015, 13:05
Localisation : La Rochelle (17)

Re: installer les dépendances

Message par Yves » 12 févr. 2016, 09:24

@Sshafi
Merci j'avais essayé sans sudo et ça ne marchais pas.
pour l'instant un blocage sur sudo apt-get ugrade
"L'opération ugrade n'est pas valabble "est la réponse en ssh
Merci encore
Yves

Avatar de l’utilisateur
Sshafi
Actif
Messages : 3891
Inscription : 01 juil. 2014, 16:08
Localisation : Albi

Re: installer les dépendances

Message par Sshafi » 12 févr. 2016, 09:39

Pardon, j'ai tapé trop vite, il fallait lire :

Code : Tout sélectionner

sudo apt-get upgrade
??? Menfin ...
VM ESXi # Aeon Lab Gen5 | RFXtrx433E | ...
Trucs & Astuces

Yves
Timide
Messages : 23
Inscription : 24 mars 2015, 13:05
Localisation : La Rochelle (17)

Re: installer les dépendances

Message par Yves » 12 févr. 2016, 09:54

@Sshafi
Ok je viens de taper la commande.
doit-on faire un reboot de jeedom ? ou relancer directement les dépendances dans le plugin zwave.
Voila l'upgrade viens de se terminer.
Merci beaucoup Sshafi.
Yves

Avatar de l’utilisateur
Sshafi
Actif
Messages : 3891
Inscription : 01 juil. 2014, 16:08
Localisation : Albi

Re: installer les dépendances

Message par Sshafi » 12 févr. 2016, 10:04

Non pas besoin de reboot, c'est linux ;)
Relance la màj des dépendances un plugin après l'autre et regarde les logs ;)
??? Menfin ...
VM ESXi # Aeon Lab Gen5 | RFXtrx433E | ...
Trucs & Astuces

Yves
Timide
Messages : 23
Inscription : 24 mars 2015, 13:05
Localisation : La Rochelle (17)

Re: installer les dépendances

Message par Yves » 12 févr. 2016, 14:16

@Sshafi
Encore merci de m'avoir sorti des dépendances.
j'ai une mini et le temps pour installer les dépendances openzwave = 3heures et 2 mn.
maintenant tout est Ok pour les dépendances.
Seul l' accès externe est nok avec vpn.
Voilà j' arrête pour aujourd'hui.
Demain est un autre jour car déjà presque 6 heures d'informatique c'est trop pour les quelques neurones qu' il me reste.
Yves

Avatar de l’utilisateur
Sshafi
Actif
Messages : 3891
Inscription : 01 juil. 2014, 16:08
Localisation : Albi

Re: installer les dépendances

Message par Sshafi » 12 févr. 2016, 14:24

:lol:
Avec plaisir ;)
Et oui la compilation super longue des dépendances openzwave sur le pi je connais :) Heureusement c'est pas tous les jours... ;)
??? Menfin ...
VM ESXi # Aeon Lab Gen5 | RFXtrx433E | ...
Trucs & Astuces

Répondre

Revenir vers « Plugin Z-Wave »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité