Avant toute chose merci de (re)prendre connaissance de la charte et de la respecter.
Pour résumer :
- Avant de poser une question, je cherche si la réponse existe
- Je suis poli, courtois et je respecte tout un chacun sur le forum
- Si un post m'agace : je m'en éloigne plutôt que de répondre d'une façon qui pourrait être mal interprétée


Il n'est jamais du luxe que de rappeler des choses simples :
Courtoisie, amabilité, politesse et bonne humeur sont les maîtres mots pour un forum sympathique, bienveillant et accueillant :)

Toute la communauté vous remercie

Z-Wave, Everspring SA413 USB -> pb d'installation des dépendances

(anciennement dénommé plugin OpenZwave)

Modérateur : nechry

Dynendal
Timide
Messages : 12
Inscription : 22 juin 2017, 11:52

Z-Wave, Everspring SA413 USB -> pb d'installation des dépendances

Message par Dynendal » 18 mai 2018, 19:27

Bonjour à tous,

J'ai fouillé un peu le forum, mais rien trouvé pour me dépanner, j'espère que je n'ai pas raté un post, et surtout que vous aurez une idée.

Dans le détail, j'utilise Jeedom (up to date) sur Rasp 3, et je viens de recevoir mon controleur Z-Wave Everspring SA413.
Je le détecte bien sur mon Rasp avec un lsusb, je le vois dans la conf du plugin /DEV/ttyACM0(/DEV/ttyACM0), mais lorsque je lance l'install des dépendances, ça plante à 30% avec les logs suivants :

Traceback (most recent call last):
File "/var/www/html/plugins/openzwave/core/class/../../resources/openzwaved/openzwaved.py", line 18, in <module>
from ozwave import globals,server_utils,rest_server
File "/var/www/html/plugins/openzwave/resources/openzwaved/ozwave/globals.py", line 1, in <module>
import utils,network_utils,controller_utils,node_utils
File "/var/www/html/plugins/openzwave/resources/openzwaved/ozwave/utils.py", line 6, in <module>
import network_utils
File "/var/www/html/plugins/openzwave/resources/openzwaved/ozwave/network_utils.py", line 7, in <module>
from openzwave.network import ZWaveNetwork,ZWaveController
ImportError: No module named openzwave.network
[2018-05-18 19:20:37][ERROR] : Impossible de lancer le démon openzwave, relancer le démon en debug et vérifiez la log

Evidemment j'ai reboot, supp et réinstall le plugin, tenter de sélectionner un autre prote clef z-wave, ou changer de port USB, mais toujours le même souci ;(

J'espère que vous aurez une idée de génie !
Merci d'avance.

Dynendal
Timide
Messages : 12
Inscription : 22 juin 2017, 11:52

Re: Z-Wave, Everspring SA413 USB -> pb d'installation des dépendances

Message par Dynendal » 22 mai 2018, 20:27

Personne n'a une idée ?
Je galère...

Avatar de l’utilisateur
nechry
Actif
Messages : 9637
Inscription : 24 juin 2014, 20:07
Localisation : Suisse
Contact :

Re: Z-Wave, Everspring SA413 USB -> pb d'installation des dépendances

Message par nechry » 23 mai 2018, 11:36

il faut donner le log des dépendances si problème de dépendances. là tu as fourni le log du demon, qui refuse de ce lancer comme les dépendances ne sont pas effectuées.
As-tu consulté la documentation avant de poser ta question?
Les demandes de support en MP ne seront pas traité mais j'accepte les dons paypal.me/nechry
Visiter mon blog http://nechry-automation.ch/

Dynendal
Timide
Messages : 12
Inscription : 22 juin 2017, 11:52

Re: Z-Wave, Everspring SA413 USB -> pb d'installation des dépendances

Message par Dynendal » 24 mai 2018, 17:28

Effectivement Nechry, je ne savais pas qu'il y avait aussi des logs dépendances, voici ce que j'obtiens

Lancement de l'installation/mise à jour des dépendances openzwave
Hit:1 http://archive.raspberrypi.org/debian stretch InRelease
Hit:2 http://mirrordirector.raspbian.org/raspbian stretch InRelease
Hit:3 https://deb.nodesource.com/node_8.x stretch InRelease
Reading package lists...
Installation des dependances
Reading package lists...
Building dependency tree...
Reading state information...
build-essential is already the newest version (12.3).
g++ is already the newest version (4:6.3.0-4).
gcc is already the newest version (4:6.3.0-4).
git is already the newest version (1:2.11.0-3+deb9u2).
libjpeg-dev is already the newest version (1:1.5.1-2).
libudev-dev is already the newest version (232-25+deb9u2).
make is already the newest version (4.1-9.1).
python-dev is already the newest version (2.7.13-2).
python-louie is already the newest version (1.1-2.1).
python-lxml is already the newest version (3.7.1-1).
python-pyudev is already the newest version (0.21.0-1).
python-requests is already the newest version (2.12.4-1).
python-serial is already the newest version (3.2.1-1).
python-setuptools is already the newest version (33.1.1-1).
unzip is already the newest version (6.0-21).
python-pip is already the newest version (9.0.1-2+rpt2).
0 upgraded, 0 newly installed, 0 to remove and 41 not upgraded.
3 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up pulseaudio (10.0-1+deb9u1) ...
Configuration file '/etc/pulse/system.pa'
==> File on system created by you or by a script.
==> File also in package provided by package maintainer.
What would you like to do about it ? Your options are:
Y or I : install the package maintainer's version
N or O : keep your currently-installed version
D : show the differences between the versions
Z : start a shell to examine the situation
The default action is to keep your current version.
*** system.pa (Y/I/N/O/D/Z) [default=N] ? dpkg: error processing package pulseaudio (--configure):
end of file on stdin at conffile prompt
dpkg: dependency problems prevent configuration of pulseaudio-module-zeroconf:
pulseaudio-module-zeroconf depends on pulseaudio (= 10.0-1+deb9u1); however:
Package pulseaudio is not configured yet.
dpkg: error processing package pulseaudio-module-zeroconf (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of pulseaudio-module-bluetooth:
pulseaudio-module-bluetooth depends on pulseaudio (= 10.0-1+deb9u1); however:
Package pulseaudio is not configured yet.
dpkg: error processing package pulseaudio-module-bluetooth (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
pulseaudio
pulseaudio-module-zeroconf
pulseaudio-module-bluetooth
E: Sub-process /usr/bin/dpkg returned an error code (1)
could not install git - abort

Dynendal
Timide
Messages : 12
Inscription : 22 juin 2017, 11:52

Re: Z-Wave, Everspring SA413 USB -> pb d'installation des dépendances

Message par Dynendal » 04 juin 2018, 20:55

Bonjour à tous,

Juste pour info, et pour clore ce point, j'ai réussi à résoudre mon souci, il s'agissait de problème de mercurial décrit dans la doc, en §12.13
https://jeedom.github.io/plugin-openzwa ... or-1-43-13

Sauf que je n'avais pas d'alerte Mercurial, et que le rm ne fonctionnait pas.
Il a fallu faire
sudo apt-get install mercurial
sudo rm /var/lib/dpkg/info/$mercurial* -f
Reboot
et à nouveau
sudo apt-get install mercurial

Depuis Zwave fonctionne impec !

Répondre

Revenir vers « Plugin Z-Wave »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité