Avant toute chose merci de (re)prendre connaissance de la charte et de la respecter.
Pour résumer :
- Avant de poser une question, je cherche si la réponse existe
- Je suis poli, courtois et je respecte tout un chacun sur le forum
- Si un post m'agace : je m'en éloigne plutôt que de répondre d'une façon qui pourrait être mal interprétée


Il n'est jamais du luxe que de rappeler des choses simples :
Courtoisie, amabilité, politesse et bonne humeur sont les maîtres mots pour un forum sympathique, bienveillant et accueillant :)

Toute la communauté vous remercie

blocage dépendances à 75% puis erreur dans le tail

(anciennement dénommé plugin OpenZwave)

Modérateur : nechry

vr34
Timide
Messages : 59
Inscription : 20 sept. 2017, 10:49

blocage dépendances à 75% puis erreur dans le tail

Message par vr34 » 22 juin 2018, 12:25

Bonjour,
Je reposte au bon endroit puisqu'il s'agit d'un problème sur l'installation du plugin z-wave et non sur l'installation d'un module z-wave ;)

Suite à un réseau z-wave instable (nombreux noeuds définitivement morts après reboot de mon RPi3), j'ai décidé de réinstaller ce réseau en supprimant mes modules z-wave, désactivant le plugin z-wave, le supprimant. Puis reboot, installation du plugin, activation puis réinstallation des dépendances mais là : blocage à 75%...
J'ai tenté de suivre la procédure dédiée de la doc (§12.13) mais sans succès :
arrêt de cron ok, arrêt de mysql ok, arrêt apache2 ok
Puis le tail -f /var/www/html/log/openzwave_update retourne :
Building CRC16Encap.o
Building MeterPulse.o
Building DeviceResetLocally.o
make[1]: *** wait: No child processes. Stop.
make[1]: *** Waiting for unfinished jobs....
make[1]: *** wait: No child processes. Stop.
/opt/python-openzwave/openzwave/cpp/build/support.mk:130: recipe for target '/opt/python-openzwave/openzwave/.lib/DeviceResetLocally.o' failed
make[2]: *** [/opt/python-openzwave/openzwave/.lib/DeviceResetLocally.o] Terminated
Makefile:272: recipe for target 'openzwave/.lib/' failed
make: *** [openzwave/.lib/] Terminated

Quoi faire ?
Merci d'avance pour vos réponses.
Cordialement,
vr34

Ma configuration : Jeedom 3.2.8 sous Stretch bootant sur SSD 60Go + dongles usb RFplayer1000 et Everspring z-wave+
Plugins : RFPlayer2, script, mode, Free SMS, mail, Imperihome (je viens d'une Zibase et je suis content de le retrouver ! ;) ),
et z-wave qui fonctionnait avant mais mal (noeuds et voisins perdus à chaque reboot)
Tous mes modules z-wave sont alimentés par secteur (sauf un EZMotion sur piles)
Jeedom V3.2 + Rfplayer + dongle Z-wave+ sur Raspberry Pi3
Modules RTS, DiO, zwave, wifi, X2D, …
Gestions chauffage, climatisation, station météo, éclairage, caméras IP, arrosage, volets roulants, ...

vr34
Timide
Messages : 59
Inscription : 20 sept. 2017, 10:49

Re: blocage dépendances à 75% puis erreur dans le tail

Message par vr34 » 23 juin 2018, 08:11

A défaut, existe-t-il un moyen pour supprimer toute trace de ce plugin pour faire ensuite une réinstallation propre ?
car dans mon cas, la désactivation et suppression du plugin z-wave sous jeedom ne suffit pas car il y a toujours la même erreur tail lors de la réinstallation des dépendances.
Jeedom V3.2 + Rfplayer + dongle Z-wave+ sur Raspberry Pi3
Modules RTS, DiO, zwave, wifi, X2D, …
Gestions chauffage, climatisation, station météo, éclairage, caméras IP, arrosage, volets roulants, ...

vr34
Timide
Messages : 59
Inscription : 20 sept. 2017, 10:49

Re: blocage dépendances à 75% puis erreur dans le tail

Message par vr34 » 26 juin 2018, 13:15

Bonjour,
Ne voyant pas de réponse, je me suis résigné à réinstaller jeedom en espérant que cette erreur disparaitrait. Hélas non : une réinstallation de jeedom (script wget -O-...) sans rien supprimer de l'ancien ne suffit pas :-(
J'ai donc pris "quelques" minutes de plus pour refaire une carte microSD propre, réinstaller teamviewer, rebooter sur mon SSD, réinstaller jeedom, le plugin z-wave avec dépendances ok :-) et une sauvegarde de jeedom)
Maintenant je ne touche plus à rien :lol:
Jeedom V3.2 + Rfplayer + dongle Z-wave+ sur Raspberry Pi3
Modules RTS, DiO, zwave, wifi, X2D, …
Gestions chauffage, climatisation, station météo, éclairage, caméras IP, arrosage, volets roulants, ...

Répondre

Revenir vers « Plugin Z-Wave »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 2 invités