Ce Forum passera en lecture seule en janvier 2020
Image
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

Mise à jour 04-02-2019

(anciennement dénommé plugin OpenZwave)

Modérateur : nechry

Avatar de l’utilisateur
zep57
Timide
Messages : 293
Inscription : 29 août 2014, 15:38
Localisation : FALCK 57

Re: Mise à jour 04-02-2019

Message par zep57 » 09 mars 2019, 08:05

Salut
Essaye synchroniser
Playmobil Robocop donc moitié en titane!
Sevice pack power de toute première génération
MERCI A TOUTE L'EQUIPE POUR LE TAF
Merci de votre patience, je suis très vieux.

Manu31240
Timide
Messages : 36
Inscription : 23 oct. 2018, 09:25

Re: Mise à jour 04-02-2019

Message par Manu31240 » 09 mars 2019, 09:15

Bonjour - La nuit porte conseil et la journée s'annonce meilleure qu'elle ne s'est terminée !
Après une bonne nuit le raspberry éteint. Ce matin redémarrage impeccable.
Grosse frayeur tout de même.
merci à tous pour m'avoir lu et/ou répondu.
Bonne journée
RaZberryPI3+capteurs qubino, fibaro+compteur d'eau secure+thermostattado+RFLink

dpm62980
Timide
Messages : 97
Inscription : 06 mars 2015, 21:01

Re: Mise à jour 04-02-2019

Message par dpm62980 » 09 mars 2019, 09:16

Bosquetia a écrit :
08 mars 2019, 19:04
Depuis Jeedom aller sur le market, choisir le plugin zwave et cliquer sur installer stable et pas cliquer sur installer beta !
Je n'avais pas cette possibilité de choix.
Après un redémarrage de la mini+, j'ai pu le faire.
Encore Merci.
C'est quand même curieux que ce soit passé en version beta tout seul.
Je pense que cela s'est produit pendant la dernière mise à jour du plugin ??? (à confirmer).
De plus, je pensais que pour avoir des plugins en version beta, il fallait avoir le core en beta aussi, ce qui n'était pas mon cas.
Le principal, c'est que ce soit ok.
Merci

John13918
Timide
Messages : 6
Inscription : 19 août 2019, 16:42

Re: Mise à jour 04-02-2019

Message par John13918 » 25 août 2019, 20:45

Bonjour, j'ai un problème lors de l'installation des dépendances sur le plugin Z-wave, arrivé à 100%, tout recommence à 0, me disant qu'elles n'ont pas été installées.

J'ai essayé de décrypter le log mais je n'y comprends vraiment rien... si quelqu'un pouvait m'aider ?

Merci d'avance !

Code : Tout sélectionner

Lancement de l'installation/mise à jour des dépendances openzwave
Atteint :1 http://archive.raspberrypi.org/debian buster InRelease
Atteint :2 http://raspbian.raspberrypi.org/raspbian buster InRelease
Lecture des listes de paquets…
Installation des dependances
Lecture des listes de paquets…
Construction de l'arbre des dépendances…
Lecture des informations d'état…
build-essential est déjà la version la plus récente (12.6).
g++ est déjà la version la plus récente (4:8.3.0-1+rpi2).
gcc est déjà la version la plus récente (4:8.3.0-1+rpi2).
git est déjà la version la plus récente (1:2.20.1-2).
libjpeg-dev est déjà la version la plus récente (1:1.5.2-2).
libudev-dev est déjà la version la plus récente (241-5+rpi1).
make est déjà la version la plus récente (4.2.1-1.2).
python-dev est déjà la version la plus récente (2.7.16-1).
python-louie est déjà la version la plus récente (1.1-4).
python-lxml est déjà la version la plus récente (4.3.2-1).
python-pyudev est déjà la version la plus récente (0.21.0-1).
python-requests est déjà la version la plus récente (2.21.0-1).
python-serial est déjà la version la plus récente (3.4-4).
python-setuptools est déjà la version la plus récente (40.8.0-1).
unzip est déjà la version la plus récente (6.0-23).
python-pip est déjà la version la plus récente (18.1-5+rpt1).
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
python3-pyperclip rpi.gpio-common
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 17 non mis à jour.
Installation des dependances Python
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Requirement already satisfied: urwid in /usr/local/lib/python2.7/dist-packages (2.0.1)
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Requirement already satisfied: louie in /usr/lib/python2.7/dist-packages (1.1)
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Requirement already satisfied: six in /usr/lib/python2.7/dist-packages (1.12.0)
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Requirement already satisfied: tornado in /usr/local/lib/python2.7/dist-packages (5.1.1)
Requirement already satisfied: backports-abc>=0.4 in /usr/local/lib/python2.7/dist-packages (from tornado) (0.5)
Requirement already satisfied: singledispatch in /usr/local/lib/python2.7/dist-packages (from tornado) (3.4.0.3)
Requirement already satisfied: futures in /usr/local/lib/python2.7/dist-packages (from tornado) (3.3.0)
Requirement already satisfied: six in /usr/lib/python2.7/dist-packages (from singledispatch->tornado) (1.12.0)
mkdir: impossible de créer le répertoire « /opt »: Le fichier existe
Désinstallation de la version précédente
Installation de Python-OpenZwave
Not uninstalling cython at /usr/lib/python2.7/dist-packages, outside environment /usr
Can't uninstall 'Cython'. No files were found to uninstall.
apt-get install --force-yes -y cython
Lecture des listes de paquets…
Construction de l'arbre des dépendances…
Lecture des informations d'état…
cython est déjà la version la plus récente (0.29.2-2).
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
python3-pyperclip rpi.gpio-common
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 17 non mis à jour.
W: --force-yes est obsolète, veuillez plutôt utiliser l'une des options commençant par --allow.
Installing dependencies for python : 2 7 16
apt-get install --force-yes -y python-pip python-dev python-docutils python-setuptools python-louie
Lecture des listes de paquets…
Construction de l'arbre des dépendances…
Lecture des informations d'état…
python-dev est déjà la version la plus récente (2.7.16-1).
python-docutils est déjà la version la plus récente (0.14+dfsg-4).
python-louie est déjà la version la plus récente (1.1-4).
python-setuptools est déjà la version la plus récente (40.8.0-1).
python-pip est déjà la version la plus récente (18.1-5+rpt1).
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
python3-pyperclip rpi.gpio-common
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 17 non mis à jour.
W: --force-yes est obsolète, veuillez plutôt utiliser l'une des options commençant par --allow.
apt-get install --force-yes -y build-essential libudev-dev g++
Lecture des listes de paquets…
Construction de l'arbre des dépendances…
Lecture des informations d'état…
build-essential est déjà la version la plus récente (12.6).
g++ est déjà la version la plus récente (4:8.3.0-1+rpi2).
libudev-dev est déjà la version la plus récente (241-5+rpi1).
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
python3-pyperclip rpi.gpio-common
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 17 non mis à jour.
W: --force-yes est obsolète, veuillez plutôt utiliser l'une des options commençant par --allow.
apt-get install --force-yes -y cython
Lecture des listes de paquets…
Construction de l'arbre des dépendances…
Lecture des informations d'état…
cython est déjà la version la plus récente (0.29.2-2).
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
python3-pyperclip rpi.gpio-common
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 17 non mis à jour.
W: --force-yes est obsolète, veuillez plutôt utiliser l'une des options commençant par --allow.
pip install nose-html
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Requirement already satisfied: nose-html in /usr/local/lib/python2.7/dist-packages (1.1)
Requirement already satisfied: nose>=0.11.1 in /usr/lib/python2.7/dist-packages (from nose-html) (1.3.7)
pip install nose-progressive
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Requirement already satisfied: nose-progressive in /usr/local/lib/python2.7/dist-packages (1.5.2)
Requirement already satisfied: blessings<2.0,>=1.3 in /usr/local/lib/python2.7/dist-packages (from nose-progressive) (1.7)
Requirement already satisfied: nose>=1.2.1 in /usr/lib/python2.7/dist-packages (from nose-progressive) (1.3.7)
Requirement already satisfied: six in /usr/lib/python2.7/dist-packages (from blessings<2.0,>=1.3->nose-progressive) (1.12.0)
pip install coverage
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Requirement already satisfied: coverage in /usr/local/lib/python2.7/dist-packages (4.5.4)
pip install nose
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Requirement already satisfied: nose in /usr/lib/python2.7/dist-packages (1.3.7)
pip install pylint
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Requirement already satisfied: pylint in /usr/local/lib/python2.7/dist-packages (1.9.5)
Requirement already satisfied: isort>=4.2.5 in /usr/local/lib/python2.7/dist-packages (from pylint) (4.3.21)
Requirement already satisfied: six in /usr/lib/python2.7/dist-packages (from pylint) (1.12.0)
Requirement already satisfied: astroid<2.0,>=1.6 in /usr/local/lib/python2.7/dist-packages (from pylint) (1.6.6)
Requirement already satisfied: singledispatch; python_version < "3.4" in /usr/local/lib/python2.7/dist-packages (from pylint) (3.4.0.3)
Requirement already satisfied: configparser; python_version == "2.7" in /usr/lib/python2.7/dist-packages (from pylint) (3.5.0b2)
Requirement already satisfied: backports.functools-lru-cache; python_version == "2.7" in /usr/lib/python2.7/dist-packages (from pylint) (1.5)
Requirement already satisfied: mccabe in /usr/local/lib/python2.7/dist-packages (from pylint) (0.6.1)
Requirement already satisfied: futures; python_version < "3.2" in /usr/local/lib/python2.7/dist-packages (from isort>=4.2.5->pylint) (3.3.0)
Requirement already satisfied: enum34>=1.1.3; python_version < "3.4" in /usr/lib/python2.7/dist-packages (from astroid<2.0,>=1.6->pylint) (1.1.6)
Requirement already satisfied: lazy-object-proxy in /usr/local/lib/python2.7/dist-packages (from astroid<2.0,>=1.6->pylint) (1.4.1)
Requirement already satisfied: wrapt in /usr/local/lib/python2.7/dist-packages (from astroid<2.0,>=1.6->pylint) (1.11.2)
#pip install docutils
#pip install setuptools
#The following line crashes with a core dump
#pip install "Cython==0.22"
Dependencies for users installed (python 2 7 16)
sed -i -e '253s/.*//' openzwave/cpp/src/value_classes/ValueID.h
cd openzwave && make
make[1] : on entre dans le répertoire « /opt/python-openzwave/openzwave »
CPPFLAGS= make -C /opt/python-openzwave/openzwave/cpp/build/ -w
make[2] : on entre dans le répertoire « /opt/python-openzwave/openzwave/cpp/build »
Building OpenZWave Version 1.4.-1
Building tinystr.o
Building tinyxmlerror.o
Building tinyxml.o
Building tinyxmlparser.o
Building hid.o
Building aeskey.o
Building aescrypt.o
Building aestab.o
Building aes_modes.o
Building Proprietary.o
Building UserCode.o
Building BarrierOperator.o
Building SensorBinary.o
Building Language.o
Building MultiChannelAssociation.o
Building WakeUp.o
Building Color.o
Building Meter.o
Building Indicator.o
Building CRC16Encap.o
Building MultiInstance.o
Building ManufacturerSpecific.o
In file included from /usr/include/c++/8/map:60,
from /opt/python-openzwave/openzwave/cpp/src/command_classes/CommandClasses.h:32,
from /opt/python-openzwave/openzwave/cpp/src/command_classes/ManufacturerSpecific.cpp:28:
/usr/include/c++/8/bits/stl_tree.h: In function ‘std::_Rb_tree<_Key, _Val, _KeyOfValue, _Compare, _Alloc>::iterator std::_Rb_tree<_Key, _Val, _KeyOfValue, _Compare, _Alloc>::_M_emplace_hint_unique(std::_Rb_tree<_Key, _Val, _KeyOfValue, _Compare, _Alloc>::const_iterator, _Args&& ...) [with _Args = {const std::piecewise_construct_t&, std::tuple<long long int&&>, std::tuple<>}; _Key = long long int; _Val = std::pair<const long long int, OpenZWave::ManufacturerSpecific::Product*>; _KeyOfValue = std::_Select1st<std::pair<const long long int, OpenZWave::ManufacturerSpecific::Product*> >; _Compare = std::less<long long int>; _Alloc = std::allocator<std::pair<const long long int, OpenZWave::ManufacturerSpecific::Product*> >]’:
/usr/include/c++/8/bits/stl_tree.h:2411:7: note: parameter passing for argument of type ‘std::_Rb_tree<long long int, std::pair<const long long int, OpenZWave::ManufacturerSpecific::Product*>, std::_Select1st<std::pair<const long long int, OpenZWave::ManufacturerSpecific::Product*> >, std::less<long long int>, std::allocator<std::pair<const long long int, OpenZWave::ManufacturerSpecific::Product*> > >::const_iterator’ {aka ‘std::_Rb_tree_const_iterator<std::pair<const long long int, OpenZWave::ManufacturerSpecific::Product*> >’} changed in GCC 7.1
_Rb_tree<_Key, _Val, _KeyOfValue, _Compare, _Alloc>::
^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
In file included from /usr/include/c++/8/map:61,
from /opt/python-openzwave/openzwave/cpp/src/command_classes/CommandClasses.h:32,
from /opt/python-openzwave/openzwave/cpp/src/command_classes/ManufacturerSpecific.cpp:28:
/usr/include/c++/8/bits/stl_map.h: In static member function ‘static bool OpenZWave::ManufacturerSpecific::LoadProductXML()’:
/usr/include/c++/8/bits/stl_map.h:518:8: note: parameter passing for argument of type ‘std::_Rb_tree<long long int, std::pair<const long long int, OpenZWave::ManufacturerSpecific::Product*>, std::_Select1st<std::pair<const long long int, OpenZWave::ManufacturerSpecific::Product*> >, std::less<long long int>, std::allocator<std::pair<const long long int, OpenZWave::ManufacturerSpecific::Product*> > >::const_iterator’ {aka ‘std::_Rb_tree_const_iterator<std::pair<const long long int, OpenZWave::ManufacturerSpecific::Product*> >’} changed in GCC 7.1
__i = _M_t._M_emplace_hint_unique(__i, std::piecewise_construct,
/usr/include/c++/8/bits/stl_map.h:518:8: note: parameter passing for argument of type ‘std::_Rb_tree<long long int, std::pair<const long long int, OpenZWave::ManufacturerSpecific::Product*>, std::_Select1st<std::pair<const long long int, OpenZWave::ManufacturerSpecific::Product*> >, std::less<long long int>, std::allocator<std::pair<const long long int, OpenZWave::ManufacturerSpecific::Product*> > >::const_iterator’ {aka ‘std::_Rb_tree_const_iterator<std::pair<const long long int, OpenZWave::ManufacturerSpecific::Product*> >’} changed in GCC 7.1
__i = _M_t._M_emplace_hint_unique(__i, std::piecewise_construct,
/usr/include/c++/8/bits/stl_map.h:518:8: note: parameter passing for argument of type ‘std::_Rb_tree<long long int, std::pair<const long long int, OpenZWave::ManufacturerSpecific::Product*>, std::_Select1st<std::pair<const long long int, OpenZWave::ManufacturerSpecific::Product*> >, std::less<long long int>, std::allocator<std::pair<const long long int, OpenZWave::ManufacturerSpecific::Product*> > >::const_iterator’ {aka ‘std::_Rb_tree_const_iterator<std::pair<const long long int, OpenZWave::ManufacturerSpecific::Product*> >’} changed in GCC 7.1
__i = _M_t._M_emplace_hint_unique(__i, std::piecewise_construct,
Building DeviceResetLocally.o
Building MeterPulse.o
Building SwitchBinary.o
Building CommandClass.o
Building Basic.o
Building Clock.o
Building Configuration.o
Building SwitchToggleBinary.o
Building Hail.o
Building ThermostatMode.o
Building SensorMultilevel.o
Building ClimateControlSchedule.o
Building SensorAlarm.o
Building TimeParameters.o
Building SwitchMultilevel.o
Building Association.o
Building ApplicationStatus.o
Building SoundSwitch.o
Building ZWavePlusInfo.o
Building CentralScene.o
Building DoorLockLogging.o
/opt/python-openzwave/openzwave/cpp/src/command_classes/DoorLockLogging.cpp: In member function ‘virtual bool OpenZWave::DoorLockLogging::HandleMsg(const uint8*, uint32, uint32)’:
/opt/python-openzwave/openzwave/cpp/src/command_classes/DoorLockLogging.cpp:312:15: error: passing argument 1 to restrict-qualified parameter aliases with argument 4 [-Werror=restrict]
snprintf(usercode, sizeof(usercode), "%s %d", usercode, (int)_data[12+i]);
^~~~~~~~                             ~~~~~~~~
cc1plus: all warnings being treated as errors
make[2]: *** [/opt/python-openzwave/openzwave/cpp/build/support.mk:136: /opt/python-openzwave/openzwave/.lib/DoorLockLogging.o] Error 1
make[2] : on quitte le répertoire « /opt/python-openzwave/openzwave/cpp/build »
make[1]: *** [Makefile:20: all] Error 2
make[1] : on quitte le répertoire « /opt/python-openzwave/openzwave »
make: *** [Makefile:273: openzwave/.lib/] Error 2
sed: impossible de lire /etc/inittab: Aucun fichier ou dossier de ce type
Raspberry Pi 3 Detected. If you use a Razberry board you must Disabling Bluetooth
Please add 'dtoverlay=pi3-miniuart-bt' to the end of the file /boot/config.txt
And reboot your Raspberry Pi
Everything is successfully installed!
Dernière édition par John13918 le 25 août 2019, 23:02, édité 1 fois.

madcow
Timide
Messages : 299
Inscription : 06 févr. 2019, 21:41

Re: Mise à jour 04-02-2019

Message par madcow » 25 août 2019, 20:49

John13918 a écrit :Bonjour, j'ai un problème lors de l'installation des dépendances sur le plugin Z-wave, arrivé à 100%, tout recommence à 0, me disant qu'elles n'ont pas été installées.

J'ai essayé de décrypter le log mais je n'y comprends vraiment rien... si quelqu'un pouvait m'aider ?

Merci d'avance !

Lancement de l'installation/mise à jour des dépendances openzwave
Atteint :1 http://archive.raspberrypi.org/debian buster InRelease
Atteint :2 http://raspbian.raspberrypi.org/raspbian buster InRelease
Lecture des listes de paquets…
Installation des dependances
Lecture des listes de paquets…
Construction de l'arbre des dépendances…
Lecture des informations d'état…
build-essential est déjà la version la plus récente (12.6).
g++ est déjà la version la plus récente (4:8.3.0-1+rpi2).
gcc est déjà la version la plus récente (4:8.3.0-1+rpi2).
git est déjà la version la plus récente (1:2.20.1-2).
libjpeg-dev est déjà la version la plus récente (1:1.5.2-2).
libudev-dev est déjà la version la plus récente (241-5+rpi1).
make est déjà la version la plus récente (4.2.1-1.2).
python-dev est déjà la version la plus récente (2.7.16-1).
python-louie est déjà la version la plus récente (1.1-4).
python-lxml est déjà la version la plus récente (4.3.2-1).
python-pyudev est déjà la version la plus récente (0.21.0-1).
python-requests est déjà la version la plus récente (2.21.0-1).
python-serial est déjà la version la plus récente (3.4-4).
python-setuptools est déjà la version la plus récente (40.8.0-1).
unzip est déjà la version la plus récente (6.0-23).
python-pip est déjà la version la plus récente (18.1-5+rpt1).
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
python3-pyperclip rpi.gpio-common
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 17 non mis à jour.
Installation des dependances Python
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Requirement already satisfied: urwid in /usr/local/lib/python2.7/dist-packages (2.0.1)
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Requirement already satisfied: louie in /usr/lib/python2.7/dist-packages (1.1)
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Requirement already satisfied: six in /usr/lib/python2.7/dist-packages (1.12.0)
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Requirement already satisfied: tornado in /usr/local/lib/python2.7/dist-packages (5.1.1)
Requirement already satisfied: backports-abc>=0.4 in /usr/local/lib/python2.7/dist-packages (from tornado) (0.5)
Requirement already satisfied: singledispatch in /usr/local/lib/python2.7/dist-packages (from tornado) (3.4.0.3)
Requirement already satisfied: futures in /usr/local/lib/python2.7/dist-packages (from tornado) (3.3.0)
Requirement already satisfied: six in /usr/lib/python2.7/dist-packages (from singledispatch->tornado) (1.12.0)
mkdir: impossible de créer le répertoire « /opt »: Le fichier existe
Désinstallation de la version précédente
Installation de Python-OpenZwave
Not uninstalling cython at /usr/lib/python2.7/dist-packages, outside environment /usr
Can't uninstall 'Cython'. No files were found to uninstall.
apt-get install --force-yes -y cython
Lecture des listes de paquets…
Construction de l'arbre des dépendances…
Lecture des informations d'état…
cython est déjà la version la plus récente (0.29.2-2).
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
python3-pyperclip rpi.gpio-common
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 17 non mis à jour.
W: --force-yes est obsolète, veuillez plutôt utiliser l'une des options commençant par --allow.
Installing dependencies for python : 2 7 16
apt-get install --force-yes -y python-pip python-dev python-docutils python-setuptools python-louie
Lecture des listes de paquets…
Construction de l'arbre des dépendances…
Lecture des informations d'état…
python-dev est déjà la version la plus récente (2.7.16-1).
python-docutils est déjà la version la plus récente (0.14+dfsg-4).
python-louie est déjà la version la plus récente (1.1-4).
python-setuptools est déjà la version la plus récente (40.8.0-1).
python-pip est déjà la version la plus récente (18.1-5+rpt1).
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
python3-pyperclip rpi.gpio-common
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 17 non mis à jour.
W: --force-yes est obsolète, veuillez plutôt utiliser l'une des options commençant par --allow.
apt-get install --force-yes -y build-essential libudev-dev g++
Lecture des listes de paquets…
Construction de l'arbre des dépendances…
Lecture des informations d'état…
build-essential est déjà la version la plus récente (12.6).
g++ est déjà la version la plus récente (4:8.3.0-1+rpi2).
libudev-dev est déjà la version la plus récente (241-5+rpi1).
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
python3-pyperclip rpi.gpio-common
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 17 non mis à jour.
W: --force-yes est obsolète, veuillez plutôt utiliser l'une des options commençant par --allow.
apt-get install --force-yes -y cython
Lecture des listes de paquets…
Construction de l'arbre des dépendances…
Lecture des informations d'état…
cython est déjà la version la plus récente (0.29.2-2).
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
python3-pyperclip rpi.gpio-common
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 17 non mis à jour.
W: --force-yes est obsolète, veuillez plutôt utiliser l'une des options commençant par --allow.
pip install nose-html
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Requirement already satisfied: nose-html in /usr/local/lib/python2.7/dist-packages (1.1)
Requirement already satisfied: nose>=0.11.1 in /usr/lib/python2.7/dist-packages (from nose-html) (1.3.7)
pip install nose-progressive
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Requirement already satisfied: nose-progressive in /usr/local/lib/python2.7/dist-packages (1.5.2)
Requirement already satisfied: blessings<2.0,>=1.3 in /usr/local/lib/python2.7/dist-packages (from nose-progressive) (1.7)
Requirement already satisfied: nose>=1.2.1 in /usr/lib/python2.7/dist-packages (from nose-progressive) (1.3.7)
Requirement already satisfied: six in /usr/lib/python2.7/dist-packages (from blessings<2.0,>=1.3->nose-progressive) (1.12.0)
pip install coverage
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Requirement already satisfied: coverage in /usr/local/lib/python2.7/dist-packages (4.5.4)
pip install nose
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Requirement already satisfied: nose in /usr/lib/python2.7/dist-packages (1.3.7)
pip install pylint
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Requirement already satisfied: pylint in /usr/local/lib/python2.7/dist-packages (1.9.5)
Requirement already satisfied: isort>=4.2.5 in /usr/local/lib/python2.7/dist-packages (from pylint) (4.3.21)
Requirement already satisfied: six in /usr/lib/python2.7/dist-packages (from pylint) (1.12.0)
Requirement already satisfied: astroid<2.0,>=1.6 in /usr/local/lib/python2.7/dist-packages (from pylint) (1.6.6)
Requirement already satisfied: singledispatch; python_version < "3.4" in /usr/local/lib/python2.7/dist-packages (from pylint) (3.4.0.3)
Requirement already satisfied: configparser; python_version == "2.7" in /usr/lib/python2.7/dist-packages (from pylint) (3.5.0b2)
Requirement already satisfied: backports.functools-lru-cache; python_version == "2.7" in /usr/lib/python2.7/dist-packages (from pylint) (1.5)
Requirement already satisfied: mccabe in /usr/local/lib/python2.7/dist-packages (from pylint) (0.6.1)
Requirement already satisfied: futures; python_version < "3.2" in /usr/local/lib/python2.7/dist-packages (from isort>=4.2.5->pylint) (3.3.0)
Requirement already satisfied: enum34>=1.1.3; python_version < "3.4" in /usr/lib/python2.7/dist-packages (from astroid<2.0,>=1.6->pylint) (1.1.6)
Requirement already satisfied: lazy-object-proxy in /usr/local/lib/python2.7/dist-packages (from astroid<2.0,>=1.6->pylint) (1.4.1)
Requirement already satisfied: wrapt in /usr/local/lib/python2.7/dist-packages (from astroid<2.0,>=1.6->pylint) (1.11.2)
#pip install docutils
#pip install setuptools
#The following line crashes with a core dump
#pip install "Cython==0.22"
Dependencies for users installed (python 2 7 16)
sed -i -e '253s/.*//' openzwave/cpp/src/value_classes/ValueID.h
cd openzwave && make
make[1] : on entre dans le répertoire « /opt/python-openzwave/openzwave »
CPPFLAGS= make -C /opt/python-openzwave/openzwave/cpp/build/ -w
make[2] : on entre dans le répertoire « /opt/python-openzwave/openzwave/cpp/build »
Building OpenZWave Version 1.4.-1
Building tinystr.o
Building tinyxmlerror.o
Building tinyxml.o
Building tinyxmlparser.o
Building hid.o
Building aeskey.o
Building aescrypt.o
Building aestab.o
Building aes_modes.o
Building Proprietary.o
Building UserCode.o
Building BarrierOperator.o
Building SensorBinary.o
Building Language.o
Building MultiChannelAssociation.o
Building WakeUp.o
Building Color.o
Building Meter.o
Building Indicator.o
Building CRC16Encap.o
Building MultiInstance.o
Building ManufacturerSpecific.o
In file included from /usr/include/c++/8/map:60,
from /opt/python-openzwave/openzwave/cpp/src/command_classes/CommandClasses.h:32,
from /opt/python-openzwave/openzwave/cpp/src/command_classes/ManufacturerSpecific.cpp:28:
/usr/include/c++/8/bits/stl_tree.h: In function ‘std::_Rb_tree<_Key, _Val, _KeyOfValue, _Compare, _Alloc>::iterator std::_Rb_tree<_Key, _Val, _KeyOfValue, _Compare, _Alloc>::_M_emplace_hint_unique(std::_Rb_tree<_Key, _Val, _KeyOfValue, _Compare, _Alloc>::const_iterator, _Args&& ...) [with _Args = {const std::piecewise_construct_t&, std::tuple<long long int&&>, std::tuple<>}; _Key = long long int; _Val = std::pair<const long long int, OpenZWave::ManufacturerSpecific::Product*>; _KeyOfValue = std::_Select1st<std::pair<const long long int, OpenZWave::ManufacturerSpecific::Product*> >; _Compare = std::less<long long int>; _Alloc = std::allocator<std::pair<const long long int, OpenZWave::ManufacturerSpecific::Product*> >]’:
/usr/include/c++/8/bits/stl_tree.h:2411:7: note: parameter passing for argument of type ‘std::_Rb_tree<long long int, std::pair<const long long int, OpenZWave::ManufacturerSpecific::Product*>, std::_Select1st<std::pair<const long long int, OpenZWave::ManufacturerSpecific::Product*> >, std::less<long long int>, std::allocator<std::pair<const long long int, OpenZWave::ManufacturerSpecific::Product*> > >::const_iterator’ {aka ‘std::_Rb_tree_const_iterator<std::pair<const long long int, OpenZWave::ManufacturerSpecific::Product*> >’} changed in GCC 7.1
_Rb_tree<_Key, _Val, _KeyOfValue, _Compare, _Alloc>::
^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
In file included from /usr/include/c++/8/map:61,
from /opt/python-openzwave/openzwave/cpp/src/command_classes/CommandClasses.h:32,
from /opt/python-openzwave/openzwave/cpp/src/command_classes/ManufacturerSpecific.cpp:28:
/usr/include/c++/8/bits/stl_map.h: In static member function ‘static bool OpenZWave::ManufacturerSpecific::LoadProductXML()’:
/usr/include/c++/8/bits/stl_map.h:518:8: note: parameter passing for argument of type ‘std::_Rb_tree<long long int, std::pair<const long long int, OpenZWave::ManufacturerSpecific::Product*>, std::_Select1st<std::pair<const long long int, OpenZWave::ManufacturerSpecific::Product*> >, std::less<long long int>, std::allocator<std::pair<const long long int, OpenZWave::ManufacturerSpecific::Product*> > >::const_iterator’ {aka ‘std::_Rb_tree_const_iterator<std::pair<const long long int, OpenZWave::ManufacturerSpecific::Product*> >’} changed in GCC 7.1
__i = _M_t._M_emplace_hint_unique(__i, std::piecewise_construct,
/usr/include/c++/8/bits/stl_map.h:518:8: note: parameter passing for argument of type ‘std::_Rb_tree<long long int, std::pair<const long long int, OpenZWave::ManufacturerSpecific::Product*>, std::_Select1st<std::pair<const long long int, OpenZWave::ManufacturerSpecific::Product*> >, std::less<long long int>, std::allocator<std::pair<const long long int, OpenZWave::ManufacturerSpecific::Product*> > >::const_iterator’ {aka ‘std::_Rb_tree_const_iterator<std::pair<const long long int, OpenZWave::ManufacturerSpecific::Product*> >’} changed in GCC 7.1
__i = _M_t._M_emplace_hint_unique(__i, std::piecewise_construct,
/usr/include/c++/8/bits/stl_map.h:518:8: note: parameter passing for argument of type ‘std::_Rb_tree<long long int, std::pair<const long long int, OpenZWave::ManufacturerSpecific::Product*>, std::_Select1st<std::pair<const long long int, OpenZWave::ManufacturerSpecific::Product*> >, std::less<long long int>, std::allocator<std::pair<const long long int, OpenZWave::ManufacturerSpecific::Product*> > >::const_iterator’ {aka ‘std::_Rb_tree_const_iterator<std::pair<const long long int, OpenZWave::ManufacturerSpecific::Product*> >’} changed in GCC 7.1
__i = _M_t._M_emplace_hint_unique(__i, std::piecewise_construct,
Building DeviceResetLocally.o
Building MeterPulse.o
Building SwitchBinary.o
Building CommandClass.o
Building Basic.o
Building Clock.o
Building Configuration.o
Building SwitchToggleBinary.o
Building Hail.o
Building ThermostatMode.o
Building SensorMultilevel.o
Building ClimateControlSchedule.o
Building SensorAlarm.o
Building TimeParameters.o
Building SwitchMultilevel.o
Building Association.o
Building ApplicationStatus.o
Building SoundSwitch.o
Building ZWavePlusInfo.o
Building CentralScene.o
Building DoorLockLogging.o
/opt/python-openzwave/openzwave/cpp/src/command_classes/DoorLockLogging.cpp: In member function ‘virtual bool OpenZWave::DoorLockLogging::HandleMsg(const uint8*, uint32, uint32)’:
/opt/python-openzwave/openzwave/cpp/src/command_classes/DoorLockLogging.cpp:312:15: error: passing argument 1 to restrict-qualified parameter aliases with argument 4 [-Werror=restrict]
snprintf(usercode, sizeof(usercode), "%s %d", usercode, (int)_data[12+i]);
^~~~~~~~ ~~~~~~~~
cc1plus: all warnings being treated as errors
make[2]: *** [/opt/python-openzwave/openzwave/cpp/build/support.mk:136: /opt/python-openzwave/openzwave/.lib/DoorLockLogging.o] Error 1
make[2] : on quitte le répertoire « /opt/python-openzwave/openzwave/cpp/build »
make[1]: *** [Makefile:20: all] Error 2
make[1] : on quitte le répertoire « /opt/python-openzwave/openzwave »
make: *** [Makefile:273: openzwave/.lib/] Error 2
sed: impossible de lire /etc/inittab: Aucun fichier ou dossier de ce type
Raspberry Pi 3 Detected. If you use a Razberry board you must Disabling Bluetooth
Please add 'dtoverlay=pi3-miniuart-bt' to the end of the file /boot/config.txt
And reboot your Raspberry Pi
Everything is successfully installed!
Bonjour,

Tu es sous Debian Buster et non Stretch.
Buster n'est pas officiellement encore supporté par Jeedom. Donc des fois ça marche pas bien.
Il faut être sur la version bêta du plugin ZWave pour que cela fonctionne sous Buster.
DIY Proxmox sur HP Proliant
Débutant sur Jeedom

Avatar de l’utilisateur
Poumi
Actif
Messages : 660
Inscription : 21 mars 2019, 22:41

Re: Mise à jour 04-02-2019

Message par Poumi » 25 août 2019, 20:51

Tu es sur Buster...

C’est pas encore supporté.

Soit tu met stretch soit tu met le plugin en bêta (tu risque d’avoir le soucis sur d’autres plugin ou même la bêta ne marchera pas...)

Avatar de l’utilisateur
Jeandhom
Actif
Messages : 1382
Inscription : 20 oct. 2015, 17:32

Re: Mise à jour 04-02-2019

Message par Jeandhom » 25 août 2019, 20:54

Pour l'instant, il vaut mieux rester sous Stretch.

Mets aussi tes logs entre balise.

John13918
Timide
Messages : 6
Inscription : 19 août 2019, 16:42

Re: Mise à jour 04-02-2019

Message par John13918 » 25 août 2019, 23:04

Merci pour les réponses rapides.

J'ai mis mon texte sous balise, désolé.

D'accord pour les solutions. Je rechercherai comment passer sous Stretch sans tout perdre, je pense qu'il y a ça quelque part :D

Répondre

Revenir vers « Plugin Z-Wave »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité