Avant toute chose merci de (re)prendre connaissance de la charte et de la respecter.
Pour résumer :
- Avant de poser une question, je cherche si la réponse existe
- Je suis poli, courtois et je respecte tout un chacun sur le forum
- Si un post m'agace : je m'en éloigne plutôt que de répondre d'une façon qui pourrait être mal interprétée


Il n'est jamais du luxe que de rappeler des choses simples :
Courtoisie, amabilité, politesse et bonne humeur sont les maîtres mots pour un forum sympathique, bienveillant et accueillant :)

Le groupe des Helpers est present pour vous aidez, n'hésitez pas à poser des questions ;)

Toute la communauté vous remercie

Mise à jour 04-02-2019

(anciennement dénommé plugin OpenZwave)

Modérateur : nechry

Avatar de l’utilisateur
loic
Administrateur
Messages : 13828
Inscription : 01 févr. 2014, 16:21

Re: Mise à jour 04-02-2019

Message par loic » 06 févr. 2019, 16:49

i-magin a écrit :
06 févr. 2019, 16:42
Merci @Loic, j'ai bien noté que le demon Z-Wave n'est pas relancé tant que les dépendances sont en cours d'installation

Mais, je me pose toujours la question suivante.... désolé je suis un néophyte !
- je lance la mise à jour du plugin Z-Wave
- la maj terminée, le demon démarre automatiquement puisque l'installation des dépendances n'est pas en cours
- est-ce que le fait que le demon Z-Wave démarre avec d'anciennes dépendances pose des problèmes ?
Par exemple, @thespy évoque la difficulté de stopper le demon pour lancer l'installation des nouvelles dépendances

Encore merci !
Faut pas se prendre la tête faut juste suivre ce qui est dit faire la mise a jour puis lancer les dépendances.
Aide nous à t'aider : mets des logs, détaille ton soucis... Vous n'aurez aucune réponse de ma part si votre demande n'est pas détaillée (log, capture d'écran lisible...) ou si vous ne postez pas dans la bonne section

i-magin
Actif
Messages : 885
Inscription : 18 août 2015, 10:23
Localisation : Villeurbanne

Re: Mise à jour 04-02-2019

Message par i-magin » 06 févr. 2019, 16:50

Merci @Loic
Jeedom V3.3.29
* DIY NUC 6I5SYK (Crucial 16GB Kit (8GBx2) DDR4 2133 MT/s) * Contrôleur Z-Wave AEOTEC GEN5 *
* VMWare ESXi 6.5.0 Update 2 Build 8294253 * VM Jeedom Debian 9.5 avec 1 CPU/4 Go de mémoire * PHP 7.0.30-0 * Clé USB : SENA UD100

petitju
Timide
Messages : 128
Inscription : 09 mai 2015, 13:10

Re: Mise à jour 04-02-2019

Message par petitju » 06 févr. 2019, 17:04

Bonjour,
J'ai fait cette MAJ (enfin suite à la MAJ en 3.2.16 la maj c'est faite toute seule).
J'ai relancé les dépendances et même redémarré ma smart.

Depuis j'ai des soucis. La queue sortante ne fait que augmenter.

Une idée de comment m'en sortir?
Jeedom: Smart
Protocoles: Zwave, RFXCom
Plugins: Agenda,Alarme,Enedis_linky,Free SMS,Freebox OS,Heliotrope,Geoloc,geotrav,DayInfo,E-mail,Mode,Monitoring,Nut free,Netatmo Station,Pushbullet,Philips Hue,Sonos,Thermostat,Vigilance Météo,Météo

JLSGVA
Timide
Messages : 7
Inscription : 31 janv. 2018, 15:01

Re: Mise à jour 04-02-2019

Message par JLSGVA » 06 févr. 2019, 17:21

Depuis la mise à jour mes scripts de consigne de température pour les thermostats Danfoss ne fonctionnent plus. La manière de les écrire à changé ? Il envoie une commande [2019-02-06 16:58:19][SCENARIO] Exécution de la commande [Bureau][Radiateur Bureau][Commande] avec comme option(s) : {"background":"0","slider":false}

D'où vient {"background":"0","slider":false} ? Comment donner une température dans la commande ?

J'utilise : #[Bureau][Radiateur Bureau][Commande]# avec comme paramètre #[Bureau][Radiateur Bureau][Consigne]# = 25

petitju
Timide
Messages : 128
Inscription : 09 mai 2015, 13:10

Re: Mise à jour 04-02-2019

Message par petitju » 06 févr. 2019, 19:44

Pour infos complémentaires
Au bout d'un certain temps (je dirais 1h30 environ), j'ai le ,nombre d'élément dans queue sortante qui augmente
Sans titre.png
Sans titre.png (87.57 Kio) Consulté 696 fois
Dans la page santé j'ai un module qui passe en association (les autres sur secteur fonctionnent)
santé.png
santé.png (119.84 Kio) Consulté 696 fois
Dans les logs des messages comme cela:

Code : Tout sélectionner

2019-02-06 18:24:00.869 Error, Node007, ERROR: Dropping command, expected response not received after 1 attempt(s)
2019-02-06 18:27:50.242 Always,
2019-02-06 18:27:50.242 Always, Dumping queued log messages
2019-02-06 18:27:50.242 Always,
2019-02-06 18:27:50.242 Always,
2019-02-06 18:27:50.242 Always, End of queued log message dump
2019-02-06 18:27:50.242 Always,
2019-02-06 18:29:30.878 Error, Node007, ERROR: Dropping command, expected response not received after 1 attempt(s)
2019-02-06 18:30:17.166 Error, Node007, ERROR: Dropping command, expected response not received after 1 attempt(s)
2019-02-06 18:30:28.266 Error, Node007, ERROR: Dropping command, expected response not received after 1 attempt(s)
2019-02-06 18:35:00.986 Error, Node007, ERROR: Dropping command, expected response not received after 1 attempt(s)
2019-02-06 18:35:59.789 Error, Node007, ERROR: Dropping command, expected response not received after 1 attempt(s)
Jeedom: Smart
Protocoles: Zwave, RFXCom
Plugins: Agenda,Alarme,Enedis_linky,Free SMS,Freebox OS,Heliotrope,Geoloc,geotrav,DayInfo,E-mail,Mode,Monitoring,Nut free,Netatmo Station,Pushbullet,Philips Hue,Sonos,Thermostat,Vigilance Météo,Météo

madcow
Timide
Messages : 236
Inscription : 06 févr. 2019, 21:41

Re: Mise à jour 04-02-2019

Message par madcow » 06 févr. 2019, 21:55

Bonsoir,

Après mise à jour et relance des dépendances OK, plus de commande possible sur mon Zwave. Exemple :

Code : Tout sélectionner

2019-02-06 21:46:56.870 Error, Node005, ERROR: Dropping command, expected response not received after 1 attempt(s)
2019-02-06 21:47:04.241 Error, Node005, ERROR: Dropping command, expected response not received after 1 attempt(s)
J'ai redémarré le démon plusieurs fois et même relancé les dépendances (avec succès) : idem.

Jeedom en 3.2.15

EDIT : après restauration du backup et rollback : tout refonctionne (1ère fois que je teste la fonction : impeccable !!).
Je suis donc en attente de toute information me permettant de comprendre le soucis (je suis un petit débutant dans Jeedom).

DIY sur Proxmox et HP Proliant.
Dernière édition par madcow le 06 févr. 2019, 22:47, édité 1 fois.
DIY Proxmox sur HP Proliant
Débutant sur Jeedom

Avatar de l’utilisateur
Ninouness
Timide
Messages : 124
Inscription : 30 oct. 2015, 16:37
Localisation : Gard

Re: Mise à jour 04-02-2019

Message par Ninouness » 06 févr. 2019, 22:36

Bonjour,

J'espère ne pas être passé à côté sur le forum, mais dans mon cas la mise à jour ne se lance pas.

J'ai l'erreur :

Code : Tout sélectionner

[2019-02-06 22:25:51][ALERT] : [START UPDATE]
[2019-02-06 22:25:51][ALERT] : Début de la mise à jour de : openzwave
[2019-02-06 22:25:51][ALERT] : Action de pré-update...
[2019-02-06 22:25:51][ALERT] : OK
[2019-02-06 22:25:51][ALERT] : Téléchargement du plugin...
[2019-02-06 22:25:52][ALERT] : Téléchargement de openzwave...
[2019-02-06 22:25:52][ALERT] : OK
[2019-02-06 22:25:52][ALERT] : Echec lors du téléchargement du fichier. Veuillez réessayer plus tard (taille inférieure à 100 octets). Cela peut être lié à un manque de place, une version minimale requise non consistente avec votre version de Jeedom, un soucis du plugin sur le market, etc.
[2019-02-06 22:25:52][ALERT] : [END UPDATE ERROR]
C'est pas ma première mise à jour et d'habitude pas de soucis mais là même après redémarrage ça ne veut pas.
Côté info, je suis en RPI3 avec une carte Z-Wave V1, mon jeedom est en 3.2.6, ma connexion internet est ok et je n'ai pas vu de logs plus explicites.

Avez vous une idée pour m'aider ?
Bonne soirée.

Avatar de l’utilisateur
Fabrice
Modérateur
Messages : 3224
Inscription : 27 oct. 2016, 22:26
Localisation : Planète terre, IDF, 93

Re: Mise à jour 04-02-2019

Message par Fabrice » 06 févr. 2019, 22:40

Bonsoir,

Et pourtant… la réponse à votre problème est écrite dans l'avant dernière phrase :

Code : Tout sélectionner

2019-02-06 22:25:52][ALERT] : Echec lors du téléchargement du fichier. Veuillez réessayer plus tard (taille inférieure à 100 octets). Cela peut être lié à un manque de place, une version minimale requise non consistente avec votre version de Jeedom, un soucis du plugin sur le market, etc.
Version minimum de Jeedom pour ce plugin : 3.2.12
Version de votre Jeedom : 3.2.6
- Il faut donc mettre à jour votre Jeedom AVANT de faire la mise à jour de ce plugin.
Helper Officiel Jeedom
- Jeedom : 3.3.29
- Protocole : Z-Wave / RFXcom / BLEA
- Raspberry Pi : Pi 3 B+ / Pi 3 B / Pi Zero W

Avatar de l’utilisateur
Ninouness
Timide
Messages : 124
Inscription : 30 oct. 2015, 16:37
Localisation : Gard

Re: Mise à jour 04-02-2019

Message par Ninouness » 06 févr. 2019, 22:45

Merci !
Je continuais à fouiller en attendant une réponse quand j'ai découvert que j'ai du laisser un peu trop longtemps jeedom de côté en 2018 car je pensais pas être aussi peu à jour car aucune mise à jour de Jeedom ne m'est proposée.
Il faut maintenant que je trouve pourquoi je suis bloqué dans cette version 3.2.6 mais ça c'est un autre sujet.

defmy
Timide
Messages : 234
Inscription : 14 sept. 2015, 08:52

Re: Mise à jour 04-02-2019

Message par defmy » 07 févr. 2019, 00:37

Pour les queues sortantes qui montent à chaque redémarrage, je pense qu-il faut trouver le module qui en est la cause. Moi par exemple j'avais intégré des module en sécurisé qui m'avaient provoqué ça, j'ai du malheureusement les ré-inclure en non sécurisé pour que tout refonctionne. Après en général, un redémarrage du service (pas du serveur) suffit à équilibrer les queues sortantes.

defmy
Timide
Messages : 234
Inscription : 14 sept. 2015, 08:52

Re: Mise à jour 04-02-2019

Message par defmy » 07 févr. 2019, 09:43

J'ai eu hier soir moi aussi une queue sortante bloquée à 12, j'ai du redémarrer pour que tout fonctionne. Je vais encore surveiller ça.

Avatar de l’utilisateur
Phil56
Actif
Messages : 759
Inscription : 11 août 2015, 11:36

Re: Mise à jour 04-02-2019

Message par Phil56 » 07 févr. 2019, 10:44

Bonjour,

je viens de lancer la mise à jour de ce plugin sur mon PI 2. Jeedom en version 3.2.16, je n'ai pas encore lancé les dépendances vu que l'installation du plugin c'est visiblement bloquée dans l'étape "Post-installation de openzwave"

Code : Tout sélectionner

[2019-02-07 09:58:53][ALERT] : [START UPDATE]
[2019-02-07 09:58:53][ALERT] : Début de la mise à jour de : openzwave 
[2019-02-07 09:58:53][ALERT] : Action de pré-update...
[2019-02-07 09:58:54][ALERT] : OK 
[2019-02-07 09:58:54][ALERT] : Téléchargement du plugin...
[2019-02-07 09:58:55][ALERT] : Téléchargement de openzwave...
[2019-02-07 09:58:58][ALERT] : OK 
[2019-02-07 09:58:58][ALERT] : Décompression du zip...
[2019-02-07 09:59:11][ALERT] : OK 
[2019-02-07 09:59:11][ALERT] : Post-installation de openzwave...
Depuis plus rien dans le fichier de log...

Je n'ai pas l'impression que la compilation des dépendances soit en cours (la charge du PI est "normale")
par contre plus de Zwave, plus accès aux pages de ce plugin (roue qui tourne).

Je peux y faire quelque chose ? reboot ?

Merci d'avance
ken@vo
Phil
Box : Jeedom Maitre dans VM Esxi NUC intel i5, Jeedom Esclave RPI2 avec Zwave, Rfxcom, Blink1, EDISIO et TTS + VM Zoneminder
Protocoles : Zwave, X10, DI-O, HUE, EDISIO
Teleinfo (Dauguet rs232 mise en réseau avec une arduino mega)

Avatar de l’utilisateur
Phil56
Actif
Messages : 759
Inscription : 11 août 2015, 11:36

Re: Mise à jour 04-02-2019

Message par Phil56 » 07 févr. 2019, 10:54

Bon visiblement l’arrêt de mon daemon Zwave pose un problème, car je l'ai tué depuis le shell (kill) et l'installation c'est terminée.
Même problème (et même solution) ensuite pour lancer les dépendances.

Mes dépendances sont en cours on verra bien ensuite...

ken@vo
Phil
Box : Jeedom Maitre dans VM Esxi NUC intel i5, Jeedom Esclave RPI2 avec Zwave, Rfxcom, Blink1, EDISIO et TTS + VM Zoneminder
Protocoles : Zwave, X10, DI-O, HUE, EDISIO
Teleinfo (Dauguet rs232 mise en réseau avec une arduino mega)

Avatar de l’utilisateur
Phil56
Actif
Messages : 759
Inscription : 11 août 2015, 11:36

Re: Mise à jour 04-02-2019

Message par Phil56 » 07 févr. 2019, 12:00

Bon au final les dépendances se sont terminées normalement et le daemon fonctionne.
J'arrive sans problème à l'arrêter et le remettre en marche.

Conclusion si la procédure de mise à jour reste bloquée comme moi, avant de faire un reboot sauvage et risquer d'aggraver la situation, vous pouvez toujours tenter d'arrêter le daemon à la mail (kill).

ken@vo
Phil
Box : Jeedom Maitre dans VM Esxi NUC intel i5, Jeedom Esclave RPI2 avec Zwave, Rfxcom, Blink1, EDISIO et TTS + VM Zoneminder
Protocoles : Zwave, X10, DI-O, HUE, EDISIO
Teleinfo (Dauguet rs232 mise en réseau avec une arduino mega)

i-magin
Actif
Messages : 885
Inscription : 18 août 2015, 10:23
Localisation : Villeurbanne

Re: Mise à jour 04-02-2019

Message par i-magin » 07 févr. 2019, 12:03

Je viens d'effectuer la maj du plugin Zwave : elle a nécessité le redémarrage de Jeedom
Je vous donne toutes les précisions sur trois messages (copies d'écran)

- Auparavant, j'ai effectué la maj du Core en 3.2.16 bien que n'étant pas concerné par la modification "Correction d’un bug lors de l’installation de dépendance de certain plugins sur smart"

- Etat du plugin Zwave avant maj
zwave1.PNG
zwave1.PNG (78.53 Kio) Consulté 499 fois

- je n'ai pas désactivé la gestion automatique du demon et j'ai lancé la maj
La maj se déroule bien
zwave2.PNG
zwave2.PNG (63.32 Kio) Consulté 499 fois

Un message sur fond bleu nous informe qu'il faut "relancer les dépendances même si elles apparaissent vertes"

On retrouve ce message dans la liste
Zwave3.PNG
Zwave3.PNG (9.33 Kio) Consulté 499 fois
Dernière édition par i-magin le 07 févr. 2019, 12:12, édité 1 fois.
Jeedom V3.3.29
* DIY NUC 6I5SYK (Crucial 16GB Kit (8GBx2) DDR4 2133 MT/s) * Contrôleur Z-Wave AEOTEC GEN5 *
* VMWare ESXi 6.5.0 Update 2 Build 8294253 * VM Jeedom Debian 9.5 avec 1 CPU/4 Go de mémoire * PHP 7.0.30-0 * Clé USB : SENA UD100

i-magin
Actif
Messages : 885
Inscription : 18 août 2015, 10:23
Localisation : Villeurbanne

Re: Mise à jour 04-02-2019

Message par i-magin » 07 févr. 2019, 12:04

Le panneau de config avant la relance des dépendances montre que le demon est bien lancé avec des dépendances anciennes

Zwave4.PNG
Zwave4.PNG (67.59 Kio) Consulté 495 fois

Je laisse le démon en gestion automatique et je lance l'installation des dépendances :

Zwave5.PNG
Zwave5.PNG (77.3 Kio) Consulté 495 fois

L'installation reste à 75% quelque temps, et se termine à 11H43 environ pour un lancement vers 11H40

Le demon ne démarre pas automatiquement

Zwave6.PNG
Zwave6.PNG (76.53 Kio) Consulté 495 fois
Dernière édition par i-magin le 07 févr. 2019, 12:51, édité 2 fois.
Jeedom V3.3.29
* DIY NUC 6I5SYK (Crucial 16GB Kit (8GBx2) DDR4 2133 MT/s) * Contrôleur Z-Wave AEOTEC GEN5 *
* VMWare ESXi 6.5.0 Update 2 Build 8294253 * VM Jeedom Debian 9.5 avec 1 CPU/4 Go de mémoire * PHP 7.0.30-0 * Clé USB : SENA UD100

i-magin
Actif
Messages : 885
Inscription : 18 août 2015, 10:23
Localisation : Villeurbanne

Re: Mise à jour 04-02-2019

Message par i-magin » 07 févr. 2019, 12:05

Je démarre le démon
Zwave7.PNG
Zwave7.PNG (69.96 Kio) Consulté 494 fois

Tout semble ok, mais le panneau Réseau Zwave est vide

zwave8.PNG
zwave8.PNG (20.95 Kio) Consulté 494 fois

Log OpenZwave

Code : Tout sélectionner

[2019-02-07 11:40:46][ERROR] : No config file found to backup
[2019-02-07 11:47:48][ERROR] : RequestHandler Unknow node id 55
L'id 55 correspond à un FGD-211 que j’ai tenté d’actionner sans succès

Log Openzwave-update

Code : Tout sélectionner

Lancement de l'installation/mise à jour des dépendances openzwave
Get:1 http://security.debian.org/debian-security stretch/updates InRelease [94.3 kB]
Ign:2 http://ftp.fr.debian.org/debian stretch InRelease
Get:3 http://ftp.fr.debian.org/debian stretch-updates InRelease [91.0 kB]
Hit:4 http://ftp.fr.debian.org/debian stretch Release
Get:5 https://deb.nodesource.com/node_8.x stretch InRelease [4647 B]
Fetched 190 kB in 0s (475 kB/s)
Reading package lists...
Installation des dependances
Reading package lists...
Building dependency tree...
Reading state information...
build-essential is already the newest version (12.3).
g++ is already the newest version (4:6.3.0-4).
gcc is already the newest version (4:6.3.0-4).
git is already the newest version (1:2.11.0-3+deb9u4).
libjpeg-dev is already the newest version (1:1.5.1-2).
python-louie is already the newest version (1.1-2.1).
python-lxml is already the newest version (3.7.1-1).
make is already the newest version (4.1-9.1).
python-serial is already the newest version (3.2.1-1).
python-dev is already the newest version (2.7.13-2).
python-pip is already the newest version (9.0.1-2).
python-setuptools is already the newest version (33.1.1-1).
python-pyudev is already the newest version (0.21.0-1).
python-requests is already the newest version (2.12.4-1).
unzip is already the newest version (6.0-21).
libudev-dev is already the newest version (232-25+deb9u8).
0 upgraded, 0 newly installed, 0 to remove and 35 not upgraded.
Installation des dependances Python
Requirement already satisfied: urwid in /usr/local/lib/python2.7/dist-packages (2.0.1)
You are using pip version 18.1, however version 19.0.1 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.
Requirement already satisfied: louie in /usr/lib/python2.7/dist-packages (1.1)
Requirement already satisfied: nose>=0.8.3 in /usr/lib/python2.7/dist-packages (from louie) (1.3.7)
You are using pip version 18.1, however version 19.0.1 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.
Requirement already satisfied: six in /usr/local/lib/python2.7/dist-packages (1.11.0)
You are using pip version 18.1, however version 19.0.1 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.
Requirement already satisfied: tornado in /usr/local/lib/python2.7/dist-packages (5.1.1)
Requirement already satisfied: singledispatch in /usr/local/lib/python2.7/dist-packages (from tornado) (3.4.0.3)
Requirement already satisfied: futures in /usr/local/lib/python2.7/dist-packages (from tornado) (3.2.0)
Requirement already satisfied: backports-abc>=0.4 in /usr/local/lib/python2.7/dist-packages (from tornado) (0.5)
Requirement already satisfied: six in /usr/local/lib/python2.7/dist-packages (from singledispatch->tornado) (1.11.0)
You are using pip version 18.1, however version 19.0.1 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.
mkdir: cannot create directory '/opt': File exists
Désinstallation de la version précédente
Installation de Python-OpenZwave
Cannot uninstall 'Cython'. It is a distutils installed project and thus we cannot accurately determine which files belong to it which would lead to only a partial uninstall.
apt-get install --force-yes -y cython
Reading package lists...
Building dependency tree...
Reading state information...
cython is already the newest version (0.25.2-1).
0 upgraded, 0 newly installed, 0 to remove and 35 not upgraded.
Installing dependencies for python : 2 7 13
apt-get install --force-yes -y python-pip python-dev python-docutils python-setuptools python-louie
Reading package lists...
Building dependency tree...
Reading state information...
python-louie is already the newest version (1.1-2.1).
python-dev is already the newest version (2.7.13-2).
python-docutils is already the newest version (0.13.1+dfsg-2).
python-pip is already the newest version (9.0.1-2).
python-setuptools is already the newest version (33.1.1-1).
0 upgraded, 0 newly installed, 0 to remove and 35 not upgraded.
apt-get install --force-yes -y build-essential libudev-dev g++
Reading package lists...
Building dependency tree...
Reading state information...
build-essential is already the newest version (12.3).
g++ is already the newest version (4:6.3.0-4).
libudev-dev is already the newest version (232-25+deb9u8).
0 upgraded, 0 newly installed, 0 to remove and 35 not upgraded.
apt-get install --force-yes -y cython
Reading package lists...
Building dependency tree...
Reading state information...
cython is already the newest version (0.25.2-1).
0 upgraded, 0 newly installed, 0 to remove and 35 not upgraded.
pip install nose-html
Requirement already satisfied: nose-html in /usr/local/lib/python2.7/dist-packages (1.1)
Requirement already satisfied: nose>=0.11.1 in /usr/lib/python2.7/dist-packages (from nose-html) (1.3.7)
You are using pip version 18.1, however version 19.0.1 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.
pip install nose-progressive
Requirement already satisfied: nose-progressive in /usr/local/lib/python2.7/dist-packages (1.5.1)
Requirement already satisfied: nose>=1.2.1 in /usr/lib/python2.7/dist-packages (from nose-progressive) (1.3.7)
Requirement already satisfied: blessings<2.0,>=1.3 in /usr/local/lib/python2.7/dist-packages (from nose-progressive) (1.7)
Requirement already satisfied: six in /usr/local/lib/python2.7/dist-packages (from blessings<2.0,>=1.3->nose-progressive) (1.11.0)
You are using pip version 18.1, however version 19.0.1 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.
pip install coverage
Requirement already satisfied: coverage in /usr/local/lib/python2.7/dist-packages (4.5.1)
You are using pip version 18.1, however version 19.0.1 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.
pip install nose
Requirement already satisfied: nose in /usr/lib/python2.7/dist-packages (1.3.7)
You are using pip version 18.1, however version 19.0.1 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.
pip install pylint
Requirement already satisfied: pylint in /usr/local/lib/python2.7/dist-packages (1.9.3)
Requirement already satisfied: six in /usr/local/lib/python2.7/dist-packages (from pylint) (1.11.0)
Requirement already satisfied: mccabe in /usr/local/lib/python2.7/dist-packages (from pylint) (0.6.1)
Requirement already satisfied: astroid<2.0,>=1.6 in /usr/local/lib/python2.7/dist-packages (from pylint) (1.6.5)
Requirement already satisfied: singledispatch; python_version < "3.4" in /usr/local/lib/python2.7/dist-packages (from pylint) (3.4.0.3)
Requirement already satisfied: isort>=4.2.5 in /usr/local/lib/python2.7/dist-packages (from pylint) (4.3.4)
Requirement already satisfied: configparser; python_version == "2.7" in /usr/local/lib/python2.7/dist-packages (from pylint) (3.5.0)
Requirement already satisfied: backports.functools-lru-cache; python_version == "2.7" in /usr/local/lib/python2.7/dist-packages (from pylint) (1.5)
Requirement already satisfied: enum34>=1.1.3; python_version < "3.4" in /usr/local/lib/python2.7/dist-packages (from astroid<2.0,>=1.6->pylint) (1.1.6)
Requirement already satisfied: lazy-object-proxy in /usr/local/lib/python2.7/dist-packages (from astroid<2.0,>=1.6->pylint) (1.3.1)
Requirement already satisfied: wrapt in /usr/local/lib/python2.7/dist-packages (from astroid<2.0,>=1.6->pylint) (1.10.11)
Requirement already satisfied: futures in /usr/local/lib/python2.7/dist-packages (from isort>=4.2.5->pylint) (3.2.0)
You are using pip version 18.1, however version 19.0.1 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.
#pip install docutils
#pip install setuptools
#The following line crashes with a core dump
#pip install "Cython==0.22"
Dependencies for users installed (python 2 7 13)
sed -i -e '253s/.*//' openzwave/cpp/src/value_classes/ValueID.h
cd openzwave && make
make[1]: Entering directory '/opt/python-openzwave/openzwave'
CPPFLAGS= make -C /opt/python-openzwave/openzwave/cpp/build/ -w
make[2]: Entering directory '/opt/python-openzwave/openzwave/cpp/build'
Building OpenZWave Version 1.4.-1
Building tinystr.o
Building tinyxmlerror.o
Building tinyxml.o
Building tinyxmlparser.o
Building hid.o
Building aeskey.o
Building aescrypt.o
Building aestab.o
Building aes_modes.o
Building Proprietary.o
Building UserCode.o
Building CentralScene.o
Building SwitchToggleMultilevel.o
Building SensorBinary.o
Building SwitchMultilevel.o
Building CommandClass.o
Building MultiCmd.o
Building MeterPulse.o
Building DoorLockLogging.o
Building ThermostatFanMode.o
Building MultiChannelAssociation.o
Building Configuration.o
Building SwitchToggleBinary.o
Building ThermostatMode.o
Building NoOperation.o
Building TimeParameters.o
Building BarrierOperator.o
Building Language.o
Building Association.o
Building DoorLock.o
Building ApplicationStatus.o
Building SoundSwitch.o
Building ClimateControlSchedule.o
Building Protection.o
Building ThermostatOperatingState.o
Building NodeNaming.o
Building Meter.o
Building WakeUp.o
Building Basic.o
Building SwitchAll.o
Building ManufacturerProprietary.o
Building Lock.o
Building Color.o
Building Hail.o
Building Clock.o
Building ThermostatFanState.o
Building SceneActivation.o
Building Powerlevel.o
Building AssociationCommandConfiguration.o
Building MultiInstance.o
Building SensorMultilevel.o
Building BasicWindowCovering.o
Building SensorAlarm.o
Building Battery.o
Building CRC16Encap.o
Building Indicator.o
Building ZWavePlusInfo.o
Building Version.o
Building Alarm.o
Building CommandClasses.o
Building ManufacturerSpecific.o
Building ThermostatSetpoint.o
Building Security.o
Building EnergyProduction.o
Building DeviceResetLocally.o
Building ControllerReplication.o
Building SwitchBinary.o
Building Value.o
Building ValueList.o
Building ValueButton.o
Building ValueInt.o
Building ValueStore.o
Building ValueDecimal.o
Building ValueRaw.o
Building ValueString.o
Building ValueByte.o
Building ValueBool.o
Building ValueSchedule.o
Building ValueShort.o
Building Controller.o
Building Wait.o
Building Thread.o
Building Stream.o
Building Log.o
Building HidController.o
Building Mutex.o
Building SerialController.o
Building Event.o
Building FileOps.o
Building TimeStamp.o
Building FileOpsImpl.o
Building TimeStampImpl.o
Building WaitImpl.o
Building ThreadImpl.o
Building LogImpl.o
Building MutexImpl.o
Building SerialControllerImpl.o
Building EventImpl.o
Building Options.o
Building Scene.o
Building Utils.o
Building Driver.o
Building ZWSecurity.o
Building Group.o
Building Node.o
Building Manager.o
Building Msg.o
Building Notification.o
Creating vers.cpp
Building vers.o
Linking Static Library
Linking Shared Library
Making ozw_config file
make[2]: Leaving directory '/opt/python-openzwave/openzwave/cpp/build'
CPPFLAGS= make -C /opt/python-openzwave/openzwave/cpp/examples/MinOZW/ -w
make[2]: Entering directory '/opt/python-openzwave/openzwave/cpp/examples/MinOZW'
Building Main.o
Linking /opt/python-openzwave/openzwave/.lib/MinOZW
g++   -o /opt/python-openzwave/openzwave/.lib/MinOZW /opt/python-openzwave/openzwave/.lib/Main.o /opt/python-openzwave/openzwave/libopenzwave.so -pthread
Creating Temporary Shell Launch Script
make[2]: Leaving directory '/opt/python-openzwave/openzwave/cpp/examples/MinOZW'
make[1]: Leaving directory '/opt/python-openzwave/openzwave'
python setup-lib.py build
running build
running build_ext
cythoning src-lib/libopenzwave/libopenzwave.pyx to src-lib/libopenzwave/libopenzwave.cpp
building 'libopenzwave' extension
creating build
creating build/temp.linux-x86_64-2.7
creating build/temp.linux-x86_64-2.7/src-lib
creating build/temp.linux-x86_64-2.7/src-lib/libopenzwave
x86_64-linux-gnu-gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -fno-strict-aliasing -Wdate-time -D_FORTIFY_SOURCE=2 -g -fdebug-prefix-map=/build/python2.7-2.7.13=. -fstack-protector-strong -Wformat -Werror=format-security -fPIC -DPY_SSIZE_T_CLEAN=1 -Iopenzwave/cpp/src/ -Iopenzwave/cpp/src/value_classes/ -Iopenzwave/cpp/src/platform/ -Iopenzwave/cpp/build/linux/ -I/usr/include/python2.7 -c src-lib/libopenzwave/libopenzwave.cpp -o build/temp.linux-x86_64-2.7/src-lib/libopenzwave/libopenzwave.o
cc1plus: warning: command line option '-Wstrict-prototypes' is valid for C/ObjC but not for C++
src-lib/libopenzwave/libopenzwave.cpp:3:0: warning: "PY_SSIZE_T_CLEAN" redefined
#define PY_SSIZE_T_CLEAN
<command-line>:0:0: note: this is the location of the previous definition
In file included from openzwave/cpp/src/aes/aescpp.h:26:0,
from openzwave/cpp/src/Driver.h:42,
from src-lib/libopenzwave/libopenzwave.cpp:459:
openzwave/cpp/src/aes/aes.h:75:0: warning: ignoring #pragma warning  [-Wunknown-pragmas]
#pragma warning( disable : 4324 )
openzwave/cpp/src/aes/aes.h:93:0: warning: ignoring #pragma warning  [-Wunknown-pragmas]
#pragma warning( default : 4324 )
src-lib/libopenzwave/libopenzwave.cpp: In function 'PyObject* __pyx_pf_12libopenzwave_9PyManager_268beginControllerCommand(__pyx_obj_12libopenzwave_PyManager*, PyObject*, PyObject*, PyObject*, PyObject*, PyObject*, PyObject*)':
src-lib/libopenzwave/libopenzwave.cpp:29891:204: warning: 'bool OpenZWave::Manager::BeginControllerCommand(uint32, OpenZWave::Driver::ControllerCommand, OpenZWave::Driver::pfnControllerCallback_t, void*, bool, uint8, uint8)' is deprecated [-Wdeprecated-declarations]
__pyx_t_6 = __Pyx_PyBool_FromLong(__pyx_v_self->manager->BeginControllerCommand(__pyx_t_1, __pyx_t_2, __pyx_f_12libopenzwave_ctrl_callback, ((void *)__pyx_v_pythonfunc), __pyx_t_3, __pyx_t_4, __pyx_t_5)); if (unlikely(!__pyx_t_6)) __PYX_ERR(0, 4120, __pyx_L1_error)
^
src-lib/libopenzwave/libopenzwave.cpp:545:36: note: in definition of macro '__Pyx_PyBool_FromLong'
#define __Pyx_PyBool_FromLong(b) ((b) ? __Pyx_NewRef(Py_True) : __Pyx_NewRef(Py_False))
^
In file included from src-lib/libopenzwave/libopenzwave.cpp:464:0:
openzwave/cpp/src/Manager.h:1731:19: note: declared here
DEPRECATED bool BeginControllerCommand( uint32 const _homeId, Driver::ControllerCommand _command, Driver::pfnControllerCallback_t _callback = NULL, void* _context = NULL, bool _highPower = false, uint8 _nodeId = 0xff, uint8 _arg = 0 );
^~~~~~~~~~~~~~~~~~~~~~
creating build/lib.linux-x86_64-2.7
x86_64-linux-gnu-g++ -pthread -shared -Wl,-O1 -Wl,-Bsymbolic-functions -Wl,-z,relro -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -Wdate-time -D_FORTIFY_SOURCE=2 -g -fdebug-prefix-map=/build/python2.7-2.7.13=. -fstack-protector-strong -Wformat -Werror=format-security -Wl,-z,relro -Wdate-time -D_FORTIFY_SOURCE=2 -g -fdebug-prefix-map=/build/python2.7-2.7.13=. -fstack-protector-strong -Wformat -Werror=format-security build/temp.linux-x86_64-2.7/src-lib/libopenzwave/libopenzwave.o openzwave/libopenzwave.a -ludev -lstdc++ -o build/lib.linux-x86_64-2.7/libopenzwave.so
python setup-lib.py install
running install
running bdist_egg
running egg_info
creating src-lib/libopenzwave.egg-info
writing requirements to src-lib/libopenzwave.egg-info/requires.txt
writing src-lib/libopenzwave.egg-info/PKG-INFO
writing top-level names to src-lib/libopenzwave.egg-info/top_level.txt
writing dependency_links to src-lib/libopenzwave.egg-info/dependency_links.txt
writing manifest file 'src-lib/libopenzwave.egg-info/SOURCES.txt'
reading manifest file 'src-lib/libopenzwave.egg-info/SOURCES.txt'
writing manifest file 'src-lib/libopenzwave.egg-info/SOURCES.txt'
installing library code to build/bdist.linux-x86_64/egg
running install_lib
running build_ext
skipping 'src-lib/libopenzwave/libopenzwave.cpp' Cython extension (up-to-date)
creating build/bdist.linux-x86_64
creating build/bdist.linux-x86_64/egg
copying build/lib.linux-x86_64-2.7/libopenzwave.so -> build/bdist.linux-x86_64/egg
creating stub loader for libopenzwave.so
byte-compiling build/bdist.linux-x86_64/egg/libopenzwave.py to libopenzwave.pyc
installing package data to build/bdist.linux-x86_64/egg
running install_data
creating build/bdist.linux-x86_64/egg/config
creating build/bdist.linux-x86_64/egg/EGG-INFO
copying src-lib/libopenzwave.egg-info/PKG-INFO -> build/bdist.linux-x86_64/egg/EGG-INFO
copying src-lib/libopenzwave.egg-info/SOURCES.txt -> build/bdist.linux-x86_64/egg/EGG-INFO
copying src-lib/libopenzwave.egg-info/dependency_links.txt -> build/bdist.linux-x86_64/egg/EGG-INFO
copying src-lib/libopenzwave.egg-info/not-zip-safe -> build/bdist.linux-x86_64/egg/EGG-INFO
copying src-lib/libopenzwave.egg-info/requires.txt -> build/bdist.linux-x86_64/egg/EGG-INFO
copying src-lib/libopenzwave.egg-info/top_level.txt -> build/bdist.linux-x86_64/egg/EGG-INFO
writing build/bdist.linux-x86_64/egg/EGG-INFO/native_libs.txt
creating dist
creating 'dist/libopenzwave-0.3.1-py2.7-linux-x86_64.egg' and adding 'build/bdist.linux-x86_64/egg' to it
removing 'build/bdist.linux-x86_64/egg' (and everything under it)
Processing libopenzwave-0.3.1-py2.7-linux-x86_64.egg
creating /usr/local/lib/python2.7/dist-packages/libopenzwave-0.3.1-py2.7-linux-x86_64.egg
Extracting libopenzwave-0.3.1-py2.7-linux-x86_64.egg to /usr/local/lib/python2.7/dist-packages
Adding libopenzwave 0.3.1 to easy-install.pth file
Installed /usr/local/lib/python2.7/dist-packages/libopenzwave-0.3.1-py2.7-linux-x86_64.egg
Processing dependencies for libopenzwave==0.3.1
Searching for six==1.11.0
Best match: six 1.11.0
Adding six 1.11.0 to easy-install.pth file
Using /usr/local/lib/python2.7/dist-packages
Finished processing dependencies for libopenzwave==0.3.1
Installation of lib finished.
python setup-api.py install
running install
running bdist_egg
running egg_info
creating src-api/openzwave.egg-info
writing requirements to src-api/openzwave.egg-info/requires.txt
writing src-api/openzwave.egg-info/PKG-INFO
writing top-level names to src-api/openzwave.egg-info/top_level.txt
writing dependency_links to src-api/openzwave.egg-info/dependency_links.txt
writing manifest file 'src-api/openzwave.egg-info/SOURCES.txt'
reading manifest file 'src-api/openzwave.egg-info/SOURCES.txt'
writing manifest file 'src-api/openzwave.egg-info/SOURCES.txt'
installing library code to build/bdist.linux-x86_64/egg
running install_lib
running build_py
creating build/lib.linux-x86_64-2.7/openzwave
copying src-api/openzwave/singleton.py -> build/lib.linux-x86_64-2.7/openzwave
copying src-api/openzwave/scene.py -> build/lib.linux-x86_64-2.7/openzwave
copying src-api/openzwave/object.py -> build/lib.linux-x86_64-2.7/openzwave
copying src-api/openzwave/node.py -> build/lib.linux-x86_64-2.7/openzwave
copying src-api/openzwave/controller.py -> build/lib.linux-x86_64-2.7/openzwave
copying src-api/openzwave/command.py -> build/lib.linux-x86_64-2.7/openzwave
copying src-api/openzwave/network.py -> build/lib.linux-x86_64-2.7/openzwave
copying src-api/openzwave/option.py -> build/lib.linux-x86_64-2.7/openzwave
copying src-api/openzwave/group.py -> build/lib.linux-x86_64-2.7/openzwave
copying src-api/openzwave/value.py -> build/lib.linux-x86_64-2.7/openzwave
copying src-api/openzwave/__init__.py -> build/lib.linux-x86_64-2.7/openzwave
creating build/bdist.linux-x86_64/egg
creating build/bdist.linux-x86_64/egg/openzwave
copying build/lib.linux-x86_64-2.7/openzwave/singleton.py -> build/bdist.linux-x86_64/egg/openzwave
copying build/lib.linux-x86_64-2.7/openzwave/scene.py -> build/bdist.linux-x86_64/egg/openzwave
copying build/lib.linux-x86_64-2.7/openzwave/object.py -> build/bdist.linux-x86_64/egg/openzwave
copying build/lib.linux-x86_64-2.7/openzwave/node.py -> build/bdist.linux-x86_64/egg/openzwave
copying build/lib.linux-x86_64-2.7/openzwave/controller.py -> build/bdist.linux-x86_64/egg/openzwave
copying build/lib.linux-x86_64-2.7/openzwave/command.py -> build/bdist.linux-x86_64/egg/openzwave
copying build/lib.linux-x86_64-2.7/openzwave/network.py -> build/bdist.linux-x86_64/egg/openzwave
copying build/lib.linux-x86_64-2.7/openzwave/option.py -> build/bdist.linux-x86_64/egg/openzwave
copying build/lib.linux-x86_64-2.7/openzwave/group.py -> build/bdist.linux-x86_64/egg/openzwave
copying build/lib.linux-x86_64-2.7/openzwave/value.py -> build/bdist.linux-x86_64/egg/openzwave
copying build/lib.linux-x86_64-2.7/openzwave/__init__.py -> build/bdist.linux-x86_64/egg/openzwave
copying build/lib.linux-x86_64-2.7/libopenzwave.so -> build/bdist.linux-x86_64/egg
byte-compiling build/bdist.linux-x86_64/egg/openzwave/singleton.py to singleton.pyc
byte-compiling build/bdist.linux-x86_64/egg/openzwave/scene.py to scene.pyc
byte-compiling build/bdist.linux-x86_64/egg/openzwave/object.py to object.pyc
byte-compiling build/bdist.linux-x86_64/egg/openzwave/node.py to node.pyc
byte-compiling build/bdist.linux-x86_64/egg/openzwave/controller.py to controller.pyc
byte-compiling build/bdist.linux-x86_64/egg/openzwave/command.py to command.pyc
byte-compiling build/bdist.linux-x86_64/egg/openzwave/network.py to network.pyc
byte-compiling build/bdist.linux-x86_64/egg/openzwave/option.py to option.pyc
byte-compiling build/bdist.linux-x86_64/egg/openzwave/group.py to group.pyc
byte-compiling build/bdist.linux-x86_64/egg/openzwave/value.py to value.pyc
byte-compiling build/bdist.linux-x86_64/egg/openzwave/__init__.py to __init__.pyc
creating build/bdist.linux-x86_64/egg/EGG-INFO
copying src-api/openzwave.egg-info/PKG-INFO -> build/bdist.linux-x86_64/egg/EGG-INFO
copying src-api/openzwave.egg-info/SOURCES.txt -> build/bdist.linux-x86_64/egg/EGG-INFO
copying src-api/openzwave.egg-info/dependency_links.txt -> build/bdist.linux-x86_64/egg/EGG-INFO
copying src-api/openzwave.egg-info/not-zip-safe -> build/bdist.linux-x86_64/egg/EGG-INFO
copying src-api/openzwave.egg-info/requires.txt -> build/bdist.linux-x86_64/egg/EGG-INFO
copying src-api/openzwave.egg-info/top_level.txt -> build/bdist.linux-x86_64/egg/EGG-INFO
writing build/bdist.linux-x86_64/egg/EGG-INFO/native_libs.txt
creating 'dist/openzwave-0.3.1-py2.7.egg' and adding 'build/bdist.linux-x86_64/egg' to it
removing 'build/bdist.linux-x86_64/egg' (and everything under it)
Processing openzwave-0.3.1-py2.7.egg
creating /usr/local/lib/python2.7/dist-packages/openzwave-0.3.1-py2.7.egg
Extracting openzwave-0.3.1-py2.7.egg to /usr/local/lib/python2.7/dist-packages
Adding openzwave 0.3.1 to easy-install.pth file
Installed /usr/local/lib/python2.7/dist-packages/openzwave-0.3.1-py2.7.egg
Processing dependencies for openzwave==0.3.1
Searching for libopenzwave==0.3.1
Best match: libopenzwave 0.3.1
Processing libopenzwave-0.3.1-py2.7-linux-x86_64.egg
libopenzwave 0.3.1 is already the active version in easy-install.pth
Using /usr/local/lib/python2.7/dist-packages/libopenzwave-0.3.1-py2.7-linux-x86_64.egg
Searching for Louie==1.1
Best match: Louie 1.1
Adding Louie 1.1 to easy-install.pth file
Using /usr/lib/python2.7/dist-packages
Searching for six==1.11.0
Best match: six 1.11.0
Adding six 1.11.0 to easy-install.pth file
Using /usr/local/lib/python2.7/dist-packages
Searching for nose==1.3.7
Best match: nose 1.3.7
Adding nose 1.3.7 to easy-install.pth file
Installing nosetests script to /usr/local/bin
Installing nosetests-2.7 script to /usr/local/bin
Using /usr/lib/python2.7/dist-packages
Finished processing dependencies for openzwave==0.3.1
Installation of API finished.
Everything is successfully installed!
Log Openzwaved
2019-02-07 11:43:52.323 Always, OpenZwave Version 1.4.0 Starting Up
A 11H55, j'ai décidé de relancer Jeedom et tout est opérationnel

En conclusion, pour ce qui me concerne :
- j'ai effectué la mise à jour sans rien modifier (j'ai laissé le demon en démarrage automatique)
- j'ai démarré le demon après l'installation des dépendances
- Zwave n'était pas opérationnel et j'ai du relancer Jeedom

A noter que Jeedom est installé sur un NUC avec Debian 9.5 (voir ma signature)
Jeedom V3.3.29
* DIY NUC 6I5SYK (Crucial 16GB Kit (8GBx2) DDR4 2133 MT/s) * Contrôleur Z-Wave AEOTEC GEN5 *
* VMWare ESXi 6.5.0 Update 2 Build 8294253 * VM Jeedom Debian 9.5 avec 1 CPU/4 Go de mémoire * PHP 7.0.30-0 * Clé USB : SENA UD100

i-magin
Actif
Messages : 885
Inscription : 18 août 2015, 10:23
Localisation : Villeurbanne

Re: Mise à jour 04-02-2019

Message par i-magin » 07 févr. 2019, 13:03

Encore quelques mots....
Le plugin Zwave étant au coeur de mon installation, j'ai pris quelques précautions :
- j'ai attendu de pouvoir faire cette maj tranquillement le matin (pour éviter un problème de gestion de chauffage le soir.... cela dit on doit toujours pouvoir repasser en mode manuel)
- Jeedom fonctionnant chez moi sous ESXi, j'ai pris un "snapshot" qui permet d'avoir une copie intégrale : Debian + Jeedom
Jeedom V3.3.29
* DIY NUC 6I5SYK (Crucial 16GB Kit (8GBx2) DDR4 2133 MT/s) * Contrôleur Z-Wave AEOTEC GEN5 *
* VMWare ESXi 6.5.0 Update 2 Build 8294253 * VM Jeedom Debian 9.5 avec 1 CPU/4 Go de mémoire * PHP 7.0.30-0 * Clé USB : SENA UD100

Avatar de l’utilisateur
b10489
Timide
Messages : 226
Inscription : 16 déc. 2016, 09:39

Re: Mise à jour 04-02-2019

Message par b10489 » 07 févr. 2019, 14:58

chez moi, impossible, "l'opération a échoué"

i-magin
Actif
Messages : 885
Inscription : 18 août 2015, 10:23
Localisation : Villeurbanne

Re: Mise à jour 04-02-2019

Message par i-magin » 07 févr. 2019, 15:03

@b10489, j'ai regardé les posts de cette page et aucun message de ta part avant....

Avec comme seule info "l'opération a échoué", je pense que ton message restera "lettre morte"
Jeedom V3.3.29
* DIY NUC 6I5SYK (Crucial 16GB Kit (8GBx2) DDR4 2133 MT/s) * Contrôleur Z-Wave AEOTEC GEN5 *
* VMWare ESXi 6.5.0 Update 2 Build 8294253 * VM Jeedom Debian 9.5 avec 1 CPU/4 Go de mémoire * PHP 7.0.30-0 * Clé USB : SENA UD100

Répondre

Revenir vers « Plugin Z-Wave »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 2 invités