Avant toute chose merci de (re)prendre connaissance de la charte et de la respecter.
Pour résumer :
- Avant de poser une question, je cherche si la réponse existe
- Je suis poli, courtois et je respecte tout un chacun sur le forum
- Si un post m'agace : je m'en éloigne plutôt que de répondre d'une façon qui pourrait être mal interprétée


Il n'est jamais du luxe que de rappeler des choses simples :
Courtoisie, amabilité, politesse et bonne humeur sont les maîtres mots pour un forum sympathique, bienveillant et accueillant :)

Le groupe des Helpers est present pour vous aidez, n'hésitez pas à poser des questions ;)

Toute la communauté vous remercie

/!\ L’ancien forum passera en lecture seule en janvier 2020 (Si community a bien pris le relais) puis nous le fermerons définitivement en janvier 2021./!\
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

impossible d'installer les dépendances

(anciennement dénommé plugin OpenZwave)

Modérateur : nechry

Avatar de l’utilisateur
sheep300
Actif
Messages : 1202
Inscription : 27 mai 2015, 23:27
Localisation : la rochelle

impossible d'installer les dépendances

Message par sheep300 » 23 mai 2019, 11:47

bonjour je viens de faire la mise a jour du plugin mais impossible d'installer les dependances
voici les log:

Code : Tout sélectionner

Lancement de l'installation/mise à jour des dépendances openzwave
Réception de:1 http://security.debian.org stretch/updates InRelease [94,3 kB]
Ign:2 http://ftp.fr.debian.org/debian stretch InRelease
Atteint:3 http://repository.veeam.com/backup/linux/agent/dpkg/debian/public stable InRelease
Ign:4 http://ppa.launchpad.net/uroni/urbackup/ubuntu eoan InRelease
Atteint:5 http://ftp.fr.debian.org/debian stretch-updates InRelease
Ign:6 http://ppa.launchpad.net/uroni/urbackup/ubuntu eoan Release
Atteint:7 http://ftp.fr.debian.org/debian stretch Release
Ign:8 http://ppa.launchpad.net/uroni/urbackup/ubuntu eoan/main amd64 Packages
Atteint:9 https://deb.nodesource.com/node_8.x jessie InRelease
Ign:10 http://ppa.launchpad.net/uroni/urbackup/ubuntu eoan/main all Packages
Ign:11 http://ppa.launchpad.net/uroni/urbackup/ubuntu eoan/main Translation-en
Ign:12 http://ppa.launchpad.net/uroni/urbackup/ubuntu eoan/main Translation-fr
Ign:13 http://ppa.launchpad.net/uroni/urbackup/ubuntu eoan/main Translation-fr_FR
Ign:14 http://ppa.launchpad.net/uroni/urbackup/ubuntu eoan/main amd64 DEP-11 Metadata
Ign:15 http://ppa.launchpad.net/uroni/urbackup/ubuntu eoan/main all DEP-11 Metadata
Ign:16 http://ppa.launchpad.net/uroni/urbackup/ubuntu eoan/main DEP-11 64x64 Icons
Ign:8 http://ppa.launchpad.net/uroni/urbackup/ubuntu eoan/main amd64 Packages
Ign:10 http://ppa.launchpad.net/uroni/urbackup/ubuntu eoan/main all Packages
Ign:11 http://ppa.launchpad.net/uroni/urbackup/ubuntu eoan/main Translation-en
Ign:12 http://ppa.launchpad.net/uroni/urbackup/ubuntu eoan/main Translation-fr
Ign:13 http://ppa.launchpad.net/uroni/urbackup/ubuntu eoan/main Translation-fr_FR
Ign:14 http://ppa.launchpad.net/uroni/urbackup/ubuntu eoan/main amd64 DEP-11 Metadata
Ign:15 http://ppa.launchpad.net/uroni/urbackup/ubuntu eoan/main all DEP-11 Metadata
Ign:16 http://ppa.launchpad.net/uroni/urbackup/ubuntu eoan/main DEP-11 64x64 Icons
Ign:8 http://ppa.launchpad.net/uroni/urbackup/ubuntu eoan/main amd64 Packages
Ign:10 http://ppa.launchpad.net/uroni/urbackup/ubuntu eoan/main all Packages
Ign:11 http://ppa.launchpad.net/uroni/urbackup/ubuntu eoan/main Translation-en
Ign:12 http://ppa.launchpad.net/uroni/urbackup/ubuntu eoan/main Translation-fr
Ign:13 http://ppa.launchpad.net/uroni/urbackup/ubuntu eoan/main Translation-fr_FR
Ign:14 http://ppa.launchpad.net/uroni/urbackup/ubuntu eoan/main amd64 DEP-11 Metadata
Ign:15 http://ppa.launchpad.net/uroni/urbackup/ubuntu eoan/main all DEP-11 Metadata
Ign:16 http://ppa.launchpad.net/uroni/urbackup/ubuntu eoan/main DEP-11 64x64 Icons
Ign:8 http://ppa.launchpad.net/uroni/urbackup/ubuntu eoan/main amd64 Packages
Ign:10 http://ppa.launchpad.net/uroni/urbackup/ubuntu eoan/main all Packages
Ign:11 http://ppa.launchpad.net/uroni/urbackup/ubuntu eoan/main Translation-en
Ign:12 http://ppa.launchpad.net/uroni/urbackup/ubuntu eoan/main Translation-fr
Ign:13 http://ppa.launchpad.net/uroni/urbackup/ubuntu eoan/main Translation-fr_FR
Ign:14 http://ppa.launchpad.net/uroni/urbackup/ubuntu eoan/main amd64 DEP-11 Metadata
Ign:15 http://ppa.launchpad.net/uroni/urbackup/ubuntu eoan/main all DEP-11 Metadata
Ign:16 http://ppa.launchpad.net/uroni/urbackup/ubuntu eoan/main DEP-11 64x64 Icons
Ign:8 http://ppa.launchpad.net/uroni/urbackup/ubuntu eoan/main amd64 Packages
Ign:10 http://ppa.launchpad.net/uroni/urbackup/ubuntu eoan/main all Packages
Ign:11 http://ppa.launchpad.net/uroni/urbackup/ubuntu eoan/main Translation-en
Ign:12 http://ppa.launchpad.net/uroni/urbackup/ubuntu eoan/main Translation-fr
Ign:13 http://ppa.launchpad.net/uroni/urbackup/ubuntu eoan/main Translation-fr_FR
Ign:14 http://ppa.launchpad.net/uroni/urbackup/ubuntu eoan/main amd64 DEP-11 Metadata
Ign:15 http://ppa.launchpad.net/uroni/urbackup/ubuntu eoan/main all DEP-11 Metadata
Ign:16 http://ppa.launchpad.net/uroni/urbackup/ubuntu eoan/main DEP-11 64x64 Icons
Err:8 http://ppa.launchpad.net/uroni/urbackup/ubuntu eoan/main amd64 Packages
404  Not Found
Ign:10 http://ppa.launchpad.net/uroni/urbackup/ubuntu eoan/main all Packages
Ign:11 http://ppa.launchpad.net/uroni/urbackup/ubuntu eoan/main Translation-en
Ign:12 http://ppa.launchpad.net/uroni/urbackup/ubuntu eoan/main Translation-fr
Ign:13 http://ppa.launchpad.net/uroni/urbackup/ubuntu eoan/main Translation-fr_FR
Ign:14 http://ppa.launchpad.net/uroni/urbackup/ubuntu eoan/main amd64 DEP-11 Metadata
Ign:15 http://ppa.launchpad.net/uroni/urbackup/ubuntu eoan/main all DEP-11 Metadata
Ign:16 http://ppa.launchpad.net/uroni/urbackup/ubuntu eoan/main DEP-11 64x64 Icons
94,3 ko réceptionnés en 8s (11,6 ko/s)
Lecture des listes de paquets…
W: The repository 'http://ppa.launchpad.net/uroni/urbackup/ubuntu eoan Release' does not have a Release file.
E: Impossible de récupérer http://ppa.launchpad.net/uroni/urbackup/ubuntu/dists/eoan/main/binary-amd64/Packages  404  Not Found
E: Le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place.
Installation des dependances
Lecture des listes de paquets…
Construction de l'arbre des dépendances…
Lecture des informations d'état…
build-essential is already the newest version (12.3).
g++ is already the newest version (4:6.3.0-4).
gcc is already the newest version (4:6.3.0-4).
git is already the newest version (1:2.11.0-3+deb9u4).
libjpeg-dev is already the newest version (1:1.5.1-2).
python-louie is already the newest version (1.1-2.1).
python-lxml is already the newest version (3.7.1-1).
make is already the newest version (4.1-9.1).
python-serial is already the newest version (3.2.1-1).
python-dev is already the newest version (2.7.13-2).
python-pip is already the newest version (9.0.1-2+deb9u1).
python-setuptools is already the newest version (33.1.1-1).
python-pyudev is already the newest version (0.21.0-1).
python-requests is already the newest version (2.12.4-1).
libudev-dev is already the newest version (232-25+deb9u11).
unzip is already the newest version (6.0-21+deb9u1).
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
linux-headers-3.16.0-5-amd64 linux-headers-3.16.0-5-common
linux-image-3.16.0-5-amd64
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 3 non mis à jour.
Installation des dependances Python
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.
Requirement already satisfied: urwid in /usr/local/lib/python2.7/dist-packages (1.3.1)
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.
Requirement already satisfied: louie in /usr/lib/python2.7/dist-packages (1.1)
Requirement already satisfied: nose>=0.8.3 in /usr/lib/python2.7/dist-packages (from louie) (1.3.7)
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.
Requirement already satisfied: six in /usr/local/lib/python2.7/dist-packages (1.12.0)
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.
Requirement already satisfied: tornado in /usr/local/lib/python2.7/dist-packages (4.5.1)
Requirement already satisfied: singledispatch in /usr/local/lib/python2.7/dist-packages (from tornado) (3.4.0.3)
Requirement already satisfied: certifi in /usr/local/lib/python2.7/dist-packages (from tornado) (2019.3.9)
Requirement already satisfied: backports_abc>=0.4 in /usr/local/lib/python2.7/dist-packages (from tornado) (0.5)
Requirement already satisfied: six in /usr/local/lib/python2.7/dist-packages (from singledispatch->tornado) (1.12.0)
mkdir: impossible de créer le répertoire « /opt »: Le fichier existe
Installation de Python-OpenZwave
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.
ERROR: Cannot uninstall 'Cython'. It is a distutils installed project and thus we cannot accurately determine which files belong to it which would lead to only a partial uninstall.
apt-get install --force-yes -y cython
Lecture des listes de paquets…
Construction de l'arbre des dépendances…
Lecture des informations d'état…
cython is already the newest version (0.25.2-1).
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
linux-headers-3.16.0-5-amd64 linux-headers-3.16.0-5-common
linux-image-3.16.0-5-amd64
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 3 non mis à jour.
Installing dependencies for python : 2 7 13
apt-get install --force-yes -y python-pip python-dev python-docutils python-setuptools python-louie
Lecture des listes de paquets…
Construction de l'arbre des dépendances…
Lecture des informations d'état…
python-louie is already the newest version (1.1-2.1).
python-dev is already the newest version (2.7.13-2).
python-docutils is already the newest version (0.13.1+dfsg-2).
python-pip is already the newest version (9.0.1-2+deb9u1).
python-setuptools is already the newest version (33.1.1-1).
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
linux-headers-3.16.0-5-amd64 linux-headers-3.16.0-5-common
linux-image-3.16.0-5-amd64
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 3 non mis à jour.
apt-get install --force-yes -y build-essential libudev-dev g++
Lecture des listes de paquets…
Construction de l'arbre des dépendances…
build-essential is already the newest version (12.3).
g++ is already the newest version (4:6.3.0-4).
libudev-dev is already the newest version (232-25+deb9u11).
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
linux-headers-3.16.0-5-amd64 linux-headers-3.16.0-5-common
linux-image-3.16.0-5-amd64
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 3 non mis à jour.
apt-get install --force-yes -y cython
Lecture des listes de paquets…
Construction de l'arbre des dépendances…
Lecture des informations d'état…
cython is already the newest version (0.25.2-1).
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
linux-headers-3.16.0-5-amd64 linux-headers-3.16.0-5-common
linux-image-3.16.0-5-amd64
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 3 non mis à jour.
pip install nose-html
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.
Requirement already satisfied: nose-html in /usr/local/lib/python2.7/dist-packages (1.1)
Requirement already satisfied: nose>=0.11.1 in /usr/lib/python2.7/dist-packages (from nose-html) (1.3.7)
pip install nose-progressive
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.
Requirement already satisfied: nose-progressive in /usr/local/lib/python2.7/dist-packages (1.5.1)
Requirement already satisfied: nose>=1.2.1 in /usr/lib/python2.7/dist-packages (from nose-progressive) (1.3.7)
Requirement already satisfied: blessings<2.0,>=1.3 in /usr/local/lib/python2.7/dist-packages (from nose-progressive) (1.6)
pip install coverage
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.
Requirement already satisfied: coverage in /usr/local/lib/python2.7/dist-packages (4.4.1)
pip install nose
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.
Requirement already satisfied: nose in /usr/lib/python2.7/dist-packages (1.3.7)
pip install pylint
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.
Requirement already satisfied: pylint in /usr/local/lib/python2.7/dist-packages (1.7.2)
Requirement already satisfied: six in /usr/local/lib/python2.7/dist-packages (from pylint) (1.12.0)
Requirement already satisfied: mccabe in /usr/local/lib/python2.7/dist-packages (from pylint) (0.6.1)
Requirement already satisfied: singledispatch; python_version < "3.4" in /usr/local/lib/python2.7/dist-packages (from pylint) (3.4.0.3)
Requirement already satisfied: isort>=4.2.5 in /usr/local/lib/python2.7/dist-packages (from pylint) (4.2.15)
Requirement already satisfied: astroid>=1.5.1 in /usr/local/lib/python2.7/dist-packages (from pylint) (1.5.3)
Requirement already satisfied: configparser; python_version == "2.7" in /usr/local/lib/python2.7/dist-packages (from pylint) (3.5.0)
Requirement already satisfied: backports.functools-lru-cache; python_version == "2.7" in /usr/local/lib/python2.7/dist-packages (from pylint) (1.4)
Requirement already satisfied: enum34>=1.1.3; python_version < "3.4" in /usr/local/lib/python2.7/dist-packages (from astroid>=1.5.1->pylint) (1.1.6)
Requirement already satisfied: lazy-object-proxy in /usr/local/lib/python2.7/dist-packages (from astroid>=1.5.1->pylint) (1.3.1)
Requirement already satisfied: wrapt in /usr/local/lib/python2.7/dist-packages (from astroid>=1.5.1->pylint) (1.10.10)
#pip install docutils
#pip install setuptools
#The following line crashes with a core dump
#pip install "Cython==0.22"
Dependencies for users installed (python 2 7 13)
sed -i -e '253s/.*//' openzwave/cpp/src/value_classes/ValueID.h
cd openzwave && make
make[1] : on entre dans le répertoire « /opt/python-openzwave/openzwave »
CPPFLAGS= make -C /opt/python-openzwave/openzwave/cpp/build/ -w
make[2] : on entre dans le répertoire « /opt/python-openzwave/openzwave/cpp/build »
Building OpenZWave Version 1.4.-1
Building tinystr.o
Building tinyxmlerror.o
Building tinyxml.o
/opt/python-openzwave/openzwave/cpp/tinyxml/tinyxml.cpp:32:15: fatal error: new: Aucun fichier ou dossier de ce type
#include <new>
^
compilation terminated.
/opt/python-openzwave/openzwave/cpp/build/support.mk:130 : la recette pour la cible « /opt/python-openzwave/openzwave/.lib/tinyxml.o » a échouée
make[2]: *** [/opt/python-openzwave/openzwave/.lib/tinyxml.o] Erreur 1
make[2] : on quitte le répertoire « /opt/python-openzwave/openzwave/cpp/build »
Makefile:20 : la recette pour la cible « all » a échouée
make[1]: *** [all] Erreur 2
make[1] : on quitte le répertoire « /opt/python-openzwave/openzwave »
Makefile:272 : la recette pour la cible « openzwave/.lib/ » a échouée
make: *** [openzwave/.lib/] Erreur 2
Everything is successfully installed!
je suis sur un nuc debian 9 a jour
quelqu'un a une idée ?
Damien

Avatar de l’utilisateur
Chrisax
Timide
Messages : 104
Inscription : 09 oct. 2017, 15:05

Re: impossible d'installer les dépendances

Message par Chrisax » 23 mai 2019, 19:23

Bonjour,
C'est étonnant de voir des dépots ubuntu sur une debian. C'est toi qui les as inclus dans ton sources.list ? Tu as essayé en le mettant en commentaires ?
Jeedom sur nuc/proxmox + dongle Aeotec GEN5 et RfxCom
Ecran de contrôle sur Rpi 3B+ et Google Voice Kit

patmtp35
Timide
Messages : 254
Inscription : 30 juil. 2014, 19:11

Re: impossible d'installer les dépendances

Message par patmtp35 » 23 mai 2019, 21:16

idem impossible de faire la maj des dépendances ..... z-wave hs
ESXi6 N54L => VM_Jeedom 3.2.11 + VM Xpenology 6.2
RFLINK USB + USB AeonTek Gen5 + USB Bluetooth + USB Teleinfo + XiaomiHome + 4 Ipcam
Imperihome Pro => AssusTAB 9"
Google Home Mini
SmartledMessenger
Rpi Musicman
Rpi SqueezePlayer

rennais35000
Timide
Messages : 71
Inscription : 09 déc. 2016, 14:56

Re: impossible d'installer les dépendances

Message par rennais35000 » 23 mai 2019, 21:41

Bonsoir,
Pareil chez moi, sur 2 jeedoms différente. J'ai plus rien qui tourne

ESoTeRiC
Timide
Messages : 8
Inscription : 07 mars 2016, 06:48

Re: impossible d'installer les dépendances

Message par ESoTeRiC » 23 mai 2019, 22:07

J'ai eu pareil que vous,

J'ai restauré à la dernière sauvegarde de cette nuit. J'ai du faire un redemarrage à froid en débranchant mon raspberry.

J'ai refait la MAJ mais sans réinstalle les dépendances. Cela fonctionne pour le moment.

J'attend des retours comme vous.

Donc pour le moment, un conseil, ne faite pas la MAJ !

rennais35000
Timide
Messages : 71
Inscription : 09 déc. 2016, 14:56

Re: impossible d'installer les dépendances

Message par rennais35000 » 23 mai 2019, 22:36

J'avais restauré, et j'avais redémarré la jeedom mais je n'avais pas pensé à éteindre et rallumer le Rasp car je ne voyais pas le rapport, effectivement ça remarche avec ma sauvegarde du coup.
Je touche plus à rien pour l'instant

Yves19
Timide
Messages : 45
Inscription : 24 févr. 2018, 21:25
Localisation : Versailles

Re: impossible d'installer les dépendances

Message par Yves19 » 23 mai 2019, 23:06

Idem sur mon rasb B .
Dépendances zwave ne se mettent pas à jour.
Blocage à 75% et time out.
Obligé de restaurer une version antérieure qui marche.
Je ne touche plus à rien pour le moment.

patmtp35
Timide
Messages : 254
Inscription : 30 juil. 2014, 19:11

Re: impossible d'installer les dépendances

Message par patmtp35 » 23 mai 2019, 23:46

resto d'hier soir et redemarage ok
mais perte d'une journée de stat ...
ESXi6 N54L => VM_Jeedom 3.2.11 + VM Xpenology 6.2
RFLINK USB + USB AeonTek Gen5 + USB Bluetooth + USB Teleinfo + XiaomiHome + 4 Ipcam
Imperihome Pro => AssusTAB 9"
Google Home Mini
SmartledMessenger
Rpi Musicman
Rpi SqueezePlayer

rennais35000
Timide
Messages : 71
Inscription : 09 déc. 2016, 14:56

Re: impossible d'installer les dépendances

Message par rennais35000 » 23 mai 2019, 23:51

Finalement les dépendances viennent de s'installer sur une de mes jeedoms, ça à l'air d'être rentré dans l'ordre. Je pense que le pb devais être coté serveur mais on en saura surement plus demain. L'équipe a dû bosser dessus.

Avatar de l’utilisateur
sheep300
Actif
Messages : 1202
Inscription : 27 mai 2015, 23:27
Localisation : la rochelle

Re: impossible d'installer les dépendances

Message par sheep300 » 24 mai 2019, 16:28

Chrisax a écrit :
23 mai 2019, 19:23
Bonjour,
C'est étonnant de voir des dépots ubuntu sur une debian. C'est toi qui les as inclus dans ton sources.list ? Tu as essayé en le mettant en commentaires ?
oui c'est normal car UrBackup (logiciel de sauvegarde) s'apuis sur son propre repository ubuntu...
je l'ai viré dans le doute mais ca change rien
Damien

Avatar de l’utilisateur
sheep300
Actif
Messages : 1202
Inscription : 27 mai 2015, 23:27
Localisation : la rochelle

Re: impossible d'installer les dépendances

Message par sheep300 » 24 mai 2019, 16:31

j'esite a mettre a jour python car ca rale de partout mais j'ai peur de faire une connerie
Damien

Avatar de l’utilisateur
Darkeyes
Actif
Messages : 1279
Inscription : 02 avr. 2015, 08:37

Re: impossible d'installer les dépendances

Message par Darkeyes » 24 mai 2019, 18:42

Salut,
Un conseil, ne pas faire les mises a jours des quelles sortent, sur un plugin critique encore plus quand il n’y a même pas le changelog.
Développement script:
- ssh_commande.php
- ip_public.sh
- BackupSamba.sh

Avatar de l’utilisateur
sheep300
Actif
Messages : 1202
Inscription : 27 mai 2015, 23:27
Localisation : la rochelle

Re: impossible d'installer les dépendances

Message par sheep300 » 24 mai 2019, 18:51

bon ben finalement j'ai fait encore mieux j'ai voulu réparer et j'ai viander complètement mon système merci les commandes de merde fournie sur un forumImage

Envoyé de mon Mi MIX 2S en utilisant Tapatalk

Damien

romanais
Actif
Messages : 1990
Inscription : 21 août 2014, 21:36
Localisation : Drôme

Re: impossible d'installer les dépendances

Message par romanais » 24 mai 2019, 19:09

Bon, j'veux pas dire mais je venais justement poster d'y aller mollo car tu cumulais les soucis, et qu'il faut se poser pour avancer en sécurité, trop tard du coup...

Quelles sont ces commandes de mierda par exemple ?
Du coup, t'es open pour réinstaller un debian strech propre et remettre un backup en place, je parie que tu résoudras tous tes soucis ;-)
Merci à toute l'équipe pour le taf

Mon matériel

Avatar de l’utilisateur
sheep300
Actif
Messages : 1202
Inscription : 27 mai 2015, 23:27
Localisation : la rochelle

Re: impossible d'installer les dépendances

Message par sheep300 » 24 mai 2019, 19:39

Je restore le backup on va vite le savoir

Envoyé de mon Mi MIX 2S en utilisant Tapatalk

Damien

Avatar de l’utilisateur
sheep300
Actif
Messages : 1202
Inscription : 27 mai 2015, 23:27
Localisation : la rochelle

Re: impossible d'installer les dépendances

Message par sheep300 » 24 mai 2019, 19:40

J'ai voulu faire un listing de tous les package et faire un réinstalle le truc c'est que avec la boucle que j'ai mis en place il a désinstaller APT il y a eu un léger problème quand il a fallu réinstaller je te laisse deviner je suis vraiment très con par des fois

Envoyé de mon Mi MIX 2S en utilisant Tapatalk

Damien

Avatar de l’utilisateur
sheep300
Actif
Messages : 1202
Inscription : 27 mai 2015, 23:27
Localisation : la rochelle

Re: impossible d'installer les dépendances

Message par sheep300 » 24 mai 2019, 20:24

Everything is successfully installed!
pour moi c'etait mais libs qui deconnais
Damien

Yves19
Timide
Messages : 45
Inscription : 24 févr. 2018, 21:25
Localisation : Versailles

Re: impossible d'installer les dépendances

Message par Yves19 » 24 mai 2019, 20:31

Ce soir les dépendances se sont correctement installées. Compter sur une Rasp B au moins 10 à 12 minutes.

Tout fonctionne OK après test.

rennais35000
Timide
Messages : 71
Inscription : 09 déc. 2016, 14:56

Re: impossible d'installer les dépendances

Message par rennais35000 » 27 mai 2019, 09:20

@ Darkeyes
"Un conseil, ne pas faire les mises a jours des quelles sortent, sur un plugin critique encore plus quand il n’y a même pas le changelog"

Si tu nous expliques ta logique, on veut bien essayer de comprendre. Car si personne n'installe les mises à jour quand elles sortent comment sauras tu qu'elles ne posent pas pb pour toi. Elles sont surement testées par les devs et surement testées aussi en déploiement sur un panel d’utilisateurs. Les pbs qui sont rencontrés par la suite sont je pense dû à la multiplicité des systémes, aux installations conjointes de codes qui peuvent se parasiter etc ... des choses difficile à prévoir en labo et il faut bien attendre les premiers retours d'expérience pour corriger au fur et à mesure.
Bien cordialement
Un blaireau qui se sacrifie pour tester pour les autres ;)

Avatar de l’utilisateur
Darkeyes
Actif
Messages : 1279
Inscription : 02 avr. 2015, 08:37

Re: impossible d'installer les dépendances

Message par Darkeyes » 27 mai 2019, 14:45

rennais35000 a écrit :
27 mai 2019, 09:20
@ Darkeyes
"Un conseil, ne pas faire les mises a jours des quelles sortent, sur un plugin critique encore plus quand il n’y a même pas le changelog"

Si tu nous expliques ta logique, on veut bien essayer de comprendre. Car si personne n'installe les mises à jour quand elles sortent comment sauras tu qu'elles ne posent pas pb pour toi. Elles sont surement testées par les devs et surement testées aussi en déploiement sur un panel d’utilisateurs. Les pbs qui sont rencontrés par la suite sont je pense dû à la multiplicité des systémes, aux installations conjointes de codes qui peuvent se parasiter etc ... des choses difficile à prévoir en labo et il faut bien attendre les premiers retours d'expérience pour corriger au fur et à mesure.
Bien cordialement
Un blaireau qui se sacrifie pour tester pour les autres ;)
Salut,

Ma remarque était surtout sur le fait qu'il n'y ai pas de changelog, de fait on lance la mise a jour sans savoir ce qui change sur le plugin.
Quand ta maison est gérée par par le plugin concerné, moi à titre perso je fais pas la mise a jour si je sais pas pourquoi il y a l'update.
Après peut être déformation professionnelle travaillant dans une DSI, on fait pas les MAJ sans les tester sur un bac a sable.
Développement script:
- ssh_commande.php
- ip_public.sh
- BackupSamba.sh

Répondre

Revenir vers « Plugin Z-Wave »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 3 invités