Avant toute chose merci de (re)prendre connaissance de la charte et de la respecter.
Pour résumer :
- Avant de poser une question, je cherche si la réponse existe
- Je suis poli, courtois et je respecte tout un chacun sur le forum
- Si un post m'agace : je m'en éloigne plutôt que de répondre d'une façon qui pourrait être mal interprétée


Il n'est jamais du luxe que de rappeler des choses simples :
Courtoisie, amabilité, politesse et bonne humeur sont les maîtres mots pour un forum sympathique, bienveillant et accueillant :)

Toute la communauté vous remercie

impossible d'installer les dépendances

(anciennement dénommé plugin OpenZwave)

Modérateur : nechry

Avatar de l’utilisateur
Phil56
Actif
Messages : 748
Inscription : 11 août 2015, 11:36

Re: impossible d'installer les dépendances

Message par Phil56 » 27 mai 2019, 15:06

Darkeyes a écrit :
27 mai 2019, 14:45
Après peut être déformation professionnelle travaillant dans une DSI, on fait pas les MAJ sans les tester sur un bac a sable.
Bonjour,

Je suis entièrement d’accord avec toi, mais là pour le coup pas simple d'avoir un vrai "bac à sable" avec un réseau Zwave fonctionnel ;)

Sinon pour revenir au problème initial, j'ai lu je penses tous les sujets sur la question de cette dernière mise à jour, et j'ai du mal à être certain de la cause du problème.

Il me semble avoir compris que le principal problème venait du fait que les "nouvelles" dépendances ZWave ne sont plus compatibles avec debian jessie !!!
J'ai bon ?
Je n'ai pas vu de message "officiel" à ce sujet.
Je demande ça car aujourd'hui je suis encore en Jessie sur un Rpi et si c'est bien le cas je vais devoir faire cette migration (ou réinstallation) avant de procéder à cette mise à jour (bien content de ne pas l'avoir déjà fait).

Bref : si quelqu'un de la team pouvait une fois pour toutes confirmer que la dernière version du plugin nécessite 'Stretch" ça serai bien.

Merci d'avance

Ken@vo
Phil

Ps : désolé si j'ai raté un message qui le dit clairement.
Box : Jeedom Maitre dans VM Esxi NUC intel i5, Jeedom Esclave RPI2 avec Zwave, Rfxcom, Blink1, EDISIO et TTS + VM Zoneminder
Protocoles : Zwave, X10, DI-O, HUE, EDISIO
Teleinfo (Dauguet rs232 mise en réseau avec une arduino mega)

Avatar de l’utilisateur
Claude69
Actif
Messages : 2053
Inscription : 04 avr. 2015, 07:57
Localisation : Nord de Lyon

Re: impossible d'installer les dépendances

Message par Claude69 » 27 mai 2019, 17:53

Hello
Pour info, il est dit et répété que si pas de changelog, c’Est que la mise à jour n’Est pas impactante. Ce qui fait que on a tendance à la lancer plus facilement. :roll:
Si il s’avère que l’info comme quoi il faut passer à strech est vrai, c’est GRAVE.
Gestion d'ouverture / fermeture Portail et garage
Gestion filtration piscine
Divers éclairages
Et tout plein d'autres choses ...
JEEDOM NUC 3.3.27 ULTIMATE

Mon matériel ici

Phillou53
Timide
Messages : 50
Inscription : 19 févr. 2017, 09:59
Localisation : Suisse

Re: impossible d'installer les dépendances

Message par Phillou53 » 28 mai 2019, 13:06

Bonjour,

Un soucis chez moi aussi lors de la relance des dépendances sur mes 2 Jeedom Smart (Jeedom 3.3.24 et ses plugins tous à jour, Debian Jessie 8.7). Est-ce normal ? J'ai lu qu'un passage à Debian Stretch était la seule solution ? Vrai dans ce cas aussi ? Que faire ?

A noter que cette relance n'a créé aucun problème sur toutes mes Jeedom RPi (le logfile openzwave_update des RPI se termine par "Everything is successfully installed!")

D'avance merci pour votre aide !

Code : Tout sélectionner

Lancement de l'installation/mise à jour des dépendances openzwave
Ign http://ftp.debian.org jessie InRelease
Hit http://ftp.debian.org jessie-updates InRelease
Ign http://ftp.debian.org jessie-backports InRelease
Hit http://repo.jeedom.com stable InRelease
Hit http://security.debian.org jessie/updates InRelease
Ign http://ftp.debian.org jessie-proposed-updates InRelease
Hit http://ftp.debian.org jessie Release.gpg
Ign http://ftp.debian.org jessie-backports Release.gpg
Ign http://ftp.debian.org jessie-proposed-updates Release.gpg
Hit http://ftp.debian.org jessie Release
Ign http://ftp.debian.org jessie-backports Release
Ign http://ftp.debian.org jessie-proposed-updates Release
Ign http://ftp.debian.org jessie-backports/main Sources/DiffIndex
Ign http://ftp.debian.org jessie-backports/contrib Sources/DiffIndex
Ign http://ftp.debian.org jessie-backports/non-free Sources/DiffIndex
Ign http://ftp.debian.org jessie-backports/main arm64 Packages/DiffIndex
Hit http://repo.jeedom.com stable/main arm64 Packages
Ign http://ftp.debian.org jessie-backports/contrib arm64 Packages/DiffIndex
Ign http://ftp.debian.org jessie-backports/non-free arm64 Packages/DiffIndex
Get:1 http://security.debian.org jessie/updates/main Sources [319 kB]
Ign http://ftp.debian.org jessie-proposed-updates/contrib Sources/DiffIndex
Ign http://ftp.debian.org jessie-proposed-updates/non-free Sources/DiffIndex
Get:2 http://security.debian.org jessie/updates/non-free Sources [1626 B]
Ign http://ftp.debian.org jessie-proposed-updates/main Sources/DiffIndex
Hit http://security.debian.org jessie/updates/contrib Sources
Ign http://repo.jeedom.com stable/main Translation-en
Ign http://ftp.debian.org jessie-proposed-updates/contrib arm64 Packages/DiffIndex
Ign http://ftp.debian.org jessie-proposed-updates/non-free arm64 Packages/DiffIndex
Ign http://ftp.debian.org jessie-proposed-updates/main arm64 Packages/DiffIndex
Hit http://oph.mdrjr.net all InRelease
Hit http://oph.mdrjr.net jessie InRelease
Get:3 http://oph.mdrjr.net all/c2 arm64 Packages
Hit http://oph.mdrjr.net all/c2 arm64 Packages
Get:4 http://oph.mdrjr.net all/main arm64 Packages
Get:5 http://oph.mdrjr.net all/testing arm64 Packages
Hit http://oph.mdrjr.net all/main arm64 Packages
Get:6 http://oph.mdrjr.net all/c2 Translation-en [321 B]
Hit http://oph.mdrjr.net all/testing arm64 Packages
Hit http://ftp.debian.org jessie/main Sources
Hit http://ftp.debian.org jessie/contrib Sources
Get:7 http://oph.mdrjr.net all/main Translation-en [323 B]
Hit http://ftp.debian.org jessie/non-free Sources
Get:8 http://oph.mdrjr.net all/testing Translation-en [326 B]
Hit http://ftp.debian.org jessie/contrib Translation-en
Hit http://ftp.debian.org jessie/main Translation-en
Hit http://ftp.debian.org jessie/non-free Translation-en
Get:9 http://oph.mdrjr.net jessie/backports arm64 Packages
Get:10 http://oph.mdrjr.net jessie/main arm64 Packages
Get:11 http://oph.mdrjr.net jessie/backports Translation-en [331 B]
Get:12 http://oph.mdrjr.net jessie/main Translation-en [326 B]
Hit http://oph.mdrjr.net jessie/backports arm64 Packages
Get:13 http://oph.mdrjr.net all/c2 Translation-en [321 B]
Err http://ftp.debian.org jessie/main arm64 Packages
404  Not Found [IP: 130.89.148.12 80]
Err http://ftp.debian.org jessie/contrib arm64 Packages
404  Not Found [IP: 130.89.148.12 80]
Err http://ftp.debian.org jessie/non-free arm64 Packages
404  Not Found [IP: 130.89.148.12 80]
Hit http://oph.mdrjr.net jessie/main arm64 Packages
Get:14 http://oph.mdrjr.net all/main Translation-en [323 B]
Get:15 http://oph.mdrjr.net all/testing Translation-en [326 B]
Get:16 http://oph.mdrjr.net jessie/backports Translation-en [331 B]
Get:17 http://oph.mdrjr.net jessie/main Translation-en [326 B]
Get:18 http://oph.mdrjr.net all/c2 Translation-en [321 B]
Get:19 http://oph.mdrjr.net all/main Translation-en [323 B]
Ign http://ftp.debian.org jessie-backports/contrib Translation-en
Ign http://ftp.debian.org jessie-backports/main Translation-en
Get:20 http://oph.mdrjr.net all/testing Translation-en [326 B]
Ign http://ftp.debian.org jessie-backports/non-free Translation-en
Get:21 http://oph.mdrjr.net jessie/backports Translation-en [331 B]
Ign http://ftp.debian.org jessie-proposed-updates/contrib Translation-en
Get:22 http://oph.mdrjr.net jessie/main Translation-en [326 B]
Ign http://ftp.debian.org jessie-proposed-updates/main Translation-en
Ign http://ftp.debian.org jessie-proposed-updates/non-free Translation-en
Get:23 http://oph.mdrjr.net all/c2 Translation-en [321 B]
Err http://ftp.debian.org jessie-backports/main Sources
404  Not Found [IP: 130.89.148.12 80]
Err http://ftp.debian.org jessie-backports/contrib Sources
404  Not Found [IP: 130.89.148.12 80]
Err http://ftp.debian.org jessie-backports/non-free Sources
404  Not Found [IP: 130.89.148.12 80]
Get:24 http://oph.mdrjr.net all/main Translation-en [323 B]
Err http://ftp.debian.org jessie-backports/main arm64 Packages
404  Not Found [IP: 130.89.148.12 80]
Err http://ftp.debian.org jessie-backports/contrib arm64 Packages
404  Not Found [IP: 130.89.148.12 80]
Err http://ftp.debian.org jessie-backports/non-free arm64 Packages
404  Not Found [IP: 130.89.148.12 80]
Err http://ftp.debian.org jessie-proposed-updates/contrib Sources
404  Not Found [IP: 130.89.148.12 80]
Get:25 http://oph.mdrjr.net all/testing Translation-en [326 B]
Err http://ftp.debian.org jessie-proposed-updates/non-free Sources
404  Not Found [IP: 130.89.148.12 80]
Err http://ftp.debian.org jessie-proposed-updates/main Sources
404  Not Found [IP: 130.89.148.12 80]
Err http://ftp.debian.org jessie-proposed-updates/contrib arm64 Packages
404  Not Found [IP: 130.89.148.12 80]
Err http://ftp.debian.org jessie-proposed-updates/non-free arm64 Packages
404  Not Found [IP: 130.89.148.12 80]
Get:26 http://oph.mdrjr.net jessie/backports Translation-en [331 B]
Err http://ftp.debian.org jessie-proposed-updates/main arm64 Packages
404  Not Found [IP: 130.89.148.12 80]
Get:27 http://oph.mdrjr.net jessie/main Translation-en [326 B]
Get:28 http://oph.mdrjr.net all/c2 Translation-en [321 B]
Ign http://oph.mdrjr.net all/c2 Translation-en
Get:29 http://oph.mdrjr.net all/main Translation-en [323 B]
Ign http://oph.mdrjr.net all/main Translation-en
Get:30 http://oph.mdrjr.net all/testing Translation-en [326 B]
Ign http://oph.mdrjr.net all/testing Translation-en
Get:31 http://oph.mdrjr.net jessie/backports Translation-en [331 B]
Ign http://oph.mdrjr.net jessie/backports Translation-en
Get:32 http://oph.mdrjr.net jessie/main Translation-en [326 B]
Ign http://oph.mdrjr.net jessie/main Translation-en
W: Failed to fetch http://ftp.debian.org/debian/dists/jessie-updates/InRelease  Unable to find expected entry 'main/source/Sources' in Release file (Wrong sources.list entry or malformed file)
W: Failed to fetch http://security.debian.org/dists/jessie/updates/InRelease  Unable to find expected entry 'main/binary-arm64/Packages' in Release file (Wrong sources.list entry or malformed file)
W: Failed to fetch http://ftp.debian.org/debian/dists/jessie-backports/main/source/Sources  404  Not Found [IP: 130.89.148.12 80]
W: Failed to fetch http://ftp.debian.org/debian/dists/jessie-backports/contrib/source/Sources  404  Not Found [IP: 130.89.148.12 80]
W: Failed to fetch http://ftp.debian.org/debian/dists/jessie-backports/non-free/source/Sources  404  Not Found [IP: 130.89.148.12 80]
W: Failed to fetch http://ftp.debian.org/debian/dists/jessie/main/binary-arm64/Packages  404  Not Found [IP: 130.89.148.12 80]
W: Failed to fetch http://ftp.debian.org/debian/dists/jessie/contrib/binary-arm64/Packages  404  Not Found [IP: 130.89.148.12 80]
W: Failed to fetch http://ftp.debian.org/debian/dists/jessie/non-free/binary-arm64/Packages  404  Not Found [IP: 130.89.148.12 80]
W: Failed to fetch http://ftp.debian.org/debian/dists/jessie-backports/main/binary-arm64/Packages  404  Not Found [IP: 130.89.148.12 80]
W: Failed to fetch http://ftp.debian.org/debian/dists/jessie-backports/contrib/binary-arm64/Packages  404  Not Found [IP: 130.89.148.12 80]
W: Failed to fetch http://ftp.debian.org/debian/dists/jessie-backports/non-free/binary-arm64/Packages  404  Not Found [IP: 130.89.148.12 80]
W: Failed to fetch http://ftp.debian.org/debian/dists/jessie-proposed-updates/contrib/source/Sources  404  Not Found [IP: 130.89.148.12 80]
W: Failed to fetch http://ftp.debian.org/debian/dists/jessie-proposed-updates/non-free/source/Sources  404  Not Found [IP: 130.89.148.12 80]
W: Failed to fetch http://ftp.debian.org/debian/dists/jessie-proposed-updates/main/source/Sources  404  Not Found [IP: 130.89.148.12 80]
W: Failed to fetch http://ftp.debian.org/debian/dists/jessie-proposed-updates/contrib/binary-arm64/Packages  404  Not Found [IP: 130.89.148.12 80]
W: Failed to fetch http://ftp.debian.org/debian/dists/jessie-proposed-updates/non-free/binary-arm64/Packages  404  Not Found [IP: 130.89.148.12 80]
W: Failed to fetch http://ftp.debian.org/debian/dists/jessie-proposed-updates/main/binary-arm64/Packages  404  Not Found [IP: 130.89.148.12 80]
E: Some index files failed to download. They have been ignored, or old ones used instead.
Installation des dependances
Reading package lists...
Building dependency tree...
Reading state information...
build-essential is already the newest version.
g++ is already the newest version.
gcc is already the newest version.
libjpeg-dev is already the newest version.
python-louie is already the newest version.
python-lxml is already the newest version.
make is already the newest version.
python-dev is already the newest version.
python-pip is already the newest version.
unzip is already the newest version.
The following packages were automatically installed and are no longer required:
klibc-utils libapparmor1 libklibc libseccomp2 linux-headers-3.14.29+
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
git-man libudev1 python-pkg-resources python-urllib3 sysvinit-core
usb-modeswitch
Suggested packages:
gettext-base git-daemon-run git-daemon-sysvinit git-doc git-el git-email
git-gui gitk gitweb git-arch git-cvs git-mediawiki git-svn python-gobject
python-qt4 python-pyside.qtcore python-ndg-httpsclient python-openssl
python-pyasn1 python-socks python-wxgtk3.0 python-wxgtk
python-setuptools-doc python-ntlm comgt wvdial
The following packages will be REMOVED:
bluetooth bluez initramfs-tools systemd systemd-sysv udev usbmount
The following NEW packages will be installed:
sysvinit-core
The following packages will be upgraded:
git git-man libudev-dev libudev1 python-pkg-resources python-pyudev
python-requests python-serial python-setuptools python-urllib3
usb-modeswitch
11 upgraded, 1 newly installed, 7 to remove and 164 not upgraded.
Need to get 6235 kB of archives.
After this operation, 13.4 MB disk space will be freed.
WARNING: The following packages cannot be authenticated!
git git-man libudev-dev libudev1 python-setuptools python-pkg-resources
python-pyudev python-urllib3 python-requests python-serial usb-modeswitch
E: There are problems and -y was used without --force-yes
could not install git - abort
3 Jeedom Raspberry Pi3 B+ Z-Wave, SSD avec boitier X820 ou Pi Desktop/Element14
2 Jeedom Smart Z-Wave et module Rfxcom
Divers périphériques Z-Wave+ et X10, Raspicam

Avatar de l’utilisateur
akenad
Actif
Messages : 539
Inscription : 27 oct. 2017, 11:39

Re: impossible d'installer les dépendances

Message par akenad » 28 mai 2019, 13:36

Pour la Smart (Odroid-C2 arm64),
des paquets Jessie arm64 ont été retirés du dépôt Debian.
Le mieux est de passer en Stretch

akenad :)
Présentation akenad
JeedomSmart Debian Stretch
Odroid-C2 eMMC Armbian Stretch Kernel 3.x
RPi3B+ SSD Raspbian Stretch
NUC Intel i7Gen7 ProxMox VM Debian Stretch
RPi4B SSD Raspbian Buster

Mes équipements

Phillou53
Timide
Messages : 50
Inscription : 19 févr. 2017, 09:59
Localisation : Suisse

Re: impossible d'installer les dépendances

Message par Phillou53 » 31 mai 2019, 18:03

Merci Akenad pour ce conseil judicieux. Un petit feed-back :

Passage à Stretch 9.4 réussi selon méthode Recovery car la méthode automatique beta ne fonctionnait pas sur ma box. Attention au formatage "profond" de la clé USB 64GB en FAT32 (j'ai utilisé EasyUS Partition Master Free pour vraiment tout effacer). Après la migration (très rapide), réinstallation de la sauvegarde Jeedom puis relance des dépendances sans aucun problème cette fois-ci. A noter que, en plus du Z-Wave, cette Smart utilise également le plugin RFXcom.

Everything is successfully installed !
3 Jeedom Raspberry Pi3 B+ Z-Wave, SSD avec boitier X820 ou Pi Desktop/Element14
2 Jeedom Smart Z-Wave et module Rfxcom
Divers périphériques Z-Wave+ et X10, Raspicam

Répondre

Revenir vers « Plugin Z-Wave »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité