Ce Forum passera en lecture seule en janvier 2020
Image
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

Wanscam HW0054 : user et password non traduits dans les commandes

Pour toute question concernant le plugin caméra
Avatar de l’utilisateur
Theduck38
Helper
Messages : 2703
Inscription : 22 févr. 2015, 17:32
Localisation : Près de Grenoble
Contact :

Wanscam HW0054 : user et password non traduits dans les commandes

Message par Theduck38 » 20 sept. 2018, 01:41

Bonjour à tous,

J'ai installé une Wanscam HW0054...
Pas de problème pour reconnaître le snapshot.

En revanche pour les commandes, j'ai un souci : impossible de contrôler la caméra si je ne mets pas le mot de passe et le user en clair directement dans la commande.
Si je laisse #username# et #password" les commandes ne fonctionnent pas. Si je les remplace directement par leur valeur entrée dans l'onglet "Equipement", ça fonctionne...

Exemple : la commande pour aller à gauche est :
/cgi-bin/hi3510/ytleft.cgi?usr=#username#&pwd=#password# => ne fonctionne pas
/cgi-bin/hi3510/ytleft.cgi?usr=admin&pwd=truc => fonctionne

Je ne trouve aucun log du plugin Camera, même en debug... du coup rien à proposer pour avancer.

Quelqu'un a déjà eu ce problème et a su le résoudre ? Ou c'est un pb connu ?
-- TD38 --
Helper Officiel Jeedom
Zimeteo sur Jeedom : http://www.meteo.lecoin.info
Jeedom Stable sur serveur custom
Le risque électrique - Afficheur leds RGB - Tablette Murale - Thermostat connecté

Pesto
Timide
Messages : 42
Inscription : 22 juin 2018, 09:50
Localisation : Moselle

Re: Wanscam HW0054 : user et password non traduits dans les commandes

Message par Pesto » 21 nov. 2018, 12:02

Salut,

J'ai exactement le même problème avec les mêmes caméras.
J'ai 4 wanscam HW0054 et visiblement les commandes ne fonctionnent pas si on ajoute pas les login et mot de passes en clair.
Est ce que tu as des nouvelles de ton côté?
Merci

Avatar de l’utilisateur
loic
Administrateur
Messages : 14865
Inscription : 01 févr. 2014, 16:21

Re: Wanscam HW0054 : user et password non traduits dans les commandes

Message par loic » 21 nov. 2018, 12:17

Bonjour,
Effectivement le remplacement n'était pas fait pour les commandes. Je viens de l'ajouter en beta.
Aide nous à t'aider : mets des logs, détaille ton soucis... Vous n'aurez aucune réponse de ma part si votre demande n'est pas détaillée (log, capture d'écran lisible...) ou si vous ne postez pas dans la bonne section

Avatar de l’utilisateur
Theduck38
Helper
Messages : 2703
Inscription : 22 févr. 2015, 17:32
Localisation : Près de Grenoble
Contact :

Re: Wanscam HW0054 : user et password non traduits dans les commandes

Message par Theduck38 » 21 nov. 2018, 22:12

Merci beaucoup, Loïc !
-- TD38 --
Helper Officiel Jeedom
Zimeteo sur Jeedom : http://www.meteo.lecoin.info
Jeedom Stable sur serveur custom
Le risque électrique - Afficheur leds RGB - Tablette Murale - Thermostat connecté

Pesto
Timide
Messages : 42
Inscription : 22 juin 2018, 09:50
Localisation : Moselle

Re: Wanscam HW0054 : user et password non traduits dans les commandes

Message par Pesto » 28 nov. 2018, 14:20

Hello,

Je viens d'installer la beta, et même problème visiblement.
Les commandes ne répondent pas, même après relance du deamon.
Pour info j'ai specifié comme type de camera Wanscam HW00XX.
Aucune info dans les logs, même en debug.
Merci

Avatar de l’utilisateur
loic
Administrateur
Messages : 14865
Inscription : 01 févr. 2014, 16:21

Re: Wanscam HW0054 : user et password non traduits dans les commandes

Message par loic » 28 nov. 2018, 14:52

En faite ma modification ne sert a rien c'était bien fait, je viens de tester chez moi ca marche il doit donc avoir un truc qui lui plait pas chez toi il faut donc que tu ouvres un ticket au support.
Aide nous à t'aider : mets des logs, détaille ton soucis... Vous n'aurez aucune réponse de ma part si votre demande n'est pas détaillée (log, capture d'écran lisible...) ou si vous ne postez pas dans la bonne section

pacanou
Timide
Messages : 43
Inscription : 09 sept. 2017, 15:33

Re: Wanscam HW0054 : user et password non traduits dans les commandes

Message par pacanou » 25 avr. 2019, 21:16

Bonjour,

Je viens de me procurer cette caméra et je n'arrive pas à la configurer, quel est le port que vous avez mis et qu'est ce que vous avez mis ?
Dans adress IP, j'ai mis IP 192.168.10.32 et port 80.
URL de snaphot : /web/tmpfs/snap.jpg
modèle : WANSCAMXXX
2.jpg
2.jpg (104.34 Kio) Consulté 1037 fois
Merci de votre aide

Avatar de l’utilisateur
Theking31
Actif
Messages : 1182
Inscription : 21 sept. 2017, 11:13
Localisation : Toulouse - Le Vernet

Re: Wanscam HW0054 : user et password non traduits dans les commandes

Message par Theking31 » 25 avr. 2019, 21:39

Si pas de réponses avant... Je te ferai des captures demain vers 13h !

Désolé pas le temps maintenant :?
Jeedom 4.0.23 sur Intel NUC 6CAYH | Linux 4.9.0-11-amd64 | Debian 9.11
Rfxcom | Z-Wave Plus Z-Stick GEN5 | Conbee 2 | => sur hub alimenté
Blea| Brodlink | Xiaomi |ESPeasy | Wifilightv2

Bosquetia
Actif
Messages : 6783
Inscription : 10 mai 2016, 07:54

Re: Wanscam HW0054 : user et password non traduits dans les commandes

Message par Bosquetia » 25 avr. 2019, 21:48

pacanou a écrit :
25 avr. 2019, 21:16
Bonjour,

Je viens de me procurer cette caméra et je n'arrive pas à la configurer, quel est le port que vous avez mis et qu'est ce que vous avez mis ?
Dans adress IP, j'ai mis IP 192.168.10.32 et port 80.
URL de snaphot : /web/tmpfs/snap.jpg
modèle : WANSCAMXXX
2.jpg

Merci de votre aide
Pour le port seul toi peut savoir ce que tu as mis dans la caméra elle même !
Pour te connecter avec un navigateur a la caméra tu utilises le port et bien c'est le même.

pacanou
Timide
Messages : 43
Inscription : 09 sept. 2017, 15:33

Re: Wanscam HW0054 : user et password non traduits dans les commandes

Message par pacanou » 25 avr. 2019, 21:52

Il y'a le port 80 et 554, dans le paramétrage de la caméra, je n'ai pas vu ou paramétrer le port comme pour les versions hw0045.
Sinon l'url de snapshot est elle bonne ?

Bosquetia
Actif
Messages : 6783
Inscription : 10 mai 2016, 07:54

Re: Wanscam HW0054 : user et password non traduits dans les commandes

Message par Bosquetia » 25 avr. 2019, 22:01

Avec un navigateur web quel port utilises-tu ?

le 554 tu es sur que c'est pas pour onvif un truc du genre...
Tu as bien du te connecter au moins une fois sur l'interface web de cette caméra non ?

Avatar de l’utilisateur
noodom
Actif
Messages : 980
Inscription : 13 juil. 2014, 17:25
Contact :

Re: Wanscam HW0054 : user et password non traduits dans les commandes

Message par noodom » 26 avr. 2019, 00:20

Salut,

J'ai exactement le même configuration que ta capture (avec la sélection de Wanscam HW00XX comme modèle et aucun problème.
Je ne me rappelle pas de manips particulière.
Question bête, tu es sûr des login/mot de passe ? (les cases sont sur fond bleu donc saisies automatiquement ?)

pacanou
Timide
Messages : 43
Inscription : 09 sept. 2017, 15:33

Re: Wanscam HW0054 : user et password non traduits dans les commandes

Message par pacanou » 26 avr. 2019, 08:52

Bonjour,

J'arrive a me connecter sur l'interface web en saisissant juste l'adresse ip local sans indiquer le port :
2.jpg
2.jpg (113.88 Kio) Consulté 981 fois
dans tous les menus, je ne trouve nul part ou paramétrer le port.

Via le logiciel ONVIF, il trouve 2 ports :
1.jpg
1.jpg (79.82 Kio) Consulté 985 fois
La caméra à une référence wanscam k54 chez aliexpress, elle ressemble à la version wanscam hw0054, c'est une imitation ?

Avatar de l’utilisateur
Theking31
Actif
Messages : 1182
Inscription : 21 sept. 2017, 11:13
Localisation : Toulouse - Le Vernet

Message par Theking31 » 26 avr. 2019, 12:31

A tester ! Mais moi c'est camera motorisée


Camera1.png
Camera1.png (472.99 Kio) Consulté 975 fois
camera2.png
camera2.png (303.12 Kio) Consulté 975 fois
camera3.png
camera3.png (154.63 Kio) Consulté 975 fois
Jeedom 4.0.23 sur Intel NUC 6CAYH | Linux 4.9.0-11-amd64 | Debian 9.11
Rfxcom | Z-Wave Plus Z-Stick GEN5 | Conbee 2 | => sur hub alimenté
Blea| Brodlink | Xiaomi |ESPeasy | Wifilightv2

pacanou
Timide
Messages : 43
Inscription : 09 sept. 2017, 15:33

Re: Wanscam HW0054 : user et password non traduits dans les commandes

Message par pacanou » 26 avr. 2019, 19:13

Bonjour,

Merci de vos retours :
@Theking31 , malheureusement çà ne fonctionne pas.
@noodom, je ne sais pas pourquoi c'est en bleu, sinon c'est bien saisie manuellement, as tu la même interface web que moi?

Avatar de l’utilisateur
noodom
Actif
Messages : 980
Inscription : 13 juil. 2014, 17:25
Contact :

Re: Wanscam HW0054 : user et password non traduits dans les commandes

Message par noodom » 26 avr. 2019, 22:04

pacanou a écrit :
26 avr. 2019, 19:13
Bonjour,

Merci de vos retours :
@Theking31 , malheureusement çà ne fonctionne pas.
@noodom, je ne sais pas pourquoi c'est en bleu, sinon c'est bien saisie manuellement, as tu la même interface web que moi?
non, moi j'ai ça :
http://www.wanscam.com/xiazai/download/ ... nglish.pdf

pacanou
Timide
Messages : 43
Inscription : 09 sept. 2017, 15:33

Re: Wanscam HW0054 : user et password non traduits dans les commandes

Message par pacanou » 26 avr. 2019, 23:34

A mince, du coup j'ai pas pris la bonne référence de cam, il y'a wanscam K54 celle que j'ai prise et HW0054, elle sont pratiquement identique mais pas au niveau du logiciel. Grrrrh.

çà fonctionne en sélectionnant le modèle comme caméra : onvif

pierre1256
Timide
Messages : 4
Inscription : 07 sept. 2018, 08:53

Re: Wanscam HW0054 : user et password non traduits dans les commandes

Message par pierre1256 » 12 mai 2019, 23:17

Bonjour,
J’ai le même problème ! Je viens d’acheter une k54 ...
Est-ce une contrefaçon ? Ou une version plus low cost faite par Wanscam ?

Je trouve la qualité de l’image assez moyenne.

Merci pour votre aide,

Bestiol
Timide
Messages : 10
Inscription : 16 mai 2017, 17:34

Re: Wanscam HW0054 : user et password non traduits dans les commandes

Message par Bestiol » 30 mai 2019, 10:02

Bonjour, même soucis avec cette k54, quelqu’un a-t-il du nouveau par rapport à son intégration?
Merci

Avatar de l’utilisateur
noodom
Actif
Messages : 980
Inscription : 13 juil. 2014, 17:25
Contact :

Wanscam HW0054 : user et password non traduits dans les commandes

Message par noodom » 30 mai 2019, 19:44

Apparemment ce n'est qu'une pâle imitation..
Pas sûr du tout qu'elle puisse être intégrée dans jeedom..
Et a priori pas avec la méthode de la Wanscam

Répondre

Revenir vers « [Plugin officiel] Caméra »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 2 invités