Ce Forum passera en lecture seule en janvier 2020
Image
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

Besoin d'aide sur Réinitialisation

Pour toute question concernant le plugin alarme
Skyjouby
Timide
Messages : 33
Inscription : 16 nov. 2018, 21:58

Besoin d'aide sur Réinitialisation

Message par Skyjouby » 02 juin 2019, 21:00

Bonjour,
j'ai programmé des plugins pour les alertes inondation et feu qui fonctionnent au poil.

A présent, je voulais programmé l'alarme. Je pense être pas trop loin du but, mais plusieurs problèmes apparaissent.
Les problème surviennent s'il y a une détection.
- Même si je déactive l'alarme avant le "déclenchement", les différentes lignes de déclenchement se déroulent.
- Pire la sirène ne s'arrête pas alors que l'instruction "Réinitialisation" l'intègre.

Je pense qu'il y a une ou plusisuers faille dans mon raisonnement/compréhension du plugin Alarme.
Pouvez-vous m'aider à identifier la faille dans mon raisonnement?

Ici, rien de très complexe, je l'active en mode "Absent" et le désactive en mode "Présent".
Image

J'ai défini une zone par capteur de présence avec pour chaque capteur, toujours les mêmes éléments: Un maintien de 0s, c'est à dire que dès qu'on passe devant, ça déroule le "Déclenchement", l’alarme s’active après 1min et le déclenchement opère après 20s (0,35 min).
Si le capteur détecte un mouvement, il envoie un push pour que j'identifie la zone de détection (j'aurais pu le faire en déclenchement immédiat avec un "Trigger" pour regrouper en une seule action plutôt qu'un par zone..., je m'en suis aperçu après coup).
Image

Je raccroche mes zones à mon unique mode: Absent
Image

Si l'alarme est activée, j'envoie un push, en parallèle message vocale sur une Google Home.
Image

Idem en action KO et reprise opérationnelle
Image

Je pense que mon problème est en partie sur cet onglet!
Voilà ce que j'ai compris: Dès qu'un capteur détecte un mouvement, il averti de l'alarme activée avec un décompte de temps (Push + tout le multi room).
Dès que l'on arrive aux 0.35min, seuil du déclenchement, je push/multi room et passe sur On la sirène.
Image

Si je désactive sans qu'un seul capteur n'ait détecté une présence, j'alerte de la désactivation sans détection.
Image


Si je désactive l'alarme alors qu'il y a une un détection, je suis censé couper la sirène et alerter par push/Multi room.
En réalité, quoiqu'il arrive, les actions de Déclenchement se suivent (toutes celles de actions immédiates de déclenchement, puis de action de déclenchement).
J'aurais voulu qu'elles s'arrêtent à l'arrêt de l'alarme.
Pire, la sirène s'active et ne se désactive pas à la désactivation de l'alarme.
Image

Où ai-je faux?
Je vous remercie pour vos retours,
Bonne soirée,
Cyril
Jeedom 3.3.36 - Raspberry - Clé ZWave GEN5 - RFP1000 - Pack Ultimate

Skyjouby
Timide
Messages : 33
Inscription : 16 nov. 2018, 21:58

Re: Besoin d'aide sur Réinitialisation

Message par Skyjouby » 07 juin 2019, 16:04

Toujours d'actualité, si jamais une âme charitable à la moindre idée :? :idea:
Jeedom 3.3.36 - Raspberry - Clé ZWave GEN5 - RFP1000 - Pack Ultimate

Répondre

Revenir vers « [Plugin officiel] Alarme »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 2 invités