Ce Forum passera en lecture seule en janvier 2020
Image
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

[clos] Impossible de redémarrer le demon ...

(anciennement dénommé plugin OpenZwave)

Modérateur : nechry

Répondre
abarrau
Actif
Messages : 977
Inscription : 22 déc. 2014, 13:12

[clos] Impossible de redémarrer le demon ...

Message par abarrau » 12 mai 2016, 14:19

Bonjour,

Je tente ma question ici ..
Depuis hier, mon réseau zwave ne répond plus.
J'ai l'erreur suivante dans la log du démon qui revient systématiquement :
[2016-05-12 14:08:21][openzwavecmd][INFO] : Lancement démon openzwave : /usr/bin/python /usr/share/nginx/www/jeedom/plugins/openzwave/core/class/../../ressources/zwaveserver/openZWave.py --pidfile=/tmp/openzwave.pid --device=/dev/ttyAMA0 --log=Error --port=8083 --config_folder=/usr/share/nginx/www/jeedom/plugins/openzwave/core/class/../../ressources/openzwave/config --data_folder=/usr/share/nginx/www/jeedom/plugins/openzwave/core/class/../../data --callback=http://127.0.0.1:80/plugins/openzwave/c ... eZwave.php --apikey=YQFCKcxGJ52BSrHCc73U --serverId=0 --suppressRefresh=0
12-05-2016 14:08:21 | info | Check flask dependency
12-05-2016 14:08:21 | error | The dependency of openzwave plugin are not installed. Please, check the plugin openzwave configuration page for instructions
12-05-2016 14:08:21 | error | Error: EOF read where object expected
J'ai relancé l'installation des dépendances, j'ai fait un reboot de la box, relancé le demon ...
Je n'arrive pas à démarrer mon réseau ; je seche !

Avez-vous une idée vers quoi me retourner / tester ? merci.

(Jeedom 2.3.3 / plugin du 2016-04-22 / carte intégré au rasberry)

Cdt,
Aurélien
Dernière édition par abarrau le 12 mai 2016, 22:40, édité 1 fois.

kouaw
Actif
Messages : 5986
Inscription : 25 janv. 2015, 22:15
Localisation : Belgium
Contact :

Re: Impossible de redémarrer le demon ...

Message par kouaw » 12 mai 2016, 15:53

Faire la mise à jour force plugin et installation dépendance

Si tjr nok alors supprimé puis remettre le plugin

Envoyé de mon HUAWEI GRA-L09 en utilisant Tapatalk

abarrau
Actif
Messages : 977
Inscription : 22 déc. 2014, 13:12

Re: Impossible de redémarrer le demon ...

Message par abarrau » 12 mai 2016, 19:37

Je vais tenter la 1ere (update forcée).
Mais hors de question pour la 2nde, il doit bien y avoir une autre solution...
(Cela me dépasse toujours ces réponses....)

kouaw
Actif
Messages : 5986
Inscription : 25 janv. 2015, 22:15
Localisation : Belgium
Contact :

Re: Impossible de redémarrer le demon ...

Message par kouaw » 12 mai 2016, 19:45

Parfois cette option à débloquer la chose nechry la déjà dit ;)

Envoyé de mon HUAWEI GRA-L09 en utilisant Tapatalk

abarrau
Actif
Messages : 977
Inscription : 22 déc. 2014, 13:12

Re: Impossible de redémarrer le demon ...

Message par abarrau » 12 mai 2016, 21:22

bin après un reboot de la box, elle ne fonctionne plus du tout ... donc mon pblm de zwave passe secondaire ... :(
c'est la merde là ! ... :'(

abarrau
Actif
Messages : 977
Inscription : 22 déc. 2014, 13:12

Re: [clos] Impossible de redémarrer le demon ...

Message par abarrau » 12 mai 2016, 22:41

tout semble être rentré dans l'ordre ...
mais comprendre la raison reste inexpliqué ...

tirikiki
Timide
Messages : 72
Inscription : 22 nov. 2014, 13:21

Re: [clos] Impossible de redémarrer le demon ...

Message par tirikiki » 12 mai 2016, 23:18

Bonsoir,
même problème que toi abarrau depuis aujourd'hui.
J'ai essayé, redémarrage box, sauvegarde d'hier, mise à jour (tout forcé), désinstallation et réinstallation du plugin mais rien n'y fait :(
J'ai plus qu'a attendre que ton miracle se propage...

abarrau
Actif
Messages : 977
Inscription : 22 déc. 2014, 13:12

Re: [clos] Impossible de redémarrer le demon ...

Message par abarrau » 14 mai 2016, 11:11

Très étrange, après un retour à la normal en milieu de semaine sans action particulière (uniquement redémarrage sucessif), ce matin après la mise à jour du plugin, je me retrouve à nouveau avec le même problème.
Je tente à nouveau une mise à jour des dépendances .... :(

Avatar de l’utilisateur
nechry
Actif
Messages : 9644
Inscription : 24 juin 2014, 20:07
Localisation : Suisse
Contact :

Re: [clos] Impossible de redémarrer le demon ...

Message par nechry » 14 mai 2016, 11:56

Il y a quelque chose dans les log? La page santée jeedom tout est ok?


Sent from my iPhone using Tapatalk
As-tu consulté la documentation avant de poser ta question?
Les demandes de support en MP ne seront pas traité mais j'accepte les dons paypal.me/nechry
Visiter mon blog http://nechry-automation.ch/

abarrau
Actif
Messages : 977
Inscription : 22 déc. 2014, 13:12

Re: [clos] Impossible de redémarrer le demon ...

Message par abarrau » 14 mai 2016, 13:10

dans la log, je n'ai eu que le message mis dans mon 1er post ...
après relance des dépendances, c'est redevenu à OK.

par contre question plus global :
1/ à chaque mise à jour du plugin, une mise à jour des dépendances est-elle obligatoire ? (sinon qu'est-ce qui justifie cette demande ?)
2/ lors d'une mise à jour du plugin n'est-il pas possible de lancer automatiquement cette mise à jour des dépendances ?

Avatar de l’utilisateur
nechry
Actif
Messages : 9644
Inscription : 24 juin 2014, 20:07
Localisation : Suisse
Contact :

Re: [clos] Impossible de redémarrer le demon ...

Message par nechry » 14 mai 2016, 15:32

Alors pour la mise a jour des dépendance avec chaque version du plugin non c'est obligatoire, en fin je veux dire que dans certain cas elle ne serait pas requise ou nécessaire. Pour la version de mai c'était obligatoire avec le support des multi instances. La prochaine version du plugin aura aussi besoin de faire pcq j'ai un correctif au niveau des modules en mode secure. C'est déja le cas a l'installation de la mise a jour si une mise a jour de dépendances est requise elle se déclenche d'elle même. Je ne comprends pas ce qui c'est passé chez toi par contre


Sent from my finger
As-tu consulté la documentation avant de poser ta question?
Les demandes de support en MP ne seront pas traité mais j'accepte les dons paypal.me/nechry
Visiter mon blog http://nechry-automation.ch/

Répondre

Revenir vers « Plugin Z-Wave »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 7 invités