Ce Forum passera en lecture seule en janvier 2020
Image
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

Plugin blea

Avatar de l’utilisateur
sheep300
Actif
Messages : 1202
Inscription : 27 mai 2015, 23:27
Localisation : la rochelle

Re: Plugin blea

Message par sheep300 » 29 déc. 2017, 12:25

#value#>3276.7?#value#-6553.4
Voici la formule à mettre dans la partie calcul de ta sonde de température

Envoyé de mon Moto G (4) en utilisant Tapatalk

Damien

benj29
Actif
Messages : 3978
Inscription : 26 mars 2017, 09:57
Contact :

Re: Plugin blea

Message par benj29 » 29 déc. 2017, 17:29

Pour le mi band active le mode visibilité sur l'appli.
Perso, je n'ai pas trouvé ça fiable sur la présence.

Envoyé de mon Moto G (5S) Plus en utilisant Tapatalk


Shaad
Timide
Messages : 187
Inscription : 10 juin 2017, 11:14

Re: Plugin blea

Message par Shaad » 02 janv. 2018, 01:03

Bonjour,

Très content de ce plugin que j'utilise depuis longtemps avec des NUT Mini pour de la détection de présence, je lui ai ajouté un Mi Flower Care récemment.
Et là je constate des choses curieuses : je reçois régulièrement 2 infos différentes à une seconde d'écart...

En regardant dans les logs, voici ce que je trouve (l'adresse du Flower Care est C4:7C:8D:65:D0:97) :
J'ai mis en gras les 2 lignes répétées.


[2018-01-02 00:51:59][DEBUG] : Connecting : C4:7C:8D:65:D0:97 with bluetooth 1
[2018-01-02 00:52:01][DEBUG] : Failed to connect to peripheral C4:7C:8D:65:D0:97, addr type: public attempt 1
[2018-01-02 00:52:07][DEBUG] : Connected... C4:7C:8D:65:D0:97
[2018-01-02 00:52:07][DEBUG] : Reading Characteristic...C4:7C:8D:65:D0:97
[2018-01-02 00:52:07][DEBUG] : Characteristic Readen .... C4:7C:8D:65:D0:97
[2018-01-02 00:52:07][DEBUG] : Writing Characteristic... C4:7C:8D:65:D0:97
[2018-01-02 00:52:07][DEBUG] : Characteristic written... C4:7C:8D:65:D0:97
[2018-01-02 00:52:07][DEBUG] : {'rsp': ['wr']}
[2018-01-02 00:52:07][DEBUG] : Writing Characteristic... C4:7C:8D:65:D0:97
[2018-01-02 00:52:07][DEBUG] : Characteristic written... C4:7C:8D:65:D0:97
[2018-01-02 00:52:07][DEBUG] : {'rsp': ['wr']}
[2018-01-02 00:52:07][DEBUG] : Subscribing to notification : C4:7C:8D:65:D0:97
[2018-01-02 00:52:07][DEBUG] : Delegated
[2018-01-02 00:52:07][DEBUG] : {'battery': 87, 'firmware': '2.7.0', 'id': u'C4:7C:8D:65:D0:97'}
[2018-01-02 00:52:07][DEBUG] : Subscribing for 2
[2018-01-02 00:52:07][DEBUG] : [(1, 'Flags', u'1a'), (7, 'Complete 128b Services', u'fc9dd0b3cb84e0840642f3f7e1e0bfcb')] True public d8:0f:99:31:ed:ba
[2018-01-02 00:52:07][DEBUG] : It's an unknown packet but not sent because this device is not Included and I'am not in learn mode d8:0f:99:31:ed:ba
[2018-01-02 00:52:07][DEBUG] : Send to jeedom : {u'devices': {u'C4:7C:8D:65:D0:97': {'battery': 87, 'source': 'local', 'firmware': '2.7.0', 'id': u'C4:7C:8D:65:D0:97'}}}
[2018-01-02 00:52:07][DEBUG] : Starting new HTTP connection (1): 127.0.0.1
[2018-01-02 00:52:08][DEBUG] : http://127.0.0.1:80 "POST /plugins/blea/core/php/jeeBlea.php?apikey=TOTO HTTP/1.1" 200 0
[2018-01-02 00:52:08][DEBUG] : Received Notification for C4:7C:8D:65:D0:97 miflora from handle 0x35
[2018-01-02 00:52:08][DEBUG] : Send to jeedom : {u'devices': {u'C4:7C:8D:65:D0:97': {'temperature': 19.6, 'sunlight': 56, 'source': 'local', 'moisture': 0, 'fertility': 0, 'id': u'C4:7C:8D:65:D0:97'}}}
[2018-01-02 00:52:08][DEBUG] : Starting new HTTP connection (1): 127.0.0.1
[2018-01-02 00:52:08][DEBUG] : http://127.0.0.1:80 "POST /plugins/blea/core/php/jeeBlea.php?apikey=TOTO HTTP/1.1" 200 0
[2018-01-02 00:52:09][DEBUG] : Received Notification for C4:7C:8D:65:D0:97 miflora from handle 0x35
[2018-01-02 00:52:09][DEBUG] : Send to jeedom : {u'devices': {u'C4:7C:8D:65:D0:97': {'temperature': 19.7, 'sunlight': 60, 'source': 'local', 'moisture': 0, 'fertility': 0, 'id': u'C4:7C:8D:65:D0:97'}}}
[2018-01-02 00:52:09][DEBUG] : Starting new HTTP connection (1): 127.0.0.1
[2018-01-02 00:52:09][DEBUG] : http://127.0.0.1:80 "POST /plugins/blea/core/php/jeeBlea.php?apikey=TOTO HTTP/1.1" 200 0
[2018-01-02 00:52:09][DEBUG] : Disconnecting... C4:7C:8D:65:D0:97
[2018-01-02 00:52:09][DEBUG] : Disconnected...C4:7C:8D:65:D0:97


Des idées de pourquoi cette répétition avec des valeurs différentes ?

Merki !

bmorlon
Timide
Messages : 8
Inscription : 01 déc. 2016, 09:08

Re: Plugin blea

Message par bmorlon » 05 janv. 2018, 08:37

Bonjour,
Je rencontre un problème avec le plugin Bluetooth Advertissement :

Le daemon se coupe au bout de quelques jours sans raison apparente. Je ne vois que ce log :

[2018-01-05 03:15:40][ERROR] : Exception on scanner (didn't resolve there is an issue with bluetooth) : Failed to execute mgmt cmd 'scanend'

J'ai essayé de le passer en mode gestion automatique et standard mais le comportement et le même.
J'ai egalement essayé de relancer les dependances, sans succes.

J'utilise un RPI3 avec le bluetooth integré.

Pourriez vous m'aider ?
Merci.
Cordialement.

bmorlon
Timide
Messages : 8
Inscription : 01 déc. 2016, 09:08

Re: Plugin blea

Message par bmorlon » 05 janv. 2018, 11:44

J'ai finalement pu reparé mon soucis grace à ce post : https://www.babash.fr/2017/04/27/raspbe ... bluetooth/

tonnerre33
Timide
Messages : 176
Inscription : 28 déc. 2015, 15:44
Localisation : Bordeaux

Re: Plugin blea

Message par tonnerre33 » 06 janv. 2018, 12:19

bmorlon a écrit :
05 janv. 2018, 11:44
J'ai finalement pu reparé mon soucis grace à ce post : https://www.babash.fr/2017/04/27/raspbe ... bluetooth/
Merci pour ton retour

Avatar de l’utilisateur
Theduck38
Helper
Messages : 2707
Inscription : 22 févr. 2015, 17:32
Localisation : Près de Grenoble
Contact :

Re: Plugin blea

Message par Theduck38 » 06 janv. 2018, 21:48

Tiens, je remarque un truc marrant... lorsque je clique sur la page 'Santé' de Jeedom, j'ai systématiquement le Démon BLEA marqué en erreur. Je recharge la page et l'erreur est partie !
Le plugin fonctionne bien.

D'autres ont le même comportement ?
-- TD38 --
Helper Officiel Jeedom
Zimeteo sur Jeedom : http://www.meteo.lecoin.info
Jeedom Stable sur serveur custom
Le risque électrique - Afficheur leds RGB - Tablette Murale - Thermostat connecté

Avatar de l’utilisateur
Theduck38
Helper
Messages : 2707
Inscription : 22 févr. 2015, 17:32
Localisation : Près de Grenoble
Contact :

Re: Plugin blea

Message par Theduck38 » 06 janv. 2018, 21:55

Correction : si je recharge en boucle la page de santé, le démon ne répond pas environ 10s toutes les 30s (approximativement, j'ai pas pris de chrono).
-- TD38 --
Helper Officiel Jeedom
Zimeteo sur Jeedom : http://www.meteo.lecoin.info
Jeedom Stable sur serveur custom
Le risque électrique - Afficheur leds RGB - Tablette Murale - Thermostat connecté

djo28
Timide
Messages : 117
Inscription : 28 mars 2015, 11:35

Re: Plugin blea

Message par djo28 » 07 janv. 2018, 08:37

J'ai le même comportement, il me semble que quelqu'un avait déjà abordé le sujet mais resté sans explications.
Perso j'ai 2 antennes et un coup c'est l'une qui apparait en erreur, un coup c'est l'autre (matériel différent).

Avatar de l’utilisateur
Theduck38
Helper
Messages : 2707
Inscription : 22 févr. 2015, 17:32
Localisation : Près de Grenoble
Contact :

Re: Plugin blea

Message par Theduck38 » 07 janv. 2018, 11:44

OK, dans tous les cas, ce n'est pas bien grave (ça n'empêche pas le fonctionnement correct en ce qui me concerne). C'est plus pour @lunarok s'il veut regarder et corriger.
Je peux fournir des logs Debug si nécessaire.
-- TD38 --
Helper Officiel Jeedom
Zimeteo sur Jeedom : http://www.meteo.lecoin.info
Jeedom Stable sur serveur custom
Le risque électrique - Afficheur leds RGB - Tablette Murale - Thermostat connecté

Avatar de l’utilisateur
Antoinekl1
Actif
Messages : 3927
Inscription : 23 mai 2015, 08:14

Re: Plugin blea

Message par Antoinekl1 » 09 janv. 2018, 12:13

Bonjour à tous

j'utilise le plugin pour le Hector Thecub, que j'ai mis dans un frigo

mais le signale ne semble pas passer la couche d'alu

j'ai Résultat de la commande : [(1, 'Flags', u'05'), (2, 'Incomplete 16b Services', u'a471')]

pourtant dans la santé, il m'indique bien PRESENT et une date de communication récente

est-ce bien ca le soucis ?
JEEDOM Smart Ultimate + 40 modules zwave
A vendre ; pack POWER jeedom - Jeedom Mini+ - Console Clazio sous Android 6

flagadoue
Timide
Messages : 11
Inscription : 01 déc. 2015, 22:44

Re: Plugin blea

Message par flagadoue » 09 janv. 2018, 19:48

Bonjour
Je suis dans le même cas que Rabieau avec des playbulb garden qui ne fonctionnent pas: l'inclusion s'est fait (vu en candle mais vu quand même) par contre, ensuite je n'ai pas la main dessus et comme il semble que la version 2.3 ne soit pas encore prise en compte, je ne sais pas si le probleme vient de là ou . . . . d'ailleurs (faut dire que je ne suis pas un cador :oops: )
Si quelqu'un a de l'info sur la prise en compte de la V2.3 ça serait sympa.
D'avance merci

thouve
Timide
Messages : 215
Inscription : 21 oct. 2016, 19:30

Re: Plugin blea

Message par thouve » 09 janv. 2018, 21:02

Salut a tous, je rencontre des problèmes avec le plugin blea.
mes mi flora et mes mi band 1S ne sont plus reconnu :/
Désolé si cela est décris dans le topic mais j'ai pas le courage de lire les 118 pages :/
J'ai pu voir dans les dernières page des problème mais par rapports a des valeurs négatives ou de connexions quand l application smartphone est allumée mais moi les apps sont fermées et le bluetooth aussi :/

Si une solution existe je suis preneur.

PS : J'ai regardé dans la partie réseau de l'application, les différents objets sont tous reconnus par mes 3 antennes mais aucunes données ne remontent

lablanchyseb
Timide
Messages : 51
Inscription : 04 mai 2016, 11:53

Re: Plugin blea

Message par lablanchyseb » 10 janv. 2018, 12:32

Bonjour

Savez vous si le module MI Bluetooth Hygrothermographe est compatible avec BLEA?

https://fr.aliexpress.com/item/D-origin ... 66522.html

Merci d'avance.

cairve
Timide
Messages : 62
Inscription : 18 déc. 2017, 11:39

Re: Plugin blea

Message par cairve » 10 janv. 2018, 20:27

Est-ce qu'il serait possible de rajouter l'indication de la batterie sur les g-tag de gigaset ? L'info est dispo, il y a même une modification du plugin dispo sur le forum.

Merci d'avance :)
Jeedom Z83 Debian 9
clé zigate 3.0f (40), clé zwave (25), clé 3G, 2 xiaomi Mi Home (30), Philips Hue (2), espeasy wifi (12), wifilight2 (2), blea (local + 1 déporté sur RPI2) + 3 Dafang custom
Awtrix 2.0, Logitech Harmony Elite
70 scénarios

nevrotik
Timide
Messages : 5
Inscription : 10 févr. 2017, 13:54

Re: Plugin blea

Message par nevrotik » 11 janv. 2018, 09:48

Bonjour,
je suis sous Jeedom 3.1.7 sur RPI 2 et j'ai un RPI Zero+ pour l'antenne
mon installation se passe bien mai je n'arrive pas à passer l'antenne en mode inclusion.
voici le log

Code : Tout sélectionner

File "/home/root/blead/resources/blead/blead.py", line 496, in <module>
listen()
File "/home/root/blead/resources/blead/blead.py", line 141, in listen
jeedom_socket.open()
File "/home/root/blead/resources/blead/jeedom/jeedom.py", line 312, in open
self.netAdapter = TCPServer((self.address, self.port), jeedom_socket_handler)
File "/usr/lib/python2.7/SocketServer.py", line 417, in __init__
self.server_bind()
File "/usr/lib/python2.7/SocketServer.py", line 431, in server_bind
self.socket.bind(self.server_address)
File "/usr/lib/python2.7/socket.py", line 228, in meth
return getattr(self._sock,name)(*args)
error: [Errno 98] Address already in use
sinon j'ai

Code : Tout sélectionner

[2018-01-11 09:45:14][DEBUG] : [(3, 'Complete 16b Services', u'9ffe'), (22, '16b Service Data', u'9ffe0000000000000000000000000000000000000000'), (255, 'Manufacturer', u'e0000121ca74b0')] False public 48:d6:d5:84:xx:xx
[2018-01-11 09:45:14][DEBUG] : It's an unknown packet but not sent because this device is not Included and I'am not in learn mode 48:d6:d5:84:32:5c
[2018-01-11 09:45:14][DEBUG] : [(255, 'Manufacturer', u'060001090003211d56499448e1befb521a3508c818ddddb297a9e1')] False random 00:2b:be:a0:b1:aa
[2018-01-11 09:45:14][DEBUG] : It's an unknown packet but not sent because this device is not Included and I'am not in learn mode 00:2b:be:a0:b1:aa
[2018-01-11 09:45:14][DEBUG] : [(1, 'Flags', u'06'), (2, 'Incomplete 16b Services', u'95fe'), (22, '16b Service Data', u'95fe3102980000c5e7658d7cc40d'), (9, 'Complete Local Name', u'Flower care')] True public c4:7c:8d:65:xx:xx
[2018-01-11 09:45:14][DEBUG] : This is a miflora device c4:7c:8d:65:xx:xx
[2018-01-11 09:45:14][DEBUG] : It's a known packet but not decoded because this device is not Included and I'am not in learn mode c4:7c:8d:65:e7:c5
[2018-01-11 09:45:15][DEBUG] : [(3, 'Complete 16b Services', u'9ffe'), (22, '16b Service Data', u'9ffe0276f66a4e4c742d755900000160e4408'), (255, 'Manufacturer', u'e0000120ca98a10e')] False public 08:9e:08:48:xx:xx
[2018-01-11 09:45:15][DEBUG] : It's an unknown packet but not sent because this device is not Included and I'am not in learn mode 08:9e:08:48:cb:d2
j'ai essayé plein de chose trouvée sur ce forum sans succès...
mises à jours,
resinstallation des dépendances en mode root...
Jeedom v2.4.4
Box: RasPi 2B, HC2
Modules: RFXcom, DIO Chacon, TRUST, Intertechno

Avatar de l’utilisateur
mika-nt28
Actif
Messages : 7993
Inscription : 05 août 2014, 08:58
Localisation : Dreux - France

Re: Plugin blea

Message par mika-nt28 » 11 janv. 2018, 10:38

Bonjour a tous,

J'essaye de comprendre l'intégration de Blea et des Itag.
J'ai lancé le scan et il a bien été détecte et j'ai coché "garder la connexion" comme indiqué dans le message bleu

Son statut présent reste a 1 malgré que le iTag est avec moi
Voici quelques log ou on vois que le tag est interrogé mais pas de réponse.

Comment fonctionne se statut, ne devrait il pas etre mis a zero lorsqu'il ne répond pas?

Code : Tout sélectionner

 Virtually send rssi to device connected as they are not seen anymore D6:24:01:FA:58:FC
[2018-01-11 10:29:56][DEBUG] : Send to jeedom : {u'devices': {u'D6:24:01:FA:58:FC': {'rssi': 'same', 'id': u'D6:24:01:FA:58:FC', 'present': 1, 'source': 'local'}}}
[2018-01-11 10:29:56][DEBUG] : Starting new HTTP connection (1): 127.0.0.1
[2018-01-11 10:29:56][DEBUG] : http://127.0.0.1:80 "POST /plugins/blea/core/php/jeeBlea.php?apikey=fsvSEUD2L30TB1NWQQFAtf4MRvkbPZQK HTTP/1.1" 200 5
Pour faciliter la compréhension de votre problème, n’oubliez pas de poster
- Des Screenshots de votre configuration
- Le Log au moment du problème constaté

Encouragez-moi https://www.paypal.me/mikant28

DamienLGD
Timide
Messages : 49
Inscription : 26 juin 2017, 16:26

Re: Plugin blea

Message par DamienLGD » 12 janv. 2018, 22:33

Salut,

J'ai acheté un parrot pot flower en solde, j'ai cru voir qu'il était compatible avec blea depuis janvier 2017, pourtant je ne le vois pas dans le champ équipement.
Quand je lance un scan je ne le vois pas non plus. Il est vraiment compatible?

Merci

Avatar de l’utilisateur
jolyp
Timide
Messages : 180
Inscription : 10 mars 2015, 20:50
Localisation : Région Parisienne

Re: Plugin blea

Message par jolyp » 14 janv. 2018, 19:09

Bonsoir

une chance de voir les niu de Nodon avec le nouveau firmware pris en charge ?
ils sont bien détectés mais trame "inconnue" ( unknown packet?)

Code : Tout sélectionner

[2018-01-14 19:06:54][DEBUG] : [(8, 'Short Local Name', u'NIU61'), (1, 'Flags', u'05'), (7, 'Complete 128b Services', u'4e495520495320414d415a494e472021'), (255, 'Manufacturer', u'590202020f01000f48452d081c2bce6404b6')] True random e6:ab:ed:95:26:8e
[b][2018-01-14 19:06:54][DEBUG] : It's a unknown packet and I known this device so I send e6:ab:ed:95:26:8e
[/b][2018-01-14 19:06:54][DEBUG] : {'name': '', 'source': 'local', 'rawdata': "[(8, 'Short Local Name', u'NIU61'), (1, 'Flags', u'05'), (7, 'Complete 128b Services', u'4e495520495320414d415a494e472021'), (255, 'Manufacturer', u'590202020f01000f48452d081c2bce6404b6')]", 'rssi': -85, 'type': 'default', 'id': u'E6:AB:ED:95:26:8E'}
[2018-01-14 19:06:55][DEBUG] : Send to jeedom : {u'devices': {u'E6:AB:ED:95:26:8E': {'name': '', 'source': 'local', 'rawdata': "[(8, 'Short Local Name', u'NIU61'), (1, 'Flags', u'05'), (7, 'Complete 128b Services', u'4e495520495320414d415a494e472021'), (255, 'Manufacturer', u'590202020f01000f48452d081c2bce6404b6')]", 'rssi': -85, 'type': 'default', 'id': u'E6:AB:ED:95:26:8E'}}}
merci
Jeedom Raspi3 (Zwave/RFCOM/RFLINK/BLEA)
Jeedom Raspi3 (Teleinfo,BLEA)
Antenne BLEA Raspi0
GW Xiaomi + capteurs divers (température, portes, présence ...)
Qubino Fil Pilote radiateur, Sondes RFXcom low cost
plugins : Thermostat, Agenda, ICS,

vincecoco
Actif
Messages : 1181
Inscription : 12 oct. 2015, 09:31

Re: Plugin blea

Message par vincecoco » 14 janv. 2018, 21:23

Hello,
Quels tags bluetooth pouvait vous me conseiller avec BLEA pour faire de la présence/absence ?
Merci

++

Répondre

Revenir vers « [Plugin Officiel] BLEA »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité