Avant toute chose merci de (re)prendre connaissance de la charte et de la respecter.
Pour résumer :
- Avant de poser une question, je cherche si la réponse existe
- Je suis poli, courtois et je respecte tout un chacun sur le forum
- Si un post m'agace : je m'en éloigne plutôt que de répondre d'une façon qui pourrait être mal interprétée


Il n'est jamais du luxe que de rappeler des choses simples :
Courtoisie, amabilité, politesse et bonne humeur sont les maîtres mots pour un forum sympathique, bienveillant et accueillant :)

Toute la communauté vous remercie

(résolu) Pb instalation dépendances Espeasy

Avatar de l’utilisateur
franx
Timide
Messages : 40
Inscription : 11 févr. 2015, 14:09
Localisation : 69 Pontcharra sur turdine

(résolu) Pb instalation dépendances Espeasy

Message par franx » 03 juil. 2018, 17:03

Bonjour,

je n'arrive pas à installer les dépendances du plugin Espeasy

je ne maitrise pas vraiment le SSH.

Voici les logs de l'installation

Début de l'installation
converted 'https://raw.githubusercontent.com/lunar ... /nodejs.sh' (ANSI_X3.4-1968) -> 'https://raw.githubusercontent.com/lunar ... /nodejs.sh' (UTF-8)
--2018-07-03 11:21:21-- https://raw.githubusercontent.com/lunar ... /nodejs.sh
Resolving raw.githubusercontent.com (raw.githubusercontent.com)... 151.101.120.133
Connecting to raw.githubusercontent.com (raw.githubusercontent.com)|151.101.120.133|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1458 (1.4K) [text/plain]
Saving to: 'dependencies.sh'
0K . 100% 8.41M=0s
2018-07-03 11:21:21 (8.41 MB/s) - 'dependencies.sh' saved [1458/1458]
Nodejs non installé
Hit http://security.debian.org jessie/updates InRelease
Ign http://http.us.debian.org jessie InRelease
Ign http://httpredir.debian.org jessie InRelease
Get:1 http://httpredir.debian.org jessie-updates InRelease [145 kB]
Hit http://http.us.debian.org jessie Release.gpg
Hit http://httpredir.debian.org jessie Release.gpg
Hit http://http.us.debian.org jessie Release
Hit http://httpredir.debian.org jessie Release
Get:2 https://repo.solid-build.xyz ./ InRelease [354 B]
Ign https://repo.solid-build.xyz ./ InRelease
Get:3 https://repo.solid-build.xyz ./ Release.gpg [481 B]
Get:4 https://repo.solid-build.xyz ./ Release
Get:5 https://repo.solid-build.xyz ./ Release [982 B]
Hit http://security.debian.org jessie/updates/main Sources
Hit http://security.debian.org jessie/updates/main armhf Packages
Hit http://security.debian.org jessie/updates/main Translation-en
Get:6 http://httpredir.debian.org jessie-updates/main Sources [17.2 kB]
Get:7 http://httpredir.debian.org jessie-updates/main armhf Packages/DiffIndex [11.8 kB]
Get:8 http://httpredir.debian.org jessie-updates/main Translation-en/DiffIndex [3688 B]
Err https://repo.solid-build.xyz ./ Release
Hit http://http.us.debian.org jessie/non-free armhf Packages
Hit http://http.us.debian.org jessie/non-free Translation-en
Get:9 http://httpredir.debian.org jessie/main Sources [7063 kB]
Get:10 http://httpredir.debian.org jessie/main armhf Packages [6675 kB]
Get:11 http://httpredir.debian.org jessie/main Translation-en [4581 kB]
Fetched 162 kB in 1min 15s (2148 B/s)
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://repo.solid-build.xyz ./ Release: The following signatures were invalid: KEYEXPIRED 1508672008
W: Failed to fetch https://repo.solid-build.xyz/debian/jes ... /./Release
W: Some index files failed to download. They have been ignored, or old ones used instead.
E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.
E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.
KO, version obsolète à upgrader
Suppression du Nodejs existant et installation du paquet recommandé
E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.
dependencies.sh: 32: [: armv7l: unexpected operator
Utilisation du dépot officiel
## Installing the NodeSource Node.js 8.x LTS Carbon repo...
## Populating apt-get cache...
+ apt-get update
Hit http://security.debian.org jessie/updates InRelease
Ign http://http.us.debian.org jessie InRelease
Ign http://httpredir.debian.org jessie InRelease
Hit http://httpredir.debian.org jessie-updates InRelease
Hit http://httpredir.debian.org jessie Release.gpg
Hit http://http.us.debian.org jessie Release.gpg
Hit http://httpredir.debian.org jessie Release
Hit http://http.us.debian.org jessie Release
Get:1 https://repo.solid-build.xyz ./ InRelease [354 B]
Ign https://repo.solid-build.xyz ./ InRelease
Get:2 https://repo.solid-build.xyz ./ Release.gpg [481 B]
Get:3 https://repo.solid-build.xyz ./ Release
Get:4 https://repo.solid-build.xyz ./ Release [982 B]
Hit http://security.debian.org jessie/updates/main Sources
Hit http://security.debian.org jessie/updates/main armhf Packages
Hit http://security.debian.org jessie/updates/main Translation-en
Get:5 http://httpredir.debian.org jessie-updates/main Sources [17.2 kB]
Get:6 http://httpredir.debian.org jessie-updates/main armhf Packages/DiffIndex [11.8 kB]
Get:7 http://httpredir.debian.org jessie-updates/main Translation-en/DiffIndex [3688 B]
Err https://repo.solid-build.xyz ./ Release
Hit http://http.us.debian.org jessie/non-free armhf Packages
Hit http://http.us.debian.org jessie/non-free Translation-en
Get:8 http://httpredir.debian.org jessie/main Sources [7063 kB]
Get:9 http://httpredir.debian.org jessie/main armhf Packages [6675 kB]
Get:10 http://httpredir.debian.org jessie/main Translation-en [4581 kB]
Fetched 17.0 kB in 1min 11s (238 B/s)
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://repo.solid-build.xyz ./ Release: The following signatures were invalid: KEYEXPIRED 1508672008
W: Failed to fetch https://repo.solid-build.xyz/debian/jes ... /./Release
W: Some index files failed to download. They have been ignored, or old ones used instead.
E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.
Error executing command, exiting
E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.
dependencies.sh: 1: dependencies.sh: nodejs: not found
Version actuelle :
dependencies.sh: 54: dependencies.sh: npm: not found
chown: cannot access 'node_modules': No such file or directory
Fin de l'installation


Merci de votre aide

Franx


Mon install: Mini plus avec disque ssd Msata
Zwave, RfxCom, PLC Bus, Xiaomi,
Dernière édition par franx le 05 juil. 2018, 11:05, édité 1 fois.
Franx

rol-rider
Actif
Messages : 4803
Inscription : 10 août 2014, 23:50

Re: Pb instalation dépendances Espeasy

Message par rol-rider » 03 juil. 2018, 18:00

d'après les logs c'est nodejs qu'il n'arrive pas à installer.
j'ai eu ce problème (résolu en SSH)
mais je serais bien incapable de t'aider et de retrouvé ce que j'ai fait !
RPI3 avec mSATA
RFXcom; RFLink; Z-Wave; Mysensors; ESPEasy
Noeuds MySensors-téléinfo-Température-Distance-Baromètre-relais
Noeuds ESPEasy-open-garage-relais-PIR-Station Météo

vincenzi1
Timide
Messages : 241
Inscription : 01 mars 2017, 20:25
Localisation : Normandie

Re: Pb instalation dépendances Espeasy

Message par vincenzi1 » 04 juil. 2018, 14:43

Salut,

tu a un problème de signature des packet

tu fait en SSH sous root

Code : Tout sélectionner

curl https://repo.solid-build.xyz/debian/jessie/bsp-imx6/Release.key | sudo apt-key add -
et après tu relance t'es dépendance

Avatar de l’utilisateur
franx
Timide
Messages : 40
Inscription : 11 févr. 2015, 14:09
Localisation : 69 Pontcharra sur turdine

Re: Pb instalation dépendances Espeasy

Message par franx » 04 juil. 2018, 16:17

Merci pour ta réponse,
je galère pour arriver a me connecter en ssh sur mon jeedom.

des que j'y arrive je test ça
Franx

rol-rider
Actif
Messages : 4803
Inscription : 10 août 2014, 23:50

Re: Pb instalation dépendances Espeasy

Message par rol-rider » 04 juil. 2018, 16:50

il y a eu une mise à jour sur le plugin espeasy, tu peux toujours faire la mise à jour et retester....on c'est jamais.
RPI3 avec mSATA
RFXcom; RFLink; Z-Wave; Mysensors; ESPEasy
Noeuds MySensors-téléinfo-Température-Distance-Baromètre-relais
Noeuds ESPEasy-open-garage-relais-PIR-Station Météo

Avatar de l’utilisateur
franx
Timide
Messages : 40
Inscription : 11 févr. 2015, 14:09
Localisation : 69 Pontcharra sur turdine

Re: Pb instalation dépendances Espeasy

Message par franx » 04 juil. 2018, 18:13

La mise a jour n'a rien changer pour moi.
il faut que j'arrive a me connecter en SSH mais je n'y comprend pas grand chose. ça ne passe pas avec jeedom et Mjeedom96
Franx

vincenzi1
Timide
Messages : 241
Inscription : 01 mars 2017, 20:25
Localisation : Normandie

Re: Pb instalation dépendances Espeasy

Message par vincenzi1 » 04 juil. 2018, 19:03

utilise putty

Avatar de l’utilisateur
franx
Timide
Messages : 40
Inscription : 11 févr. 2015, 14:09
Localisation : 69 Pontcharra sur turdine

Re: Pb instalation dépendances Espeasy

Message par franx » 04 juil. 2018, 19:11

ok pour Putty mais j'ultilise quoi comme nom d'utilisateur et mot de passe ?
Franx

vincenzi1
Timide
Messages : 241
Inscription : 01 mars 2017, 20:25
Localisation : Normandie

Re: Pb instalation dépendances Espeasy

Message par vincenzi1 » 04 juil. 2018, 20:40

franx a écrit :
04 juil. 2018, 19:11
ok pour Putty mais j'ultilise quoi comme nom d'utilisateur et mot de passe ?
ta quoi comme distribution ?

Avatar de l’utilisateur
franx
Timide
Messages : 40
Inscription : 11 févr. 2015, 14:09
Localisation : 69 Pontcharra sur turdine

Re: Pb instalation dépendances Espeasy

Message par franx » 04 juil. 2018, 20:55

Voila ce que me donne l'onglet Health


Linux linux 3.14.79-fslc-imx6-sr #1 SMP Wed Sep 13 12:05:55 UTC 2017 armv7l GNU/Linux [8.9]
Franx

vincenzi1
Timide
Messages : 241
Inscription : 01 mars 2017, 20:25
Localisation : Normandie

Re: Pb instalation dépendances Espeasy

Message par vincenzi1 » 04 juil. 2018, 22:51

sa me donne pas grande chose
juste que sa tourne sur ARM un Raspberry ?

tu la installer comment ton jeedom ?

Avatar de l’utilisateur
franx
Timide
Messages : 40
Inscription : 11 févr. 2015, 14:09
Localisation : 69 Pontcharra sur turdine

Re: Pb instalation dépendances Espeasy

Message par franx » 04 juil. 2018, 22:59

C'est une box mini + avec un disque ssd . j'ai tout reinstallé il y a 2 mois environs avec une image Miniplus V 3.1.7 jessie
Franx

vincenzi1
Timide
Messages : 241
Inscription : 01 mars 2017, 20:25
Localisation : Normandie

Re: Pb instalation dépendances Espeasy

Message par vincenzi1 » 04 juil. 2018, 23:06

ok donc par défaut c'est
pseudo: root
password: debian

rol-rider
Actif
Messages : 4803
Inscription : 10 août 2014, 23:50

Re: Pb instalation dépendances Espeasy

Message par rol-rider » 04 juil. 2018, 23:15

c'est les images réalisé par bronche ?

il y a les codes dans son fichier lisez moi
ça semble être en SSH debian et debian et pour root debian
Une image pour humingboard Mini plus - Jessie et Jeedom 3.1.7 (SSH: debian / debian - root / debian - jeedom admin -admin)
RPI3 avec mSATA
RFXcom; RFLink; Z-Wave; Mysensors; ESPEasy
Noeuds MySensors-téléinfo-Température-Distance-Baromètre-relais
Noeuds ESPEasy-open-garage-relais-PIR-Station Météo

Avatar de l’utilisateur
franx
Timide
Messages : 40
Inscription : 11 févr. 2015, 14:09
Localisation : 69 Pontcharra sur turdine

Re: Pb instalation dépendances Espeasy

Message par franx » 04 juil. 2018, 23:18

Merci à tous les 2, j’essaie ça demain


Envoyé de mon iPhone en utilisant Tapatalk
Franx

Avatar de l’utilisateur
franx
Timide
Messages : 40
Inscription : 11 févr. 2015, 14:09
Localisation : 69 Pontcharra sur turdine

Re: Pb instalation dépendances Espeasy

Message par franx » 04 juil. 2018, 23:18

Merci à tous les 2, j’essaie ça demain


Envoyé de mon iPhone en utilisant Tapatalk
Franx

Avatar de l’utilisateur
franx
Timide
Messages : 40
Inscription : 11 févr. 2015, 14:09
Localisation : 69 Pontcharra sur turdine

Re: Pb instalation dépendances Espeasy

Message par franx » 05 juil. 2018, 08:31

on avance, j'arrive a me connecter en ssh avec debian debian avec putty.
par contre comment je sais si je suis en root avec ce login ?
Franx

rol-rider
Actif
Messages : 4803
Inscription : 10 août 2014, 23:50

Re: Pb instalation dépendances Espeasy

Message par rol-rider » 05 juil. 2018, 08:43

Ba, là tu ne dois pas y être.
Quand tu fais un sudo...... Il va te demander le MDP Root.
Mais, quand tu auras résolu ton problème, il serait souhaitable de modifier les MDP.

Envoyé de mon Nexus 7 en utilisant Tapatalk

RPI3 avec mSATA
RFXcom; RFLink; Z-Wave; Mysensors; ESPEasy
Noeuds MySensors-téléinfo-Température-Distance-Baromètre-relais
Noeuds ESPEasy-open-garage-relais-PIR-Station Météo

Avatar de l’utilisateur
franx
Timide
Messages : 40
Inscription : 11 févr. 2015, 14:09
Localisation : 69 Pontcharra sur turdine

Re: Pb instalation dépendances Espeasy

Message par franx » 05 juil. 2018, 08:58

C'est ok pour la connexion en SSH, j'ai passé la commande curl https://repo.solid-build.xyz/debian/jes ... elease.key | sudo apt-key add -

Il m'a redemandé le mdp a la fin pour le sudo, Nickel.

par contre j'ai relancé les dépendances apres mais l'install n'aboutit pas.

je vous joint les logs

Accueil
Analyse
Outils
Plugins
1

08:57:14
Gestion
Mode inclusion
Configuration
Santé
Mes espeasy



Aucun espeasy détecté, démarrer un node pour ajout
Configuration du plugin
ESPeasy (espeasy) - stable
Etat
StatutActifAction

Version2018-07-03 01:18:21 Version Jeedom2.4
Auteurlunarok LicenseAGPL
Log

Niveau de log localAucunDefautDebugInfoWarningError
Logs
Dépendances
Nom Statut Installation Dernière installation
Local NOK 2018-06-19 22:28:09
Démon
Nom Statut Configuration (Re)Démarrer Arrêter Gestion automatique Dernier lancement
Local NOK NOK Gestion automatique désactivée Inconnue
Configuration

IP Controleur à saisir dans ESPeasy (onglet config) : 192.168.0.145
Port Controleur à saisir dans ESPeasy (onglet config) : 8121
Publish template à saisir dans ESPeasy (onglet tools, puis bouton advanced) :device=%sysname%&taskid=%id%&cmd=%valname%&value=%value%
Fonctionnalités

interactNon
cronNon
cron5Non
cron15Non
cron30Non
cronHourlyNon
cronDailyNon
Log du plugin

Rechercher



Début de l'installation
converted 'https://raw.githubusercontent.com/lunar ... /nodejs.sh' (ANSI_X3.4-1968) -> 'https://raw.githubusercontent.com/lunar ... /nodejs.sh' (UTF-8)
--2018-07-05 06:51:06-- https://raw.githubusercontent.com/lunar ... /nodejs.sh
Resolving raw.githubusercontent.com (raw.githubusercontent.com)... 151.101.120.133
Connecting to raw.githubusercontent.com (raw.githubusercontent.com)|151.101.120.133|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1458 (1.4K) [text/plain]
Saving to: 'dependencies.sh'
0K . 100% 10.1M=0s
2018-07-05 06:51:06 (10.1 MB/s) - 'dependencies.sh' saved [1458/1458]
Nodejs non installé
Hit http://security.debian.org jessie/updates InRelease
Ign http://http.us.debian.org jessie InRelease
Hit http://http.us.debian.org jessie Release.gpg
Ign http://httpredir.debian.org jessie InRelease
Hit http://http.us.debian.org jessie Release
Hit http://httpredir.debian.org jessie-updates InRelease
Hit http://httpredir.debian.org jessie Release.gpg
Get:1 https://repo.solid-build.xyz ./ InRelease [354 B]
Ign https://repo.solid-build.xyz ./ InRelease
Hit https://repo.solid-build.xyz ./ Release.gpg
Hit http://httpredir.debian.org jessie Release
Hit https://repo.solid-build.xyz ./ Release
Hit http://security.debian.org jessie/updates/main Sources
Hit http://security.debian.org jessie/updates/main armhf Packages
Hit http://security.debian.org jessie/updates/main Translation-en
Hit http://http.us.debian.org jessie/non-free armhf Packages
Hit http://http.us.debian.org jessie/non-free Translation-en
Hit http://httpredir.debian.org jessie-updates/main Sources
Get:2 http://httpredir.debian.org jessie-updates/main armhf Packages/DiffIndex [11.8 kB]
Get:3 http://httpredir.debian.org jessie-updates/main Translation-en/DiffIndex [3688 B]
Hit https://repo.solid-build.xyz ./ Sources
Hit https://repo.solid-build.xyz ./ Packages
Hit http://httpredir.debian.org jessie/main Sources
Get:4 https://repo.solid-build.xyz ./ Translation-en [351 B]
Get:5 https://repo.solid-build.xyz ./ Translation-en [351 B]
Get:6 https://repo.solid-build.xyz ./ Translation-en [351 B]
Hit http://httpredir.debian.org jessie/main armhf Packages
Get:7 https://repo.solid-build.xyz ./ Translation-en [351 B]
Get:8 https://repo.solid-build.xyz ./ Translation-en [351 B]
Ign https://repo.solid-build.xyz ./ Translation-en
Hit http://httpredir.debian.org jessie/main Translation-en
Fetched 15.5 kB in 32s (484 B/s)
E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.
E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.
KO, version obsolète à upgrader
Suppression du Nodejs existant et installation du paquet recommandé
E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.
dependencies.sh: 32: [: armv7l: unexpected operator
Utilisation du dépot officiel
## Installing the NodeSource Node.js 8.x LTS Carbon repo...
## Populating apt-get cache...
+ apt-get update
Hit http://security.debian.org jessie/updates InRelease
Ign http://http.us.debian.org jessie InRelease
Hit http://http.us.debian.org jessie Release.gpg
Hit http://http.us.debian.org jessie Release
Ign http://httpredir.debian.org jessie InRelease
Hit http://httpredir.debian.org jessie-updates InRelease
Get:1 https://repo.solid-build.xyz ./ InRelease [354 B]
Ign https://repo.solid-build.xyz ./ InRelease
Hit https://repo.solid-build.xyz ./ Release.gpg
Hit https://repo.solid-build.xyz ./ Release
Hit http://httpredir.debian.org jessie Release.gpg
Hit http://security.debian.org jessie/updates/main Sources
Hit http://httpredir.debian.org jessie Release
Hit http://security.debian.org jessie/updates/main armhf Packages
Hit http://security.debian.org jessie/updates/main Translation-en
Hit http://http.us.debian.org jessie/non-free armhf Packages
Hit http://http.us.debian.org jessie/non-free Translation-en
Hit https://repo.solid-build.xyz ./ Sources
Hit https://repo.solid-build.xyz ./ Packages
Hit http://httpredir.debian.org jessie-updates/main Sources
Get:2 https://repo.solid-build.xyz ./ Translation-en [351 B]
Get:3 https://repo.solid-build.xyz ./ Translation-en [351 B]
Get:4 https://repo.solid-build.xyz ./ Translation-en [351 B]
Get:5 http://httpredir.debian.org jessie-updates/main armhf Packages/DiffIndex [11.8 kB]
Get:6 https://repo.solid-build.xyz ./ Translation-en [351 B]
Get:7 https://repo.solid-build.xyz ./ Translation-en [351 B]
Ign https://repo.solid-build.xyz ./ Translation-en
Get:8 http://httpredir.debian.org jessie-updates/main Translation-en/DiffIndex [3688 B]
Hit http://httpredir.debian.org jessie/main Sources
Hit http://httpredir.debian.org jessie/main armhf Packages
Hit http://httpredir.debian.org jessie/main Translation-en
Fetched 15.5 kB in 32s (477 B/s)
E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.
Error executing command, exiting
E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.
dependencies.sh: 1: dependencies.sh: nodejs: not found
Version actuelle :
dependencies.sh: 54: dependencies.sh: npm: not found
chown: cannot access 'node_modules': No such file or directory
Fin de l'installation
Franx

vincenzi1
Timide
Messages : 241
Inscription : 01 mars 2017, 20:25
Localisation : Normandie

Re: Pb instalation dépendances Espeasy

Message par vincenzi1 » 05 juil. 2018, 09:15

ok

fait

Code : Tout sélectionner

sudo dpkg --configure -a

Répondre

Revenir vers « [Plugin Tiers] ESPEasy »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 0 invité