Avant toute chose merci de (re)prendre connaissance de la charte et de la respecter.
Pour résumer :
- Avant de poser une question, je cherche si la réponse existe
- Je suis poli, courtois et je respecte tout un chacun sur le forum
- Si un post m'agace : je m'en éloigne plutôt que de répondre d'une façon qui pourrait être mal interprétée


Il n'est jamais du luxe que de rappeler des choses simples :
Courtoisie, amabilité, politesse et bonne humeur sont les maîtres mots pour un forum sympathique, bienveillant et accueillant :)

Le groupe des Helpers est present pour vous aidez, n'hésitez pas à poser des questions ;)

Toute la communauté vous remercie

[RESOLU] Problème de connexion https

De l'installation à l'utilisation venez discuter de JEEDOM au quotidien
Saint-Jey
Timide
Messages : 89
Inscription : 22 oct. 2017, 15:25

[RESOLU] Problème de connexion https

Message par Saint-Jey » 24 juil. 2018, 10:29

Bonjour à tous,

je viens demander de l'aide car je suis en train de tourner en rond et ça me rend fou.

J'essaye désespérément d'accéder à mon jeedom en https...

En http, pas de soucis, je configure ma livebox comme il faut :
dyndns80.PNG
dyndns80.PNG (12.81 Kio) Consulté 1590 fois
et j'accède sans problème à l'interface de jeedom.

Dès que je passe en https dans la configuration de la box :
dyndns.PNG
dyndns.PNG (13.73 Kio) Consulté 1590 fois
c'est le merdier et le navigateur me met une erreur :
error.PNG
error.PNG (16.85 Kio) Consulté 1590 fois
je ne comprends pas ce que je fais de mal. J'avais essayer de configurer le https avec le port 443 en entrée et en sortie mais le résultat est le même...

Est-ce que vous savez ce qu'il faut faire pour que la redirection se fasse ?

Merci d'avance
Dernière édition par Saint-Jey le 31 juil. 2018, 10:09, édité 1 fois.

Avatar de l’utilisateur
poluket
Helper
Messages : 1854
Inscription : 19 août 2017, 17:02
Localisation : Chastre - Belgique
Contact :

Re: Problème de connexion https

Message par poluket » 24 juil. 2018, 10:42

ton serveur fonctionne en https en local? tu as activé les ssl sur ton serveur?

https://jeedom.github.io/documentation/ ... e_en_place

en general, on redirige le 443 sur le 443 et pas sur le 80.
pour tes protocoles, ouvre juste le TCP, pas besoin de l'UDP
Helper Officiel Jeedom

Installation KNX + Sonos + Xiaomi Yeelight + Jeedom sur VM Proxmox + wifi unifi avec contrôleur + NAS DS1513+ + UPS + PFsense FW

Saint-Jey
Timide
Messages : 89
Inscription : 22 oct. 2017, 15:25

Re: Problème de connexion https

Message par Saint-Jey » 24 juil. 2018, 10:52

non en local, il est en http.
Je n'avais pas conscience qu'il y avait autant de paramétrage pour accéder à jeedom en https...
je pensais qu'il suffisait d'ouvrir les ports dans le routeur.
je vais lire ton tuto avec attention et essayer de réaliser les étapes.

Saint-Jey
Timide
Messages : 89
Inscription : 22 oct. 2017, 15:25

Re: Problème de connexion https

Message par Saint-Jey » 24 juil. 2018, 10:59

en lisant le tuto, je me rends compte qu'il faut un nom de domaine...
C'est pas possible simplement avec un dyndns ? Il faut obligatoirement payer pour avoir un domaine ?

Avatar de l’utilisateur
coke
Helper
Messages : 581
Inscription : 21 juil. 2014, 11:37
Localisation : essonne

Re: Problème de connexion https

Message par coke » 24 juil. 2018, 11:39

Bonjour,

personnellement j'ai suivi ce tuto
https://www.domo-blog.fr/securiser-jeed ... e-http-01/

je n'ai pas acheté de nom de domaine, j’utilise le dyndns fourni par synology et cela marche nikel.
MERCI À L'ÉQUIPE POUR LE TAF

Helper Officiel Jeedom

Saint-Jey
Timide
Messages : 89
Inscription : 22 oct. 2017, 15:25

Re: Problème de connexion https

Message par Saint-Jey » 24 juil. 2018, 11:58

coke a écrit :
24 juil. 2018, 11:39
Bonjour,

personnellement j'ai suivi ce tuto
https://www.domo-blog.fr/securiser-jeed ... e-http-01/

je n'ai pas acheté de nom de domaine, j’utilise le dyndns fourni par synology et cela marche nikel.
je ne comprends pas comment tu as fait.
Dans le tuto que tu as indiqué, il est demandé à chaque fois un nom de domaine.

Avatar de l’utilisateur
coke
Helper
Messages : 581
Inscription : 21 juil. 2014, 11:37
Localisation : essonne

Re: Problème de connexion https

Message par coke » 24 juil. 2018, 12:03

Saint-Jey a écrit :
24 juil. 2018, 11:58
coke a écrit :
24 juil. 2018, 11:39
Bonjour,

personnellement j'ai suivi ce tuto
https://www.domo-blog.fr/securiser-jeed ... e-http-01/

je n'ai pas acheté de nom de domaine, j’utilise le dyndns fourni par synology et cela marche nikel.
je ne comprends pas comment tu as fait.
Dans le tuto que tu as indiqué, il est demandé à chaque fois un nom de domaine.
Dans ton cas ton nom de domaine et celui de ton dyndns, quand on te demande ton nom de domaine tu met ton dyndns
tu en a bien 1, tu en a parler un peu plus haut ?
MERCI À L'ÉQUIPE POUR LE TAF

Helper Officiel Jeedom

Saint-Jey
Timide
Messages : 89
Inscription : 22 oct. 2017, 15:25

Re: Problème de connexion https

Message par Saint-Jey » 24 juil. 2018, 13:32

coke a écrit :
24 juil. 2018, 12:03
Saint-Jey a écrit :
24 juil. 2018, 11:58
coke a écrit :
24 juil. 2018, 11:39
Bonjour,

personnellement j'ai suivi ce tuto
https://www.domo-blog.fr/securiser-jeed ... e-http-01/

je n'ai pas acheté de nom de domaine, j’utilise le dyndns fourni par synology et cela marche nikel.
je ne comprends pas comment tu as fait.
Dans le tuto que tu as indiqué, il est demandé à chaque fois un nom de domaine.
Dans ton cas ton nom de domaine et celui de ton dyndns, quand on te demande ton nom de domaine tu met ton dyndns
tu en a bien 1, tu en a parler un peu plus haut ?
oui exact j'en ai un.
J'essaie dans la semaine de paramétrer tout ça
Merci pour le coup de main

Avatar de l’utilisateur
coke
Helper
Messages : 581
Inscription : 21 juil. 2014, 11:37
Localisation : essonne

Re: Problème de connexion https

Message par coke » 24 juil. 2018, 15:10

pas de problème, sinon passe en MP je prendrais la main sur ton jeedom.
MERCI À L'ÉQUIPE POUR LE TAF

Helper Officiel Jeedom

Saint-Jey
Timide
Messages : 89
Inscription : 22 oct. 2017, 15:25

Re: Problème de connexion https

Message par Saint-Jey » 31 juil. 2018, 09:25

coke a écrit :
24 juil. 2018, 15:10
pas de problème, sinon passe en MP je prendrais la main sur ton jeedom.
Formidable, ça fonctionne !
Merci pour ton aide.
D'ailleurs, question subsidiaire, si je migre mon installation de mon raspberry vers un NUC (ou équivalent), je vais devoir refaire la manipulation ou le transfert de sauvegarde prend aussi en compte ce que je viens de faire ?

Avatar de l’utilisateur
poluket
Helper
Messages : 1854
Inscription : 19 août 2017, 17:02
Localisation : Chastre - Belgique
Contact :

Re: Problème de connexion https

Message par poluket » 31 juil. 2018, 09:28

Saint-Jey a écrit :
31 juil. 2018, 09:25
coke a écrit :
24 juil. 2018, 15:10
pas de problème, sinon passe en MP je prendrais la main sur ton jeedom.
Formidable, ça fonctionne !
Merci pour ton aide.
D'ailleurs, question subsidiaire, si je migre mon installation de mon raspberry vers un NUC (ou équivalent), je vais devoir refaire la manipulation ou le transfert de sauvegarde prend aussi en compte ce que je viens de faire ?
il faut tout recommencer, ce n'est pas lié au backup applicatif de jeedom
Helper Officiel Jeedom

Installation KNX + Sonos + Xiaomi Yeelight + Jeedom sur VM Proxmox + wifi unifi avec contrôleur + NAS DS1513+ + UPS + PFsense FW

Saint-Jey
Timide
Messages : 89
Inscription : 22 oct. 2017, 15:25

Re: Problème de connexion https

Message par Saint-Jey » 31 juil. 2018, 10:09

poluket a écrit :
31 juil. 2018, 09:28
Saint-Jey a écrit :
31 juil. 2018, 09:25
coke a écrit :
24 juil. 2018, 15:10
pas de problème, sinon passe en MP je prendrais la main sur ton jeedom.
Formidable, ça fonctionne !
Merci pour ton aide.
D'ailleurs, question subsidiaire, si je migre mon installation de mon raspberry vers un NUC (ou équivalent), je vais devoir refaire la manipulation ou le transfert de sauvegarde prend aussi en compte ce que je viens de faire ?
il faut tout recommencer, ce n'est pas lié au backup applicatif de jeedom
OK merci beaucoup

w4zu
Timide
Messages : 23
Inscription : 28 déc. 2015, 16:39

Re: Problème de connexion https

Message par w4zu » 31 juil. 2018, 11:03

J'ai créer un script en bash pour ajouter https sur votre installation jeedom.

Code : Tout sélectionner

https://github.com/w4zu/jeedomssl/tree/master
Le script fait ceci (dans l'ordre):
  • Vérifie que la commande lancée (bash jeedomssl.sh jeedom.ledomaine.fr votremail@mail.com)
  • Installation outils net-tools et dnsutils
  • Vérifie que le domaine pointe bien vers l'ip de votre modem
  • Vérifie que http est bien en écoute sur le port 80
  • ajoute le mod ssl
  • reload apache
  • installation de certbot-auto
  • Création des dossiers pour certbot
  • Création des certificats SSL
  • Création du vhost SSL
  • Ajoute une cron pour le renew du certificat
  • Vérifie la configuration apache
A exécuter en root.

Avatar de l’utilisateur
tirailleurdd
Timide
Messages : 48
Inscription : 19 mars 2017, 09:49
Localisation : Camargue

Re: [RESOLU] Problème de connexion https

Message par tirailleurdd » 02 août 2018, 10:54

Salut!

Je viens de tester ton script pour ma nouvelle Install sur proxmox, un vrai bonheur!
Un grand merci à toi w4zu pour ton travail et surtout pour le partage !
Jeedom sur RPi3 + SSD + z-wave.me

Ikari
Timide
Messages : 101
Inscription : 29 mars 2016, 08:21

Re: [RESOLU] Problème de connexion https

Message par Ikari » 08 août 2018, 17:14

Bonjour,
suite à la tentative de migration de mon certificat letsencrypt en suivant le tuto domo'blog (https://www.domo-blog.fr/securiser-jeed ... ge-http-01) j'ai tout pêté mon jeedom qui n'est plus accessible qu'en ssh via putty :roll:
je pense que c'est le serveur apache qui est en vrac car :

Code : Tout sélectionner

root@jeedom:~# systemctl status -l apache2.service
● apache2.service - LSB: Apache2 web server
   Loaded: loaded (/etc/init.d/apache2)
  Drop-In: /lib/systemd/system/apache2.service.d
           └─forking.conf
   Active: failed (Result: exit-code) since Wed 2018-08-08 17:05:02 CEST; 4s ago
  Process: 31604 ExecStop=/etc/init.d/apache2 stop (code=exited, status=0/SUCCESS)
  Process: 13519 ExecStart=/etc/init.d/apache2 start (code=exited, status=1/FAILURE)

Aug 08 17:05:02 jeedom apache2[13519]: Starting web server: apache2 failed!
Aug 08 17:05:02 jeedom apache2[13519]: The apache2 configtest failed. ... (warning).
Aug 08 17:05:02 jeedom apache2[13519]: Output of config test was:
Aug 08 17:05:02 jeedom apache2[13519]: AH00526: Syntax error on line 13 of /etc/apache2/sites-enabled/mon domaine OVH.ssl.conf:
Aug 08 17:05:02 jeedom apache2[13519]: SSLCertificateFile: file '/root/ssl/letsencrypt/etc/live/mon domaine OVH/cert.pem' does not exist or is empty
Aug 08 17:05:02 jeedom apache2[13519]: Action 'configtest' failed.
Aug 08 17:05:02 jeedom apache2[13519]: The Apache error log may have more information.
Aug 08 17:05:02 jeedom systemd[1]: apache2.service: control process exited, code=exited status=1
Aug 08 17:05:02 jeedom systemd[1]: Failed to start LSB: Apache2 web server.
Aug 08 17:05:02 jeedom systemd[1]: Unit apache2.service entered failed state.
j'ai essayé de lancé de w4zu mais forcément ça n'a pas corrigé le problème.
Je suis nul commandes ssh et je n'arrive pas à trouver de tuto pour récupérer ce problème de serveur apache.
qqun pourrait-il m'aider ?

glou
Timide
Messages : 124
Inscription : 01 juil. 2017, 12:03
Localisation : 27
Contact :

Re: [RESOLU] Problème de connexion https

Message par glou » 08 août 2018, 17:18

/mon domaine OVH/

c'est ton nom de domaine ou tu l'a viré pour ici ?
- NAS DIY (raid5/msata/2xGbps) qui héberge Jeedom, TvH, LMS.
- Un à 2 RPI (toute gamme) par piece (Kodi/Squeezelite/Jeedouino)
Je me suis autoattribué le titre de RPi-BricolBoy, niveau "Or" , et ca se passe ici

Ikari
Timide
Messages : 101
Inscription : 29 mars 2016, 08:21

Re: [RESOLU] Problème de connexion https

Message par Ikari » 08 août 2018, 17:31

glou a écrit :/mon domaine OVH/

c'est ton nom de domaine ou tu l'a viré pour ici ?
Oui c'est moi qui l'ai viré pour ici

Envoyé de mon Redmi Note 4X en utilisant Tapatalk


Avatar de l’utilisateur
poluket
Helper
Messages : 1854
Inscription : 19 août 2017, 17:02
Localisation : Chastre - Belgique
Contact :

Re: [RESOLU] Problème de connexion https

Message par poluket » 08 août 2018, 20:35

Ton problème vient du fait que tu as supprimé l'ancien certificat et donc, jeedom ne sait plus démarrer en SSL.

Ce qu'il faut faire:
Supprimer la partie de ta config en SSL et rendre ton site accessible en http. Puis relancer la création de certificat et une fois que le certificat est dispose, remettre le SSL...

Essaye de renommer ton fichier mon domaine OVH.ssl.conf en .txt et redémarre apache
Helper Officiel Jeedom

Installation KNX + Sonos + Xiaomi Yeelight + Jeedom sur VM Proxmox + wifi unifi avec contrôleur + NAS DS1513+ + UPS + PFsense FW

w4zu
Timide
Messages : 23
Inscription : 28 déc. 2015, 16:39

Re: [RESOLU] Problème de connexion https

Message par w4zu » 12 août 2018, 13:03

tirailleurdd a écrit :
02 août 2018, 10:54
Salut!

Je viens de tester ton script pour ma nouvelle Install sur proxmox, un vrai bonheur!
Un grand merci à toi w4zu pour ton travail et surtout pour le partage !
:D ;)

w4zu
Timide
Messages : 23
Inscription : 28 déc. 2015, 16:39

Re: [RESOLU] Problème de connexion https

Message par w4zu » 12 août 2018, 13:09

Ikari a écrit :
08 août 2018, 17:14
Bonjour,
suite à la tentative de migration de mon certificat letsencrypt en suivant le tuto domo'blog (https://www.domo-blog.fr/securiser-jeed ... ge-http-01) j'ai tout pêté mon jeedom qui n'est plus accessible qu'en ssh via putty :roll:
je pense que c'est le serveur apache qui est en vrac car :

Code : Tout sélectionner

root@jeedom:~# systemctl status -l apache2.service
● apache2.service - LSB: Apache2 web server
   Loaded: loaded (/etc/init.d/apache2)
  Drop-In: /lib/systemd/system/apache2.service.d
           └─forking.conf
   Active: failed (Result: exit-code) since Wed 2018-08-08 17:05:02 CEST; 4s ago
  Process: 31604 ExecStop=/etc/init.d/apache2 stop (code=exited, status=0/SUCCESS)
  Process: 13519 ExecStart=/etc/init.d/apache2 start (code=exited, status=1/FAILURE)

Aug 08 17:05:02 jeedom apache2[13519]: Starting web server: apache2 failed!
Aug 08 17:05:02 jeedom apache2[13519]: The apache2 configtest failed. ... (warning).
Aug 08 17:05:02 jeedom apache2[13519]: Output of config test was:
Aug 08 17:05:02 jeedom apache2[13519]: AH00526: Syntax error on line 13 of /etc/apache2/sites-enabled/mon domaine OVH.ssl.conf:
Aug 08 17:05:02 jeedom apache2[13519]: SSLCertificateFile: file '/root/ssl/letsencrypt/etc/live/mon domaine OVH/cert.pem' does not exist or is empty
Aug 08 17:05:02 jeedom apache2[13519]: Action 'configtest' failed.
Aug 08 17:05:02 jeedom apache2[13519]: The Apache error log may have more information.
Aug 08 17:05:02 jeedom systemd[1]: apache2.service: control process exited, code=exited status=1
Aug 08 17:05:02 jeedom systemd[1]: Failed to start LSB: Apache2 web server.
Aug 08 17:05:02 jeedom systemd[1]: Unit apache2.service entered failed state.
j'ai essayé de lancé de w4zu mais forcément ça n'a pas corrigé le problème.
Je suis nul commandes ssh et je n'arrive pas à trouver de tuto pour récupérer ce problème de serveur apache.
qqun pourrait-il m'aider ?
Alors avant de redémarrer apache il faut TOUJOURS faire la commande suivante :
"apache2ctl configtest"
Si Syntax OK vous pouvez redémarrer. Si autre message > JAMAIS redemarrer apache

Sinon pour t'aider tu peux faire la commande : mv /etc/apache2/sites-enabled/mon domaine OVH.ssl.conf /etc/apache2/sites-enabled/mon domaine OVH.ssl.conf.disable

et ensuite redémarrer apache. Ensuite tu peux utiliser mon script =)

Répondre

Revenir vers « Utilisation »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Bercolly et 1 invité