Avant toute chose merci de (re)prendre connaissance de la charte et de la respecter.
Pour résumer :
- Avant de poser une question, je cherche si la réponse existe
- Je suis poli, courtois et je respecte tout un chacun sur le forum
- Si un post m'agace : je m'en éloigne plutôt que de répondre d'une façon qui pourrait être mal interprétée


Il n'est jamais du luxe que de rappeler des choses simples :
Courtoisie, amabilité, politesse et bonne humeur sont les maîtres mots pour un forum sympathique, bienveillant et accueillant :)

Le groupe des Helpers est present pour vous aidez, n'hésitez pas à poser des questions ;)

Toute la communauté vous remercie

/!\ L’ancien forum passera en lecture seule en janvier 2020 (Si community a bien pris le relais) puis nous le fermerons définitivement en janvier 2021./!\
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

[Résolu][Plugin Tiers][Telegram] disable_notify ne fonctionne pas

Pour échanger sur les plugins classés en catégorie "Communication"
Répondre
Avatar de l’utilisateur
Bull
Helper
Messages : 342
Inscription : 01 mars 2016, 21:06
Localisation : Spain

[Résolu][Plugin Tiers][Telegram] disable_notify ne fonctionne pas

Message par Bull » 12 janv. 2019, 22:35

Salut J'ai testé depuis longtemps avec ce problème que les messages que j'envoie avec l'option notify_disable=1 sonnent, j'ai des commandes reecho, j'ai créé de nouveaux bots... rien je ne suis incapable de m'envoyer des messages sans son à moi-même à partir de mon bot.

Voici quelques exemples de journaux de Telegram.

Code : Tout sélectionner

[2019-01-12 21:15:03][DEBUG] : Call url https://api.telegram.org/botapikey/sendMessage with option Array (     [disable_notification] => 1     [parse_mode] => HTML     [text] => test para ver si deja de sonar cada hora. piramid bot     [chat_id] => xxxxxx )
[2019-01-12 21:15:03][DEBUG] : Result : {"ok":true,"result":{"message_id":xxxx,"from":{"id":xxxx,"is_bot":true,"first_name":"bot","username":"bot"},"chat":{"id":xxxxx,"first_name":"xxxx","username":"xxxx","type":"private"},"date":1547324101,"text":"test para ver si deja de sonar cada hora. "}}
[2019-01-12 22:10:02][DEBUG] : Call url https://api.telegram.org/botapikey/sendMessage with option Array (     [disable_notification] => 1     [parse_mode] => HTML     [text] => test para ver si deja de sonar cada hora.     [chat_id] => xxxxx )
[2019-01-12 22:10:04][DEBUG] : Result : {"ok":true,"result":{"message_id":xxxxx,"from":{"id":xxxx,"is_bot":true,"first_name":"bot","username":"bot"},"chat":{"id":xxxxx,"first_name":"xxxx","username":"xxxx","type":"private"},"date":1547327402,"text":"test para ver si deja de sonar cada hora."}}
[2019-01-12 22:15:02][DEBUG] : Call url https://api.telegram.org/botapikey/sendMessage with option Array (     [disable_notification] => 1     [parse_mode] => HTML     [text] => test para ver si deja de sonar cada hora.  [chat_id] => xxxxxx )
[2019-01-12 22:15:02][DEBUG] : Result : {"ok":true,"result":{"message_id":xxx,"from":{"id":xxxxxx,"is_bot":true,"first_name":"bot","username":"bot"},"chat":{"id":xxxxxx,"first_name":"xxxx","username":"xxx","type":"private"},"date":1547327700,"text":"test para ver si deja de sonar cada hora. "}}
Mon téléphone est un Xiaomi Redmi Note 4 avec MIUI 10, j'ai essayé d'abaisser la priorité des notifications à "low" et rien, quand je fais des tests il semble fonctionner mais quand le temps passe il ne fonctionne plus.

Toute aide est la bienvenue.

Salutations
Bull
Dernière édition par Bull le 27 mai 2019, 11:48, édité 1 fois.
Helper Officiel Jeedom

Avatar de l’utilisateur
Bull
Helper
Messages : 342
Inscription : 01 mars 2016, 21:06
Localisation : Spain

Re: [Plugin Tiers][Telegram] disable_notify ne fonctionne pas

Message par Bull » 15 janv. 2019, 09:23

Personne n'utilise cette option ? Je voudrais exclure un problème avec l'application télegram androïd parce que dans le telegram desktop le "son" n'est pas reproduit.
Helper Officiel Jeedom

Mips2648
Actif
Messages : 910
Inscription : 08 sept. 2018, 17:09

Re: [Plugin Tiers][Telegram] disable_notify ne fonctionne pas

Message par Mips2648 » 31 janv. 2019, 14:45

Bull a écrit :
12 janv. 2019, 22:35
Salut J'ai testé depuis longtemps avec ce problème que les messages que j'envoie avec l'option notify_disable=1 sonnent, j'ai des commandes reecho, j'ai créé de nouveaux bots... rien je ne suis incapable de m'envoyer des messages sans son à moi-même à partir de mon bot.

Voici quelques exemples de journaux de Telegram.

Code : Tout sélectionner

[2019-01-12 21:15:03][DEBUG] : Call url https://api.telegram.org/botapikey/sendMessage with option Array (     [disable_notification] => 1     [parse_mode] => HTML     [text] => test para ver si deja de sonar cada hora. piramid bot     [chat_id] => xxxxxx )
[2019-01-12 21:15:03][DEBUG] : Result : {"ok":true,"result":{"message_id":xxxx,"from":{"id":xxxx,"is_bot":true,"first_name":"bot","username":"bot"},"chat":{"id":xxxxx,"first_name":"xxxx","username":"xxxx","type":"private"},"date":1547324101,"text":"test para ver si deja de sonar cada hora. "}}
[2019-01-12 22:10:02][DEBUG] : Call url https://api.telegram.org/botapikey/sendMessage with option Array (     [disable_notification] => 1     [parse_mode] => HTML     [text] => test para ver si deja de sonar cada hora.     [chat_id] => xxxxx )
[2019-01-12 22:10:04][DEBUG] : Result : {"ok":true,"result":{"message_id":xxxxx,"from":{"id":xxxx,"is_bot":true,"first_name":"bot","username":"bot"},"chat":{"id":xxxxx,"first_name":"xxxx","username":"xxxx","type":"private"},"date":1547327402,"text":"test para ver si deja de sonar cada hora."}}
[2019-01-12 22:15:02][DEBUG] : Call url https://api.telegram.org/botapikey/sendMessage with option Array (     [disable_notification] => 1     [parse_mode] => HTML     [text] => test para ver si deja de sonar cada hora.  [chat_id] => xxxxxx )
[2019-01-12 22:15:02][DEBUG] : Result : {"ok":true,"result":{"message_id":xxx,"from":{"id":xxxxxx,"is_bot":true,"first_name":"bot","username":"bot"},"chat":{"id":xxxxxx,"first_name":"xxxx","username":"xxx","type":"private"},"date":1547327700,"text":"test para ver si deja de sonar cada hora. "}}
Mon téléphone est un Xiaomi Redmi Note 4 avec MIUI 10, j'ai essayé d'abaisser la priorité des notifications à "low" et rien, quand je fais des tests il semble fonctionner mais quand le temps passe il ne fonctionne plus.

Toute aide est la bienvenue.

Salutations
Bull

L'option est 'disable_notify=1' et pas 'notify_disable=1', je suppose que ton problème est là ;-)
Développeur et auteur des plugins suivants, (entre autre Arlo, Solaredge, Design Image, Gotify...) et aidant sur plein d'autres!

Si vous voulez contribuer, un don fait toujours plaisir : https://paypal.me/mips2648

Avatar de l’utilisateur
Bull
Helper
Messages : 342
Inscription : 01 mars 2016, 21:06
Localisation : Spain

Re: [Plugin Tiers][Telegram] disable_notify ne fonctionne pas

Message par Bull » 31 janv. 2019, 15:00

Vous avez raison, ça a dû être en le traduisant (je ne suis pas francophone). Le problème ne sait pas vraiment ce que ça pourrait être. Si de l'application d'android, si de l'api.... J'ai fait beaucoup de tests et j'en suis arrivé aux conclusions suivantes (au moins avec mon téléphone Xiaomi avec MUIU 10) :
1 - La notification retentit toujours après 5 minutes après l'envoi du dernier message ( approximativement).
2 - Le second message et les messages successifs fonctionnent bien (ils ne sonnent pas) mais le temps passe et nous revenons au point 1.
Dans le Telegram Desktop, la notification avec disable_notify fonctionne correctement 100% du temps (elle ne sonne pas).
4.- avec disable_notify=0 le téléphone ne vibre pas, il émet aussi le son.

Je deviens folle.

merci
Bull
Mips2648 a écrit :
31 janv. 2019, 14:45
Bull a écrit :
12 janv. 2019, 22:35
Salut J'ai testé depuis longtemps avec ce problème que les messages que j'envoie avec l'option notify_disable=1 sonnent, j'ai des commandes reecho, j'ai créé de nouveaux bots... rien je ne suis incapable de m'envoyer des messages sans son à moi-même à partir de mon bot.

Voici quelques exemples de journaux de Telegram.

Code : Tout sélectionner

[2019-01-12 21:15:03][DEBUG] : Call url https://api.telegram.org/botapikey/sendMessage with option Array (     [disable_notification] => 1     [parse_mode] => HTML     [text] => test para ver si deja de sonar cada hora. piramid bot     [chat_id] => xxxxxx )
[2019-01-12 21:15:03][DEBUG] : Result : {"ok":true,"result":{"message_id":xxxx,"from":{"id":xxxx,"is_bot":true,"first_name":"bot","username":"bot"},"chat":{"id":xxxxx,"first_name":"xxxx","username":"xxxx","type":"private"},"date":1547324101,"text":"test para ver si deja de sonar cada hora. "}}
[2019-01-12 22:10:02][DEBUG] : Call url https://api.telegram.org/botapikey/sendMessage with option Array (     [disable_notification] => 1     [parse_mode] => HTML     [text] => test para ver si deja de sonar cada hora.     [chat_id] => xxxxx )
[2019-01-12 22:10:04][DEBUG] : Result : {"ok":true,"result":{"message_id":xxxxx,"from":{"id":xxxx,"is_bot":true,"first_name":"bot","username":"bot"},"chat":{"id":xxxxx,"first_name":"xxxx","username":"xxxx","type":"private"},"date":1547327402,"text":"test para ver si deja de sonar cada hora."}}
[2019-01-12 22:15:02][DEBUG] : Call url https://api.telegram.org/botapikey/sendMessage with option Array (     [disable_notification] => 1     [parse_mode] => HTML     [text] => test para ver si deja de sonar cada hora.  [chat_id] => xxxxxx )
[2019-01-12 22:15:02][DEBUG] : Result : {"ok":true,"result":{"message_id":xxx,"from":{"id":xxxxxx,"is_bot":true,"first_name":"bot","username":"bot"},"chat":{"id":xxxxxx,"first_name":"xxxx","username":"xxx","type":"private"},"date":1547327700,"text":"test para ver si deja de sonar cada hora. "}}
Mon téléphone est un Xiaomi Redmi Note 4 avec MIUI 10, j'ai essayé d'abaisser la priorité des notifications à "low" et rien, quand je fais des tests il semble fonctionner mais quand le temps passe il ne fonctionne plus.

Toute aide est la bienvenue.

Salutations
Bull

L'option est 'disable_notify=1' et pas 'notify_disable=1', je suppose que ton problème est là ;-)
Helper Officiel Jeedom

Swr
Actif
Messages : 688
Inscription : 08 nov. 2016, 20:56
Localisation : 44

Re: [Plugin Tiers][Telegram] disable_notify ne fonctionne pas

Message par Swr » 31 janv. 2019, 15:12

J'ai mis en option "empty=1"

Sent from my Redmi Note 4 using Tapatalk


Avatar de l’utilisateur
Bull
Helper
Messages : 342
Inscription : 01 mars 2016, 21:06
Localisation : Spain

Re: [Plugin Tiers][Telegram] disable_notify ne fonctionne pas

Message par Bull » 31 janv. 2019, 15:38

"disable_notify=1 empty=1" o "empty=1", J'ai essayé et j'entends toujours le son :-( Je suis sur le point de faire un hardreset du mobile, mais je suis très paresseux :-(
Swr a écrit :
31 janv. 2019, 15:12
J'ai mis en option "empty=1"

Sent from my Redmi Note 4 using Tapatalk
Helper Officiel Jeedom

Mips2648
Actif
Messages : 910
Inscription : 08 sept. 2018, 17:09

Re: [Plugin Tiers][Telegram] disable_notify ne fonctionne pas

Message par Mips2648 » 31 janv. 2019, 17:22

"empty=1" c'est pour retirer les "boutons" de réponses qui seraient éventuellement affichés (suite à un "ask" précédent)

Et tu confirmes que cela fonctionne pour toi sous telegram desktop. Donc le problème vient du telephone ou de la version de telegram installée sur celui-ci.
Développeur et auteur des plugins suivants, (entre autre Arlo, Solaredge, Design Image, Gotify...) et aidant sur plein d'autres!

Si vous voulez contribuer, un don fait toujours plaisir : https://paypal.me/mips2648

Swr
Actif
Messages : 688
Inscription : 08 nov. 2016, 20:56
Localisation : 44

Re: [Plugin Tiers][Telegram] disable_notify ne fonctionne pas

Message par Swr » 31 janv. 2019, 18:08

Bull a écrit :
31 janv. 2019, 15:00
Vous avez raison, ça a dû être en le traduisant (je ne suis pas francophone). Le problème ne sait pas vraiment ce que ça pourrait être. Si de l'application d'android, si de l'api.... J'ai fait beaucoup de tests et j'en suis arrivé aux conclusions suivantes (au moins avec mon téléphone Xiaomi avec MUIU 10) :
1 - La notification retentit toujours après 5 minutes après l'envoi du dernier message ( approximativement).
2 - Le second message et les messages successifs fonctionnent bien (ils ne sonnent pas) mais le temps passe et nous revenons au point 1.
Dans le Telegram Desktop, la notification avec disable_notify fonctionne correctement 100% du temps (elle ne sonne pas).
4.- avec disable_notify=0 le téléphone ne vibre pas, il émet aussi le son.

Je deviens folle.

merci
Bull
Mips2648 a écrit :
31 janv. 2019, 14:45
Bull a écrit :
12 janv. 2019, 22:35
Salut J'ai testé depuis longtemps avec ce problème que les messages que j'envoie avec l'option notify_disable=1 sonnent, j'ai des commandes reecho, j'ai créé de nouveaux bots... rien je ne suis incapable de m'envoyer des messages sans son à moi-même à partir de mon bot.

Voici quelques exemples de journaux de Telegram.

Code : Tout sélectionner

[2019-01-12 21:15:03][DEBUG] : Call url https://api.telegram.org/botapikey/sendMessage with option Array (     [disable_notification] => 1     [parse_mode] => HTML     [text] => test para ver si deja de sonar cada hora. piramid bot     [chat_id] => xxxxxx )
[2019-01-12 21:15:03][DEBUG] : Result : {"ok":true,"result":{"message_id":xxxx,"from":{"id":xxxx,"is_bot":true,"first_name":"bot","username":"bot"},"chat":{"id":xxxxx,"first_name":"xxxx","username":"xxxx","type":"private"},"date":1547324101,"text":"test para ver si deja de sonar cada hora. "}}
[2019-01-12 22:10:02][DEBUG] : Call url https://api.telegram.org/botapikey/sendMessage with option Array (     [disable_notification] => 1     [parse_mode] => HTML     [text] => test para ver si deja de sonar cada hora.     [chat_id] => xxxxx )
[2019-01-12 22:10:04][DEBUG] : Result : {"ok":true,"result":{"message_id":xxxxx,"from":{"id":xxxx,"is_bot":true,"first_name":"bot","username":"bot"},"chat":{"id":xxxxx,"first_name":"xxxx","username":"xxxx","type":"private"},"date":1547327402,"text":"test para ver si deja de sonar cada hora."}}
[2019-01-12 22:15:02][DEBUG] : Call url https://api.telegram.org/botapikey/sendMessage with option Array (     [disable_notification] => 1     [parse_mode] => HTML     [text] => test para ver si deja de sonar cada hora.  [chat_id] => xxxxxx )
[2019-01-12 22:15:02][DEBUG] : Result : {"ok":true,"result":{"message_id":xxx,"from":{"id":xxxxxx,"is_bot":true,"first_name":"bot","username":"bot"},"chat":{"id":xxxxxx,"first_name":"xxxx","username":"xxx","type":"private"},"date":1547327700,"text":"test para ver si deja de sonar cada hora. "}}
Mon téléphone est un Xiaomi Redmi Note 4 avec MIUI 10, j'ai essayé d'abaisser la priorité des notifications à "low" et rien, quand je fais des tests il semble fonctionner mais quand le temps passe il ne fonctionne plus.

Toute aide est la bienvenue.

Salutations
Bull

L'option est 'disable_notify=1' et pas 'notify_disable=1', je suppose que ton problème est là ;-)
Je pense avoir un symptôme similaire sur Xiaomi MUIU10, je n'avais pas essayé de supprimer les alertes avec notify_disable=1, ayant dit cela j'ai en permanence plusieurs rappels des notifications, j'ai essayé de modifier les options de Telegram sans succés. Je ne sais pas si cela t'aide.

Avatar de l’utilisateur
Bull
Helper
Messages : 342
Inscription : 01 mars 2016, 21:06
Localisation : Spain

Re: [Plugin Tiers][Telegram] disable_notify ne fonctionne pas

Message par Bull » 31 janv. 2019, 19:42

Eh bien, je pense que j'ai trouvé la solution dans l'espoir de faire d'autres tests.

S'il sert quelqu'un à l'avenir, le problème de son était généré par le Apex Launcher et le Apex Notify. J'ai supprimé les deux du système et maintenant il semble que s'il répond aux demandes de disable_notify=1

Un grand merci à tous pour vos contributions, parfois le moyen le plus rapide de résoudre un problème est de parler aux autres ;-)

Bull
Helper Officiel Jeedom

Jef73
Timide
Messages : 362
Inscription : 27 déc. 2017, 10:41
Localisation : Nantes

Re: [Plugin Tiers][Telegram] disable_notify ne fonctionne pas

Message par Jef73 » 03 mai 2019, 17:54

Hello,

Je n'ai aucun logiciel "Apex" quelconque, mais j'ai le même problème : malgré l'option « disable_notify=1 », Telegram vibre et sonne :(
Et si j'installe l'application Chrome sur mon PC, là aussi j'ai la notification qui s'active et réveille le quartier, donc ça ne provient pas du smartphone.

Il y a quelqu'un pour qui ça fonctionne ce mode silencieux ?

Avatar de l’utilisateur
Bull
Helper
Messages : 342
Inscription : 01 mars 2016, 21:06
Localisation : Spain

Re: [Plugin Tiers][Telegram] disable_notify ne fonctionne pas

Message par Bull » 04 mai 2019, 10:50

Eh bien, je n'ai pas tout arrangé pour moi, ça marche pendant environ 48 heures, après ça, je sélectionne un autre son de notification et apparemment il arrête de sonner à nouveau et ainsi de suite environ toutes les 48 heures.... Je pense que c'est peut-être un problème dans mon cas de la distribution de Xiaomi.

J'enquête toujours sur le problème

Bull
Jef73 a écrit :
03 mai 2019, 17:54
Hello,

Je n'ai aucun logiciel "Apex" quelconque, mais j'ai le même problème : malgré l'option « disable_notify=1 », Telegram vibre et sonne :(
Et si j'installe l'application Chrome sur mon PC, là aussi j'ai la notification qui s'active et réveille le quartier, donc ça ne provient pas du smartphone.

Il y a quelqu'un pour qui ça fonctionne ce mode silencieux ?
Helper Officiel Jeedom

Avatar de l’utilisateur
Bull
Helper
Messages : 342
Inscription : 01 mars 2016, 21:06
Localisation : Spain

Re: [Plugin Tiers][Telegram] disable_notify ne fonctionne pas

Message par Bull » 27 mai 2019, 11:47

Eh bien, je pense que j'ai trouvé la cause du problème, en faisant des tests par erreur, j'ai involontairement supprimé le plugin, donc j'ai dû le réinstaller et après avoir refait tous mes scénarios je peux dire que le disable_notify fonctionne sans problème depuis presque un mois. Je comprends donc que le problème peut venir pour ceux d'entre nous qui avaient ce plugin installé avant l'implémentation de ces options.

Bull
Helper Officiel Jeedom

Répondre

Revenir vers « [Catégorie] Communication »

Qui est en ligne ?

Utilisateurs parcourant ce forum : blueterry, scn60 et 2 invités