Ce Forum passera en lecture seule en janvier 2020
Image
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

[Plugin Tiers][Sujet Principal] Rflink : passerelle RF433 multi-protocoles

Pour échanger sur les plugins classés en catégorie "Protocoles domotiques"
Trax
Timide
Messages : 5
Inscription : 04 mars 2019, 12:25

Re: [Plugin Tiers][Sujet Principal] Rflink : passerelle RF433 multi-protocoles

Message par Trax » 25 avr. 2019, 22:36

Oui ce port apparait uniquement quand le cable usb est branché et le port mappé dans la configuration de la VM.

antar
Timide
Messages : 52
Inscription : 20 avr. 2019, 11:18

Re: [Plugin Tiers][Sujet Principal] Rflink : passerelle RF433 multi-protocoles

Message par antar » 26 avr. 2019, 19:54

Bonjour,

Ceci est mon premier post (plutôt question), j'espère ne pas me tromper d'endroit ni de méthode !

Je suis nouveau sur jeedom et quelque chose m'échappe :?: : je dois renouveler parfois une consigne à un équipement (Volet sur Chacon DIO) pour que l'ordre soit appliqué : exemple ce matin : mon scénario n'a pas ouvert mon volet de cuisine, et le premier clic sur bouton ouvrir non plus, mais le second lui oui... Je ne sais pas ou regarder dans les logs ce qui "coince" a part dans analyse/logs ou je vois bien les 2 consignes manuelles envoyées :

[2019-04-20 09:45:36][INFO] : Exécution de la commande [Rez de chaussée][Telec. volets derrière][Ouvrir volet cuisine] avec les paramètres {"utid":"1555745821937"}
[2019-04-20 09:45:50][INFO] : Exécution de la commande [Rez de chaussée][Telec. volets derrière][Ouvrir volet cuisine] avec les paramètres {"utid":"1555745821937"}

Pour info les consignes sont la copie des actions sur les télécommandes (je n'ai pas associé les modules directement à mon install, mais uniquement les telecommandes)

Merci de vos éclairages le forum !

PS : je suis sans doute un boulet mais je reitere ce message puisque n'ayant pas obtenu de reponse precedemment et ne sachant pas comment le up...

merci d'avance
Rpi3 sous Raspbian
RFLink (Arduino mega 2560 clone - Montage breadboard - Recepteur superheterodyne RX B6 / Emetteur XK FST)
ESP Easy (Sonoff basic modifié en relai contact sec, Wemos D1 Mini)
Shelly 2.5
Cozytouch Thermor
Connexoon Somfy

rol-rider
Actif
Messages : 5086
Inscription : 10 août 2014, 23:50

Re: [Plugin Tiers][Sujet Principal] Rflink : passerelle RF433 multi-protocoles

Message par rol-rider » 26 avr. 2019, 20:34

C'est peut-être juste un problème de portée, tu as quoi comme antenne ? Si c'est l'antenne proposée sur le site nodo....elle n'est pas terrible.

Envoyé de mon Redmi Note 6 Pro en utilisant Tapatalk

RPI3 avec mSATA
RFXcom; RFLink; Z-Wave; Mysensors; ESPEasy
Noeuds MySensors-téléinfo-Température-Distance-Baromètre-relais
Noeuds ESPEasy-open-garage-relais-PIR-Station Météo

antar
Timide
Messages : 52
Inscription : 20 avr. 2019, 11:18

Re: [Plugin Tiers][Sujet Principal] Rflink : passerelle RF433 multi-protocoles

Message par antar » 26 avr. 2019, 21:06

Merci de ta réponse, non ce n'est pas un problème de portée je pense, j'ai parfois ce phénomène avec un volet qui est à maxi 6m du rflink, et le module de la cuisine qui est le plus loin (facilement plus de 10m) reçoit a chaque fois l'ordre.

De plus sur mon ancienne install Domoticz je n'avais pas de problème...
Mon module emetteur est celui de ce kit : https://www.amazon.fr/gp/product/B00G23 ... UTF8&psc=1

Le module est un XKFST.

A force de tourner en rond je commencais à pencher pour une défaillance de celui ci, et je pensais trouver des explications dans les logs, sans succes
Rpi3 sous Raspbian
RFLink (Arduino mega 2560 clone - Montage breadboard - Recepteur superheterodyne RX B6 / Emetteur XK FST)
ESP Easy (Sonoff basic modifié en relai contact sec, Wemos D1 Mini)
Shelly 2.5
Cozytouch Thermor
Connexoon Somfy

antar
Timide
Messages : 52
Inscription : 20 avr. 2019, 11:18

Re: [Plugin Tiers][Sujet Principal] Rflink : passerelle RF433 multi-protocoles

Message par antar » 27 avr. 2019, 10:30

Ce que je pensais sur la portée s'est conforté ce matin, un volet a 2m du rflink ne s'est pas ouvert, et un autre a 10m lui oui...

Encore une fois dans les logs (en mode info ... je ne sais pas si c'est le mode le plus élévé de logs) aucune erreur : tous les éléments ont la coche verte.

Une âme charitable pour m'aider a résoudre cette enquête ? :?: :geek:
Rpi3 sous Raspbian
RFLink (Arduino mega 2560 clone - Montage breadboard - Recepteur superheterodyne RX B6 / Emetteur XK FST)
ESP Easy (Sonoff basic modifié en relai contact sec, Wemos D1 Mini)
Shelly 2.5
Cozytouch Thermor
Connexoon Somfy

rol-rider
Actif
Messages : 5086
Inscription : 10 août 2014, 23:50

Re: [Plugin Tiers][Sujet Principal] Rflink : passerelle RF433 multi-protocoles

Message par rol-rider » 27 avr. 2019, 11:23

ba ça va pas être facile ! charitable ou pas !
--tu gères l'envoie par scénario ? je suppose ? c'est aléatoire ou toujours le même qui cloche ? tu as essayer de mettre une tempo entre chaque envoie ....pour voir ?
--comment est ton montage ? (vu l'émetteur que tu utilises) ce n'est pas le PCB de chez nodo ? tout est soudé ou sur breadboard ?
je te conseille de faire des soudures propres pour garantir un bon fonctionnement dans le temps.
--comment est l'alimentation de ton rflink ? as tu un condensateur sur l'alim ? il se peut que l'émetteur de dispose de plus assez de courant pour plusieurs commandes successives, le condo genre 220µF (ou plus) permet de stoker un peu de courant.
--si tu n'as pas d'erreur sur l'envoie de la commande....c'est quel est envoyée le problème est ailleurs. test le mode debug pour les logs.
RPI3 avec mSATA
RFXcom; RFLink; Z-Wave; Mysensors; ESPEasy
Noeuds MySensors-téléinfo-Température-Distance-Baromètre-relais
Noeuds ESPEasy-open-garage-relais-PIR-Station Météo

antar
Timide
Messages : 52
Inscription : 20 avr. 2019, 11:18

Re: [Plugin Tiers][Sujet Principal] Rflink : passerelle RF433 multi-protocoles

Message par antar » 27 avr. 2019, 11:59

- les commandes sont envoyées via scénario exact, mais j'ai déjà constaté des ordres également non appliqués au premier envoi lors de commandes envoyées manuellement et individuellement.
- je viens d'appliquer une tempo "wait" sans condition de 15 secondes entre chaque commande pour la fermeture de mes volets, verdict ce soir ! meme si la remarque ci dessus me laisse hélas peu confiant sur le resultat :cry:
- mon montage est, encore une fois tu as deviné, sans pcb et est sur un breadboard
- l'alim de mon rflink... euh... :?: ...arduino en usb sur rpi3, sans condensateur, je savais pas que ca pouvait etre utile, et a vrai dire je savais meme pas que c'etait utilisé sur certains montages
- je vais passer en mode debug mes logs et surveiller ca

juste pour rappel : via domoticz et avec le meme montage rflink je n'avais pas ce problème

merci de ces pistes a flairer ! ;)
Rpi3 sous Raspbian
RFLink (Arduino mega 2560 clone - Montage breadboard - Recepteur superheterodyne RX B6 / Emetteur XK FST)
ESP Easy (Sonoff basic modifié en relai contact sec, Wemos D1 Mini)
Shelly 2.5
Cozytouch Thermor
Connexoon Somfy

Trax
Timide
Messages : 5
Inscription : 04 mars 2019, 12:25

Re: [Plugin Tiers][Sujet Principal] Rflink : passerelle RF433 multi-protocoles

Message par Trax » 28 avr. 2019, 22:04

Petit up, j'ai installé un jeedom sur une machine physique, importé la sauvegarde, installé les dépendances et ca a fonctionné du premier coup. J'ai alors refais une fresh install esxi, debain et jeedom mais toujours pareil. Quelqun utilise esxi avec un rflink, y a il une manip particulière a faire ? Demain je vais tenter ma chance sous proxmox.

team18fr
Actif
Messages : 1119
Inscription : 11 oct. 2014, 18:41

Re: [Plugin Tiers][Sujet Principal] Rflink : passerelle RF433 multi-protocoles

Message par team18fr » 29 avr. 2019, 19:51

Bonjour depuis le version R48 ( octobre 2017 ) il n'y a pas eu d'autre mise à jour pensez-vous qu'il y en aura d'autre ?

antar
Timide
Messages : 52
Inscription : 20 avr. 2019, 11:18

Re: [Plugin Tiers][Sujet Principal] Rflink : passerelle RF433 multi-protocoles

Message par antar » 29 avr. 2019, 21:25

@ rol-rider (et âmes charitables ;) )

le wait a son effet et mes volets reçoivent bien les commandes une a une pour la fermeture, mais bizarrement (je n'y comprends rien !) l'ouverture le matin pose parfois problème sur le 1er volet (second le plus proche du rflink) de mon scénario à ouvrir : il reste désespérément fermé...

j'ai commandé un autre émetteur 433 pour mon montage RFLink pour tester car aucune erreur dans les logs même en debug, je commence a soupçonner des caprices du bouzin et pour 2€ je me suis laissé tenter...

si t'as un idée du phénomène que je rencontre je suis preneur :idea:

merci
Rpi3 sous Raspbian
RFLink (Arduino mega 2560 clone - Montage breadboard - Recepteur superheterodyne RX B6 / Emetteur XK FST)
ESP Easy (Sonoff basic modifié en relai contact sec, Wemos D1 Mini)
Shelly 2.5
Cozytouch Thermor
Connexoon Somfy

rol-rider
Actif
Messages : 5086
Inscription : 10 août 2014, 23:50

Re: [Plugin Tiers][Sujet Principal] Rflink : passerelle RF433 multi-protocoles

Message par rol-rider » 29 avr. 2019, 23:00

Moi, je commencerais par mettre un condensateur au borne (+/-) de l'émetteur.
Je crois ( de mémoire) qu'il est recommandé d'utiliser un 10micro, mais tu peux mettre plus, ça risque rien.

Envoyé de mon Redmi Note 6 Pro en utilisant Tapatalk

RPI3 avec mSATA
RFXcom; RFLink; Z-Wave; Mysensors; ESPEasy
Noeuds MySensors-téléinfo-Température-Distance-Baromètre-relais
Noeuds ESPEasy-open-garage-relais-PIR-Station Météo

Avatar de l’utilisateur
Lecl0ne
Timide
Messages : 184
Inscription : 11 août 2018, 16:57

Re: [Plugin Tiers][Sujet Principal] Rflink : passerelle RF433 multi-protocoles

Message par Lecl0ne » 30 avr. 2019, 15:48

Bonjour les amis,

J'ai monté mon petit arduino Mega 2560 avec RFlink et le CC2500 qui va bien pour piloter mon Ikea Ansluta.
Je sais pas si je peux dire que tout est bien réalisé, mais j'arrive depuis jeedom à sniffer mon appui de bouton !! Seulement quand je fais tester la commande, ça ne fait rien. J'ai passé de nombreuses heures à tout ça, j'espère que vous allez pouvoir m'aider..

rol-rider
Actif
Messages : 5086
Inscription : 10 août 2014, 23:50

Re: [Plugin Tiers][Sujet Principal] Rflink : passerelle RF433 multi-protocoles

Message par rol-rider » 30 avr. 2019, 18:39

comment as tu créé ton équipement ?
tu as reçu quoi comme code ?
RPI3 avec mSATA
RFXcom; RFLink; Z-Wave; Mysensors; ESPEasy
Noeuds MySensors-téléinfo-Température-Distance-Baromètre-relais
Noeuds ESPEasy-open-garage-relais-PIR-Station Météo

Avatar de l’utilisateur
Lecl0ne
Timide
Messages : 184
Inscription : 11 août 2018, 16:57

Re: [Plugin Tiers][Sujet Principal] Rflink : passerelle RF433 multi-protocoles

Message par Lecl0ne » 30 avr. 2019, 23:38

Mon équipement est arrivé tout seul en mode inclusion, il comporte 4 commandes dont 2 info et 2 actions.

barzick
Timide
Messages : 13
Inscription : 28 avr. 2019, 22:35

Re: [Plugin Tiers][Sujet Principal] Rflink : passerelle RF433 multi-protocoles

Message par barzick » 01 mai 2019, 13:47

Bonjour tous le monde,

je suis nouveau ici. Je viens de m'équiper de la Freebox Delta, Raspberry PI3, Arduino mega+ émetteur récepteur 433mhz et je suis en attente d'un clé Zigate.
L'installation de jeedom c'est bien passe, les different plugin comme Freebox_OS c'est passe grace à un membre du Forum.
Mais la je viens d'acheter le plugin RFLINK et ça marche pas. Sur PC tous se passe bien, je réception et envoye le signal sans probleme.
Dans le log de rflink à priori la connection se fait bien, mais aucune ecoute de signal.

Voici le log.


Wed May 01 2019 00:53:43 GMT+0200 (CEST) - Jeedom url : http://127.0.0.1:80/plugins/rflink/core ... xxxxxxxxxx, gwAddress : /dev/ttyACM0
Wed May 01 2019 00:53:43 GMT+0200 (CEST) - server bound on 8020
Port open
Wed May 01 2019 00:53:44 GMT+0200 (CEST) - 20;00;Nodo RadioFrequencyLink - RFLink Gateway V1.1 - R48;
Wed May 01 2019 00:53:44 GMT+0200 (CEST) - Send Value : 20;00;Nodo RadioFrequencyLink - RFLink Gateway V1.1 - R48;
Wed May 01 2019 00:53:44 GMT+0200 (CEST) - Got response Value : 200
Wed May 01 2019 00:53:45 GMT+0200 (CEST) - Server connected
Wed May 01 2019 00:53:45 GMT+0200 (CEST) - 20;01;STATUS;setRF433=ON;setNodoNRF=OFF;setMilight=OFF;setLivingColors=OFF;setAnsluta=OFF;setGPIO=OFF;setBLE=OFF;setMysensors=OFF;
Wed May 01 2019 00:53:45 GMT+0200 (CEST) - Send Value : 20;01;STATUS;setRF433=ON;setNodoNRF=OFF;setMilight=OFF;setLivingColors=OFF;setAnsluta=OFF;setGPIO=OFF;setBLE=OFF;setMysensors=OFF;
Wed May 01 2019 00:53:45 GMT+0200 (CEST) - Got response Value : 200

Une Idee?

J'ai mis le firmware directement depuis le plugin, j'ai rajouté avrdude.

malheureusement je ne suis pas un pro.

D'avance merci à tous le mondes

mjeanne
Actif
Messages : 624
Inscription : 11 mars 2017, 18:36

Re: [Plugin Tiers][Sujet Principal] Rflink : passerelle RF433 multi-protocoles

Message par mjeanne » 01 mai 2019, 17:43

Bonjour, votre log semble indiquer que le rflink communique bien avec Jeedom. Donc dans ce cas, la seule différence que je suppose par rapport à vos tests sur PC, c'est la puissance électrique des ports USB. Avez-vous une bonne alim sur votre PI ?

barzick
Timide
Messages : 13
Inscription : 28 avr. 2019, 22:35

Re: [Plugin Tiers][Sujet Principal] Rflink : passerelle RF433 multi-protocoles

Message par barzick » 01 mai 2019, 17:50

je l'ai mis sur un adaptateur 3A. Mais sur le plugin il indique aucun rflink détecté.

barzick
Timide
Messages : 13
Inscription : 28 avr. 2019, 22:35

Re: [Plugin Tiers][Sujet Principal] Rflink : passerelle RF433 multi-protocoles

Message par barzick » 01 mai 2019, 18:49

Bonjour tous le monde, j'ai réinstallé raspbian et jeedom. J'ai remis quelque paquets qui manquait et changé l'alimentation car mjeanne m'a mis le doute et a priori c'est du 3A chinois, apres avoir changé l'alimentation j'ai enfin un signal.

Donc grand merci à mjeanne.

Avatar de l’utilisateur
Lecl0ne
Timide
Messages : 184
Inscription : 11 août 2018, 16:57

Re: [Plugin Tiers][Sujet Principal] Rflink : passerelle RF433 multi-protocoles

Message par Lecl0ne » 02 mai 2019, 12:10

Puisque vous parlez d'alimentation, moi je reçois bien les signaux, par inclusion, de mon Ikea Ansluta.
Mais quand je fais tester, ça ne fait rien.
J'ai mon Raspberry qui est alimenté en 5v, 2.5A et mon Arduino (connecté en USB à mon Raspberry) qui est alimenté en 9V 1A.
Est-ce que le fait que je n'arrive pas a émettre mon signal pourrait être un soucis d'alimentation? Est-ce possible de pouvoir recevoir mais pas d'émettre?

mjeanne
Actif
Messages : 624
Inscription : 11 mars 2017, 18:36

Re: [Plugin Tiers][Sujet Principal] Rflink : passerelle RF433 multi-protocoles

Message par mjeanne » 02 mai 2019, 13:02

Bonjour, je ne suis pas certain que mixer 2 alim, dont une en 9V, ne soit pas sans risque pour le PI. Si jamais il y a un retour par le cable USB, il risque de ne pas aimer.
D'autre part, en ayant 2 alimentations, vous avez aussi 2 "masses" pas forcement communes. Chez moi j'ai juste une alim 3A/5V sur le PI et c'est lui qui alimente le rflink.
Enfin, il est possible que l'envoi ne fonctionne pas même si la réception est OK, car ce sont 2 circuits différents sur le module Aurel (c'est du semi-duplex). Vérifiez que vous l'avez bien relié, en particulier son alimentation (broche 10)
Dernier point, renvoyer un signal de télécommande ne fonctionne pas toujours, en particulier si c'est du code tournant. Vérifiez que votre télécommande envoi toujours le même signal pour la même fonction.

Répondre

Revenir vers « [Catégorie] Protocoles domotiques »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 6 invités