Avant toute chose merci de (re)prendre connaissance de la charte et de la respecter.
Pour résumer :
- Avant de poser une question, je cherche si la réponse existe
- Je suis poli, courtois et je respecte tout un chacun sur le forum
- Si un post m'agace : je m'en éloigne plutôt que de répondre d'une façon qui pourrait être mal interprétée


Il n'est jamais du luxe que de rappeler des choses simples :
Courtoisie, amabilité, politesse et bonne humeur sont les maîtres mots pour un forum sympathique, bienveillant et accueillant :)

Le groupe des Helpers est present pour vous aidez, n'hésitez pas à poser des questions ;)

Toute la communauté vous remercie

/!\ L’ancien forum passera en lecture seule en janvier 2020 (Si community a bien pris le relais) puis nous le fermerons définitivement en janvier 2021./!\
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

Ouverture de porte reste bloqué en ouvert

Retrouvez ici des sujets concernant le protocole Z-Wave et les modules domotiques de type Z-Wave utilisés avec JEEDOM
Répondre
OUARZA
Timide
Messages : 289
Inscription : 13 févr. 2019, 08:10

Ouverture de porte reste bloqué en ouvert

Message par OUARZA » 28 juin 2019, 11:02

Bonjour,
Je rencontre un problème avec mes capteurs FGK-101 et FGDW-002.
Si ils restent longtemps ouvert (toute une nuit par exemple), lors de la fermeture, ils ne se mettent pas à jour dans Jeedom.
Pourtant j'ai bien l'impression que la communication se fasse correctement.
Le voyant bleu du capteur s'allume lors de l'ouverture et de la fermeture.
Même après un redémarrage de Jeedom, le problème persiste.

Dans les logs, j'ai ceci, est-ce lié à cela ?

Code : Tout sélectionner

[2019-06-28 06:48:05][ERROR] : Error on send request to jeedom ('Connection aborted.', error(104, 'Connection reset by peer')) retry : 0/3
[2019-06-28 06:48:05][ERROR] : Error on send request to jeedom HTTPConnectionPool(host='127.0.0.1', port=80): Max retries exceeded with url: /plugins/openzwave/core/php/jeeZwave.php?apikey=9THhOui6ywJQdZXXXXXXXXXXXXXXXXXXXX (Caused by NewConnectionError('<requests.packages.urllib3.connection.HTTPConnection object at 0x72b1e9b0>: Failed to establish a new connection: [Errno 111] Connection refused',)) retry : 1/3
[2019-06-28 06:48:05][ERROR] : Error on send request to jeedom HTTPConnectionPool(host='127.0.0.1', port=80): Max retries exceeded with url: /plugins/openzwave/core/php/jeeZwave.php?apikey=9THhOui6ywJQdZXXXXXXXXXXXXXXXXXXXX (Caused by NewConnectionError('<requests.packages.urllib3.connection.HTTPConnection object at 0x72b1e9f0>: Failed to establish a new connection: [Errno 111] Connection refused',)) retry : 2/3
[2019-06-28 06:48:05][ERROR] : Critical error on  send_changes_async local variable 'r' referenced before assignment
[2019-06-28 06:48:05][ERROR] : Error on send request to jeedom HTTPConnectionPool(host='127.0.0.1', port=80): Max retries exceeded with url: /plugins/openzwave/core/php/jeeZwave.php?apikey=9THhOui6ywJQdZXXXXXXXXXXXXXXXXXXXX (Caused by NewConnectionError('<requests.packages.urllib3.connection.HTTPConnection object at 0x72b2d310>: Failed to establish a new connection: [Errno 111] Connection refused',)) retry : 0/3
[2019-06-28 06:48:05][ERROR] : Error on send request to jeedom HTTPConnectionPool(host='127.0.0.1', port=80): Max retries exceeded with url: /plugins/openzwave/core/php/jeeZwave.php?apikey=9THhOui6ywJQdZXXXXXXXXXXXXXXXXXXXX (Caused by NewConnectionError('<requests.packages.urllib3.connection.HTTPConnection object at 0x72b1e430>: Failed to establish a new connection: [Errno 111] Connection refused',)) retry : 1/3
[2019-06-28 06:48:05][ERROR] : Error on send request to jeedom HTTPConnectionPool(host='127.0.0.1', port=80): Max retries exceeded with url: /plugins/openzwave/core/php/jeeZwave.php?apikey=9THhOui6ywJQdZXXXXXXXXXXXXXXXXXXXX (Caused by NewConnectionError('<requests.packages.urllib3.connection.HTTPConnection object at 0x72b1ebd0>: Failed to establish a new connection: [Errno 111] Connection refused',)) retry : 2/3
[2019-06-28 06:48:05][ERROR] : Critical error on  send_changes_async local variable 'r' referenced before assignment
Avez-vous le même problème ?
Comment régler cela ?

Merci
Mathieu
Dernière édition par OUARZA le 28 juin 2019, 14:22, édité 1 fois.

Swatmorpheus
Actif
Messages : 909
Inscription : 23 avr. 2015, 14:38
Localisation : Haute Gironde

Re: Oouverture de porte reste bloqué en ouvert

Message par Swatmorpheus » 28 juin 2019, 12:11

Salut , comment est ton maillage ?? car si ton module est en limite et a une grosse latence ça peut venir de là.
vérifie la derniere fois que ton module a envoyé un message au contrôleur.
vérifie la table de routage et essaye de soigner ton réseau , attends 24h le temps que tout tes modules se réveillent.
Prod: jeedom V3.2.12 DIY RPI3 + Zwave (fibaro) + Zigbee (xiaomi) + IPXV4 + X4VR
AppleTV4k
PI3 : Max2play
PiZéro: PiCoreplayer
Mini+: OpenElec 7.0.1 Kodi 16.1 Jarvis
En préinstall pour migration: Nuc hystou ,ESXi6.7,jeedom V3.2.12, LMS ,Owncloud

OUARZA
Timide
Messages : 289
Inscription : 13 févr. 2019, 08:10

Re: Ouverture de porte reste bloqué en ouvert

Message par OUARZA » 28 juin 2019, 12:58

Merci Swatmorpheus,
Je vais regarder cela.
jeedom2.PNG
jeedom2.PNG (153.73 Kio) Consulté 324 fois
jeedom3.PNG
jeedom3.PNG (15.11 Kio) Consulté 323 fois
Ce matin, j'ai eu le problème avec 5 capteurs dont certains sont proches de ma clé Z-wave.

Mathieu
Dernière édition par OUARZA le 28 juin 2019, 14:22, édité 1 fois.

Swatmorpheus
Actif
Messages : 909
Inscription : 23 avr. 2015, 14:38
Localisation : Haute Gironde

Re: Oouverture de porte reste bloqué en ouvert

Message par Swatmorpheus » 28 juin 2019, 13:26

tu n'as pas beaucoup de module sur secteur on dirait , pour le maillage c'est pas top.
Alors essaye la commande : "rafraichir les infos du noeud" dans les modules qui sont en défaut et réveilles les , fais le un par un et une fois qu'ils ont les 3 ok fais soigner le réseau et attend 24h pour voir si les voisins ont changés.
j'ai surligné en jaune la commande
capturezwave.PNG
capturezwave.PNG (99.86 Kio) Consulté 319 fois
Prod: jeedom V3.2.12 DIY RPI3 + Zwave (fibaro) + Zigbee (xiaomi) + IPXV4 + X4VR
AppleTV4k
PI3 : Max2play
PiZéro: PiCoreplayer
Mini+: OpenElec 7.0.1 Kodi 16.1 Jarvis
En préinstall pour migration: Nuc hystou ,ESXi6.7,jeedom V3.2.12, LMS ,Owncloud

Swatmorpheus
Actif
Messages : 909
Inscription : 23 avr. 2015, 14:38
Localisation : Haute Gironde

Re: Oouverture de porte reste bloqué en ouvert

Message par Swatmorpheus » 28 juin 2019, 13:34

d’ailleurs je vois que un module n'a pas fini son association ( DT ouverture entrée) de plus sa batterie est à 0 donc test au voltmetre sa pile et celui du cellier ne communique pas avec le contrôleur on le voit avec les ok , rentre dedans onglet association et choisi le contrôleur sinon faire la procédure sur le screen , pour le fgk de l'entrée juste réveiller le module et faire soigner le réseau
Capture_association.PNG
Capture_association.PNG (35 Kio) Consulté 315 fois
Prod: jeedom V3.2.12 DIY RPI3 + Zwave (fibaro) + Zigbee (xiaomi) + IPXV4 + X4VR
AppleTV4k
PI3 : Max2play
PiZéro: PiCoreplayer
Mini+: OpenElec 7.0.1 Kodi 16.1 Jarvis
En préinstall pour migration: Nuc hystou ,ESXi6.7,jeedom V3.2.12, LMS ,Owncloud

OUARZA
Timide
Messages : 289
Inscription : 13 févr. 2019, 08:10

Re: Ouverture de porte reste bloqué en ouvert

Message par OUARZA » 28 juin 2019, 15:04

Mon capteur de porte d'entrée est bien associé.
jeedom4.PNG
jeedom4.PNG (36.88 Kio) Consulté 304 fois

OUARZA
Timide
Messages : 289
Inscription : 13 févr. 2019, 08:10

Re: Ouverture de porte reste bloqué en ouvert

Message par OUARZA » 28 juin 2019, 17:08

De retour chez moi, j'ouvre et je referme l'ensemble des capteurs ouvert à tort et là, il se referme...
Pourtant, j'ai des capteurs à 0% de batterie...
jeedom_bat.JPG
jeedom_bat.JPG (58.84 Kio) Consulté 294 fois

Qui est en plus incohérent avec l'information que j'ai dans Equipements.
jeedom_bat1.JPG
jeedom_bat1.JPG (15.92 Kio) Consulté 294 fois

Mathieu

OUARZA
Timide
Messages : 289
Inscription : 13 févr. 2019, 08:10

Re: Ouverture de porte reste bloqué en ouvert

Message par OUARZA » 02 juil. 2019, 09:24

Bonjour Swatmorpheus,
Merci beaucoup pour ton aide.
J'ai changé les piles de 3 capteurs et ce matin, je n'ai pas eu de problème de remontée d'état après une longue période en état "ouvert".
J'ai testé 2 piles, 3,62 et 3,65v pour du 3,6v. Elles semblent bonnes, non ?

Je me pose la question de l'information dans "Analyse => Équipements". Faut-il activer l'historique et afficher l'état de la batterie de chaque équipement pour que l'information soit juste à cet endroit ?
piles.PNG
piles.PNG (20.63 Kio) Consulté 248 fois
piles2.PNG
piles2.PNG (44.93 Kio) Consulté 248 fois

Autre chose, j'avais paramétré des alertes, qui n'ont pas fonctionné. Est-ce à cause du && dans la notification ?

Merci par avance.
Mathieu

madcow
Timide
Messages : 293
Inscription : 06 févr. 2019, 21:41

Re: Ouverture de porte reste bloqué en ouvert

Message par madcow » 02 juil. 2019, 09:36

Bonjour,

Les piles ER14250 présentes dans les FGK101 ont leur tension stable même quand elles sont déchargées. D'où la difficulté de détecter leur fin de vie.

https://nechry-automation.ch/2017/05/10 ... -partie-1/
DIY Proxmox sur HP Proliant
Débutant sur Jeedom

OUARZA
Timide
Messages : 289
Inscription : 13 févr. 2019, 08:10

Re: Ouverture de porte reste bloqué en ouvert

Message par OUARZA » 13 juil. 2019, 10:22

Bonjour @madcow,
Merci beaucoup pour l'article.
Il est préférable de prendre des piles de la marque EVE ou SAFT ?

Mathieu

madcow
Timide
Messages : 293
Inscription : 06 févr. 2019, 21:41

Re: Ouverture de porte reste bloqué en ouvert

Message par madcow » 13 juil. 2019, 10:49

OUARZA a écrit :Bonjour @madcow,
Merci beaucoup pour l'article.
Il est préférable de prendre des piles de la marque EVE ou SAFT ?

Mathieu
Bonjour,

Je n'ai jamais testé l'une de ces marques dans cette technologie.

EVE c'est celle utilisée par Fibaro.
SAFT je connais c'est une marque réputée mais jamais testé en ER14250.
DIY Proxmox sur HP Proliant
Débutant sur Jeedom

OUARZA
Timide
Messages : 289
Inscription : 13 févr. 2019, 08:10

Re: Ouverture de porte reste bloqué en ouvert

Message par OUARZA » 13 juil. 2019, 11:32

Merci pour ton retour.
Mathieu

Swatmorpheus
Actif
Messages : 909
Inscription : 23 avr. 2015, 14:38
Localisation : Haute Gironde

Re: Ouverture de porte reste bloqué en ouvert

Message par Swatmorpheus » 13 juil. 2019, 14:27

j'ai un ami chez qui j'ai fais une installation et j'ai énormément de soucis avec ces capteur de porte/fenêtre zwave+ , chez moi j'ai les anciens avec un zstick S2 donc les ancien contrôleur et pas de latence , rien , tout fonctionne bien.
Chez lui y'a même des capteurs qui ne veulent même pas changer d'état !!! alors que l'on voit bien qu'ils se réveillent et qu'ils communiquent. la diode bleu ne s'allume qu'une fois sur 3 ou alors faut attendre un moment ou faire un réveil manuel pour qu'ils fonctionnent normalement tandis que sur les miens même si j'approche et enlève rapidement l'aimant ça clignote dans tout les sens , même problème pour certains de ces œil de fibaro (donc 1 à 1m du contrôleur) , il a modules 8 sur 27 sur secteur bien réparti dans la maison. il a un nuc 7200u 16go de ram et un gen5 donc c'est pas le serveur qui rame.
Prod: jeedom V3.2.12 DIY RPI3 + Zwave (fibaro) + Zigbee (xiaomi) + IPXV4 + X4VR
AppleTV4k
PI3 : Max2play
PiZéro: PiCoreplayer
Mini+: OpenElec 7.0.1 Kodi 16.1 Jarvis
En préinstall pour migration: Nuc hystou ,ESXi6.7,jeedom V3.2.12, LMS ,Owncloud

Répondre

Revenir vers « [Plugin Officiel] Z-Wave »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité