Ce Forum passera en lecture seule en janvier 2020
Image
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

Plugin blea

Avatar de l’utilisateur
raqpub
Timide
Messages : 274
Inscription : 04 juin 2015, 08:21
Localisation : Earth

Re: Plugin blea

Message par raqpub » 28 juil. 2019, 20:30

Theduck38 a écrit :
28 juil. 2019, 12:45
Bonjour,

@raqpub, ton Jeedom plus tes antennes sont sous Jessie ? Ou seulement le Jeedom et pas les antennes ?

J'utilise un Rpi avec Max2Play dessus en tant qu'antenne, avec un service d'auto démarrage de @Bull pour lancer automatiquement le démon en cas de reboot. Je suis donc très prudent avant de faire la mise à jour...
Je n'ai pas d'autre antenne que le bluetooth du raspberry qui héberge Jeedom.

benj29
Actif
Messages : 3978
Inscription : 26 mars 2017, 09:57
Contact :

Re: Plugin blea

Message par benj29 » 28 juil. 2019, 20:56

Theduck38 a écrit :Bonjour,

@raqpub, ton Jeedom plus tes antennes sont sous Jessie ? Ou seulement le Jeedom et pas les antennes ?

J'utilise un Rpi avec Max2Play dessus en tant qu'antenne, avec un service d'auto démarrage de @Bull pour lancer automatiquement le démon en cas de reboot. Je suis donc très prudent avant de faire la mise à jour...
J'ai proposé une autre méthode plus fiable sur mon blog. Aussi, le plugin intègre une gestion auto maintenant plus fiable.

Envoyé de mon JSN-L21 en utilisant Tapatalk


Aur3l1
Timide
Messages : 7
Inscription : 19 janv. 2019, 18:38

Re: Plugin blea

Message par Aur3l1 » 28 juil. 2019, 21:25

Bonjour,
Comme d'autres utilisateurs, le démon n'est plus fonctionnel depuis la dernière mise à jour.
J'ai réessayé de réinstallé le plugin, redémarré jeedom, changé la clé de port, relancé une dizaine de fois les dépendances mais rien n'y fait...
Une idée de comment procéder ?
Restauration de Jeedom en attendant une future mise à jour ?
Merci.

Avatar de l’utilisateur
propositionjoe
Timide
Messages : 302
Inscription : 17 févr. 2016, 21:39
Contact :

Re: Plugin blea

Message par propositionjoe » 28 juil. 2019, 21:49

Salut,
J'ai mis à jour le plugin,
C'est fonctionnel avec jessie.

Je n'ai pas creusé si mes modifications des commandes sur le scripts y étaient ou pas pour quelque chose.
Et comme recommandé j'ai mis à jour les antennes à partir de la page http du plugin blea.
Proxmox avec VM jeedom
Zigbee2mqtt, Broadlink, Zwave, Blea, Tasmotta, EspEasy
Mon blog: https://carmagnole.ovh

figo12
Timide
Messages : 20
Inscription : 28 févr. 2017, 17:15

Re: Plugin blea

Message par figo12 » 29 juil. 2019, 09:47

Bonjour,
Depuis la maj jeedom en 3.3.28, j'ai des problèmes (comme d'autres apparemment) avec le plugin BLEA.
D’abord un pb de démon qui ne se lance plus:
J'ai donc comme d'autre essayé de relancer les dépendances,... mais sans succès, car je suis resté bloqué plus d'une heure a 20%
J'ai donc rebooté ma Smart Jessie Jeedom, et ressayé ... mais la aussi sans succès. Je passe directement a 60% pendant 1 mn, puis plus rien (NOK)
Comme lu plus haut dans le forum, j'ai forcé la réinstallation du plugin, et ressayé mais la encore pas de succès.
Je ne connais rien a Linux, mais j'ai remarqué dans les logs du "Blea_local", quelques erreurs qui pourraient expliquer le phénomène
des Erreur 404 et sudo: pip3: command not found
Ci dessous le log ""Blea_local"
********************************************************
* Installation des dépendances *
********************************************************
Hit http://repo.jeedom.com stable InRelease
Ign http://ftp.debian.org jessie InRelease
Hit http://ftp.debian.org jessie-updates InRelease
Hit http://security.debian.org jessie/updates InRelease
Ign http://ftp.debian.org jessie-backports InRelease
Ign http://ftp.debian.org jessie-proposed-updates InRelease
Ign http://ftp.debian.org stretch InRelease
Hit http://ftp.debian.org jessie Release.gpg
Hit http://repo.jeedom.com stable/main arm64 Packages
Ign http://ftp.debian.org jessie-backports Release.gpg
Ign http://ftp.debian.org jessie-proposed-updates Release.gpg
Hit http://ftp.debian.org stretch Release.gpg
Get:1 http://security.debian.org jessie/updates/main Sources [327 kB]
Hit http://ftp.debian.org jessie-updates/main Sources
Hit http://ftp.debian.org jessie-updates/contrib Sources
Ign http://repo.jeedom.com stable/main Translation-en
Hit http://ftp.debian.org jessie-updates/non-free Sources
Get:2 http://security.debian.org jessie/updates/non-free Sources [1629 B]
Hit http://ftp.debian.org jessie Release
Hit http://security.debian.org jessie/updates/contrib Sources
Ign http://ftp.debian.org jessie-backports Release
Hit http://oph.mdrjr.net all InRelease
Ign http://ftp.debian.org jessie-proposed-updates Release
Hit http://ftp.debian.org stretch Release
Hit http://oph.mdrjr.net jessie InRelease
Get:3 http://oph.mdrjr.net all/c2 arm64 Packages
Ign http://ftp.debian.org jessie-backports/main Sources/DiffIndex
Get:4 http://oph.mdrjr.net all/main arm64 Packages
Ign http://ftp.debian.org jessie-backports/contrib Sources/DiffIndex
Hit http://oph.mdrjr.net all/c2 arm64 Packages
Ign http://ftp.debian.org jessie-backports/non-free Sources/DiffIndex
Get:5 http://oph.mdrjr.net all/testing arm64 Packages
Ign http://ftp.debian.org jessie-backports/main arm64 Packages/DiffIndex
Ign http://ftp.debian.org jessie-backports/contrib arm64 Packages/DiffIndex
Hit http://oph.mdrjr.net all/main arm64 Packages
Ign http://ftp.debian.org jessie-backports/non-free arm64 Packages/DiffIndex
Get:6 http://oph.mdrjr.net all/c2 Translation-en [321 B]
Get:7 http://oph.mdrjr.net all/main Translation-en [323 B]
Ign http://ftp.debian.org jessie-proposed-updates/contrib Sources/DiffIndex
Hit http://oph.mdrjr.net all/testing arm64 Packages
Ign http://ftp.debian.org jessie-proposed-updates/non-free Sources/DiffIndex
Ign http://ftp.debian.org jessie-proposed-updates/main Sources/DiffIndex
Get:8 http://oph.mdrjr.net all/testing Translation-en [326 B]
Ign http://ftp.debian.org jessie-proposed-updates/contrib arm64 Packages/DiffIndex
Ign http://ftp.debian.org jessie-proposed-updates/non-free arm64 Packages/DiffIndex
Get:9 http://oph.mdrjr.net jessie/backports arm64 Packages
Ign http://ftp.debian.org jessie-proposed-updates/main arm64 Packages/DiffIndex
Get:10 http://oph.mdrjr.net jessie/main arm64 Packages
Get:11 http://oph.mdrjr.net jessie/backports Translation-en [331 B]
Get:12 http://oph.mdrjr.net jessie/main Translation-en [326 B]
Get:13 http://oph.mdrjr.net all/c2 Translation-en [321 B]
Hit http://oph.mdrjr.net jessie/backports arm64 Packages
Get:14 http://oph.mdrjr.net all/main Translation-en [323 B]
Hit http://ftp.debian.org jessie/main Sources
Hit http://oph.mdrjr.net jessie/main arm64 Packages
Hit http://ftp.debian.org jessie/contrib Sources
Get:15 http://oph.mdrjr.net all/testing Translation-en [326 B]
Hit http://ftp.debian.org jessie/non-free Sources
Get:16 http://oph.mdrjr.net jessie/backports Translation-en [331 B]
Get:17 http://oph.mdrjr.net jessie/main Translation-en [326 B]
Get:18 http://oph.mdrjr.net all/c2 Translation-en [321 B]
Get:19 http://oph.mdrjr.net all/main Translation-en [323 B]
Get:20 http://oph.mdrjr.net all/testing Translation-en [326 B]
Get:21 http://oph.mdrjr.net jessie/backports Translation-en [331 B]
Get:22 http://oph.mdrjr.net jessie/main Translation-en [326 B]
Get:23 http://oph.mdrjr.net all/c2 Translation-en [321 B]
Get:24 http://oph.mdrjr.net all/main Translation-en [323 B]
Get:25 http://oph.mdrjr.net all/testing Translation-en [326 B]
Get:26 http://oph.mdrjr.net jessie/backports Translation-en [331 B]
Hit http://ftp.debian.org stretch/main arm64 Packages
Get:27 http://oph.mdrjr.net jessie/main Translation-en [326 B]
Hit http://ftp.debian.org stretch/contrib arm64 Packages
Hit http://ftp.debian.org stretch/non-free arm64 Packages
Get:28 http://oph.mdrjr.net all/c2 Translation-en [321 B]
Ign http://oph.mdrjr.net all/c2 Translation-en
Hit http://ftp.debian.org stretch/contrib Translation-en
Get:29 http://oph.mdrjr.net all/main Translation-en [323 B]
Ign http://oph.mdrjr.net all/main Translation-en
Hit http://ftp.debian.org stretch/main Translation-en
Hit http://ftp.debian.org stretch/non-free Translation-en
Get:30 http://oph.mdrjr.net all/testing Translation-en [326 B]
Ign http://oph.mdrjr.net all/testing Translation-en
Get:31 http://oph.mdrjr.net jessie/backports Translation-en [331 B]
Ign http://oph.mdrjr.net jessie/backports Translation-en
Get:32 http://oph.mdrjr.net jessie/main Translation-en [326 B]
Ign http://oph.mdrjr.net jessie/main Translation-en
Ign http://ftp.debian.org jessie-backports/contrib Translation-en
Ign http://ftp.debian.org jessie-backports/main Translation-en
Ign http://ftp.debian.org jessie-backports/non-free Translation-en
Ign http://ftp.debian.org jessie-proposed-updates/contrib Translation-en
Ign http://ftp.debian.org jessie-proposed-updates/main Translation-en
Ign http://ftp.debian.org jessie-proposed-updates/non-free Translation-en
Err http://ftp.debian.org jessie-backports/main Sources
404 Not Found [IP: 2001:67c:2564:a119::148:12 80]
Err http://ftp.debian.org jessie-backports/contrib Sources
404 Not Found [IP: 2001:67c:2564:a119::148:12 80]
Err http://ftp.debian.org jessie-backports/non-free Sources
404 Not Found [IP: 2001:67c:2564:a119::148:12 80]
Err http://ftp.debian.org jessie-backports/main arm64 Packages
404 Not Found [IP: 2001:67c:2564:a119::148:12 80]
Err http://ftp.debian.org jessie-backports/contrib arm64 Packages
404 Not Found [IP: 2001:67c:2564:a119::148:12 80]
Err http://ftp.debian.org jessie-backports/non-free arm64 Packages
404 Not Found [IP: 2001:67c:2564:a119::148:12 80]
Err http://ftp.debian.org jessie-proposed-updates/contrib Sources
404 Not Found [IP: 2001:67c:2564:a119::148:12 80]
Err http://ftp.debian.org jessie-proposed-updates/non-free Sources
404 Not Found [IP: 2001:67c:2564:a119::148:12 80]
Err http://ftp.debian.org jessie-proposed-updates/main Sources
404 Not Found [IP: 2001:67c:2564:a119::148:12 80]
Err http://ftp.debian.org jessie-proposed-updates/contrib arm64 Packages
404 Not Found [IP: 2001:67c:2564:a119::148:12 80]
Err http://ftp.debian.org jessie-proposed-updates/non-free arm64 Packages
404 Not Found [IP: 2001:67c:2564:a119::148:12 80]
Err http://ftp.debian.org jessie-proposed-updates/main arm64 Packages
404 Not Found [IP: 2001:67c:2564:a119::148:12 80]
W: There is no public key available for the following key IDs:
AA8E81B4331F7F50
W: Failed to fetch http://ftp.debian.org/debian/dists/jess ... /InRelease Unable to find expected entry 'main/binary-arm64/Packages' in Release file (Wrong sources.list entry or malformed file)

W: Failed to fetch http://security.debian.org/dists/jessie ... /InRelease Unable to find expected entry 'main/binary-arm64/Packages' in Release file (Wrong sources.list entry or malformed file)

W: Failed to fetch http://ftp.debian.org/debian/dists/jessie/Release Unable to find expected entry 'main/binary-arm64/Packages' in Release file (Wrong sources.list entry or malformed file)

W: Failed to fetch http://ftp.debian.org/debian/dists/jess ... ce/Sources 404 Not Found [IP: 2001:67c:2564:a119::148:12 80]

W: Failed to fetch http://ftp.debian.org/debian/dists/jess ... ce/Sources 404 Not Found [IP: 2001:67c:2564:a119::148:12 80]

W: Failed to fetch http://ftp.debian.org/debian/dists/jess ... ce/Sources 404 Not Found [IP: 2001:67c:2564:a119::148:12 80]

W: Failed to fetch http://ftp.debian.org/debian/dists/jess ... 4/Packages 404 Not Found [IP: 2001:67c:2564:a119::148:12 80]

W: Failed to fetch http://ftp.debian.org/debian/dists/jess ... 4/Packages 404 Not Found [IP: 2001:67c:2564:a119::148:12 80]

W: Failed to fetch http://ftp.debian.org/debian/dists/jess ... 4/Packages 404 Not Found [IP: 2001:67c:2564:a119::148:12 80]

W: Failed to fetch http://ftp.debian.org/debian/dists/jess ... ce/Sources 404 Not Found [IP: 2001:67c:2564:a119::148:12 80]

W: Failed to fetch http://ftp.debian.org/debian/dists/jess ... ce/Sources 404 Not Found [IP: 2001:67c:2564:a119::148:12 80]

W: Failed to fetch http://ftp.debian.org/debian/dists/jess ... ce/Sources 404 Not Found [IP: 2001:67c:2564:a119::148:12 80]

W: Failed to fetch http://ftp.debian.org/debian/dists/jess ... 4/Packages 404 Not Found [IP: 2001:67c:2564:a119::148:12 80]

W: Failed to fetch http://ftp.debian.org/debian/dists/jess ... 4/Packages 404 Not Found [IP: 2001:67c:2564:a119::148:12 80]

W: Failed to fetch http://ftp.debian.org/debian/dists/jess ... 4/Packages 404 Not Found [IP: 2001:67c:2564:a119::148:12 80]

E: Some index files failed to download. They have been ignored, or old ones used instead.
E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.
E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.
E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.
sudo: pip3: command not found
E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.
sudo: pip3: command not found
sudo: pip3: command not found
sudo: pip3: command not found
Cloning into 'bluepy'...
running build
running build_py
creating build
creating build/lib
creating build/lib/bluepy
copying bluepy/thingy52.py -> build/lib/bluepy
copying bluepy/sensortag.py -> build/lib/bluepy
copying bluepy/scanner.py -> build/lib/bluepy
copying bluepy/scan_fuzz.py -> build/lib/bluepy
copying bluepy/get_services.py -> build/lib/bluepy
copying bluepy/btle.py -> build/lib/bluepy
copying bluepy/blescan.py -> build/lib/bluepy
copying bluepy/__init__.py -> build/lib/bluepy
copying bluepy/uuids.json -> build/lib/bluepy
copying bluepy/bluez-src.tgz -> build/lib/bluepy
copying bluepy/bluepy-helper.c -> build/lib/bluepy
copying bluepy/Makefile -> build/lib/bluepy
running install
Working dir is /tmp/bluepy
execute make -C ./bluepy clean
execute make -C bluepy -j1
running build
running build_py
copying bluepy/bluepy-helper -> build/lib/bluepy
running install_lib
copying build/lib/bluepy/bluepy-helper -> /usr/local/lib/python3.4/dist-packages/bluepy
copying build/lib/bluepy/Makefile -> /usr/local/lib/python3.4/dist-packages/bluepy
copying build/lib/bluepy/bluepy-helper.c -> /usr/local/lib/python3.4/dist-packages/bluepy
copying build/lib/bluepy/bluez-src.tgz -> /usr/local/lib/python3.4/dist-packages/bluepy
copying build/lib/bluepy/uuids.json -> /usr/local/lib/python3.4/dist-packages/bluepy
copying build/lib/bluepy/__init__.py -> /usr/local/lib/python3.4/dist-packages/bluepy
copying build/lib/bluepy/blescan.py -> /usr/local/lib/python3.4/dist-packages/bluepy
copying build/lib/bluepy/btle.py -> /usr/local/lib/python3.4/dist-packages/bluepy
copying build/lib/bluepy/get_services.py -> /usr/local/lib/python3.4/dist-packages/bluepy
copying build/lib/bluepy/scan_fuzz.py -> /usr/local/lib/python3.4/dist-packages/bluepy
copying build/lib/bluepy/scanner.py -> /usr/local/lib/python3.4/dist-packages/bluepy
copying build/lib/bluepy/sensortag.py -> /usr/local/lib/python3.4/dist-packages/bluepy
copying build/lib/bluepy/thingy52.py -> /usr/local/lib/python3.4/dist-packages/bluepy
byte-compiling /usr/local/lib/python3.4/dist-packages/bluepy/__init__.py to __init__.cpython-34.pyc
byte-compiling /usr/local/lib/python3.4/dist-packages/bluepy/blescan.py to blescan.cpython-34.pyc
byte-compiling /usr/local/lib/python3.4/dist-packages/bluepy/btle.py to btle.cpython-34.pyc
byte-compiling /usr/local/lib/python3.4/dist-packages/bluepy/get_services.py to get_services.cpython-34.pyc
byte-compiling /usr/local/lib/python3.4/dist-packages/bluepy/scan_fuzz.py to scan_fuzz.cpython-34.pyc
byte-compiling /usr/local/lib/python3.4/dist-packages/bluepy/scanner.py to scanner.cpython-34.pyc
byte-compiling /usr/local/lib/python3.4/dist-packages/bluepy/sensortag.py to sensortag.cpython-34.pyc
byte-compiling /usr/local/lib/python3.4/dist-packages/bluepy/thingy52.py to thingy52.cpython-34.pyc
running install_egg_info
running egg_info
creating bluepy.egg-info
writing entry points to bluepy.egg-info/entry_points.txt
writing bluepy.egg-info/PKG-INFO
writing dependency_links to bluepy.egg-info/dependency_links.txt
writing top-level names to bluepy.egg-info/top_level.txt
writing manifest file 'bluepy.egg-info/SOURCES.txt'
reading manifest file 'bluepy.egg-info/SOURCES.txt'
writing manifest file 'bluepy.egg-info/SOURCES.txt'
removing '/usr/local/lib/python3.4/dist-packages/bluepy-1.1.4.egg-info' (and everything under it)
Copying bluepy.egg-info to /usr/local/lib/python3.4/dist-packages/bluepy-1.1.4.egg-info
running install_scripts
Installing thingy52 script to /usr/local/bin
Installing blescan script to /usr/local/bin
Installing sensortag script to /usr/local/bin
sudo: pip3: command not found
sudo: pip3: command not found
********************************************************
* Installation terminée *
********************************************************
Merci de m'aider a trouver une solution

minos71
Timide
Messages : 65
Inscription : 09 août 2018, 00:48

Re: Plugin blea

Message par minos71 » 29 juil. 2019, 12:35

Hello,

moi aussi dans mes logs : ImportError: No module named 'bluepy' depuis la derniere Màj du core.

j 'ai fait une re-installation des dépendances à l'instant , et tout est OK...

Mips2648
Actif
Messages : 932
Inscription : 08 sept. 2018, 17:09

Re: Plugin blea

Message par Mips2648 » 29 juil. 2019, 13:58

Swr a écrit :
27 juil. 2019, 09:14
J'anticipe un peu le futur
Quelqu'un sait il dire si la migration de Jeedom sur Buster va telle nécessiter de faire migrer également les antennes BLEA ?
L'os pour jeedom est complètement indépendant de l'os qui tourne les antennes, aucun besoin de les garder synchro.
Donc si un jour il faudra migrer les antennes BLEA, ca ne sera que parce que les modules python utilisés ne sont plus supportés sous stretch ou jessie.
Tu peux aussi déjà installer des antennes sous buster même si jeedom est sous stretch par exemple.
Développeur et auteur des plugins suivants, (entre autre Arlo, Solaredge, Design Image, Gotify...) et aidant sur plein d'autres!

Si vous voulez contribuer, un don fait toujours plaisir : https://paypal.me/mips2648


Avatar de l’utilisateur
akenad
Actif
Messages : 694
Inscription : 27 oct. 2017, 11:39

Re: Plugin blea

Message par akenad » 29 juil. 2019, 16:12

figo12 a écrit :
29 juil. 2019, 09:47
... J'ai donc rebooté ma Smart Jessie Jeedom ...
... Merci de m'aider a trouver une solution
Des paquets ne sont plus disponibles en Jessie arm64.
Le mieux est de passer en Stretch.

akenad :)
Présentation akenad
JeedomSmart Debian Stretch
Odroid-C2 eMMC Armbian Stretch Kernel 3.x
RPi3B+ SSD Raspbian Stretch
NUC Intel i7Gen7 ProxMox VM Debian Stretch & Buster
RPi4B SSD Raspbian Buster

Mes équipements

answer35
Timide
Messages : 52
Inscription : 09 mars 2018, 16:42

Re: Plugin blea

Message par answer35 » 29 juil. 2019, 16:18

Même problème chez moi, Problème avec le démon puis avec les dépendances suite à une désactivation du plugin. Mon Jeedom est installé sur un stretch

benj29
Actif
Messages : 3978
Inscription : 26 mars 2017, 09:57
Contact :

Re: Plugin blea

Message par benj29 » 29 juil. 2019, 16:43

Pourquoi s'entêter à rester sous Jessie ? Alors que tout est OK sur Stretch depuis bientôt plus d'un an (autant pour ma part, j'avais fait les frais de quelques soucis en Debian9 au tout début). On en est à la 9.9 et la 10 a pointé son nez en stable de mémoire il y a peu preuve de la maturité de la 9.

Avatar de l’utilisateur
propositionjoe
Timide
Messages : 302
Inscription : 17 févr. 2016, 21:39
Contact :

Re: Plugin blea

Message par propositionjoe » 29 juil. 2019, 16:47

benj29 a écrit :
29 juil. 2019, 16:43
Pourquoi s'entêter à rester sous Jessie ?
Exception faite pour les antennes,
Y a encore pas mal d'images qui tournent sous Jessie.
Proxmox avec VM jeedom
Zigbee2mqtt, Broadlink, Zwave, Blea, Tasmotta, EspEasy
Mon blog: https://carmagnole.ovh

Avatar de l’utilisateur
akenad
Actif
Messages : 694
Inscription : 27 oct. 2017, 11:39

Re: Plugin blea

Message par akenad » 29 juil. 2019, 17:00

benj29 a écrit :
29 juil. 2019, 16:43
Pourquoi s'entêter à rester sous Jessie ? Alors que tout est OK sur Stretch depuis bientôt plus d'un an (autant pour ma part, j'avais fait les frais de quelques soucis en Debian9 au tout début). On en est à la 9.9 et la 10 a pointé son nez en stable de mémoire il y a peu preuve de la maturité de la 9.

Bonjour @benj29,

Je suis plutôt d’accord, ça fait plus d’un an que j’incite les membres du forum à migrer sur Stretch via mes [RTEX].
Ce qui serait bien c’est que Jeedom SAS expurge sa documentation officielle de Jessie, trop de problèmes à l’heure actuelle sont uniquement liés aux dépendances.
Il y a toujours des irréductibles qui cherchent à toujours fonctionner avec Jessie. C’est vrai c’est toujours possible si on « bricole » mais ce n’est pas à la portée de tout le monde.
Ça devient vraiment légitime et compréhensible d’abandonner Jessie au profit de Stretch, surtout depuis la sortie de buster en stable.

akenad :)
Dernière édition par akenad le 30 juil. 2019, 01:20, édité 1 fois.
Présentation akenad
JeedomSmart Debian Stretch
Odroid-C2 eMMC Armbian Stretch Kernel 3.x
RPi3B+ SSD Raspbian Stretch
NUC Intel i7Gen7 ProxMox VM Debian Stretch & Buster
RPi4B SSD Raspbian Buster

Mes équipements

Avatar de l’utilisateur
Kiminou
Timide
Messages : 12
Inscription : 30 mars 2019, 19:07

Re: Plugin blea

Message par Kiminou » 29 juil. 2019, 18:15

syl62 a écrit :
28 juil. 2019, 11:56
Bonjour,

Pour le problème d'affichage des images sur le Dotti, dans les log on peut voir cette erreur.
[2019-07-28 11:43:13.855][DEBUG] : SOCKET-READ------Message received in socket JEEDOM_SOCKET_MESSAGE
[2019-07-28 11:43:13.857][DEBUG] : SOCKET-READ------Received command from jeedom : action
[2019-07-28 11:43:13.858][DEBUG] : SOCKET-READ------Attempt an action on a device
[2019-07-28 11:43:13.860][DEBUG] : DOTTI------Already a connection for xx:xx:xx:xx:xx:xx use it
[2019-07-28 11:43:13.860][DEBUG] : SOCKET-READ------Action Thread Launched
[2019-07-28 11:43:13.861][DEBUG] : DOTTI------Sending Display
[2019-07-28 11:43:13.862][DEBUG] : DOTTI------Failed to finish : 'dict' object has no attribute 'iteritems'

Quelqu'un connaît une solution à ce problème ?

slt
Hello,

Après mise à jour de Jeedom en 3.3.29 et du plugin blea (daté du 2019-07-29 10:40:01), j'ai toujours les mêmes problèmes avec Dotti.
C'est assez frustrant de ne plus pouvoir envoyer nos images sur l'appareil pour nos scénarios.
Et rebelote mes images sont encore parti mais toujours 2 images "Coeur" et "Luigi" dans la bibliothèque.
Hystou i3, Raspberry Pi 2, Contrôleur Z-Wave Plus Z-Stick GEN5, ASUS USB-BT400, Zigate, Sena UD100-G03, Huawei e169, Dotti, Divoom Tivoo V5.0, Jeedom 3.3.31.

i-magin
Actif
Messages : 987
Inscription : 18 août 2015, 10:23
Localisation : Villeurbanne

Re: Plugin blea

Message par i-magin » 29 juil. 2019, 18:32

Je viens d'effectuer la maj de BLEA de la version 2019-05-22 à la version 2019-07-29 10:40:01
Pour les informations concernant la version de Jeedom et ma configuration, voir ma signature
Important : ma version Jeedom est stretch

Après maj de BLEA :
- log Blea-update : vide (j'avais volontairement vidé cette log avant maj)
- log Blea-local :

Code : Tout sélectionner

Traceback (most recent call last):
File "/var/www/html/plugins/blea/resources/blead/blead.py", line 26, in <module>
from bluepy.btle import Scanner, DefaultDelegate
ImportError: No module named 'bluepy'
Traceback (most recent call last):
File "/var/www/html/plugins/blea/resources/blead/blead.py", line 26, in <module>
from bluepy.btle import Scanner, DefaultDelegate
ImportError: No module named 'bluepy'
- log Blea : "[2019-07-29 18:03:34][ERROR] : Impossible de lancer le démon blea, vérifiez la log" - Ce message d'erreur est repris dans le panneau global des messages
- la date de dernière installation des dépendances n'a pas changé (pour ma part 2018-10-25)
- Demon : NOK

Je relance les dépendances : durée 1mn environ (voir ma configuration matérielle dans ma signature)
Puis, je redémarre le Demon

Log de blea-local

Code : Tout sélectionner

********************************************************
*			 Installation des dépendances			 *
********************************************************
Hit:1 http://security.debian.org/debian-security stretch/updates InRelease
Ign:2 http://ftp.fr.debian.org/debian stretch InRelease
Get:3 http://ftp.fr.debian.org/debian stretch-updates InRelease [91.0 kB]
Hit:4 http://ftp.fr.debian.org/debian stretch Release
Hit:5 https://deb.nodesource.com/node_8.x stretch InRelease
Fetched 91.0 kB in 0s (195 kB/s)
Reading package lists...
Reading package lists...
Building dependency tree...
Reading state information...
bluetooth is already the newest version (5.43-2+deb9u1).
build-essential is already the newest version (12.3).
libffi-dev is already the newest version (3.2.1-6).
python3-requests is already the newest version (2.12.4-1).
python3-requests set to manually installed.
libssl-dev is already the newest version (1.1.0k-1~deb9u1).
Suggested packages:
python3-wxgtk3.0 | python3-wxgtk python-setuptools-doc
The following NEW packages will be installed:
libbluetooth-dev libbluetooth3 libpython3-dev libpython3.5 libpython3.5-dev
python3-dev python3-pyudev python3-serial python3-setuptools python3.5-dev
rfkill
0 upgraded, 11 newly installed, 0 to remove and 58 not upgraded.
Need to get 40.2 MB of archives.
After this operation, 62.1 MB of additional disk space will be used.
Get:1 http://ftp.fr.debian.org/debian stretch/main amd64 libbluetooth3 amd64 5.43-2+deb9u1 [97.8 kB]
Get:2 http://ftp.fr.debian.org/debian stretch/main amd64 libpython3.5 amd64 3.5.3-1+deb9u1 [1372 kB]
Get:3 http://ftp.fr.debian.org/debian stretch/main amd64 libpython3.5-dev amd64 3.5.3-1+deb9u1 [37.7 MB]
Get:4 http://ftp.fr.debian.org/debian stretch/main amd64 libpython3-dev amd64 3.5.3-1 [18.7 kB]
Get:5 http://ftp.fr.debian.org/debian stretch/main amd64 python3.5-dev amd64 3.5.3-1+deb9u1 [413 kB]
Get:6 http://ftp.fr.debian.org/debian stretch/main amd64 python3-dev amd64 3.5.3-1 [1154 B]
Get:7 http://ftp.fr.debian.org/debian stretch/main amd64 python3-pyudev all 0.21.0-1 [40.2 kB]
Get:8 http://ftp.fr.debian.org/debian stretch/main amd64 python3-serial all 3.2.1-1 [65.3 kB]
Get:9 http://ftp.fr.debian.org/debian stretch/main amd64 python3-setuptools all 33.1.1-1 [215 kB]
Get:10 http://ftp.fr.debian.org/debian stretch/main amd64 rfkill amd64 0.5-1+b1 [8284 B]
Get:11 http://ftp.fr.debian.org/debian stretch/main amd64 libbluetooth-dev amd64 5.43-2+deb9u1 [191 kB]
debconf: unable to initialize frontend: Dialog
debconf: (Dialog frontend will not work on a dumb terminal, an emacs shell buffer, or without a controlling terminal.)
debconf: falling back to frontend: Readline
debconf: unable to initialize frontend: Readline
debconf: (This frontend requires a controlling tty.)
debconf: falling back to frontend: Teletype
dpkg-preconfigure: unable to re-open stdin:
Fetched 40.2 MB in 3s (12.3 MB/s)
Selecting previously unselected package libbluetooth3:amd64.
(Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 70699 files and directories currently installed.)
Preparing to unpack .../00-libbluetooth3_5.43-2+deb9u1_amd64.deb ...
Unpacking libbluetooth3:amd64 (5.43-2+deb9u1) ...
Selecting previously unselected package libpython3.5:amd64.
Preparing to unpack .../01-libpython3.5_3.5.3-1+deb9u1_amd64.deb ...
Unpacking libpython3.5:amd64 (3.5.3-1+deb9u1) ...
Selecting previously unselected package libpython3.5-dev:amd64.
Preparing to unpack .../02-libpython3.5-dev_3.5.3-1+deb9u1_amd64.deb ...
Unpacking libpython3.5-dev:amd64 (3.5.3-1+deb9u1) ...
Selecting previously unselected package libpython3-dev:amd64.
Preparing to unpack .../03-libpython3-dev_3.5.3-1_amd64.deb ...
Unpacking libpython3-dev:amd64 (3.5.3-1) ...
Selecting previously unselected package python3.5-dev.
Preparing to unpack .../04-python3.5-dev_3.5.3-1+deb9u1_amd64.deb ...
Unpacking python3.5-dev (3.5.3-1+deb9u1) ...
Selecting previously unselected package python3-dev.
Preparing to unpack .../05-python3-dev_3.5.3-1_amd64.deb ...
Unpacking python3-dev (3.5.3-1) ...
Selecting previously unselected package python3-pyudev.
Preparing to unpack .../06-python3-pyudev_0.21.0-1_all.deb ...
Unpacking python3-pyudev (0.21.0-1) ...
Selecting previously unselected package python3-serial.
Preparing to unpack .../07-python3-serial_3.2.1-1_all.deb ...
Unpacking python3-serial (3.2.1-1) ...
Selecting previously unselected package python3-setuptools.
Preparing to unpack .../08-python3-setuptools_33.1.1-1_all.deb ...
Unpacking python3-setuptools (33.1.1-1) ...
Selecting previously unselected package rfkill.
Preparing to unpack .../09-rfkill_0.5-1+b1_amd64.deb ...
Unpacking rfkill (0.5-1+b1) ...
Selecting previously unselected package libbluetooth-dev.
Preparing to unpack .../10-libbluetooth-dev_5.43-2+deb9u1_amd64.deb ...
Unpacking libbluetooth-dev (5.43-2+deb9u1) ...
Setting up python3-serial (3.2.1-1) ...
Setting up libpython3.5:amd64 (3.5.3-1+deb9u1) ...
Setting up libbluetooth3:amd64 (5.43-2+deb9u1) ...
Setting up python3-pyudev (0.21.0-1) ...
Setting up libpython3.5-dev:amd64 (3.5.3-1+deb9u1) ...
Processing triggers for libc-bin (2.24-11+deb9u3) ...
Processing triggers for man-db (2.7.6.1-2) ...
Setting up python3-setuptools (33.1.1-1) ...
Setting up python3.5-dev (3.5.3-1+deb9u1) ...
Setting up rfkill (0.5-1+b1) ...
Setting up libpython3-dev:amd64 (3.5.3-1) ...
Setting up libbluetooth-dev (5.43-2+deb9u1) ...
Setting up python3-dev (3.5.3-1) ...
Reading package lists...
Building dependency tree...
Reading state information...
The following additional packages will be installed:
python-pip python-pip-whl python3-cffi-backend python3-crypto
python3-cryptography python3-idna python3-keyring python3-keyrings.alt
python3-pyasn1 python3-secretstorage python3-wheel python3-xdg
Suggested packages:
python3-crypto-dbg python-crypto-doc python-cryptography-doc
python3-cryptography-vectors gnome-keyring libkf5wallet-bin
gir1.2-gnomekeyring-1.0 python3-pykde4 doc-base python-secretstorage-doc
The following NEW packages will be installed:
python3-cffi-backend python3-crypto python3-cryptography python3-idna
python3-keyring python3-keyrings.alt python3-pip python3-pyasn1
python3-secretstorage python3-wheel python3-xdg
The following packages will be upgraded:
python-pip python-pip-whl
2 upgraded, 11 newly installed, 0 to remove and 56 not upgraded.
Need to get 2482 kB of archives.
After this operation, 4860 kB of additional disk space will be used.
Get:1 http://ftp.fr.debian.org/debian stretch/main amd64 python-pip all 9.0.1-2+deb9u1 [179 kB]
Get:2 http://ftp.fr.debian.org/debian stretch/main amd64 python-pip-whl all 9.0.1-2+deb9u1 [1399 kB]
Get:3 http://ftp.fr.debian.org/debian stretch/main amd64 python3-cffi-backend amd64 1.9.1-2 [70.1 kB]
Get:4 http://ftp.fr.debian.org/debian stretch/main amd64 python3-crypto amd64 2.6.1-7 [259 kB]
Get:5 http://ftp.fr.debian.org/debian stretch/main amd64 python3-idna all 2.2-1 [32.7 kB]
Get:6 http://ftp.fr.debian.org/debian stretch/main amd64 python3-pyasn1 all 0.1.9-2 [34.5 kB]
Get:7 http://ftp.fr.debian.org/debian stretch/main amd64 python3-cryptography amd64 1.7.1-3+deb9u1 [210 kB]
Get:8 http://ftp.fr.debian.org/debian stretch/main amd64 python3-secretstorage all 2.3.1-2 [14.2 kB]
Get:9 http://ftp.fr.debian.org/debian stretch/main amd64 python3-keyring all 10.1-1 [36.8 kB]
Get:10 http://ftp.fr.debian.org/debian stretch/main amd64 python3-keyrings.alt all 1.3-1 [16.2 kB]
Get:11 http://ftp.fr.debian.org/debian stretch/main amd64 python3-pip all 9.0.1-2+deb9u1 [142 kB]
Get:12 http://ftp.fr.debian.org/debian stretch/main amd64 python3-wheel all 0.29.0-2 [51.8 kB]
Get:13 http://ftp.fr.debian.org/debian stretch/main amd64 python3-xdg all 0.25-4 [35.7 kB]
apt-listchanges: Reading changelogs...
debconf: unable to initialize frontend: Dialog
debconf: (Dialog frontend will not work on a dumb terminal, an emacs shell buffer, or without a controlling terminal.)
debconf: falling back to frontend: Readline
debconf: unable to initialize frontend: Readline
debconf: (This frontend requires a controlling tty.)
debconf: falling back to frontend: Teletype
dpkg-preconfigure: unable to re-open stdin:
Fetched 2482 kB in 0s (3118 kB/s)
(Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 71068 files and directories currently installed.)
Preparing to unpack .../00-python-pip_9.0.1-2+deb9u1_all.deb ...
Unpacking python-pip (9.0.1-2+deb9u1) over (9.0.1-2) ...
Preparing to unpack .../01-python-pip-whl_9.0.1-2+deb9u1_all.deb ...
Unpacking python-pip-whl (9.0.1-2+deb9u1) over (9.0.1-2) ...
Selecting previously unselected package python3-cffi-backend.
Preparing to unpack .../02-python3-cffi-backend_1.9.1-2_amd64.deb ...
Unpacking python3-cffi-backend (1.9.1-2) ...
Selecting previously unselected package python3-crypto.
Preparing to unpack .../03-python3-crypto_2.6.1-7_amd64.deb ...
Unpacking python3-crypto (2.6.1-7) ...
Selecting previously unselected package python3-idna.
Preparing to unpack .../04-python3-idna_2.2-1_all.deb ...
Unpacking python3-idna (2.2-1) ...
Selecting previously unselected package python3-pyasn1.
Preparing to unpack .../05-python3-pyasn1_0.1.9-2_all.deb ...
Unpacking python3-pyasn1 (0.1.9-2) ...
Selecting previously unselected package python3-cryptography.
Preparing to unpack .../06-python3-cryptography_1.7.1-3+deb9u1_amd64.deb ...
Unpacking python3-cryptography (1.7.1-3+deb9u1) ...
Selecting previously unselected package python3-secretstorage.
Preparing to unpack .../07-python3-secretstorage_2.3.1-2_all.deb ...
Unpacking python3-secretstorage (2.3.1-2) ...
Selecting previously unselected package python3-keyring.
Preparing to unpack .../08-python3-keyring_10.1-1_all.deb ...
Unpacking python3-keyring (10.1-1) ...
Selecting previously unselected package python3-keyrings.alt.
Preparing to unpack .../09-python3-keyrings.alt_1.3-1_all.deb ...
Unpacking python3-keyrings.alt (1.3-1) ...
Selecting previously unselected package python3-pip.
Preparing to unpack .../10-python3-pip_9.0.1-2+deb9u1_all.deb ...
Unpacking python3-pip (9.0.1-2+deb9u1) ...
Selecting previously unselected package python3-wheel.
Preparing to unpack .../11-python3-wheel_0.29.0-2_all.deb ...
Unpacking python3-wheel (0.29.0-2) ...
Selecting previously unselected package python3-xdg.
Preparing to unpack .../12-python3-xdg_0.25-4_all.deb ...
Unpacking python3-xdg (0.25-4) ...
Setting up python-pip-whl (9.0.1-2+deb9u1) ...
Setting up python3-cffi-backend (1.9.1-2) ...
Setting up python3-crypto (2.6.1-7) ...
Setting up python3-idna (2.2-1) ...
Setting up python3-xdg (0.25-4) ...
Setting up python3-keyrings.alt (1.3-1) ...
Setting up python3-wheel (0.29.0-2) ...
Setting up python3-pyasn1 (0.1.9-2) ...
Setting up python3-pip (9.0.1-2+deb9u1) ...
Processing triggers for man-db (2.7.6.1-2) ...
Setting up python-pip (9.0.1-2+deb9u1) ...
Setting up python3-cryptography (1.7.1-3+deb9u1) ...
Setting up python3-secretstorage (2.3.1-2) ...
Setting up python3-keyring (10.1-1) ...
Collecting setuptools
Downloading https://files.pythonhosted.org/packages/ec/51/f45cea425fd5cb0b0380f5b0f048ebc1da5b417e48d304838c02d6288a1e/setuptools-41.0.1-py2.py3-none-any.whl (575kB)
Installing collected packages: setuptools
Found existing installation: setuptools 33.1.1
Not uninstalling setuptools at /usr/lib/python3/dist-packages, outside environment /usr
Successfully installed setuptools-41.0.1
Reading package lists...
Building dependency tree...
Reading state information...
git is already the newest version (1:2.11.0-3+deb9u4).
libglib2.0-dev is already the newest version (2.50.3-2).
0 upgraded, 0 newly installed, 0 to remove and 56 not upgraded.
Requirement already satisfied: pyudev in /usr/lib/python3/dist-packages
Requirement already satisfied: pyserial in /usr/lib/python3/dist-packages
Requirement already satisfied: requests in /usr/lib/python3/dist-packages
Cloning into 'bluepy'...
running build
running build_py
creating build
creating build/lib
creating build/lib/bluepy
copying bluepy/thingy52.py -> build/lib/bluepy
copying bluepy/sensortag.py -> build/lib/bluepy
copying bluepy/scanner.py -> build/lib/bluepy
copying bluepy/scan_fuzz.py -> build/lib/bluepy
copying bluepy/get_services.py -> build/lib/bluepy
copying bluepy/btle.py -> build/lib/bluepy
copying bluepy/blescan.py -> build/lib/bluepy
copying bluepy/__init__.py -> build/lib/bluepy
copying bluepy/uuids.json -> build/lib/bluepy
copying bluepy/bluez-src.tgz -> build/lib/bluepy
copying bluepy/bluepy-helper.c -> build/lib/bluepy
copying bluepy/Makefile -> build/lib/bluepy
running install
Working dir is /tmp/bluepy
execute make -C ./bluepy clean
execute make -C bluepy -j1
running build
running build_py
copying bluepy/bluepy-helper -> build/lib/bluepy
running install_lib
creating /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/bluepy-helper -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/Makefile -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/bluepy-helper.c -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/bluez-src.tgz -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/uuids.json -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/__init__.py -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/blescan.py -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/btle.py -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/get_services.py -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/scan_fuzz.py -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/scanner.py -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/sensortag.py -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/thingy52.py -> /usr/local/lib/python3.5/dist-packages/bluepy
byte-compiling /usr/local/lib/python3.5/dist-packages/bluepy/__init__.py to __init__.cpython-35.pyc
byte-compiling /usr/local/lib/python3.5/dist-packages/bluepy/blescan.py to blescan.cpython-35.pyc
byte-compiling /usr/local/lib/python3.5/dist-packages/bluepy/btle.py to btle.cpython-35.pyc
byte-compiling /usr/local/lib/python3.5/dist-packages/bluepy/get_services.py to get_services.cpython-35.pyc
byte-compiling /usr/local/lib/python3.5/dist-packages/bluepy/scan_fuzz.py to scan_fuzz.cpython-35.pyc
byte-compiling /usr/local/lib/python3.5/dist-packages/bluepy/scanner.py to scanner.cpython-35.pyc
byte-compiling /usr/local/lib/python3.5/dist-packages/bluepy/sensortag.py to sensortag.cpython-35.pyc
byte-compiling /usr/local/lib/python3.5/dist-packages/bluepy/thingy52.py to thingy52.cpython-35.pyc
running install_egg_info
running egg_info
creating bluepy.egg-info
writing bluepy.egg-info/PKG-INFO
writing dependency_links to bluepy.egg-info/dependency_links.txt
writing top-level names to bluepy.egg-info/top_level.txt
writing entry points to bluepy.egg-info/entry_points.txt
writing manifest file 'bluepy.egg-info/SOURCES.txt'
reading manifest file 'bluepy.egg-info/SOURCES.txt'
writing manifest file 'bluepy.egg-info/SOURCES.txt'
Copying bluepy.egg-info to /usr/local/lib/python3.5/dist-packages/bluepy-1.1.4-py3.5.egg-info
running install_scripts
Installing blescan script to /usr/local/bin
Installing thingy52 script to /usr/local/bin
Installing sensortag script to /usr/local/bin
Requirement already satisfied: cryptography in /usr/lib/python3/dist-packages
Requirement already satisfied: pycrypto in /usr/lib/python3/dist-packages
********************************************************
*			 Installation terminée					*
********************************************************
Tout est opérationnel
De nouvelles options sont apparues dans la configuration au niveau du demon (je rappelle que je n'avais pas fait de maj depuis mai)
Version Démon Local : 2.6.3
Deux messages dans le panneau global :
2019-07-29 18:06:19 blea Attention : installation des dépendances lancée
2019-07-29 18:02:57 blea Pensez à mettre à jour vos antennes et relancer leurs dépendances si besoin ...

En conclusion, cette maj a nécessité de relancer les dépendances, mais tout est ok

J'ai souhaité détailler la procédure pour partager mon REX
Jeedom RC V4.0.23
* DIY NUC 6I5SYK (Crucial 16GB Kit (8GBx2) DDR4 2133 MT/s) * Contrôleur Z-Wave AEOTEC GEN5 *
* VMWare ESXi 6.7.0 Update 3 (Build 14320388) * VM Jeedom Debian 9.5 avec 1 CPU/4 Go de mémoire * PHP 7.0.30-0 * Clé USB : SENA UD100

i-magin
Actif
Messages : 987
Inscription : 18 août 2015, 10:23
Localisation : Villeurbanne

Re: Plugin blea

Message par i-magin » 29 juil. 2019, 19:17

Une petite information complémentaire....

Ma compagne vient de rentrer et son Tracker Nut mini n'est pas détecté
Je me dis que la maj de BLEA peut y être pour quelque chose
Test de mon Nut FIND 3 dans le micro onde : la détection fonctionne bien

Je décide donc de changer la pile du Nut mini qui date du 15/09/2018
Et la détection fonctionne bien

Attention aux coïncidences et aux batteries faiblardes
Jeedom RC V4.0.23
* DIY NUC 6I5SYK (Crucial 16GB Kit (8GBx2) DDR4 2133 MT/s) * Contrôleur Z-Wave AEOTEC GEN5 *
* VMWare ESXi 6.7.0 Update 3 (Build 14320388) * VM Jeedom Debian 9.5 avec 1 CPU/4 Go de mémoire * PHP 7.0.30-0 * Clé USB : SENA UD100

Avatar de l’utilisateur
technarf
Timide
Messages : 124
Inscription : 30 mars 2017, 10:06

Re: Plugin blea

Message par technarf » 29 juil. 2019, 20:22

Bonjour,
Je rencontre un problème depuis la mise à jour du 29 juillet (ça ressemble fort à celui rencontré par d'autres)
Lorsque je lance les dépendances, j'ai ce log :

Code : Tout sélectionner

********************************************************
*			 Installation des dépendances			 *
********************************************************
Atteint:1 http://security.debian.org/debian-security stretch/updates InRelease
Ign:2 http://ftp.fr.debian.org/debian stretch InRelease
Atteint:3 http://ftp.fr.debian.org/debian stretch-updates InRelease
Atteint:4 http://ftp.fr.debian.org/debian stretch Release
Atteint:6 http://ftp.debian.org/debian stretch-backports InRelease
Lecture des listes de paquets…
Lecture des listes de paquets…
Construction de l'arbre des dépendances…
Lecture des informations d'état…
bluetooth is already the newest version (5.43-2+deb9u1).
libbluetooth-dev is already the newest version (5.43-2+deb9u1).
build-essential is already the newest version (12.3).
libffi-dev is already the newest version (3.2.1-6).
python3-serial is already the newest version (3.2.1-1).
python3-setuptools is already the newest version (33.1.1-1).
python3-dev is already the newest version (3.5.3-1).
python3-pyudev is already the newest version (0.21.0-1).
python3-requests is already the newest version (2.12.4-1).
rfkill is already the newest version (0.5-1+b1).
libssl-dev is already the newest version (1.1.0k-1~deb9u1).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Lecture des listes de paquets…
Construction de l'arbre des dépendances…
Lecture des informations d'état…
debconf: Impossible d'initialiser l'interface : Dialog
debconf: (L'interface dialog ne fonctionnera pas avec un terminal rustique (« dumb »), un tampon shell d'Emacs ou sans terminal de contrôle.)
debconf: Utilisation de l'interface Readline en remplacement
debconf: Impossible d'initialiser l'interface : Readline
debconf: (Cette interface a besoin d'un terminal de contrôle.)
debconf: Utilisation de l'interface Teletype en remplacement
dpkg-preconfigure: impossible de réouvrir stdin :
0 mis à jour, 0 nouvellement installés, 1 réinstallés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 0 o/142 ko dans les archives.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
(Lecture de la base de données... 
(Lecture de la base de données... 5%
(Lecture de la base de données... 10%
(Lecture de la base de données... 15%
(Lecture de la base de données... 20%
(Lecture de la base de données... 25%
(Lecture de la base de données... 30%
(Lecture de la base de données... 35%
(Lecture de la base de données... 40%
(Lecture de la base de données... 45%
(Lecture de la base de données... 50%
(Lecture de la base de données... 55%
(Lecture de la base de données... 60%
(Lecture de la base de données... 65%
(Lecture de la base de données... 70%
(Lecture de la base de données... 75%
(Lecture de la base de données... 80%
(Lecture de la base de données... 85%
(Lecture de la base de données... 90%
(Lecture de la base de données... 95%
(Lecture de la base de données... 100%
(Lecture de la base de données... 74446 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../python3-pip_9.0.1-2+deb9u1_all.deb ...
Dépaquetage de python3-pip (9.0.1-2+deb9u1) sur (9.0.1-2+deb9u1) ...
Paramétrage de python3-pip (9.0.1-2+deb9u1) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.6.1-2) ...
Requirement already up-to-date: setuptools in /usr/local/lib/python3.6/site-packages (41.0.1)
Lecture des listes de paquets…
Construction de l'arbre des dépendances…
Lecture des informations d'état…
git is already the newest version (1:2.11.0-3+deb9u4).
libglib2.0-dev is already the newest version (2.50.3-2).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Requirement already satisfied: pyudev in /usr/local/lib/python3.6/site-packages (0.21.0)
Requirement already satisfied: six in /usr/local/lib/python3.6/site-packages (from pyudev) (1.12.0)
Requirement already satisfied: pyserial in /usr/local/lib/python3.6/site-packages (3.4)
Requirement already satisfied: requests in /usr/local/lib/python3.6/site-packages (2.21.0)
Requirement already satisfied: chardet<3.1.0,>=3.0.2 in /usr/local/lib/python3.6/site-packages (from requests) (3.0.4)
Requirement already satisfied: urllib3<1.25,>=1.21.1 in /usr/local/lib/python3.6/site-packages (from requests) (1.24.1)
Requirement already satisfied: idna<2.9,>=2.5 in /usr/local/lib/python3.6/site-packages (from requests) (2.8)
Requirement already satisfied: certifi>=2017.4.17 in /usr/local/lib/python3.6/site-packages (from requests) (2018.11.29)
Clonage dans 'bluepy'...
running build
running build_py
creating build
creating build/lib
creating build/lib/bluepy
copying bluepy/scan_fuzz.py -> build/lib/bluepy
copying bluepy/blescan.py -> build/lib/bluepy
copying bluepy/__init__.py -> build/lib/bluepy
copying bluepy/btle.py -> build/lib/bluepy
copying bluepy/get_services.py -> build/lib/bluepy
copying bluepy/scanner.py -> build/lib/bluepy
copying bluepy/thingy52.py -> build/lib/bluepy
copying bluepy/sensortag.py -> build/lib/bluepy
copying bluepy/uuids.json -> build/lib/bluepy
copying bluepy/bluez-src.tgz -> build/lib/bluepy
copying bluepy/bluepy-helper.c -> build/lib/bluepy
copying bluepy/Makefile -> build/lib/bluepy
running install
Working dir is /tmp/bluepy
execute make -C ./bluepy clean
execute make -C bluepy -j1
running build
running build_py
copying bluepy/bluepy-helper -> build/lib/bluepy
running install_lib
copying build/lib/bluepy/Makefile -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/scan_fuzz.py -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/blescan.py -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/uuids.json -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/__init__.py -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/btle.py -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/get_services.py -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/scanner.py -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/bluez-src.tgz -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/bluepy-helper -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/thingy52.py -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/sensortag.py -> /usr/local/lib/python3.5/dist-packages/bluepy
copying build/lib/bluepy/bluepy-helper.c -> /usr/local/lib/python3.5/dist-packages/bluepy
byte-compiling /usr/local/lib/python3.5/dist-packages/bluepy/scan_fuzz.py to scan_fuzz.cpython-35.pyc
byte-compiling /usr/local/lib/python3.5/dist-packages/bluepy/blescan.py to blescan.cpython-35.pyc
byte-compiling /usr/local/lib/python3.5/dist-packages/bluepy/__init__.py to __init__.cpython-35.pyc
byte-compiling /usr/local/lib/python3.5/dist-packages/bluepy/btle.py to btle.cpython-35.pyc
byte-compiling /usr/local/lib/python3.5/dist-packages/bluepy/get_services.py to get_services.cpython-35.pyc
byte-compiling /usr/local/lib/python3.5/dist-packages/bluepy/scanner.py to scanner.cpython-35.pyc
byte-compiling /usr/local/lib/python3.5/dist-packages/bluepy/thingy52.py to thingy52.cpython-35.pyc
byte-compiling /usr/local/lib/python3.5/dist-packages/bluepy/sensortag.py to sensortag.cpython-35.pyc
running install_egg_info
running egg_info
creating bluepy.egg-info
writing dependency_links to bluepy.egg-info/dependency_links.txt
writing entry points to bluepy.egg-info/entry_points.txt
writing top-level names to bluepy.egg-info/top_level.txt
writing bluepy.egg-info/PKG-INFO
writing manifest file 'bluepy.egg-info/SOURCES.txt'
reading manifest file 'bluepy.egg-info/SOURCES.txt'
writing manifest file 'bluepy.egg-info/SOURCES.txt'
removing '/usr/local/lib/python3.5/dist-packages/bluepy-1.1.4.egg-info' (and everything under it)
Copying bluepy.egg-info to /usr/local/lib/python3.5/dist-packages/bluepy-1.1.4.egg-info
running install_scripts
Installing thingy52 script to /usr/local/bin
Installing blescan script to /usr/local/bin
Installing sensortag script to /usr/local/bin
Requirement already satisfied: cryptography in /usr/local/lib/python3.6/site-packages (2.7)
Requirement already satisfied: asn1crypto>=0.21.0 in /usr/local/lib/python3.6/site-packages (from cryptography) (0.24.0)
Requirement already satisfied: cffi!=1.11.3,>=1.8 in /usr/local/lib/python3.6/site-packages (from cryptography) (1.12.3)
Requirement already satisfied: six>=1.4.1 in /usr/local/lib/python3.6/site-packages (from cryptography) (1.12.0)
Requirement already satisfied: pycparser in /usr/local/lib/python3.6/site-packages (from cffi!=1.11.3,>=1.8->cryptography) (2.19)
Requirement already satisfied: pycrypto in /usr/local/lib/python3.6/site-packages (2.6.1)
********************************************************
*			 Installation terminée					*
********************************************************
De ce que j'en vois, tout semble OK selon la log mais les dépendances restent désespérément en NOK malgré de nombreux essais de réinstallation.
Impossible de relancer le démon du fait que les dépendances sont considérées comme KO.
Si quelqu'un a la solution, je suis preneur, en attendant, je restaure une sauvegarde.
(pour info je suis sous stretch)

benj29
Actif
Messages : 3978
Inscription : 26 mars 2017, 09:57
Contact :

Re: Plugin blea

Message par benj29 » 29 juil. 2019, 21:30

propositionjoe a écrit :
29 juil. 2019, 16:47
benj29 a écrit :
29 juil. 2019, 16:43
Pourquoi s'entêter à rester sous Jessie ?
Exception faite pour les antennes,
Y a encore pas mal d'images qui tournent sous Jessie.
Salut propositionjoe. Oui pour les antennes, je peux comprendre.
Après j'ai passé mon Jeedom sous Debian9 il y a plus d'un an.
Après un premier déboire (blea en VM) que j'ai payé, tout a très bien roulé.

Du coup quelques mois plus tard, je me suis pris par la main et j'ai sauté le pas.
Faut dire qu'une image de PI3 avec juste BLEA ce n'est pas le plus long à faire.
Surtout quand la première est faite, etcher !

Comme dit Akenad, autant sauter le pas pour être à jour.
C'est malheureusement un peu la tendance actuelle.
Ou alors il ne faut plus chercher les mises à jour !

Avatar de l’utilisateur
DuplO
Actif
Messages : 715
Inscription : 17 sept. 2015, 14:04

Re: Plugin blea

Message par DuplO » 30 juil. 2019, 10:24

Bonjour,

j'ai aussi un souci avec mon MiFlora depuis quelques semaines, voici ce que j'ai :

Santé du plugin Blea :
Image

Santé du MiFlora :
Image

Voici les logs Blea :

Code : Tout sélectionner

[2019-07-30 08:04:09.091][DEBUG] : SCANNER------[(1, 'Flags', '06'), (2, 'Incomplete 16b Services', '0000fe95-0000-1000-8000-00805f9b34fb'), (22, '16b Service Data', '95fe31029800000d4d628d7cc40d'), (9, 'Complete Local Name', 'Flower mate')] True public c4:7c:8d:62:4d:0d
[2019-07-30 08:04:09.093][DEBUG] : SCANNER------This is a miflora device c4:7c:8d:62:4d:0d
[2019-07-30 08:04:09.094][DEBUG] : Xiaomi Flower Care PARSE data: 95fe31029800000d4d628d7cc40d
[2019-07-30 08:04:09.095][DEBUG] : {'rssi': -74, 'present': 1, 'name': 'Flower mate', 'source': 'local', 'type': 'miflora', 'id': 'C4:7C:8D:62:4D:0D'}
[2019-07-30 08:04:09.296][DEBUG] : Send to jeedom : {'devices': {'C4:7C:8D:62:4D:0D': {'rssi': -74, 'present': 1, 'name': 'Flower mate', 'source': 'local', 'type': 'miflora', 'id': 'C4:7C:8D:62:4D:0D'}}}
J'ai envie de dire que jusqu'ici tout va bien.
Par contre les infos du MiFlora ne se mettent pas à jour au niveau du Device et de même sur le design :
Image

J'ai réussi à avoir une remontée d'info vendredi dernier après avoir relancé l'installation des dépendances et redémarrage du démon.
Mais depuis rien, même en le refaisant.
Par contre j'ai d'autre objets connectés via Blea qui fonctionnent bien : des nuts et une sonde Xiaomi temp/hydro.

Une idée ?

Merci

======================
PS : dans les logs on peut voir 'Incomplete 16b Services'. Le problème peut venir de là ?
======================
PPS : j'ai retrouvé mon MiFlora depuis 30 minutes, j'ai fait plusieurs manips mais celle qui semble avoir fonctionné est de décocher la case Activé dans l'équipement lui même, sauvegarder, recocher la case et sauvegarder une dernière fois.
Si ça peut servir à quelqu'un :)

i-magin
Actif
Messages : 987
Inscription : 18 août 2015, 10:23
Localisation : Villeurbanne

Re: Plugin blea

Message par i-magin » 30 juil. 2019, 11:49

Bonjour

Hier soir, j'ai exécuté l'option avancée "Configs modules" que l'on trouve dans la configuration du plugin BLEA :
- On obtient ce message "Etes-vous sûr de vouloir télécharger les dernières configurations des modules ? Ceci relancera le plugin Blea"
- j'ai validé le message et une nouvelle log s'est créée : "Blea-syncconf"
En voici son contenu :

Code : Tout sélectionner

Lancement de la synchronisation des configurations
Déplacement dans le répertoire de travail
Récupération des sources (cette étape peut durer quelques minutes)
Cloning into 'plugin-blea'...
Suppression des configurations Jeedom existantes
Copie des nouvelles configurations Jeedom
awoxmesh
beagle
beewismartdoor
blpnr
default
dotti
dreamscreen
fitbit
flowerpower
gigaset
hector
itag
jinlin
kst1
logiswitch
lywsd02
meyerdom4contacts
miband
miflora
miscale
miscale2
myfox
niu
noke
nut
parrotpot
playbulb
ropot
ruuvi
smartplug
tb05
ticatag
tile
wistiki
xiaomiht
yeelight
Suppression des configurations Blea python existantes
Copie des nouvelles configurations Blea Python
__init__.py
awoxmesh.py
beagle.py
beewismartdoor.py
blpnr.py
dotti.py
dreamscreen.py
fitbit.py
gigaset.py
hector.py
itag.py
jinlin.py
kst1.py
logiswitch.py
lywsd02.py
meyerdom4contacts.py
miband.py
miband2.py
miband3.py
miband4.py
miflora.py
miscale.py
miscale2.py
myfox.py
niu.py
noke.py
nut.py
parrotplant.py
playbulb.py
ropot.py
ruuvi.py
smartplug.py
tb05.py
ticatag.py
tile.py
wistiki.py
xiaomiht.py
yeelight.py
yeelightcandela.py
Nettoyage du répertoire de travail
Vos configurations sont maintenant à jour !
Le démon va se relancer, vous pouvez fermer cette fenêtre
La dernière information précise donc que "Le demon va se relancer"... ce qui n'a pas été le cas (j'ai toujours la date et heure du dernier lancement suite à maj du plugin)
Est-ce que le fait de ne pas avoir l'option "Redémarrer démon" activée a pu empêcher le redémarrage ?
Dans la doc, il est précisé :
Dernière étape optionnelle mais recommandée: activez la gestion automatique du démon en cliquant sur le bouton correspondant. Cela fera en sorte que le plugin tentera de relancer automatiquement le démon distant en cas de perte de connexion (pratique si votre pi distant a été temporairement débranché du secteur ou qu’il a été redémarré suite à des mises à jours).
Il n'est pas indiqué que cela est nécessaire dans la procédure de configurations des modules

Dans le changelog en date du 20/07/2019, il est précisé :
Rajout de la possibilité de récupérer les nouvelles configurations sans mettre à jour le plugin
En résumé :
- Est-ce que le redémarrage du demon BLEA est nécessaire après l'exécution de "Configs modules" ?
- Le lancement est théoriquement automatique. Pour cela faut-il cocher l'option "Redémarrer démon" ?
- La relance des dépendances ne semble pas nécessaire

J'en profite pour remercier le helper @Fabrice qui assure le relais sur les questions posées
Jeedom RC V4.0.23
* DIY NUC 6I5SYK (Crucial 16GB Kit (8GBx2) DDR4 2133 MT/s) * Contrôleur Z-Wave AEOTEC GEN5 *
* VMWare ESXi 6.7.0 Update 3 (Build 14320388) * VM Jeedom Debian 9.5 avec 1 CPU/4 Go de mémoire * PHP 7.0.30-0 * Clé USB : SENA UD100

Répondre

Revenir vers « [Plugin Officiel] BLEA »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 9 invités