Ce Forum passera en lecture seule en janvier 2020
Image
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

[Plugin Tiers] Plugin Alexa-API

Pour échanger sur les plugins classés en catégorie "Communication"
Scholl
Timide
Messages : 85
Inscription : 17 oct. 2017, 21:03

Re: [Plugin Tiers] Plugin Alexa-API

Message par Scholl » 05 août 2019, 19:36

Didier3L a écrit :
25 juil. 2019, 18:05
Bonjour
j'ai un problème avec le demon du plugin qui est NOK :(

J'ai relancé les dépendances, refait le cookies

Code : Tout sélectionner

[2019-7-25 16:00:08] Alexa-API: ******************** Lancement Serveur ***********************
[2019-7-25 16:00:08] Alexa-Remote: cookie was provided
[2019-7-25 16:00:08] Alexa-API: Error while initializing alexa
[2019-7-25 16:00:08] Alexa-API: Error: no csrf found
Bonjour,
J'ai le même problème, le demon se relance avec la Béta OUUUF
Merci

jbltpcblt
Timide
Messages : 14
Inscription : 25 août 2017, 07:48

Re: [Plugin Tiers] Plugin Alexa-API

Message par jbltpcblt » 08 août 2019, 09:37

Bonjour,
Alexaapi version bêta.
Depuis quelques temps je dois relancer le démon pour que alexaapi fonctionne normalement.

log avant relancement du deamon :


[2019-08-08 09:15:03][DEBUG] : ---------------------------------------------DEBUT CRON-*/15 * * * *-----------------------
[2019-08-08 09:15:06][DEBUG] : updating online status of Alexa Chambre to true
[2019-08-08 09:15:06][DEBUG] : updating online status of Alexa Echo Sub to true
[2019-08-08 09:15:06][DEBUG] : updating online status of Alexa Salle de bain to true
[2019-08-08 09:15:06][DEBUG] : updating online status of Alexa Living Gauche to true
[2019-08-08 09:15:06][DEBUG] : updating online status of Alexa Living Droite to true
[2019-08-08 09:15:06][DEBUG] : updating online status of Partout to true
[2019-08-08 09:15:06][DEBUG] : updating online status of Alexa Bureau to true
[2019-08-08 09:15:06][DEBUG] : updating online status of Piece Principale to true
[2019-08-08 09:15:06][DEBUG] : updating online status of Paire de caissons de basses stéréo to true
[2019-08-08 09:15:06][DEBUG] : updating online status of Alexa Cuisine to true
[2019-08-08 09:15:06][DEBUG] : capabilities : "ACTIVE_AFTER_FRO, PERSISTENT_CONNECTION, SLEEP, TIMERS_ALARMS_NOTIFICATIONS_VOLUME, EARCONS, TUPLE, CHANGE_NAME, FLASH_BRIEFING, MICROPHONE, ALLOW_LOG_UPLOAD, DEREGISTER_DEVICE, SUPPORTS_SOFTWARE_VERSION, REQUIRES_OOBE_FOR_SETUP, VOLUME_SETTING, SOUND_SETTINGS, SUPPORTS_CONNECTED_HOME_CLOUD_ONLY, TUPLE_CATEGORY_C, UPDATE_WIFI"
[2019-08-08 09:15:06][DEBUG] : -----------------------------Test NON Lancé sur *Alexa Echo Sub*------------------------
[2019-08-08 09:15:06][DEBUG] : capabilities : "ACTIVE_AFTER_FRO, PERSISTENT_CONNECTION, GADGETS, TAHOE_BYOD, PAIR_REMOTE, GOLDFISH, DREAM_TRAINING, CHANGE_NAME, FAR_FIELD_WAKE_WORD, DS_VOLUME_SETTING, ALLOW_LOG_UPLOAD, DEREGISTER_DEVICE, DIALOG_INTERFACE_VERSION, REQUIRES_OOBE_FOR_SETUP, SET_LOCALE, AUX_SETTINGS, SUPPORTS_CONNECTED_HOME_CLOUD_ONLY, AUDIO_PLAYER, POPTART, KINDLE_BOOKS, TUPLE_CATEGORY_A, PAIR_BT_SINK, SLEEP, TIMERS_ALARMS_NOTIFICATIONS_VOLUME, EARCONS, AUDIBLE, TEMPERATURE_SENSOR, TUPLE, CUSTOM_ALARM_TONE, MUSIC_SKILL, FLASH_BRIEFING, MICROPHONE, LOCAL_VOICE, REMINDERS, LEMUR_ALPHA, SUPPORTS_SOFTWARE_VERSION, VOLUME_SETTING, TIMERS_AND_ALARMS, ALEXA_PRESENCE, SUPPORT_CALENDAR_ALERT, VOICE_TRAINING, ASCENDING_ALARM_VOLUME, SOUND_SETTINGS, PAIR_BT_SOURCE, UPDATE_WIFI"
[2019-08-08 09:15:06][DEBUG] : -----------------------------Test Lancé sur *Alexa Living Droite*------------------------
[2019-08-08 09:15:06][DEBUG] : buildReminderRequest
[2019-08-08 09:15:06][INFO] : Request : http://10.89.66.93:3456/reminder?text=t ... 04845302G1
[2019-08-08 09:15:07][DEBUG] : Result : {}
[2019-08-08 09:15:07][DEBUG] : **********************Suppression Reminder id**A18O6U1UQFJ0XK-G2A0U204845302G1-6b7e4b1b-5b88-4b5c-9005-33a90c2f6699*********************************
[2019-08-08 09:15:07][DEBUG] : builddeleteReminderRequest
[2019-08-08 09:15:07][INFO] : Request : http://10.89.66.93:3456/deleteReminder? ... 04845302G1
[2019-08-08 09:15:07][DEBUG] : Result : {}
[2019-08-08 09:15:07][DEBUG] : ********************** TROUVE le Reminder 2060 donc c'est OK**********************************
[2019-08-08 09:15:09][DEBUG] : capabilities : "ACTIVE_AFTER_FRO, PERSISTENT_CONNECTION, GADGETS, TAHOE_BYOD, PAIR_REMOTE, GOLDFISH, DREAM_TRAINING, CHANGE_NAME, FAR_FIELD_WAKE_WORD, DS_VOLUME_SETTING, ALLOW_LOG_UPLOAD, DEREGISTER_DEVICE, DIALOG_INTERFACE_VERSION, REQUIRES_OOBE_FOR_SETUP, SET_LOCALE, AUX_SETTINGS, SUPPORTS_CONNECTED_HOME_CLOUD_ONLY, AUDIO_PLAYER, POPTART, KINDLE_BOOKS, TUPLE_CATEGORY_A, PAIR_BT_SINK, SLEEP, TIMERS_ALARMS_NOTIFICATIONS_VOLUME, EARCONS, AUDIBLE, TEMPERATURE_SENSOR, TUPLE, CUSTOM_ALARM_TONE, MUSIC_SKILL, FLASH_BRIEFING, MICROPHONE, LOCAL_VOICE, REMINDERS, LEMUR_ALPHA, SUPPORTS_SOFTWARE_VERSION, VOLUME_SETTING, TIMERS_AND_ALARMS, ALEXA_PRESENCE, SUPPORT_CALENDAR_ALERT, VOICE_TRAINING, ASCENDING_ALARM_VOLUME, SOUND_SETTINGS, PAIR_BT_SOURCE, UPDATE_WIFI"
[2019-08-08 09:15:09][DEBUG] : -----------------------------Test Lancé sur *Alexa Living Gauche*------------------------
[2019-08-08 09:15:09][DEBUG] : Connexion close non détectée dans le CRON. Tout va bien.
[2019-08-08 09:15:23][DEBUG] : buildNextAlarmRequest sur Next Alarm When
[2019-08-08 09:15:23][INFO] : Request : http://10.89.66.93:3456/whennextalarm?p ... 1181740UT2
[2019-08-08 09:15:23][DEBUG] : Result : {"status":500,"title":"Alexa.whennextalarm","detail":"Retour vide"}
[2019-08-08 09:15:23][DEBUG] : buildNextMusicalAlarmRequest
[2019-08-08 09:15:23][INFO] : Request : http://10.89.66.93:3456/whennextmusical ... 1181740UT2
[2019-08-08 09:15:24][DEBUG] : Result : {"status":500,"title":"Alexa.whennextalarm","detail":"Retour vide"}
[2019-08-08 09:15:24][DEBUG] : buildNextReminderRequest
[2019-08-08 09:15:24][INFO] : Request : http://10.89.66.93:3456/whennextreminde ... 1181740UT2
[2019-08-08 09:15:24][DEBUG] : Result : {"status":500,"title":"Alexa.whennextreminder","detail":"Retour vide"}
[2019-08-08 09:19:49][DEBUG] : buildSpeakRequest
[2019-08-08 09:19:49][INFO] : Request : http://10.89.66.93:3456/speak?text=essa ... 08819403XD
[2019-08-08 09:19:49][DEBUG] : Result : {"value":"Send"}



Redémarrage du démon, tout est ok est la commande speak fonctionne.

09:28:16][INFO] : Arrêt du service alexaapi
[2019-08-08 09:28:16][INFO] : Arrêt du service alexaapi
[2019-08-08 09:28:16][INFO] : Lancement du démon alexaapi
[2019-08-08 09:28:16][DEBUG] : Lancement démon alexaapi : nice -n 19 nodejs /var/www/html/plugins/alexaapi/resources/alexaapi.js 10.89.66.93 amazon.fr alexa.amazon.fr
[2019-08-08 09:28:16][INFO] : Démon alexaapi lancé
[2019-08-08 09:28:32][DEBUG] : buildSpeakRequest
[2019-08-08 09:28:32][INFO] : Request : http://10.89.66.93:3456/speak?text=essa ... 08819403XD
[2019-08-08 09:28:32][DEBUG] : Result : {"value":"Send"}


Quelqu'un d'autre à le même problème ? comment y remédier.
Pour info :
J’ai déjà essayer les classiques, suppression des alexa, désinstallation du plugin, réinstallation de celui-ci, Scan des alexa, ….

Avatar de l’utilisateur
tomdom
Actif
Messages : 925
Inscription : 14 nov. 2016, 05:46

Re: [Plugin Tiers] Plugin Alexa-API

Message par tomdom » 08 août 2019, 12:00

Bonjour,

J'ai le même problème. Me concernant il n'y a que la fonction speak qui ne fonctionne pas sans relancer le service. Les autres fonctions que j'utilise sont ok
Il y a 10 catégories de personnes, celles qui connaissent le binaire et les autres
.

Avatar de l’utilisateur
coyote
Timide
Messages : 56
Inscription : 28 juil. 2015, 09:31

Re: [Plugin Tiers] Plugin Alexa-API

Message par coyote » 08 août 2019, 17:07

donch56 a écrit :
27 juil. 2019, 23:10
Salut,
Depuis la dernière MAJ, les accents semblent bizarrement gérer dans ce que dit alexa. Par exemple, "alarme activée" se dit "alarme activae" et "bonne journée" se dit "bonne journae".... pareil chez vous?
depuis que je suis passé en béta, j'ai la même chose: nettement moins WAF :( j'ai bien vu la réponse de Nebz... le stagiaire amazon est rentré et a fait encore des siennes :oops:

Peut-être une idée de contournement (comme la béta déja) car ca vient peut être de la conversion faite dans la chaine de caractère pour les accents (UTF...) ?
Jeedom depuis 2015
Rapsberry pi3 / clé AOEN Z-Wave / RFXCOM / clé 3G / SSD
Modules ZWAVE Fibaro actionneurs simples et doubles + volet roulants
xiaomi aqara + capteurs ouverture/présence
sondes OREGON THGN132N/THGR122N
Alexa echo SPOT et DOT

Dje
Timide
Messages : 15
Inscription : 09 févr. 2019, 20:00

Re: [Plugin Tiers] Plugin Alexa-API

Message par Dje » 09 août 2019, 16:07

Bonjour à tous,

suite au dysfonctionnement sur le plugin stable, j'ai désinstallé et réinstallé la version Beta cependant je ne peux pas m'identifier pour la création du cookie Amazon. J'ai bien une fenêtre qui s'ouvre mais j'ai ce message " Ce site est inaccessible 169.254.xx.xx a mis trop de temps à répondre.
Effectuez une recherche Google sur 169 254 xxxx.
ERR_CONNECTION_TIMED_OUT ".

Etant novice je ne vois pas d'où vient le problème... Si quelqu'un à une piste je suis preneur

Avatar de l’utilisateur
Nebz
Modérateur
Messages : 6489
Inscription : 23 avr. 2017, 01:37
Localisation : Belgique

Re: [Plugin Tiers] Plugin Alexa-API

Message par Nebz » 10 août 2019, 11:42

Dje a écrit :Bonjour à tous,

suite au dysfonctionnement sur le plugin stable, j'ai désinstallé et réinstallé la version Beta cependant je ne peux pas m'identifier pour la création du cookie Amazon. J'ai bien une fenêtre qui s'ouvre mais j'ai ce message " Ce site est inaccessible 169.254.xx.xx a mis trop de temps à répondre.
Effectuez une recherche Google sur 169 254 xxxx.
ERR_CONNECTION_TIMED_OUT ".

Etant novice je ne vois pas d'où vient le problème... Si quelqu'un à une piste je suis preneur
Hello,

Premièrement pas besoin de desinstaller pour passer de l'un à l'autre, tu peux simplement installer l'autre branche.

Deuxièmement, tu dois configurer ton ip interne dans jeedom > configuration > réseau


Envoyé de mon iPhone en utilisant Tapatalk
Dev plugin Homebridge

- Fournissez les logs, la capture de vos commandes et vos types génériques svp
- Constructif et bonne humeur, on est pas là pour se lancer des périfs z-wave à la figure :-)

Un petit don ça fait toujours plaisir :)

yala37
Timide
Messages : 46
Inscription : 15 juil. 2016, 10:32

[Plugin Tiers] Plugin Alexa-API

Message par yala37 » 10 août 2019, 22:04

Hello, cf message suivant, merci d’avance.
Dernière édition par yala37 le 10 août 2019, 22:04, édité 1 fois.

yala37
Timide
Messages : 46
Inscription : 15 juil. 2016, 10:32

Re: [Plugin Tiers] Plugin Alexa-API

Message par yala37 » 10 août 2019, 22:09

jbltpcblt a écrit :Bonjour,
Alexaapi version bêta.
Depuis quelques temps je dois relancer le démon pour que alexaapi fonctionne normalement.

log avant relancement du deamon :


[2019-08-08 09:15:03][DEBUG] : ---------------------------------------------DEBUT CRON-*/15 * * * *-----------------------
[2019-08-08 09:15:06][DEBUG] : updating online status of Alexa Chambre to true
[2019-08-08 09:15:06][DEBUG] : updating online status of Alexa Echo Sub to true
[2019-08-08 09:15:06][DEBUG] : updating online status of Alexa Salle de bain to true
[2019-08-08 09:15:06][DEBUG] : updating online status of Alexa Living Gauche to true
[2019-08-08 09:15:06][DEBUG] : updating online status of Alexa Living Droite to true
[2019-08-08 09:15:06][DEBUG] : updating online status of Partout to true
[2019-08-08 09:15:06][DEBUG] : updating online status of Alexa Bureau to true
[2019-08-08 09:15:06][DEBUG] : updating online status of Piece Principale to true
[2019-08-08 09:15:06][DEBUG] : updating online status of Paire de caissons de basses stéréo to true
[2019-08-08 09:15:06][DEBUG] : updating online status of Alexa Cuisine to true
[2019-08-08 09:15:06][DEBUG] : capabilities : "ACTIVE_AFTER_FRO, PERSISTENT_CONNECTION, SLEEP, TIMERS_ALARMS_NOTIFICATIONS_VOLUME, EARCONS, TUPLE, CHANGE_NAME, FLASH_BRIEFING, MICROPHONE, ALLOW_LOG_UPLOAD, DEREGISTER_DEVICE, SUPPORTS_SOFTWARE_VERSION, REQUIRES_OOBE_FOR_SETUP, VOLUME_SETTING, SOUND_SETTINGS, SUPPORTS_CONNECTED_HOME_CLOUD_ONLY, TUPLE_CATEGORY_C, UPDATE_WIFI"
[2019-08-08 09:15:06][DEBUG] : -----------------------------Test NON Lancé sur *Alexa Echo Sub*------------------------
[2019-08-08 09:15:06][DEBUG] : capabilities : "ACTIVE_AFTER_FRO, PERSISTENT_CONNECTION, GADGETS, TAHOE_BYOD, PAIR_REMOTE, GOLDFISH, DREAM_TRAINING, CHANGE_NAME, FAR_FIELD_WAKE_WORD, DS_VOLUME_SETTING, ALLOW_LOG_UPLOAD, DEREGISTER_DEVICE, DIALOG_INTERFACE_VERSION, REQUIRES_OOBE_FOR_SETUP, SET_LOCALE, AUX_SETTINGS, SUPPORTS_CONNECTED_HOME_CLOUD_ONLY, AUDIO_PLAYER, POPTART, KINDLE_BOOKS, TUPLE_CATEGORY_A, PAIR_BT_SINK, SLEEP, TIMERS_ALARMS_NOTIFICATIONS_VOLUME, EARCONS, AUDIBLE, TEMPERATURE_SENSOR, TUPLE, CUSTOM_ALARM_TONE, MUSIC_SKILL, FLASH_BRIEFING, MICROPHONE, LOCAL_VOICE, REMINDERS, LEMUR_ALPHA, SUPPORTS_SOFTWARE_VERSION, VOLUME_SETTING, TIMERS_AND_ALARMS, ALEXA_PRESENCE, SUPPORT_CALENDAR_ALERT, VOICE_TRAINING, ASCENDING_ALARM_VOLUME, SOUND_SETTINGS, PAIR_BT_SOURCE, UPDATE_WIFI"
[2019-08-08 09:15:06][DEBUG] : -----------------------------Test Lancé sur *Alexa Living Droite*------------------------
[2019-08-08 09:15:06][DEBUG] : buildReminderRequest
[2019-08-08 09:15:06][INFO] : Request : http://10.89.66.93:3456/reminder?text=t ... 04845302G1
[2019-08-08 09:15:07][DEBUG] : Result : {}
[2019-08-08 09:15:07][DEBUG] : **********************Suppression Reminder id**A18O6U1UQFJ0XK-G2A0U204845302G1-6b7e4b1b-5b88-4b5c-9005-33a90c2f6699*********************************
[2019-08-08 09:15:07][DEBUG] : builddeleteReminderRequest
[2019-08-08 09:15:07][INFO] : Request : http://10.89.66.93:3456/deleteReminder? ... 04845302G1
[2019-08-08 09:15:07][DEBUG] : Result : {}
[2019-08-08 09:15:07][DEBUG] : ********************** TROUVE le Reminder 2060 donc c'est OK**********************************
[2019-08-08 09:15:09][DEBUG] : capabilities : "ACTIVE_AFTER_FRO, PERSISTENT_CONNECTION, GADGETS, TAHOE_BYOD, PAIR_REMOTE, GOLDFISH, DREAM_TRAINING, CHANGE_NAME, FAR_FIELD_WAKE_WORD, DS_VOLUME_SETTING, ALLOW_LOG_UPLOAD, DEREGISTER_DEVICE, DIALOG_INTERFACE_VERSION, REQUIRES_OOBE_FOR_SETUP, SET_LOCALE, AUX_SETTINGS, SUPPORTS_CONNECTED_HOME_CLOUD_ONLY, AUDIO_PLAYER, POPTART, KINDLE_BOOKS, TUPLE_CATEGORY_A, PAIR_BT_SINK, SLEEP, TIMERS_ALARMS_NOTIFICATIONS_VOLUME, EARCONS, AUDIBLE, TEMPERATURE_SENSOR, TUPLE, CUSTOM_ALARM_TONE, MUSIC_SKILL, FLASH_BRIEFING, MICROPHONE, LOCAL_VOICE, REMINDERS, LEMUR_ALPHA, SUPPORTS_SOFTWARE_VERSION, VOLUME_SETTING, TIMERS_AND_ALARMS, ALEXA_PRESENCE, SUPPORT_CALENDAR_ALERT, VOICE_TRAINING, ASCENDING_ALARM_VOLUME, SOUND_SETTINGS, PAIR_BT_SOURCE, UPDATE_WIFI"
[2019-08-08 09:15:09][DEBUG] : -----------------------------Test Lancé sur *Alexa Living Gauche*------------------------
[2019-08-08 09:15:09][DEBUG] : Connexion close non détectée dans le CRON. Tout va bien.
[2019-08-08 09:15:23][DEBUG] : buildNextAlarmRequest sur Next Alarm When
[2019-08-08 09:15:23][INFO] : Request : http://10.89.66.93:3456/whennextalarm?p ... 1181740UT2
[2019-08-08 09:15:23][DEBUG] : Result : {"status":500,"title":"Alexa.whennextalarm","detail":"Retour vide"}
[2019-08-08 09:15:23][DEBUG] : buildNextMusicalAlarmRequest
[2019-08-08 09:15:23][INFO] : Request : http://10.89.66.93:3456/whennextmusical ... 1181740UT2
[2019-08-08 09:15:24][DEBUG] : Result : {"status":500,"title":"Alexa.whennextalarm","detail":"Retour vide"}
[2019-08-08 09:15:24][DEBUG] : buildNextReminderRequest
[2019-08-08 09:15:24][INFO] : Request : http://10.89.66.93:3456/whennextreminde ... 1181740UT2
[2019-08-08 09:15:24][DEBUG] : Result : {"status":500,"title":"Alexa.whennextreminder","detail":"Retour vide"}
[2019-08-08 09:19:49][DEBUG] : buildSpeakRequest
[2019-08-08 09:19:49][INFO] : Request : http://10.89.66.93:3456/speak?text=essa ... 08819403XD
[2019-08-08 09:19:49][DEBUG] : Result : {"value":"Send"}



Redémarrage du démon, tout est ok est la commande speak fonctionne.

09:28:16][INFO] : Arrêt du service alexaapi
[2019-08-08 09:28:16][INFO] : Arrêt du service alexaapi
[2019-08-08 09:28:16][INFO] : Lancement du démon alexaapi
[2019-08-08 09:28:16][DEBUG] : Lancement démon alexaapi : nice -n 19 nodejs /var/www/html/plugins/alexaapi/resources/alexaapi.js 10.89.66.93 amazon.fr alexa.amazon.fr
[2019-08-08 09:28:16][INFO] : Démon alexaapi lancé
[2019-08-08 09:28:32][DEBUG] : buildSpeakRequest
[2019-08-08 09:28:32][INFO] : Request : http://10.89.66.93:3456/speak?text=essa ... 08819403XD
[2019-08-08 09:28:32][DEBUG] : Result : {"value":"Send"}


Quelqu'un d'autre à le même problème ? comment y remédier.
Pour info :
J’ai déjà essayer les classiques, suppression des alexa, désinstallation du plugin, réinstallation de celui-ci, Scan des alexa, ….

Hello, même problème pour moi, obligé de relancer Alexa api régulièrement (a priori quotidiennement), les fonctions volume, speak, routines sont impactées (et sûrement d’autres que je n’ai pas testé).

Merci pour vos retours.


Envoyé de mon iPhone en utilisant Tapatalk

paulnux
Timide
Messages : 330
Inscription : 19 juil. 2015, 11:28
Localisation : 72

Re: [Plugin Tiers] Plugin Alexa-API

Message par paulnux » 14 août 2019, 10:50

Bonjour,
est ce que au jours d'aujourd’hui la version stable fonctionne ?
Jeedom Mini+, Zigate
Temp Xiaomi
Ouverture Xiaomi
Ampoule Ikea, Xiaomi
Détecteur mouvement Xiaomi

Pi3B+, ZStick GEN5, SENA UD100, Gateway Xiaomi
PSM02
FGMS-001
ZM1602
Ampoule Yeelight
Echo Plus
Nut mini
Balance Xiaomi
MiFlora
WorxLandroidS

vdh053
Timide
Messages : 15
Inscription : 24 déc. 2018, 22:42

Re: [Plugin Tiers] Plugin Alexa-API

Message par vdh053 » 14 août 2019, 13:26

Pareil pour moi, la version stable et beta sont concernées, la commande speak ne fonctionne plus sans relancer le démon.

Une prochaine version est prévue pour régler le problème ?

Avatar de l’utilisateur
edreams
Actif
Messages : 928
Inscription : 01 déc. 2014, 11:57
Localisation : Près de Montpellier

Re: [Plugin Tiers] Plugin Alexa-API

Message par edreams » 14 août 2019, 19:36

Pareil pour moi, je suis en béta et depuis une paire de semaines plus de speak possible sans relancer le démon (alors que pourtant il n'est pas planté).
* Jeedom VM sur Synology DS916+ 8Go/24To / Zwave AEON GEN5 / RfxTrx433E *

Matériel complet --> http://forum.jeedom.fr/memberlist.php?m ... ile&u=1001 <--

Avatar de l’utilisateur
edreams
Actif
Messages : 928
Inscription : 01 déc. 2014, 11:57
Localisation : Près de Montpellier

Re: [Plugin Tiers] Plugin Alexa-API

Message par edreams » 14 août 2019, 22:46

Tiens... une maj de la béta vient d'être poussée... voyons voir si ça corrige le problème ?
* Jeedom VM sur Synology DS916+ 8Go/24To / Zwave AEON GEN5 / RfxTrx433E *

Matériel complet --> http://forum.jeedom.fr/memberlist.php?m ... ile&u=1001 <--

Avatar de l’utilisateur
Nebz
Modérateur
Messages : 6489
Inscription : 23 avr. 2017, 01:37
Localisation : Belgique

Re: [Plugin Tiers] Plugin Alexa-API

Message par Nebz » 15 août 2019, 09:29

Non rien à voir, c'est moi qui l'ai poussée, c'est pour mettre à jour nodejs en v12. C'est pour debian buster.

Comme dit précédemment, on attends le retour de Sigalou... c'est lui qui se charge du "métier " du plug-in, moi je ne fait que la mécanique et le plug-in.


Envoyé de mon iPhone en utilisant Tapatalk
Dev plugin Homebridge

- Fournissez les logs, la capture de vos commandes et vos types génériques svp
- Constructif et bonne humeur, on est pas là pour se lancer des périfs z-wave à la figure :-)

Un petit don ça fait toujours plaisir :)

Avatar de l’utilisateur
edreams
Actif
Messages : 928
Inscription : 01 déc. 2014, 11:57
Localisation : Près de Montpellier

Re: [Plugin Tiers] Plugin Alexa-API

Message par edreams » 15 août 2019, 16:15

D'accord, merci Nebz.
* Jeedom VM sur Synology DS916+ 8Go/24To / Zwave AEON GEN5 / RfxTrx433E *

Matériel complet --> http://forum.jeedom.fr/memberlist.php?m ... ile&u=1001 <--

Avatar de l’utilisateur
sigalou
Actif
Messages : 1075
Inscription : 23 janv. 2017, 16:02

Re: [Plugin Tiers] Plugin Alexa-API

Message par sigalou » 15 août 2019, 18:47

Nebz a écrit :
15 août 2019, 09:29
Non rien à voir, c'est moi qui l'ai poussée, c'est pour mettre à jour nodejs en v12. C'est pour debian buster.

Comme dit précédemment, on attends le retour de Sigalou... c'est lui qui se charge du "métier " du plug-in, moi je ne fait que la mécanique et le plug-in.


Envoyé de mon iPhone en utilisant Tapatalk
Hello tous,

Je viens d'atterir apres 18j en nouvelle Angleterre.
Je vois que ça a bien discuté, je me lance pas dans toutes les pages de discussions.
Merci Nebz d'avoir tenu le suivi.
A très vite donc, d'ici we sûrement.
Sigalou

Utilisateur/Développeur Plugin Jeedom
Créateur des plugins Alexa-API & WatchDog



paulnux
Timide
Messages : 330
Inscription : 19 juil. 2015, 11:28
Localisation : 72

Re: [Plugin Tiers] Plugin Alexa-API

Message par paulnux » 17 août 2019, 16:39

Bonjour,
Je voudrais tester, mais si je comprend bien pour l'instant sa bug,
Alors je dois installer la version stable, la beta, rien pour l'instant ?
Jeedom Mini+, Zigate
Temp Xiaomi
Ouverture Xiaomi
Ampoule Ikea, Xiaomi
Détecteur mouvement Xiaomi

Pi3B+, ZStick GEN5, SENA UD100, Gateway Xiaomi
PSM02
FGMS-001
ZM1602
Ampoule Yeelight
Echo Plus
Nut mini
Balance Xiaomi
MiFlora
WorxLandroidS

Avatar de l’utilisateur
edreams
Actif
Messages : 928
Inscription : 01 déc. 2014, 11:57
Localisation : Près de Montpellier

Re: [Plugin Tiers] Plugin Alexa-API

Message par edreams » 18 août 2019, 21:11

Actuellement la beta me parait plus stable (sans jeu de mot)
* Jeedom VM sur Synology DS916+ 8Go/24To / Zwave AEON GEN5 / RfxTrx433E *

Matériel complet --> http://forum.jeedom.fr/memberlist.php?m ... ile&u=1001 <--

yohannshome
Timide
Messages : 14
Inscription : 24 févr. 2017, 19:29

Re: [Plugin Tiers] Plugin Alexa-API

Message par yohannshome » 19 août 2019, 09:05

Bonjour à tous, j'ai lu les dernières pages du sujet. Il semblerait que le soucis de Cookie soit passé pour tout le monde, mais chez moi ca ne fonctionne pas.

Plus en détail :
  • Le plugin s'installe correctement
  • Dans la page configuration, lorsque je clique sur le bouton pour le coookie, ca ouvre une fenetre et je peux me connecter à Amazon
  • Je ferme la popup et je clique sur le bouton dans la page de configuration
  • Il y a écrit que la génération du cookie a marché
  • Je sauve et recharge la page, le bouton cookie se réinitialise (comme si je n'avais pas fait la procédure
Quand je vais dans le log, on voit les mêmes choses que ceux qui expliquaient ne pas pouvoir générer le cookie après le changement effectué par Amazon :
initCookie - Error: no csrf found
Est ce que quelqu'un peut m'aider svp ?

Merci d'avance, Yohann

yohannshome
Timide
Messages : 14
Inscription : 24 févr. 2017, 19:29

Re: [Plugin Tiers] Plugin Alexa-API

Message par yohannshome » 19 août 2019, 17:21

J'ajoute que lorsque je clique pour créer le cookie, la fenêtre popup affiche l'url locale avec un port particulier.

Cette url locale n'est pas celle qui est protégée par un cert SSL.

Avatar de l’utilisateur
sigalou
Actif
Messages : 1075
Inscription : 23 janv. 2017, 16:02

Re: [Plugin Tiers] Plugin Alexa-API

Message par sigalou » 20 août 2019, 19:54

yohannshome a écrit :
19 août 2019, 17:21
J'ajoute que lorsque je clique pour créer le cookie, la fenêtre popup affiche l'url locale avec un port particulier.

Cette url locale n'est pas celle qui est protégée par un cert SSL.
Salut Yohan,

Désolé, j'étais en congés, tu dois avoir la version stable, elle pose souci avec les changements d'Amazon, teste la beta, ça devrait fonctionner.
Ça fonctionne impec chez moi.
Sigalou

Utilisateur/Développeur Plugin Jeedom
Créateur des plugins Alexa-API & WatchDog



Répondre

Revenir vers « [Catégorie] Communication »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 7 invités