Avant toute chose merci de (re)prendre connaissance de la charte et de la respecter.
Pour résumer :
- Avant de poser une question, je cherche si la réponse existe
- Je suis poli, courtois et je respecte tout un chacun sur le forum
- Si un post m'agace : je m'en éloigne plutôt que de répondre d'une façon qui pourrait être mal interprétée


Il n'est jamais du luxe que de rappeler des choses simples :
Courtoisie, amabilité, politesse et bonne humeur sont les maîtres mots pour un forum sympathique, bienveillant et accueillant :)

Toute la communauté vous remercie

[Plugin Officiel][Sujet Principal] Lifx

Pour échanger sur les plugins classés en catégorie "Objets connectés"
Avatar de l’utilisateur
rocket13011
Actif
Messages : 645
Inscription : 07 sept. 2014, 21:29
Localisation : Lyon

[Plugin Officiel][Sujet Principal] Lifx

Message par rocket13011 » 18 oct. 2016, 16:01

Bonjour,

Voici mon premier plugin Officiel ( après le plugin mobile hein !! ).

lien market :
https://www.jeedom.com/market/index.php ... &name=lifx

Doc :
https://jeedom.github.io/documentation/ ... index.html
Équipe développement JEEDOM
Développeur Mobile JEEDOM / Responsable relation partenaire

Dev des plugins :
Mobile, Lifx

duke
Timide
Messages : 2
Inscription : 10 août 2016, 14:27

Re: [Sujet officiel] Lifx

Message par duke » 20 oct. 2016, 10:52

Bonjour,

Superbe job @rocket13011.
J'ai commencé à l'utiliser disposant de 8 ampoules LIFX aujourd'hui dans mon appartement.
J'avais développé un script, en mode http, pour reprendre les commandes principales afin de m'en servir pour savoir si je n'avais pas oublié d'éteindre une lumière lorsque je ne suis pas chez moi et je remarque qu'il manque l'état connecté (alimenté électriquement ou pas) car l'API LIFX te retourne deux états :
  • état connecté électrtiquement
  • état allumé, qui garde l'état de l'ampoule avant déconnection électrique et du coup affiche allumé alors que la lumière est éteinte
A voir dans une prochaine version ;)
Encore merci pour ce superbe boulot avec l'API LAN.

Avatar de l’utilisateur
rocket13011
Actif
Messages : 645
Inscription : 07 sept. 2014, 21:29
Localisation : Lyon

Re: [Sujet officiel] Lifx

Message par rocket13011 » 04 nov. 2016, 10:21

exact ! je vais voir a faire un si pas de réponse alors mettre en éteint ;)

Merci pour ton retour !
Équipe développement JEEDOM
Développeur Mobile JEEDOM / Responsable relation partenaire

Dev des plugins :
Mobile, Lifx

chiron59
Timide
Messages : 3
Inscription : 30 nov. 2016, 22:04

Re: [Sujet officiel] Lifx

Message par chiron59 » 30 nov. 2016, 22:10

bonjour,
j'ai un pb avec le plugin lifix
deseperement NOK...
voici mes logs

Traceback (most recent call last):
File "/var/www/html/plugins/lifx/resources/lifx_master.py", line 68, in
Sniffer()
File "/var/www/html/plugins/lifx/resources/lifx_master.py", line 16, in __init__
self.port = UDP_BROADCAST_PORT
NameError: global name 'UDP_BROADCAST_PORT' is not defined

et apres un sudo pip install lifxlan==0.3.0 :
Requirement already satisfied: lifxlan==0.3.0 in /usr/local/lib/python2.7/dist-packages

si vous avez une idée...

kouaw
Actif
Messages : 5986
Inscription : 25 janv. 2015, 22:15
Localisation : Belgium
Contact :

Re: [Sujet officiel] Lifx

Message par kouaw » 30 nov. 2016, 22:12

NameError: global name 'UDP_BROADCAST_PORT' is not defined <-- en gros tu as pas choisi de port ;)

chiron59
Timide
Messages : 3
Inscription : 30 nov. 2016, 22:04

Re: [Sujet officiel] Lifx

Message par chiron59 » 01 déc. 2016, 13:11

merci pour l'info mais la doc sur lifix n'est pas disponible a l'heure actuelle. ou puis je definir le port udp pour le plugin?

Joeman
Timide
Messages : 38
Inscription : 03 oct. 2015, 18:25

Re: [Sujet officiel] Lifx

Message par Joeman » 26 déc. 2016, 21:58

chiron59 a écrit :merci pour l'info mais la doc sur lifix n'est pas disponible a l'heure actuelle. ou puis je definir le port udp pour le plugin?
En supposant que le réponse ait encore un intérêt pour toi, pourquoi est ce que tu veux définir ce port ? À ma connaissance, il n'est pas possible de définir ce port du coté de la LIFX elle même, donc je ne vois pas ce que tu pourrais faire de l'information du coté du plugin jeedom.

De mon coté, j'ai un problème avec jeedom et ma lifx1000 depuis la fin de la semaine dernière: je ne sais pas s'il s'agit d'une coïncidence avec une mise à jour de l'application android ou non mais jeedom ne parvient plus ni à récupérer l'état de la lampe, ni à agir dessus. LA seule chose qui semble fonctionner est l'extinction de la lampe!
L'application android continue elle de fonctionner correctement

Coté jeedom, j'ai essayé dans l'ordre
- réinstaller les dépendances
- relancer le démon
- supprimer puis rescanner pour trouver la lampe
Et toujours le même comportement: aucun retour dans le widget du dashboard de l'état de la lampe, et toujours aucun effet des actions sur le widget vis à vis de la lampe.
Je peux faire ce que je veux

Les logs en DEBUG sur le plugin ne disent pas grand chose, par exemple dans un cas de changement de luminosité:

Code : Tout sélectionner

[2016-12-26 21:11:19][INFO] : Lancement du démon lifx
[2016-12-26 21:11:19][INFO] : Lancement démon lifx : /usr/bin/python /usr/share/nginx/www/jeedom/plugins/lifx/resources/lifx_master.py
[2016-12-26 21:11:19][INFO] : Démon lifx lancé
[2016-12-26 21:11:50][DEBUG] : Action :d0:73:d5:11:94:d9 // 192.168.0.129 pour > luminosity
[2016-12-26 21:11:50][DEBUG] : 45
[2016-12-26 21:11:50][DEBUG] : /usr/bin/python /usr/share/nginx/www/jeedom/plugins/lifx/resources/action_lifx.py --mac=d0:73:d5:11:94:d9 --ip=192.168.0.129 --action=luminosity --luminosity=29490
Si quelqu'un a une idée de ce qui pourrait ne pas fonctionner, je suis preneur.
Est ce que le protocole pourrait avoir changé du coté de LIFX ?

Poyo75
Timide
Messages : 1
Inscription : 31 déc. 2016, 16:47

Re: [Sujet officiel] Lifx

Message par Poyo75 » 31 déc. 2016, 17:21

Bonjour,

Je vais commencer par vous féliciter pour ce plugin qui m'est très utile. (y)
Ma première utilisation/configuration avec mes 2 premières ampoules a parfaitement fonctionné.
J'ai une jolie image de mes ampoules et elles sont découverte comme modèle "Original 1000".
Mais j'ai un petit souci avec mes toutes nouvelles ampoules, la génération 3 de Lifx.
Le scan les découvre correctement mais là plus d'image ni d'information concernant le modèle.
Je n'ai aussi pas le même nombre de commandes (4 au lieu de 6) ni les couleurs pré-définies.
Si je regarde les informations brutes, je vois que le contenu du champs "Configuration" n'est pas le même pour mes 2 modèles.
Du coup, je peux juste éteindre ou allumer mes nouvelles ampoules via le plugin.

Voilà, si vous pouviez m'indiquer la voie pour corriger cela ou faire un petit update du plugin (je sais que cela prend du temps) ce serait sympa.

Merci :-)

Joeman
Timide
Messages : 38
Inscription : 03 oct. 2015, 18:25

Re: [Sujet officiel] Lifx

Message par Joeman » 01 janv. 2017, 15:02

Joeman a écrit :
chiron59 a écrit :merci pour l'info mais la doc sur lifix n'est pas disponible a l'heure actuelle. ou puis je definir le port udp pour le plugin?
En supposant que le réponse ait encore un intérêt pour toi, pourquoi est ce que tu veux définir ce port ? À ma connaissance, il n'est pas possible de définir ce port du coté de la LIFX elle même, donc je ne vois pas ce que tu pourrais faire de l'information du coté du plugin jeedom.

De mon coté, j'ai un problème avec jeedom et ma lifx1000 depuis la fin de la semaine dernière: je ne sais pas s'il s'agit d'une coïncidence avec une mise à jour de l'application android ou non mais jeedom ne parvient plus ni à récupérer l'état de la lampe, ni à agir dessus. LA seule chose qui semble fonctionner est l'extinction de la lampe!
L'application android continue elle de fonctionner correctement

Coté jeedom, j'ai essayé dans l'ordre
- réinstaller les dépendances
- relancer le démon
- supprimer puis rescanner pour trouver la lampe
Et toujours le même comportement: aucun retour dans le widget du dashboard de l'état de la lampe, et toujours aucun effet des actions sur le widget vis à vis de la lampe.
Je peux faire ce que je veux

Les logs en DEBUG sur le plugin ne disent pas grand chose, par exemple dans un cas de changement de luminosité:

Code : Tout sélectionner

[2016-12-26 21:11:19][INFO] : Lancement du démon lifx
[2016-12-26 21:11:19][INFO] : Lancement démon lifx : /usr/bin/python /usr/share/nginx/www/jeedom/plugins/lifx/resources/lifx_master.py
[2016-12-26 21:11:19][INFO] : Démon lifx lancé
[2016-12-26 21:11:50][DEBUG] : Action :d0:73:d5:11:94:d9 // 192.168.0.129 pour > luminosity
[2016-12-26 21:11:50][DEBUG] : 45
[2016-12-26 21:11:50][DEBUG] : /usr/bin/python /usr/share/nginx/www/jeedom/plugins/lifx/resources/action_lifx.py --mac=d0:73:d5:11:94:d9 --ip=192.168.0.129 --action=luminosity --luminosity=29490
Si quelqu'un a une idée de ce qui pourrait ne pas fonctionner, je suis preneur.
Est ce que le protocole pourrait avoir changé du coté de LIFX ?
Bonne Année à tous!

J'en profite pour m'auto répondre. J'ai résolu mon problème.
Pour ceux que ça intéresse, j'ai fait dans l'ordre
  • Réinitialisation en paramètre d'usine de la LIFX 1000
    Suppression dans l'application android
    Ajout dans l'application andrdoid
    Suppression dans jeedom
    Ajout dans jeedom
Et voilà!
Il faut croire que le problème venait bien de la lampe elle même, puisque par rapport à mes précédents essais, c'est le réinitialisation en paramètres d'usine qui semble avoir résolu mon problème.

Edit du 04/01/17
En fait, mon problème n'est pas résolu. J'ai toujours la lampe qui répond correctement à l’application android. Couleur, luminosité, tout fonctionne.
Quand j'essaie de controler depuis jeedom, la seule chose qui fonctionne est l'extinction. Je n'ai pas non plus la remontée du niveau de luminosité au niveau du widget.
Sachant qu'en plus cela a fonctionné pendant plusieurs semaines, je n'ai aucune idée de ce qui peut foirer.
Si j'ai le temps, j'essaierai de regarder ce weekend au niveau tcpdump ce qui part de jeedom à destination de la lampe.

Edit du 07/01/17
Cela refonctionne après avoir fait depuis l'application android "mettre à jour le micrologiciel". Je ne suis même pas sur que le firmware ait été mis à jour. Hasard ou coïncidence, aucune idée mais cela fonctionne correctement à nouveau.

ColeTrickle
Timide
Messages : 5
Inscription : 28 juin 2016, 09:51

Re: [Plugin Officiel][Sujet Principal] Lifx

Message par ColeTrickle » 19 juin 2017, 12:40

Bonjour,

J'ai le même problème que les autres utilisateurs : je n'arrive pas à contrôler ma LIFX1000 depuis le widget.
J'ai supprimé les ampoules dans JEEDOM, réinstaller le plugin, redémarrage des dépendances, du daemon, recherche automatique des ampoules.
Elles apparaissent bien mais impossible de contrôler autre chose que l'ouverture ou la fermeture de l'ampoule.
J'ai créé un scénario qui ne réagit pas non plus, rien de parlant dans les logs...

Quelqu'un a une idée ?

Merci.

Krinogen
Timide
Messages : 1
Inscription : 29 juil. 2017, 22:35

Re: [Plugin Officiel][Sujet Principal] Lifx

Message par Krinogen » 29 juil. 2017, 22:37

Le plug-in ne détecte pas les ampoules de type A19 (v2.14). Aucun problème pour mes LIFX original (v2.1)
Patch possible s'il vous plait ? j'ai acheté ce plug in dans l'espoir qu'il fonctionne

alfcorp
Timide
Messages : 56
Inscription : 20 avr. 2015, 23:03

Re: [Plugin Officiel][Sujet Principal] Lifx

Message par alfcorp » 06 sept. 2017, 22:07

Hello,

suite à la dernière mise à jour de LIFX sur mes White 800, plus rien ne marche...
Le Scan ne semble pas marcher et les commandes ON et OFF ne fonctionne plus.
Est ce que l'on peut aider au developpement / debug de ce plugin qui me pilote mes 8 Lifx ?
C'est problématique là :-)

merci

Alf

alfcorp
Timide
Messages : 56
Inscription : 20 avr. 2015, 23:03

Re: [Plugin Officiel][Sujet Principal] Lifx

Message par alfcorp » 06 sept. 2017, 23:11

Hello,

Je me réponds :-)
Cela marche maintenant.
J'ai téléchargé la dernière version de la lib pyhton lifxlan ici : https://github.com/mclarkk/lifxlan
J'ai désactiver le plugin Lifx
J'ai supprimé les fichiers sur jeedom du répertoire /usr/share/nginx/www/jeedom/plugins/lifx/resources/lifxlan
J'ai mis les fichiers récupérés du Git ci dessus à la place (tout cela via winscp)
Via SSH (Putty) :
cd /usr/share/nginx/www/jeedom/plugins/lifx/resources/lifxlan/
sudo chown www-data:www-data *.*

Réactiviation du plugIn avec relance du deamon.

Si en amont la gestion n'a pas changée cette nouvelle lib permet de fonctionner avec la dernière MAJ de LIFX
Etant entendu qu'à la prochaine MAJ, cela risque d'être écrasé si celle ci n'inclut pas la dernière version de la lib :-)

Hope this help

Alf

Avatar de l’utilisateur
rocket13011
Actif
Messages : 645
Inscription : 07 sept. 2014, 21:29
Localisation : Lyon

Re: [Plugin Officiel][Sujet Principal] Lifx

Message par rocket13011 » 07 sept. 2017, 13:28

correction faite dans la stable qui arrive demain ;)

je rajoute dans le mois les nouveaux modèles et la prise en charge de l'IR.
Équipe développement JEEDOM
Développeur Mobile JEEDOM / Responsable relation partenaire

Dev des plugins :
Mobile, Lifx

alfcorp
Timide
Messages : 56
Inscription : 20 avr. 2015, 23:03

Re: [Plugin Officiel][Sujet Principal] Lifx

Message par alfcorp » 07 sept. 2017, 17:13

Hello,

Attention aussi à un point : si dans les noms de vos lampes il y a des caractères français, le scanner.py se plante pour une question d'encodage.
Il faut forcer UTF-8 et cela se débloque.
Pour ca, j'ai ajouté en entête du fichier scanner.py les lignes suivantes :

import sys
reload(sys)
sys.setdefaultencoding('utf-8')

cela semble fonctionner.
J'ai juste une erreur plus loin :

File "/var/www/html/plugins/lifx/resources/lifxlan/device.py", line 508, in req_with_resp
raise WorkflowException("WorkflowException: Did not receive {} from {} (Name: {}) in response to {}".format(str(response_type), str(self.mac_addr), str(self.label), str(msg_type)))
lifxlan.errors.WorkflowException: WorkflowException: Did not receive [<class 'lifxlan.msgtypes.StateVersion'>] from d0:73:d5:13:00:3d (Name: Chambre) in response to <class 'lifxlan.msgtypes.GetVersion'>

mais qui ne bloque pas le scan mais il faut lancer plusieurs fois le scan pour avoir finalement la totalité des lampes...
L'erreur a lieu de manière aléatoire sur différentes lampes.
Il faut que jecreuse ce point.
Pas très grave mais bon...

A savoir que je fais les tests sur une install toute fraiche sur Rasp3 avec Stretch, ariadb & php7 (n'ayant pas trouvé de distrib de raspbian Jessie...)

Alf

Avatar de l’utilisateur
tomdom
Actif
Messages : 848
Inscription : 14 nov. 2016, 05:46

Re: [Plugin Officiel][Sujet Principal] Lifx

Message par tomdom » 13 sept. 2017, 09:46

Bonjour,
rocket13011 a écrit :
07 sept. 2017, 13:28

je rajoute dans le mois les nouveaux modèles et la prise en charge de l'IR.
Est-ce que la LIfx A19 (product id=27) est dans la liste des nouveaux modèles ?

Merci
Il y a 10 catégories de personnes, celles qui connaissent le binaire et les autres
.

Avatar de l’utilisateur
rocket13011
Actif
Messages : 645
Inscription : 07 sept. 2014, 21:29
Localisation : Lyon

Re: [Plugin Officiel][Sujet Principal] Lifx

Message par rocket13011 » 16 sept. 2017, 00:42

je vais rajouter tout les modèles, donc normalement oui ;)
Équipe développement JEEDOM
Développeur Mobile JEEDOM / Responsable relation partenaire

Dev des plugins :
Mobile, Lifx

alfcorp
Timide
Messages : 56
Inscription : 20 avr. 2015, 23:03

Re: [Plugin Officiel][Sujet Principal] Lifx

Message par alfcorp » 25 sept. 2017, 07:42

Hello rocket13011,

Merci pour ton plugin d'abord : il marche nickel.
Pour pouvoir gérer correctement ce que je souhaite faire, est ce possible de faire en sorte que la mise à jour en fonction de l'état réel de la lampe se fasse de manière récurrente ?
Je m’explique :
Lorsque que les lumières sont allumées par l'interrupteur (donc de déconnecté à connecté), les infos sur le widget ne sont pas mises à jour en fonction de son état réel....Ce qui me pose un problème pour savoir dans quel état réel, les lampes se trouvent.
Est ce que mettre un cron paramétrable pour forcer le rafraîchissement est possible ?
Ce serait top.

Merci

Alf

Avatar de l’utilisateur
tomdom
Actif
Messages : 848
Inscription : 14 nov. 2016, 05:46

Re: [Plugin Officiel][Sujet Principal] Lifx

Message par tomdom » 13 oct. 2017, 16:33

Bonjour,

J'ai la version 2017-09-26 16:07:28 et mon ampoule Lifx A19 n'est pas reconnu. Est-ce que cette ampoule a été intégrée dans cette mise à jour ?

Merci
Il y a 10 catégories de personnes, celles qui connaissent le binaire et les autres
.

Avatar de l’utilisateur
tomdom
Actif
Messages : 848
Inscription : 14 nov. 2016, 05:46

Re: [Plugin Officiel][Sujet Principal] Lifx

Message par tomdom » 18 oct. 2017, 13:00

Bonjour,

En regardant le code du plugin, elles ne sont pas prises en compte.

Le seront-elles ?

Merci
Il y a 10 catégories de personnes, celles qui connaissent le binaire et les autres
.

Répondre

Revenir vers « [Catégorie] Objets connectés »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 0 invité