Avant toute chose merci de (re)prendre connaissance de la charte et de la respecter.
Pour résumer :
- Avant de poser une question, je cherche si la réponse existe
- Je suis poli, courtois et je respecte tout un chacun sur le forum
- Si un post m'agace : je m'en éloigne plutôt que de répondre d'une façon qui pourrait être mal interprétée


Il n'est jamais du luxe que de rappeler des choses simples :
Courtoisie, amabilité, politesse et bonne humeur sont les maîtres mots pour un forum sympathique, bienveillant et accueillant :)

Toute la communauté vous remercie

Impossible d'installer les dépendances

Retrouvez ici des sujets concernant le protocole MQTT et les modules domotiques de type MQTT utilisés avec JEEDOM
/!\ Plugin MQTT non officiel
Répondre
Avatar de l’utilisateur
rombautsdidier
Timide
Messages : 269
Inscription : 01 juin 2016, 07:56
Contact :

Impossible d'installer les dépendances

Message par rombautsdidier » 02 sept. 2017, 19:08

Bonjour,

Suite à l'achat d'une carte arduino Wifi (intégré, pas le shield), je suis obligé de passer par MQTT pour pouvoir communiquer avec Jeedom. Je pensais pouvoir faire des requêtes HTTP directement mais ce n'est pas possible. J'ai tenté avec REST mais cela ne fonctionne pas.

Donc, j'ai voulu installer le plugin MQTT dans Jeedom mais j'ai l'erreur suivante pendant l'installation des dépendances.

W: Failed to fetch http://www.deb-multimedia.org/dists/jessie/InRelease Unable to find expected entry 'main/binary-arm64/Packages' in Release file (Wrong sources.list entry or malformed file)
E: Some index files failed to download. They have been ignored, or old ones used instead.

Que puis-je faire pour permettre au plugin de fonctionner?

Je suis sous Jeedom 3.0.11 sur une Jeedom SMART.

Merci pour votre aide.
Didier Rombauts (http://didier.rombauts.fr)
Jeedom SMART - v3.3.18 -TeleInfo 1.1 - SP3 - MP1 - Roller Shutter 2
SP103 - FGMS-001 - FGS-222 - ZW100 - PST02-A - PH-PSG01
OpenSprinkler - Remotec ZXT-120 - FGCD-001

Avatar de l’utilisateur
lunarok
Actif
Messages : 6210
Inscription : 08 août 2014, 12:48
Localisation : Anjou

Re: Impossible d'installer les dépendances

Message par lunarok » 02 sept. 2017, 22:34

Merci d'ouvrir un ticket au support. Ca n'a rien à voir avec les dépendances de MQTT en particulier mais c'est un problème récurrent de mauvais dépot sur les smart.
Mon Blog | Xiaomi Home
Pour contribuer au développement des plugins (don ou achat de matériel) : Paypal
Aides nous à t'aider : les logs, détails du soucis, la doc, recherche sur le forum ...
PS : pas de support par MP, je ne répondrais pas

Avatar de l’utilisateur
rombautsdidier
Timide
Messages : 269
Inscription : 01 juin 2016, 07:56
Contact :

Re: Impossible d'installer les dépendances

Message par rombautsdidier » 02 sept. 2017, 22:54

Merci pour ta réponse mais je ne peux pas créer un ticket vu que le plugin n'est pas officiel...
Comment procéder alors?
Didier Rombauts (http://didier.rombauts.fr)
Jeedom SMART - v3.3.18 -TeleInfo 1.1 - SP3 - MP1 - Roller Shutter 2
SP103 - FGMS-001 - FGS-222 - ZW100 - PST02-A - PH-PSG01
OpenSprinkler - Remotec ZXT-120 - FGCD-001

Avatar de l’utilisateur
rombautsdidier
Timide
Messages : 269
Inscription : 01 juin 2016, 07:56
Contact :

Re: Impossible d'installer les dépendances

Message par rombautsdidier » 02 sept. 2017, 22:56

Je l'ai mis dans la catégorie générale.
J'espère avoir une réponse car effectivement, j'avais déjà eu un soucis pour les rapports PDF envoyé par mail où il manquait un package.
J'ai fini par l'installer moi-même pour régler le problème.
J'attends donc des nouvelles de l'équipe.
Merci
Didier Rombauts (http://didier.rombauts.fr)
Jeedom SMART - v3.3.18 -TeleInfo 1.1 - SP3 - MP1 - Roller Shutter 2
SP103 - FGMS-001 - FGS-222 - ZW100 - PST02-A - PH-PSG01
OpenSprinkler - Remotec ZXT-120 - FGCD-001

Avatar de l’utilisateur
rombautsdidier
Timide
Messages : 269
Inscription : 01 juin 2016, 07:56
Contact :

Re: Impossible d'installer les dépendances

Message par rombautsdidier » 02 sept. 2017, 23:03

Ce qui m'étonne quand même, c'est que si je me rends sur le site http://www.deb-multimedia.org/dists/jessie/InRelease, je ne trouve nulle part main/binary-arm64/Packages dans la liste des packages.

Pour info, quand je lance mosquitto_sub sur la smart, je vois bien les messages publiés.
Didier Rombauts (http://didier.rombauts.fr)
Jeedom SMART - v3.3.18 -TeleInfo 1.1 - SP3 - MP1 - Roller Shutter 2
SP103 - FGMS-001 - FGS-222 - ZW100 - PST02-A - PH-PSG01
OpenSprinkler - Remotec ZXT-120 - FGCD-001

vineux
Timide
Messages : 15
Inscription : 04 juil. 2017, 08:54

Re: Impossible d'installer les dépendances

Message par vineux » 06 sept. 2017, 23:16

bonjour
je ne parviens pas (non plus) à installer les dépendances.
Selon lunarok ce serait dû à un problème de dépôt.
y a t il du neuf depuis le 2 septembre ?

il n'est pas possible d ouvrir un ticket avec la version stable (2017-06-19 01:03:11) .
jeedom renvoit ceci: [ticket::save] Vous ne pouvez ouvrir un ticket avec un plugin en beta
la version du 2017-06-19 01:03:11 est-elle beta (alors quelle est donnée stable sur le market) ?

merci

Avatar de l’utilisateur
rombautsdidier
Timide
Messages : 269
Inscription : 01 juin 2016, 07:56
Contact :

Re: Impossible d'installer les dépendances

Message par rombautsdidier » 06 sept. 2017, 23:22

Ce plugin n'est pas un officiel donc pas de support pour ce dernier.
J'ai donc créé un ticket général et il m'a été répondu que le problème devrait être résolu dans les jours qui viennent.
Didier Rombauts (http://didier.rombauts.fr)
Jeedom SMART - v3.3.18 -TeleInfo 1.1 - SP3 - MP1 - Roller Shutter 2
SP103 - FGMS-001 - FGS-222 - ZW100 - PST02-A - PH-PSG01
OpenSprinkler - Remotec ZXT-120 - FGCD-001

vineux
Timide
Messages : 15
Inscription : 04 juil. 2017, 08:54

Re: Impossible d'installer les dépendances

Message par vineux » 18 sept. 2017, 19:29

des nouvelles ?

Bosquetia
Actif
Messages : 6487
Inscription : 10 mai 2016, 07:54

Re: Impossible d'installer les dépendances

Message par Bosquetia » 18 sept. 2017, 20:32

vineux a écrit :
18 sept. 2017, 19:29
des nouvelles ?
Il s'est juste passé 12 jours, moins les weekend, moins le temps de travail de chacun, laissons le temps au temps non ?
;) ;) ;)

Avatar de l’utilisateur
lunarok
Actif
Messages : 6210
Inscription : 08 août 2014, 12:48
Localisation : Anjou

Re: Impossible d'installer les dépendances

Message par lunarok » 18 sept. 2017, 20:48

Et puis meme, vous avez la réponse : c'est pas mqtt mais les dépôts de la smart, donc si vous voulez que ca avance voyez avec le support, pas le forum

Envoyé de mon ONEPLUS A3010 en utilisant Tapatalk

Mon Blog | Xiaomi Home
Pour contribuer au développement des plugins (don ou achat de matériel) : Paypal
Aides nous à t'aider : les logs, détails du soucis, la doc, recherche sur le forum ...
PS : pas de support par MP, je ne répondrais pas

vineux
Timide
Messages : 15
Inscription : 04 juil. 2017, 08:54

Re: Impossible d'installer les dépendances

Message par vineux » 01 oct. 2017, 21:30

Il s'est juste passé 24 jours, moins les weekend, moins le temps de travail de chacun, laissons le temps au temps non ?

Bosquetia
Actif
Messages : 6487
Inscription : 10 mai 2016, 07:54

Re: Impossible d'installer les dépendances

Message par Bosquetia » 01 oct. 2017, 21:54

vineux a écrit :
01 oct. 2017, 21:30
Il s'est juste passé 24 jours, moins les weekend, moins le temps de travail de chacun, laissons le temps au temps non ?
L'auteur du plugin a répondu au dessus. Tu as fait ce qu'il t'a indiqué ?

Avatar de l’utilisateur
lunarok
Actif
Messages : 6210
Inscription : 08 août 2014, 12:48
Localisation : Anjou

Re: Impossible d'installer les dépendances

Message par lunarok » 01 oct. 2017, 22:00

vineux a écrit :
01 oct. 2017, 21:30
Il s'est juste passé 24 jours, moins les weekend, moins le temps de travail de chacun, laissons le temps au temps non ?
Va pleurer sur un ticket, et arrête de polluer le fil.
Mon Blog | Xiaomi Home
Pour contribuer au développement des plugins (don ou achat de matériel) : Paypal
Aides nous à t'aider : les logs, détails du soucis, la doc, recherche sur le forum ...
PS : pas de support par MP, je ne répondrais pas

Avatar de l’utilisateur
lunarok
Actif
Messages : 6210
Inscription : 08 août 2014, 12:48
Localisation : Anjou

Re: Impossible d'installer les dépendances

Message par lunarok » 02 oct. 2017, 05:46

Tu as bien sur installer la 3.1

Envoyé de mon ONEPLUS A3010 en utilisant Tapatalk

Mon Blog | Xiaomi Home
Pour contribuer au développement des plugins (don ou achat de matériel) : Paypal
Aides nous à t'aider : les logs, détails du soucis, la doc, recherche sur le forum ...
PS : pas de support par MP, je ne répondrais pas

vineux
Timide
Messages : 15
Inscription : 04 juil. 2017, 08:54

Re: Impossible d'installer les dépendances

Message par vineux » 02 oct. 2017, 19:20

je suis en 3.1.5.

quand j essaye d ouvrir un ticket pour MQTT pour le dépôt j'obtiens:
Le plugin n'est pas un plugin officiel il n'y a donc pas de support dessus. Veuillez contacter l'auteur en passant par le forum.

quand j essaye d ouvrir un ticket général pour le dépôt j'obtiens:
Votre service pack ne vous permet pas d'ouvrir pour une question générale

il ne me reste que ce doux forum

merci pour toute aide utile

Avatar de l’utilisateur
lunarok
Actif
Messages : 6210
Inscription : 08 août 2014, 12:48
Localisation : Anjou

Re: Impossible d'installer les dépendances

Message par lunarok » 02 oct. 2017, 19:23

Mais pas dans cette section, désolé mais ton pb est spécifique à la smart, donc le forum MQTT va pas faire fourre tout
En achetant une smart t'as forcément un support pack, donc ticket
Mon Blog | Xiaomi Home
Pour contribuer au développement des plugins (don ou achat de matériel) : Paypal
Aides nous à t'aider : les logs, détails du soucis, la doc, recherche sur le forum ...
PS : pas de support par MP, je ne répondrais pas

Avatar de l’utilisateur
rombautsdidier
Timide
Messages : 269
Inscription : 01 juin 2016, 07:56
Contact :

Re: Impossible d'installer les dépendances

Message par rombautsdidier » 06 oct. 2017, 21:03

vineux a écrit :
02 oct. 2017, 19:20
je suis en 3.1.5.

quand j essaye d ouvrir un ticket pour MQTT pour le dépôt j'obtiens:
Le plugin n'est pas un plugin officiel il n'y a donc pas de support dessus. Veuillez contacter l'auteur en passant par le forum.

quand j essaye d ouvrir un ticket général pour le dépôt j'obtiens:
Votre service pack ne vous permet pas d'ouvrir pour une question générale

il ne me reste que ce doux forum

merci pour toute aide utile
J’ai déjà fait un ticket et on m’a répondu que ce sera réglé dans les meilleurs délais.
Didier Rombauts (http://didier.rombauts.fr)
Jeedom SMART - v3.3.18 -TeleInfo 1.1 - SP3 - MP1 - Roller Shutter 2
SP103 - FGMS-001 - FGS-222 - ZW100 - PST02-A - PH-PSG01
OpenSprinkler - Remotec ZXT-120 - FGCD-001

Chris37
Timide
Messages : 4
Inscription : 23 mars 2018, 08:04

Re: Impossible d'installer les dépendances

Message par Chris37 » 28 mars 2018, 11:04

Bonjour à tous,

J'ai un souci aussi avec un raspberry PI 1 que l'on m'a prêté.

Raspbian c'est bien installé, jeedom aussi, même si c'était très long. Et je souhaite le faire communiquer avec des sonoff tasmota. Donc avec MQTT.
Avec le puging MQTT, il chercher mais m'installe aucune dépendance. A chaque fois j'ai 0 installation.
J'ai testé avec le pluging jMQTT et là j'avais espoirs, car cela lançais une barre de progression d'installation des dépendances, mais après 2 heures, toujours a 0%.

Je vais attendre un peu pour m'acheter un pi3, mais si vous avez une idée.

rebel59540
Timide
Messages : 89
Inscription : 24 févr. 2017, 19:50

Re: Impossible d'installer les dépendances

Message par rebel59540 » 10 déc. 2018, 17:23

bonjour j'ais réinstaller jeedom fait une restauration mais la j'essaye de réinstaller les dépendances
mais il reste sur nok
quelqu'un peut me donner un coup de main svp

jais sa dans le log

Début d'installation des dépendances
Reading package lists...
Building dependency tree...
Reading state information...
lsb-release is already the newest version (9.20161125+rpi1).
php-pear is already the newest version (1:1.10.1+submodules+notgz-9).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Hit:1 http://raspbian.raspberrypi.org/raspbian stretch InRelease
Ign:2 http://archive.raspberrypi.org/debian stretch InRelease
Get:3 http://archive.raspberrypi.org/debian stretch Release [24.8 kB]
Get:4 http://archive.raspberrypi.org/debian stretch Release.gpg [488 B]
Fetched 25.3 kB in 46s (540 B/s)
Reading package lists...
Reading package lists...
Building dependency tree...
Reading state information...
libmosquitto-dev is already the newest version (1.4.10-3+deb9u2).
mosquitto is already the newest version (1.4.10-3+deb9u2).
mosquitto-clients is already the newest version (1.4.10-3+deb9u2).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/20151012/mosquitto.so' - /usr/lib/php/20151012/mosquitto.so: cannot open shared object file: No such file or directory in Unknown on line 0
Reading package lists...
Building dependency tree...
Reading state information...
php7.0-dev is already the newest version (7.0.30-0+deb9u1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Fin installation des dépendances

Répondre

Revenir vers « [Plugin Tiers] MQTT »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 0 invité