Avant toute chose merci de (re)prendre connaissance de la charte et de la respecter.
Pour résumer :
- Avant de poser une question, je cherche si la réponse existe
- Je suis poli, courtois et je respecte tout un chacun sur le forum
- Si un post m'agace : je m'en éloigne plutôt que de répondre d'une façon qui pourrait être mal interprétée


Il n'est jamais du luxe que de rappeler des choses simples :
Courtoisie, amabilité, politesse et bonne humeur sont les maîtres mots pour un forum sympathique, bienveillant et accueillant :)

Toute la communauté vous remercie

Fibaro Flood sensor FGFS-101 ZW5 v3.3 non reconnu

Uniquement pour apporter des contributions aux configurations OpenZwave (corrections de configurations erronées ou compléments de configurations manquantes). Si vous avez un souci avec votre module, merci de poster dans Périphériques Z-Wave !

Modérateur : nechry

TiTerm
Timide
Messages : 24
Inscription : 16 mars 2018, 09:31
Contact :

Re: Fibaro Flood sensor FGFS-101 ZW5 v3.3 non reconnu

Message par TiTerm » 06 oct. 2018, 14:27

Il faut bien avouer que il n'y a que très peu d'évolution sur jeedom ces derniers temps
Se réfugier derrière le support pour ignorer les évolutions des périphériques me semble surprenant
Jeedom sans les périphériques ne sert pas à grand chose et les PR dune communauté sont du pain béni pour une société.

J'ai plus l'impression qu'il y a eu un pb entre la communauté de dev autonome et la société qui gère jeedom.

Et je dois bien avouer que si mon choix devait être fait aujourd'hui, ce ne serait peut être plus jeedom

yadert
Timide
Messages : 15
Inscription : 18 mai 2015, 13:37
Localisation : Aisne
Contact :

Re: Fibaro Flood sensor FGFS-101 ZW5 v3.3 non reconnu

Message par yadert » 06 oct. 2018, 15:51

Bonjour,

Je partage complétement vos interrogations et sensations vis a vis de jeedom.
L'idée n'est pas de faire polémique.
Mais c'est vrai que j'ai du mal à comprendre : j'ai ouvert un ticket vis à vis de ce problème et je n'ai eu aucun retour.
Alors oui, je suis sur une plateforme DIY (donc "gratuit") et je n'ai pas de service pack. Je comprend complétement que je ne soit pas prioritaire vis a vis des utilisateurs ayant acheté leur solution.
Toutefois, la demande concerne la prise en charge d'une variante d'un périphérique zwave existant. Je pense que ça serai profitable aussi bien aux utilisateurs ayant "payé" leur jeedom qu'aux autres membres de la communauté.

Alors c'est vrai qu'on trouve souvent une solution sur le forum (merci au passage à tout le monde !) et que modifier quelques fichiers de conf n'est pas très compliqué. J'ai d’ailleurs été confronté à un problème similaire avec le plugin ikealight (non prise en charge d'une ampoule, solutionné en modifiant un fichier de config).

Deux problèmes de prise en charge de périphériques sur deux plugins officiels de l'équipe, sur lesquels je n'ai pas l'impression qu'il y ai d'action... ça ne me rassure pas.

Imaginez la sensation d'un utilisateur ayant déjà acheté quelques périphériques (ex : le flood sensor fibaro) qu'il a intégré sans problème et que quelques années après, il achète le même périphérique, qu'il tombe sur une nouvelle version du constructeur et qu'il est impossible de l'intégré sur jeedom.... dur dur quand même.

Je comprend que l'équipe soit sur d'autres sujets mais l'intégration de périphérique est essentiel surtout concernant zwave ,un des protocole sur lequel jeedom base sa box).

Il y a quelque temps je me demandait si je n'allais pas investir dans une "vrai" box jeedom pour avoir le support et arrêter de "bricoler". J'avoue qu'aujourd'hui je me demande plutôt si je ne vais pas basculer vers une autre solution.

Loin de moi l'idée pour pousser un coup de gueule ou de cracher sur le boulot colossale qui a été accomplie par la teeam, ou de lancer une polémique. Je voulais plutôt partager mon point de vue et ma crainte vis a vis de jeedom.

Yadert.
Yadert.
JEEDom Stable |DIY|Raspberry Pi 3/B + module MSATA
Mon matériel ici

mortyre
Actif
Messages : 970
Inscription : 17 mai 2016, 16:51

Re: Fibaro Flood sensor FGFS-101 ZW5 v3.3 non reconnu

Message par mortyre » 06 oct. 2018, 16:31

Il ne faut pas généraliser non plus, il ne faut pas confondre évolution et maintenance corrective ou évolutive du core et des plugins.

Je ne suis pas à la place de la société Jeedom donc je ne sais pas ce qu'il en est de la prise en charge des modules qui changent juste d'id (prise, motion, inondation, ..) en terme de process.

Ce que je peux juste constater, c'est que quand Nechry gérait les mises à jour de conf c'était beaucoup plus rapide, et on savait ici sur le forum si cela avait été pris en compte puisqu'il donnait lui même le retour. C'est ce qu'il manque le plus aujourd’hui.

Mais cela ne remet en rien en cause le travail de la société Jeedom.
PROD: NAS1815+ VMM Strech 9.4 / Jeedom 3.2.12 / MariaDB 10.1.26 / PHP 7.0.27
DEV: DIY Odroid C2 16gb Strech 9.4 / Jeedom 3.3.x beta / MariaDB 10.1.26 / PHP 7.0.27

yadert
Timide
Messages : 15
Inscription : 18 mai 2015, 13:37
Localisation : Aisne
Contact :

Re: Fibaro Flood sensor FGFS-101 ZW5 v3.3 non reconnu

Message par yadert » 06 oct. 2018, 20:12

Entièrement d'accord, ce qu'il manque le plus c'est le manque de com et de retour sur les demandes.
Maintenant pour gèrer tout ça il faut du temps... C'est certainement ce qui manque a l'équipe.
Mais j'ai confiance !

Envoyé de mon Nokia 6.1 en utilisant Tapatalk

Yadert.
JEEDom Stable |DIY|Raspberry Pi 3/B + module MSATA
Mon matériel ici

TiTerm
Timide
Messages : 24
Inscription : 16 mars 2018, 09:31
Contact :

Re: Fibaro Flood sensor FGFS-101 ZW5 v3.3 non reconnu

Message par TiTerm » 08 oct. 2018, 09:22

Pour info, moi, j'ai acheté la solution Jeedom, avec tous les packs et certains plug-ins.
Je n'ai pas ouvert de ticket puisque j'ai fait un PR la solution, mais des PR encore plus vieux que le mien existe déjà pour ce composant.

Au-delà de la mise à jour de jeedom qui, payant ou pas, est quand même très calme, la maintenance des périphériques supportés conditionne la survie de la solution. À la vitesse où sortent les nouveaux périphériques ou les nouvelles versions, il ne faudra pas très longtemps pour être confronté à des problèmes similaires à ce détecteur d'inondation sur d'autres périphériques au point que cela devienne bloquant.

Les forks comme NotAuthorised parlent d'eux même... <<<=== La censure sur le nom des projets concurrents aussi est surprenante,
Ex : https://www.luc-sanchez.fr/2018/05/next ... 7sEahMzZUM

À suivre, mais néanmoins problématique pour le moment
Dernière édition par TiTerm le 08 oct. 2018, 13:41, édité 2 fois.

yadert
Timide
Messages : 15
Inscription : 18 mai 2015, 13:37
Localisation : Aisne
Contact :

Re: Fibaro Flood sensor FGFS-101 ZW5 v3.3 non reconnu

Message par yadert » 08 oct. 2018, 11:42

En effet, que les maj du core ou des fonctionnalités soit lente ça ne me dérange pas trop tant que c'est stable et utilisable.
En revanche si les prises en charge de périphériques sont aussi lente que le reste, on risque de finir par se demander a chaque fois qu'on achète un module si celui ci va fonctionner ou pas...
Alors généralement on trouve une solution en bidouillant mais qu'est-ce que ça va donner quand une maj sortira ? On stress aussi que ça casse nos modifications ?



Envoyé de mon Nokia 6.1 en utilisant Tapatalk

Yadert.
JEEDom Stable |DIY|Raspberry Pi 3/B + module MSATA
Mon matériel ici

mortyre
Actif
Messages : 970
Inscription : 17 mai 2016, 16:51

Re: Fibaro Flood sensor FGFS-101 ZW5 v3.3 non reconnu

Message par mortyre » 09 oct. 2018, 16:59

Vous pouvez regarder dans le plugin OpenZwave en Beta les config sont souvent mis à jour dessus (ils attendent souvent ne nouvelle version de Jeedom pour pousser ce plugin en stable en même temps).
PROD: NAS1815+ VMM Strech 9.4 / Jeedom 3.2.12 / MariaDB 10.1.26 / PHP 7.0.27
DEV: DIY Odroid C2 16gb Strech 9.4 / Jeedom 3.3.x beta / MariaDB 10.1.26 / PHP 7.0.27

Avatar de l’utilisateur
fredyl7
Timide
Messages : 17
Inscription : 27 déc. 2017, 22:07

Re: Fibaro Flood sensor FGFS-101 ZW5 v3.3 non reconnu

Message par fredyl7 » 31 oct. 2018, 23:04

@TiTerm: j'ai effectué tes 3 manip', mais impossible de faire reconnaître mon nouveau module..
Fibaro Flood Sensor FGFS-101 v3.3 EU

Pour être précis j'ai lancé ça (j'ai vérifié, j'ai bien la ligne pour l'id 1003 ajoutée dans le xml) :

Code : Tout sélectionner

cd /var/www/html/plugins/openzwave/

sudo cp -p core/config/devices/fibaro_271/271.2817.4098_fgfs101zw5.flood.sensor.json core/config/devices/fibaro_271/271.2817.4099_fgfs101zw5.flood.sensor.json

sudo cp -p core/config/devices/fibaro_271/271.2817.4098_fgfs101zw5.flood.sensor.jpg core/config/devices/fibaro_271/271.2817.4099_fgfs101zw5.flood.sensor.jpg

sudo sed -i -e '/<Product type="0b01" id="1002" name="FGFS101 Zwave+ Flood Sensor" config="fibaro\/fgfs101zw5.xml" \/>/a\' -e '<Product type="0b01" id="1003" name="FGFS101 Zwave+ Flood Sensor" config="fibaro\/fgfs101zw5.xml" \/>' resources/openzwaved/config/manufacturer_specific.xml
Ensuite j'ai dés-associé le module non reconnu, puis ré-associé.
Cela n'a rien changé, donc j'ai relancé le démon du plugin Z-Wave mais cela ne change rien non plus, malgré plusieurs autres associations/dés-associations.

Du coup, pour essayer de comprendre la cause, j'ai plusieurs questions :
- pour le Xml, comment as tu trouvé l'id (constructeur) du nouveau module ?
- pour le Json et l'image, comment as tu trouvé qu'il fallait mettre 4099 au lieu de 4098 ?
- comment le plugin Z-wave fait pour savoir que le module d'id 1003 s'affiche avec l'image 4099 ?

Merci d'avance

Avatar de l’utilisateur
fredyl7
Timide
Messages : 17
Inscription : 27 déc. 2017, 22:07

Re: Fibaro Flood sensor FGFS-101 ZW5 v3.3 non reconnu

Message par fredyl7 » 31 oct. 2018, 23:39

Bah j'ai fait une pause, retour sur Jeedom j'ai l'idée d'essayer le bouton "Synchroniser", sans savoir ce que cela fait 'vraiment' et boum j'ai l'image etc.. de mon module !! :lol:

Cool, plus qu'a tester ;)

TiTerm
Timide
Messages : 24
Inscription : 16 mars 2018, 09:31
Contact :

Re: Fibaro Flood sensor FGFS-101 ZW5 v3.3 non reconnu

Message par TiTerm » 01 nov. 2018, 14:04

@freedy7, Je me suis inspiré des fichiers de déclaration de la version précédente du module.
Le nouveau module n'étant pas reconnu, dans jeedom, regarde les premiers screenshot que j'ai mis dans ce thread, tu verras d'où viennent l'id constructeur etc....
Ensuite, avec les nouvelles valeurs et la façon dont était déclaré l'ancienne version, j'ai juste adapté.

Avatar de l’utilisateur
fredyl7
Timide
Messages : 17
Inscription : 27 déc. 2017, 22:07

Re: Fibaro Flood sensor FGFS-101 ZW5 v3.3 non reconnu

Message par fredyl7 » 01 nov. 2018, 14:24

Ok, sorry, j'avais zappé que ta première capture d'écran correspondait au module encore 'non reconnu'.
Ok, donc c'est l'Identifiant produit : 4099 (0x1003)
Décimal -> Hexa, hyper simple.

Merci pour ta réponse ;)

Avatar de l’utilisateur
Maikinoki
Timide
Messages : 28
Inscription : 19 nov. 2014, 20:48

Re: Fibaro Flood sensor FGFS-101 ZW5 v3.3 non reconnu

Message par Maikinoki » 07 janv. 2019, 16:45

Hello,

Je déterre ce sujet car pour moi qui ait une Jeedom Smart, même souci d'inclusion. Ticket de support créé mais aucun retour.
Je trouve cela franchement dommage ce manque d'information, c'est quand même très impactant : n'ayant aucun module plus ancien de ce type, je ne peux en recréer un autre par copie ou genre (et de toute façon c'est de la bidouille). Savoir qu'il y a des PR non prise en compte qui corrigent le souci ça m'énerve d'autant plus...

A noter : j'ai profité du questionnaire Jeedom pour remonter mon soutiens, ma satisfaction globale sur l'application mais mon mécontentement sur ce type de communication. Même pas un "On a pris en compte votre ticket mais on va mettre du temps à le traiter".

Tewill
Timide
Messages : 5
Inscription : 29 août 2018, 08:42

Re: Fibaro Flood sensor FGFS-101 ZW5 v3.3 non reconnu

Message par Tewill » 12 janv. 2019, 14:23

J'ai fait une demande à Jeedom.
J'ai ouvert un ticket.
Je reviens dès que j'ai reçu une réponse.

Répondre

Revenir vers « Configurations OpenZwave Manquantes »

Qui est en ligne ?

Utilisateurs parcourant ce forum : epgdurand et 1 invité