Avant toute chose merci de (re)prendre connaissance de la charte et de la respecter.
Pour résumer :
- Avant de poser une question, je cherche si la réponse existe
- Je suis poli, courtois et je respecte tout un chacun sur le forum
- Si un post m'agace : je m'en éloigne plutôt que de répondre d'une façon qui pourrait être mal interprétée


Il n'est jamais du luxe que de rappeler des choses simples :
Courtoisie, amabilité, politesse et bonne humeur sont les maîtres mots pour un forum sympathique, bienveillant et accueillant :)

Toute la communauté vous remercie

Raspberry pi B et wifi

drs
Actif
Messages : 1161
Inscription : 04 nov. 2016, 10:44

Raspberry pi B et wifi

Message par drs » 12 août 2018, 19:03

Bonjour

Je craque :)

j'ai récupéré un ancien raspberry (model B), et je voudrais installer une clé wifi dessus. J'ai mis une raspbian Stretch dernière version. Ce petit raspberry pourrait peut être servir comme petit jeedom déporté, ou bien de tests (ou plein d'autres choses encore).

Ma clé wifi est bien reconnue:

Code : Tout sélectionner

[pi@raspberrypi:~ $ lsusb
Bus 001 Device 007: ID 046d:c521 Logitech, Inc. Cordless Mouse Receiver
Bus 001 Device 006: ID 05ac:0221 Apple, Inc. Aluminum Keyboard (ISO)
Bus 001 Device 005: ID 05ac:1006 Apple, Inc. Hub in Aluminum Keyboard
Bus 001 Device 004: ID 0bda:8172 Realtek Semiconductor Corp. RTL8191SU 802.11n WLAN Adapter
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. SMC9514 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Elle voir bien mon réseau wifi, avec la commande iwlist wlan0 scanning:

Code : Tout sélectionner

[pi@raspberrypi:~ $ iwlist wlan0 scanning
wlan0     Scan completed :
          Cell 01 - Address: 9C:3D:CF:34:4B:71
                    ESSID:"NOM-SSID"
                    Protocol:IEEE 802.11bgn
                    Mode:Master
                    Frequency:2.412 GHz (Channel 1)
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
                              12 Mb/s; 48 Mb/s
                    Extra:rsn_ie=30140100000fac040100000fac040100000fac020c00
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK
                    IE: Unknown: DD850050F204104A00011010440001021057000101103B00010310470010E5CD91B7717CE92488BC414E22BF53BD1021000D4E4554474541522C20496E632E102300075236343030763210240007523634303076321042000233321054000800060050F20400011011000752363430307632100800022008103C0001031049000600372A000120
                    Signal level=57/100  
J'ai configuré mon fichier /etc/wpa_supplicant/wpa_supplicant.conf avec:

Code : Tout sélectionner

network={
ssid="NOM-SSID"
psk="MACLEPSK"
proto=RSN
key_mgmt=WPA-PSK
pairwise=CCMP
auth_alg=OPEN
}

J'ai modifié mon fichier /etc/network/interfaces avec:

Code : Tout sélectionner

# interfaces(5) file used by ifup(8) and ifdown(8)

# Please note that this file is written to be used with dhcpcd
# For static IP, consult /etc/dhcpcd.conf and 'man dhcpcd.conf'

# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
Et quand je redémarre, l'eth0 prend bien une adresse, mais pas le wlan0:

Code : Tout sélectionner

eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.249.190  netmask 255.255.255.0  broadcast 192.168.249.255
        inet6 fe80::5867:cdf7:ace5:2770  prefixlen 64  scopeid 0x20<link>
        ether b8:27:eb:67:c7:d4  txqueuelen 1000  (Ethernet)
        RX packets 1191  bytes 104670 (102.2 KiB)
        RX errors 0  dropped 75  overruns 0  frame 0
        TX packets 718  bytes 112754 (110.1 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlan0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 24:05:0f:95:15:d0  txqueuelen 1000  (Ethernet)
        RX packets 9  bytes 1215 (1.1 KiB)
        RX errors 0  dropped 6  overruns 0  frame 0
        TX packets 8  bytes 1240 (1.2 KiB)
        TX errors 0  dropped 1 overruns 0  carrier 0  collisions 0
J'ai testé en modifiant le fichier /etc/network/interfaces avec des "choses" trouvées sur internet (ici par exemple: https://weworkweplay.com/play/automatic ... i-network/), mais lorsque je le fais, j'ai un message de dhcpcd qui n'a pas pu démarrer...

Je suis sûr qu'il y a une procédure simple pour le faire, mais je ne dois pas trouver la bonne.

Une idée sur la chose?

Merci

drs
Actif
Messages : 1161
Inscription : 04 nov. 2016, 10:44

Re: Raspberry pi B et wifi

Message par drs » 13 août 2018, 12:18

Re

J'ai suivi aussi ce tuto, qui parait très simple https://wiki.debian.org/fr/WiFi/HowToUse.

Mais à l'étape ifup wlan0, j'obtiens:

Code : Tout sélectionner

ifup: /etc/network/interfaces:11: option with empty value
ifup: couldn't read interfaces file "/etc/network/interfaces"
Je sèche complètement...

Networks514
Timide
Messages : 324
Inscription : 02 sept. 2016, 22:22

Re: Raspberry pi B et wifi

Message par Networks514 » 13 août 2018, 15:14

drs a écrit :
13 août 2018, 12:18
Re

J'ai suivi aussi ce tuto, qui parait très simple https://wiki.debian.org/fr/WiFi/HowToUse.

Mais à l'étape ifup wlan0, j'obtiens:

Code : Tout sélectionner

ifup: /etc/network/interfaces:11: option with empty value
ifup: couldn't read interfaces file "/etc/network/interfaces"
Je sèche complètement...
Et avec le wifi interne du pi sans passerpar une clé wifi ça fonctionne ?
J'utilise le wifi interne (sur pi debian) qui pointe vers la box opérateur et l'Ethernet vers mon routeur perso
Voici si cela peut t'aider ma conf

vi /etc/network/interfaces

Code : Tout sélectionner

auto lo
iface lo inet loopback
 
auto eth0
allow-hotplug eth0
iface eth0 inet manual
 
auto wlan0
allow-hotplug wlan0
iface wlan0 inet manual
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
 
auto wlan1
allow-hotplug wlan1
iface wlan1 inet manual
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
vi /etc/wpa_supplicant/wpa_supplicant.conf

Code : Tout sélectionner

country=FR
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

network={
    ssid="The_ESSID_from_earlier"
    psk="Your_wifi_password"
}
Networks514
Jeedom / Synology DS411j / Synology DS916+8G / Rpi3 / Zibase
Zwave / Enocean / Rflink / Xiaomi / Bluetooth

drs
Actif
Messages : 1161
Inscription : 04 nov. 2016, 10:44

Re: Raspberry pi B et wifi

Message par drs » 13 août 2018, 17:06

Salut

Merci de ta réponse, mais je n'ai pas de wifi intégré, c'est un raspberry model B, donc juste avec Ethernet.

Mais au final j'ai réussi en suivant ce sujet: https://www.raspberrypi.org/forums/view ... p?t=196886

Au final, voici ce que j'ai fais (je détaille la procédure, cela pourra peut être servir à quelqu'un):

1. CONFIGURER LE FICHIER /etc/network/interfaces, comme suit:

Code : Tout sélectionner

# interfaces(5) file used by ifup(8) and ifdown(8)

# Please note that this file is written to be used with dhcpcd
# For static IP, consult /etc/dhcpcd.conf and 'man dhcpcd.conf'

# Include files from /etc/network/interfaces.d:
#source-directory /etc/network/interfaces.d
auto lo
iface lo inet loopback

iface eth0 inet manual

auto wlan0
allow-hotplug wlan0
iface wlan0 inet manual
        wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
2. Générer un hash de la clé WPA, avec la commande:
wpa_passphrase SSID CLE_WPA

Il va sortir des lignes de ce type:

Code : Tout sélectionner

network={
	ssid="ssid"
	#psk="psk normale"
	psk=hash-psk
}
3. Configurer le fichier /etc/wpa_supplicant/wpa-supplicant.conf, comme suit:

Code : Tout sélectionner

update_config=1
country=FR
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
network={
	ssid="ssid"
	#psk="psk normale"
	psk=hash-psk
}

3. Activer le wpa_supplicant, avec la commande:

Code : Tout sélectionner

systemctl enable wpa_supplicant.service
4. Reboot et enjoy :)


Il me reste un dernier détail: dans le nom de mon SSID, j'ai le caractère -, et cela ne fonctionne pas. Par contre, sur un autre SSID avec juste des lettres, il se connecte sans problème.
J'ai essayé pas mal de choses:
- entrer le caractère d'échappement (si mon nom est SSID-SSID, j'ai mis SSID\-SSID)
- faire un calcul de la valeur SSID-SSID en hexa, et le mettre à la place
Mais rien à faire, je le vois bien essayer de se connecter à mon SSID, mais il me dit que la clé est pas bonne (mais elle l'est)

Networks514
Timide
Messages : 324
Inscription : 02 sept. 2016, 22:22

Re: Raspberry pi B et wifi

Message par Networks514 » 13 août 2018, 19:27

Hello ,
J'ai déjà vu des pb similaires pour lequel le paquet wpa_supplicant était buggé. Pour ton caractère - , c'est effectivement mieux de passer en Hexa.
Si tu génères ta clé psk via https://www.wireshark.org/tools/wpa-psk.html tu obtiens le même hash qu'en ligne de commande ?
Networks514
Jeedom / Synology DS411j / Synology DS916+8G / Rpi3 / Zibase
Zwave / Enocean / Rflink / Xiaomi / Bluetooth

drs
Actif
Messages : 1161
Inscription : 04 nov. 2016, 10:44

Re: Raspberry pi B et wifi

Message par drs » 14 août 2018, 09:15

Networks514 a écrit :
13 août 2018, 19:27
Hello ,
J'ai déjà vu des pb similaires pour lequel le paquet wpa_supplicant était buggé. Pour ton caractère - , c'est effectivement mieux de passer en Hexa.
Si tu génères ta clé psk via https://www.wireshark.org/tools/wpa-psk.html tu obtiens le même hash qu'en ligne de commande ?
Merci pour ta réponse. J'ai testé, mais cela me donne le même résultat qu'avec wpa_passphrase.

J'ai vraiment un problème avec le SSID avec le caractère -, car un autre SSID avec que des lettres (et la même clé que le SSID d'origine) fonctionne impec.

Répondre

Revenir vers « Raspberry Pi »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité