Avant toute chose merci de (re)prendre connaissance de la charte et de la respecter.
Pour résumer :
- Avant de poser une question, je cherche si la réponse existe
- Je suis poli, courtois et je respecte tout un chacun sur le forum
- Si un post m'agace : je m'en éloigne plutôt que de répondre d'une façon qui pourrait être mal interprétée


Il n'est jamais du luxe que de rappeler des choses simples :
Courtoisie, amabilité, politesse et bonne humeur sont les maîtres mots pour un forum sympathique, bienveillant et accueillant :)

Toute la communauté vous remercie

[Plugin Tiers] Loxone

bossensky
Timide
Messages : 39
Inscription : 27 févr. 2015, 13:35

Re: [Plugin Tiers] Loxone

Message par bossensky » 04 févr. 2019, 15:54

Bonjour Lunarok,

Je viens de refaire le test avec une installation neuve en Debian 9 et j'ai la même erreur encore, ci-dessous mon log, merci d'avance.

Début de l'installation
--2019-02-04 15:46:07-- https://raw.githubusercontent.com/lunar ... /nodejs.sh
Resolving raw.githubusercontent.com (raw.githubusercontent.com)... 151.101.120.133
Connecting to raw.githubusercontent.com (raw.githubusercontent.com)|151.101.120.133|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1489 (1.5K) [text/plain]
Saving to: 'dependencies.sh'
0K . 100% 66.0M=0s
2019-02-04 15:46:08 (66.0 MB/s) - 'dependencies.sh' saved [1489/1489]
dependencies.sh: 3: [: /tmp/jeedom/loxone/dependancy: unexpected operator
Nodejs non installé
Ign:1 http://ftp.fr.debian.org/debian stretch InRelease
Hit:2 http://security.debian.org/debian-security stretch/updates InRelease
Hit:3 http://ftp.fr.debian.org/debian stretch-updates InRelease
Hit:4 http://ftp.fr.debian.org/debian stretch Release
Reading package lists...
Reading package lists...
Building dependency tree...
Reading state information...
lsb-release is already the newest version (9.20161125).
lsb-release set to manually installed.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
KO, version obsolète à upgrader
Suppression du Nodejs existant et installation du paquet recommandé
Reading package lists...
Building dependency tree...
Reading state information...
E: Unable to locate package npm
dependencies.sh: 37: [: x86_64: unexpected operator
Utilisation du dépot officiel
## Installing the NodeSource Node.js 8.x LTS Carbon repo...
## Populating apt-get cache...
+ apt-get update
Hit:1 http://security.debian.org/debian-security stretch/updates InRelease
Ign:2 http://ftp.fr.debian.org/debian stretch InRelease
Hit:3 http://ftp.fr.debian.org/debian stretch-updates InRelease
Hit:4 http://ftp.fr.debian.org/debian stretch Release
Reading package lists...
## Confirming "stretch" is supported...
+ curl -sLf -o /dev/null 'https://deb.nodesource.com/node_8.x/dis ... ch/Release'
## Adding the NodeSource signing key to your keyring...
+ curl -s https://deb.nodesource.com/gpgkey/nodesource.gpg.key | apt-key add -
Warning: apt-key output should not be parsed (stdout is not a terminal)
OK
## Creating apt sources list file for the NodeSource Node.js 8.x LTS Carbon repo...
+ echo 'deb https://deb.nodesource.com/node_8.x stretch main' > /etc/apt/sources.list.d/nodesource.list
+ echo 'deb-src https://deb.nodesource.com/node_8.x stretch main' >> /etc/apt/sources.list.d/nodesource.list
## Running `apt-get update` for you...
+ apt-get update
Hit:1 http://security.debian.org/debian-security stretch/updates InRelease
Ign:2 http://ftp.fr.debian.org/debian stretch InRelease
Hit:3 http://ftp.fr.debian.org/debian stretch-updates InRelease
Get:4 https://deb.nodesource.com/node_8.x stretch InRelease [4647 B]
Hit:5 http://ftp.fr.debian.org/debian stretch Release
Get:6 https://deb.nodesource.com/node_8.x stretch/main Sources [762 B]
Get:8 https://deb.nodesource.com/node_8.x stretch/main amd64 Packages [1009 B]
Fetched 6418 B in 0s (7316 B/s)
Reading package lists...
## Run `sudo apt-get install -y nodejs` to install Node.js 8.x LTS Carbon and npm
## You may also need development tools to build native addons:
sudo apt-get install gcc g++ make
## To install the Yarn package manager, run:
curl -sL https://dl.yarnpkg.com/debian/pubkey.gpg | sudo apt-key add -
echo "deb https://dl.yarnpkg.com/debian/ stable main" | sudo tee /etc/apt/sources.list.d/yarn.list
sudo apt-get update && sudo apt-get install yarn
Reading package lists...
Building dependency tree...
Reading state information...
The following NEW packages will be installed:
nodejs
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 13.6 MB of archives.
After this operation, 64.3 MB of additional disk space will be used.
Get:1 https://deb.nodesource.com/node_8.x stretch/main amd64 nodejs amd64 8.15.0-1nodesource1 [13.6 MB]
debconf: unable to initialize frontend: Dialog
debconf: (Dialog frontend will not work on a dumb terminal, an emacs shell buffer, or without a controlling terminal.)
debconf: falling back to frontend: Readline
debconf: unable to initialize frontend: Readline
debconf: (This frontend requires a controlling tty.)
debconf: falling back to frontend: Teletype
dpkg-preconfigure: unable to re-open stdin:
Fetched 13.6 MB in 5s (2500 kB/s)
Selecting previously unselected package nodejs.
(Reading database ...
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 57531 files and directories currently installed.)
Preparing to unpack .../nodejs_8.15.0-1nodesource1_amd64.deb ...
Unpacking nodejs (8.15.0-1nodesource1) ...
Setting up nodejs (8.15.0-1nodesource1) ...
Processing triggers for man-db (2.7.6.1-2) ...
Version actuelle : v8.15.0
> websocket@1.0.28 install /var/www/html/plugins/loxone/resources/node_modules/websocket
> (node-gyp rebuild 2> builderror.log) || (exit 0)
make: Entering directory '/var/www/html/plugins/loxone/resources/node_modules/websocket/build'
CXX(target) Release/obj.target/bufferutil/src/bufferutil.o
SOLINK_MODULE(target) Release/obj.target/bufferutil.node
COPY Release/bufferutil.node
CXX(target) Release/obj.target/validation/src/validation.o
SOLINK_MODULE(target) Release/obj.target/validation.node
COPY Release/validation.node
make: Leaving directory '/var/www/html/plugins/loxone/resources/node_modules/websocket/build'
> lxcommunicator@0.9.0 postinstall /var/www/html/plugins/loxone/resources/node_modules/lxcommunicator
> node ./browserify.js
Creating browserified module...
Creating debug module
Creating release module
Saving debug module
Saving release module
LxCommunicator~Browser.js and LxCommunicator~Browser.min.js has been created!
npm notice created a lockfile as package-lock.json. You should commit this file.
added 274 packages from 277 contributors and audited 1282 packages in 28.71s
found 0 vulnerabilities
Fin de l'installation

iopaza
Timide
Messages : 191
Inscription : 11 avr. 2015, 09:56

Re: [Plugin Tiers] Loxone

Message par iopaza » 17 mars 2019, 17:33

Bonjour,
J'avais pas vraiment eu le temps de regarder le plugin, en tout cas bravo.
Je viens de regarder au niveau de la récupération des commandes infos de chaque pièce, et qui sont bien crées et c'est génial.
Cependant, je m'aperçois que tout ce qui vient de mon extension n'est pas créé. Es-ce que j'ai oublié quelque chose ou bien c'est en cours d'ajout?
Merci
Jeedom mini+ et Rpi2
-RFXCOM --> 4 modules/-ZWAVE --> 15 modules/-KNX --> 3 modules/-LOXONE et EXTENSION/-IPX V4 et Extension, Fil pilote/- HUE --> 2 modules/-MILIGHT et ARILUX/-ORVIBO
-LEGRAND CPL (non utilisé)

tigroux06
Timide
Messages : 78
Inscription : 23 mai 2015, 08:30

Re: [Plugin Tiers] Loxone

Message par tigroux06 » 17 avr. 2019, 17:44

Bonjour Lunarok

D'abord merci pour ton plugin.

Je viens d'installer le plugin Loxone mais je n'arrive pas à le faire fonctionner.
J'ai crée une entré virtuel sur Loxone avec le port UDP 7778.
Mais la connexion ne s’établit pas. Je ne vois rien dans les logs d'assez parlant.

J'ai ce message:
Echec de la requête HTTP : http://192.168.40.250/data/LoxAPP3.json cURL error : Connection timed out after 30000 milliseconds

Je sais pas si tu as besoin de plus d'informations

Avatar de l’utilisateur
lunarok
Actif
Messages : 6251
Inscription : 08 août 2014, 12:48
Localisation : Anjou

Re: [Plugin Tiers] Loxone

Message par lunarok » 17 avr. 2019, 20:49

Ton Jeedom n'arrive meme pas à joindre le Loxone là. Tu es sur de l'IP ??? .40.250 et le jeedom ?
Mon Blog | Xiaomi Home
Pour contribuer au développement des plugins (don ou achat de matériel) : Paypal
Aides nous à t'aider : les logs, détails du soucis, la doc, recherche sur le forum ...
PS : pas de support par MP, je ne répondrais pas

tigroux06
Timide
Messages : 78
Inscription : 23 mai 2015, 08:30

Re: [Plugin Tiers] Loxone

Message par tigroux06 » 17 avr. 2019, 22:31

Salut

Oui Loxone 192.168.40.250 et Jeedom 192.168.40.100

Avatar de l’utilisateur
lunarok
Actif
Messages : 6251
Inscription : 08 août 2014, 12:48
Localisation : Anjou

Re: [Plugin Tiers] Loxone

Message par lunarok » 17 avr. 2019, 22:34

Là il te dit que depuis Jeedom il n'arrive pas à joindre Loxone. Et c'est réseau, connection timeout
Mon Blog | Xiaomi Home
Pour contribuer au développement des plugins (don ou achat de matériel) : Paypal
Aides nous à t'aider : les logs, détails du soucis, la doc, recherche sur le forum ...
PS : pas de support par MP, je ne répondrais pas

tigroux06
Timide
Messages : 78
Inscription : 23 mai 2015, 08:30

Re: [Plugin Tiers] Loxone

Message par tigroux06 » 17 avr. 2019, 23:37

Le test http qu'effectue Jeedom se fait sur le port 80 du Loxone?

Avatar de l’utilisateur
lunarok
Actif
Messages : 6251
Inscription : 08 août 2014, 12:48
Localisation : Anjou

Re: [Plugin Tiers] Loxone

Message par lunarok » 18 avr. 2019, 07:56

Oui, quand aucun port n'est précisé en http c'est 80 le standard, c'est le port d'écoute loxone
Mon Blog | Xiaomi Home
Pour contribuer au développement des plugins (don ou achat de matériel) : Paypal
Aides nous à t'aider : les logs, détails du soucis, la doc, recherche sur le forum ...
PS : pas de support par MP, je ne répondrais pas

tigroux06
Timide
Messages : 78
Inscription : 23 mai 2015, 08:30

Re: [Plugin Tiers] Loxone

Message par tigroux06 » 18 avr. 2019, 08:29

Ah je vais regarder je l'avais peut être changé.
Si je l'ai changé je dois le mettre où ?
Après l'adresse IP avec : ?

Cela ne va pas gêner pour l'udp ensuite ?

Avatar de l’utilisateur
lunarok
Actif
Messages : 6251
Inscription : 08 août 2014, 12:48
Localisation : Anjou

Re: [Plugin Tiers] Loxone

Message par lunarok » 18 avr. 2019, 10:11

J'ai jamais vu d'option pour mettre le Loxone sur un autre port que 80. Comment tu t'y connectes exactement avec quelle adresse dans l'app mobile par exemple ?
J'ai plutot l'impression que ton problème est réseau entre les 2 vu que ni le http ni l'udp marche. Pourquoi un réseau .40.x ? tu as des vlan ou autres ?
Mon Blog | Xiaomi Home
Pour contribuer au développement des plugins (don ou achat de matériel) : Paypal
Aides nous à t'aider : les logs, détails du soucis, la doc, recherche sur le forum ...
PS : pas de support par MP, je ne répondrais pas

tigroux06
Timide
Messages : 78
Inscription : 23 mai 2015, 08:30

Re: [Plugin Tiers] Loxone

Message par tigroux06 » 18 avr. 2019, 23:44

Je me connecte avec l'adresse 192.168.40.250:7777
Non je n'ai pas de vlan pour le moment mais j'ai juste changé mon IP réseau et mon DHCP.

Répondre

Revenir vers « [Catégorie] Passerelle Domotique »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 0 invité