Avant toute chose merci de (re)prendre connaissance de la charte et de la respecter.
Pour résumer :
- Avant de poser une question, je cherche si la réponse existe
- Je suis poli, courtois et je respecte tout un chacun sur le forum
- Si un post m'agace : je m'en éloigne plutôt que de répondre d'une façon qui pourrait être mal interprétée


Il n'est jamais du luxe que de rappeler des choses simples :
Courtoisie, amabilité, politesse et bonne humeur sont les maîtres mots pour un forum sympathique, bienveillant et accueillant :)

Le groupe des Helpers est present pour vous aidez, n'hésitez pas à poser des questions ;)

Toute la communauté vous remercie

/!\ L’ancien forum passera en lecture seule en janvier 2020./!\
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

Jeedom OK mais SSH impossible

Pour parler de tout, et surtout de rien !
Répondre
Avatar de l’utilisateur
Patdec
Actif
Messages : 756
Inscription : 21 janv. 2015, 15:49
Localisation : Tournai

Jeedom OK mais SSH impossible

Message par Patdec » 14 juin 2019, 16:39

Bonjour,

Accès externe Jeedom = OK. Les commandes de mes volets fonctionnent.
Analyse santé, tout est vert.
J'ai relancé les dépendances par acquis de conscience.
J'ai remis les droits.
J'ai redémarré Jeedom
Les commandes telles que cat, rm, cp dans __ OS/DB --> Administration fonctionnent.
J'ai supprimé le fichier /etc/fail2ban/jail.local pensant que j'aurai pu lui mettre des paramètres inadaptés.

Par contre, avec
Putty en SSH = Network error : Connection timed out
Winscp = Erreur réseau connexion à l'hôte " mon domaine.ddns.net " refusée


Ici , les dernières lignes de http error

Si vous avez une idée, bien sur je suis preneur.

Quel fichier regarder ?

Code : Tout sélectionner

[Sun Jun 09 19:18:33.550566 2019] [access_compat:error] [pid 28116] [client 121.201.109.80:20130] AH01797: client denied by server configuration: /var/www/html/data/admin
[Sun Jun 09 19:18:33.786852 2019] [:error] [pid 28116] [client 121.201.109.80:20130] script '/var/www/html/12.php' not found or unable to stat
[Sun Jun 09 19:18:34.027385 2019] [:error] [pid 28116] [client 121.201.109.80:20130] script '/var/www/html/ecmsmod.php' not found or unable to stat
[Sun Jun 09 19:18:34.965305 2019] [:error] [pid 28116] [client 121.201.109.80:20130] script '/var/www/html/user.php' not found or unable to stat, referer: 554fcae493e564ee0dc75bdf2ebf94caads|a:3:{s:2:"id";s:3:"'/*";s:3:"num";s:141:"*/ union select 1,0x272F2A,3,4,5,6,7,8,0x7b247b24524345275d3b6469652f2a2a2f286d6435284449524543544f52595f534550415241544f5229293b2f2f7d7d,0--";s:4:"name";s:3:"ads";}554fcae493e564ee0dc75bdf2ebf94ca
[Sun Jun 09 19:18:35.647113 2019] [:error] [pid 28116] [client 121.201.109.80:20130] script '/var/www/html/search.php' not found or unable to stat
[Mon Jun 10 10:48:37.361763 2019] [:error] [pid 2446] [client 51.77.74.32:49590] script '/var/www/html/elrekt.php' not found or unable to stat
[10-Jun-2019 10:48:37 Europe/Berlin] PHP Notice:  Array to string conversion in /var/www/html/index.php on line 28
[Mon Jun 10 15:17:31.622988 2019] [core:error] [pid 9186] [client 192.228.100.252:46716] AH00126: Invalid URI in request GET HTTP/1.1 HTTP/1.1
[Mon Jun 10 15:17:31.957819 2019] [:error] [pid 28116] [client 192.228.100.252:47054] script '/var/www/html/wp-login.php' not found or unable to stat
[Tue Jun 11 03:00:17.178673 2019] [:error] [pid 3037] [client 5.188.210.101:55761] script '/var/www/html/echo.php' not found or unable to stat, referer: https://www.google.com/
[Tue Jun 11 22:09:38.472783 2019] [access_compat:error] [pid 3037] [client 49.51.171.36:52829] AH01797: client denied by server configuration: /var/www/html/data/admin
[Tue Jun 11 22:09:38.500011 2019] [access_compat:error] [pid 3037] [client 49.51.171.36:52829] AH01797: client denied by server configuration: /var/www/html/data/admin
[Wed Jun 12 19:02:40.066963 2019] [:error] [pid 2446] [client 62.244.212.172:60356] script '/var/www/html/elrekt.php' not found or unable to stat
[12-Jun-2019 19:02:40 Europe/Berlin] PHP Notice:  Array to string conversion in /var/www/html/index.php on line 28
[Fri Jun 14 09:47:29.630661 2019] [mpm_prefork:notice] [pid 489] AH00163: Apache/2.4.25 (Debian) configured -- resuming normal operations
[Fri Jun 14 09:47:29.635990 2019] [core:notice] [pid 489] AH00094: Command line: '/usr/sbin/apache2'
warning: commands will be executed using /bin/sh
job 3 at Fri Jun 14 16:12:00 2019
Dernière édition par Patdec le 22 juin 2019, 08:58, édité 1 fois.
Débutant Jeedom.
VirtualBox 6.0.10 sur Tablette I Works 12 sous Win 10 - Debian 9.9
Jeedom 3.3.33 - Contrôleur Aeotec ZW 090 C
Modules Fibaro FGR-222

Avatar de l’utilisateur
Patdec
Actif
Messages : 756
Inscription : 21 janv. 2015, 15:49
Localisation : Tournai

Re: Jeedom OK mais SSH impossible

Message par Patdec » 17 juin 2019, 00:01

Petit up .

La commande "last" me montre qu'aucune connexion pirate ne s'est logué avec succès. C'est déjà ça !!!

Il est possible à partir de Os_Db --> Administration de créer un fichier dans l'arborescence linux.
Par contre nano, vi, vim semble ne pas pouvoir écrire dedans.

Peut-être avec un script ?

Edit: Le plugin Jexplorer de Kiboost ne rapporte pas l'arborescence de Linux et comme je veux écrire dans /etc/fail2ban/jail.local c'est pas ici encore possible.
Débutant Jeedom.
VirtualBox 6.0.10 sur Tablette I Works 12 sous Win 10 - Debian 9.9
Jeedom 3.3.33 - Contrôleur Aeotec ZW 090 C
Modules Fibaro FGR-222

Avatar de l’utilisateur
Patdec
Actif
Messages : 756
Inscription : 21 janv. 2015, 15:49
Localisation : Tournai

Re: Jeedom OK mais SSH impossible

Message par Patdec » 22 juin 2019, 00:21

Peut être une piste, qu'en pensez vous ?

La box sur laquelle je suis connecté en externe me renseigne une IPv4 et une IPv6 actives.
Ma box au domicile n'ayant qu'une IPv4 expliquerai ce problème.
Ssh écoutant sur les 2, me conseilleriez vous de désactiver l'IPv6 ? qui enverrait des trames incomprises par la box domicile.

Comme il y a plusieurs fichiers à modifier suivant ce site , vos avis m'aiderons pour lancer la procédure ou non.
Débutant Jeedom.
VirtualBox 6.0.10 sur Tablette I Works 12 sous Win 10 - Debian 9.9
Jeedom 3.3.33 - Contrôleur Aeotec ZW 090 C
Modules Fibaro FGR-222

Avatar de l’utilisateur
Patdec
Actif
Messages : 756
Inscription : 21 janv. 2015, 15:49
Localisation : Tournai

Re: Jeedom OK mais SSH impossible

Message par Patdec » 23 juin 2019, 10:09

La suite.....

Je pense avoir désactivé les écoutes sur l 'IPv6.

Sudo netstat.jpg
Sudo netstat.jpg (112.26 Kio) Consulté 494 fois

ifconfig.jpg
ifconfig.jpg (80.1 Kio) Consulté 494 fois


La VM et Jeedom ont été redémarrés.
Toujours pas de connexion avec Putty de l'extérieur.



Erreur réseau.jpg
Erreur réseau.jpg (17.69 Kio) Consulté 494 fois

A partir de _OS/DB, tout baigne.
Si vous avez une piste ?.......
Débutant Jeedom.
VirtualBox 6.0.10 sur Tablette I Works 12 sous Win 10 - Debian 9.9
Jeedom 3.3.33 - Contrôleur Aeotec ZW 090 C
Modules Fibaro FGR-222

Avatar de l’utilisateur
Jeandhom
Actif
Messages : 1354
Inscription : 20 oct. 2015, 17:32

Re: Jeedom OK mais SSH impossible

Message par Jeandhom » 23 juin 2019, 11:52

Que donne : ping 192.168.1.61

La résolution DNS fonctionne-t-elle ?
Que donne : ping mondomaine.ddns.net

Avatar de l’utilisateur
LuluDom
Timide
Messages : 111
Inscription : 30 oct. 2017, 12:51

Re: Jeedom OK mais SSH impossible

Message par LuluDom » 23 juin 2019, 13:28

Voici deux liens qui m'ont bien servi au moment de configurer mon ssh Jeedom entre mon PC Windows 10 (j'y utilise le récent openssh de Windows 10 en lieu et place de Putty) et mon Jeedom Do-It-Yourself en Debian Streetch sur eeepc.

viewtopic.php?f=190&t=32438

https://linuxhint.com/enable-ssh-server-debian/

Le deuxième lien surtout m'a bien aidé !

Avatar de l’utilisateur
Patdec
Actif
Messages : 756
Inscription : 21 janv. 2015, 15:49
Localisation : Tournai

Re: Jeedom OK mais SSH impossible

Message par Patdec » 23 juin 2019, 14:18

Jeandhom a écrit :
23 juin 2019, 11:52
Que donne : ping 192.168.1.61

La résolution DNS fonctionne-t-elle ?
Que donne : ping mondomaine.ddns.net
Bonjour Jeandhom,

192.168.1.61 ne donne rien. Cela me parait normal car c'est mon IP locale Jeedom.

J'ai testé ici mondomaine.ddns.net port 2222 (mondomaine étant un nom d'emprunt), j'obtiens " Impossible de se connecter mondomaine.ddns.net:2222 ".

ping mondomaine.ddns.net ne donne rien. Par contre dans Google ou sur mon GSM en connexion de données mondomaine.ddns.net m'amène sur mon serveur Jeedom ( ma tablette sous VM Virtualbox ) et tout fonctionne au poil.

C'est juste la connexion en ssh qui fonctionne pas.

Merci pour ton intérêt.
Débutant Jeedom.
VirtualBox 6.0.10 sur Tablette I Works 12 sous Win 10 - Debian 9.9
Jeedom 3.3.33 - Contrôleur Aeotec ZW 090 C
Modules Fibaro FGR-222

Avatar de l’utilisateur
Patdec
Actif
Messages : 756
Inscription : 21 janv. 2015, 15:49
Localisation : Tournai

Re: Jeedom OK mais SSH impossible

Message par Patdec » 23 juin 2019, 14:38

LuluDom a écrit :
23 juin 2019, 13:28
Voici deux liens qui m'ont bien servi au moment de configurer mon ssh Jeedom entre mon PC Windows 10 (j'y utilise le récent openssh de Windows 10 en lieu et place de Putty) et mon Jeedom Do-It-Yourself en Debian Streetch sur eeepc.

viewtopic.php?f=190&t=32438

https://linuxhint.com/enable-ssh-server-debian/
Bonjour LuluDom,

J'ai toujours fonctionné avec Putty et souvent avec Winscp que je trouve plus convivial par son interface graphique.
Je peux juste assurer que SSH est en service. J'ai redémarré la machine ce matin à 9h03 après l'avoir éteinte proprement par le soft. ( Roue crantée --> Eteindre )

status ssh.jpg
status ssh.jpg (140.29 Kio) Consulté 454 fois
Est-ce que tu pourrais envoyer la même commande dans la console _OS/DB et comparer le résultat avec ma copie d'écran ?

Bon, pendant que tu y travailles je vais à la plage et me rafraîchir. ( Sud Corse ) . Je ferais quelques brassées pour toi :D :D
Débutant Jeedom.
VirtualBox 6.0.10 sur Tablette I Works 12 sous Win 10 - Debian 9.9
Jeedom 3.3.33 - Contrôleur Aeotec ZW 090 C
Modules Fibaro FGR-222

nicosoft
Timide
Messages : 61
Inscription : 07 déc. 2018, 22:07

Re: Jeedom OK mais SSH impossible

Message par nicosoft » 23 juin 2019, 15:35

Bonjour,
Avec quel compte essayez vous de vous connecter ?
root ne peut pas se connecter en ssh sur les dernières versions de Debian. Il faut modifier le fichier de conf pour que cela soit possible ou se connecter via un autre compte puis -> su

mjeanne
Actif
Messages : 621
Inscription : 11 mars 2017, 18:36

Re: Jeedom OK mais SSH impossible

Message par mjeanne » 23 juin 2019, 16:44

Bonjour,

a la lecture de ce topic entier, je ne comprends pas trop ce que vous cherchez a faire. Si j'ai bien compris, vous voulez un accès SSH depuis l’extérieur de votre réseau, j'ai raison ?
La question qui se pose déjà, c'est alors de savoir si cela fonctionne en local, depuis votre réseau. Donc que donne une connexion SSH vers l'IP de votre jeedom sur le port 2222 que vous avez choisi ?
Si cela ne fonctionne pas, il faut revoir les paramètre de votre ou vos parefeux et le routage dans votre réseau.
Si cela fonctionne, il faut alors vérifier que le port 2222 est bien natté de votre box internet vers votre Jeedom.
Et enfin, il faut tester depuis l'extérieur du réseau via votre domaine. Si vous testez depuis le réseau local, il est peu probable que cela fonctionne, car les box ne gèrent pas de loopback.


Petit conseil: à la lecture de votre log HTTP, vous avez ouvert votre Jeedom au monde entier et vous avec déjà des attaques de bots. Pensez à maximiser la sécurité ! Perso je vous recommande de ne pas exposer le port 80 et de privilégier un accès via VPN, ou un filtrage d'IP.

Avatar de l’utilisateur
LuluDom
Timide
Messages : 111
Inscription : 30 oct. 2017, 12:51

Re: Jeedom OK mais SSH impossible

Message par LuluDom » 23 juin 2019, 17:33

Bonjour,

Je ne m'y connais pas tant que ça et donc je ne sais pas d'emblée ce que ce log veut dire, mais le voici :

Code : Tout sélectionner

● ssh.service - OpenBSD Secure Shell server
   Loaded: loaded (/lib/systemd/system/ssh.service; enabled; vendor preset: enabled)
   Active: active (running) since Sun 2019-05-19 22:10:42 CEST; 1 months 4 days ago
 Main PID: 568 (sshd)
    Tasks: 1 (limit: 4915)
   CGroup: /system.slice/ssh.service
           └─568 /usr/sbin/sshd -D

juin 23 17:05:42 Jeedom sshd[17917]: pam_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh ruser= r
juin 23 17:05:44 Jeedom sshd[17917]: Failed password for root from 58.242.83.31 port 45858 ssh2
juin 23 17:05:47 Jeedom sshd[17917]: Failed password for root from 58.242.83.31 port 45858 ssh2
juin 23 17:05:50 Jeedom sshd[17917]: Received disconnect from 58.242.83.31 port 45858:11:  [preauth]
juin 23 17:05:50 Jeedom sshd[17917]: Disconnected from 58.242.83.31 port 45858 [preauth]
juin 23 17:07:46 Jeedom sshd[21292]: pam_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh ruser= r
juin 23 17:07:48 Jeedom sshd[21292]: Failed password for root from 58.242.83.31 port 28386 ssh2
juin 23 17:07:51 Jeedom sshd[21292]: Failed password for root from 58.242.83.31 port 28386 ssh2
juin 23 17:14:15 Jeedom sshd[31754]: Accepted password for jeedom from 192.168.0.127 port 53712 ssh2
juin 23 17:14:15 Jeedom sshd[31754]: pam_unix(sshd:session): session opened for user jeedom by (uid=0)

Notez bien que je lance mon SSH en local. Je n'avais pas saisi que vous vouliez le faire depuis l'externe.

Pour je ne sais plus quelle manipulation, j'ai contourné le problème d'accès à une machine intertne depuis l'interne sans NAT loopback avec une modificaiton simple du fichier hosts de Windows : ajout de l'adresse locale de Jeedom suivie sur la même ligne de l'adresse web de Jeedom. Ce n'est pas une bidouille mais après maintes recherche une solution propre et la seule que j'ai trouvée.

https://www.commentcamarche.net/faq/599 ... hier-hosts

Salva57
Timide
Messages : 55
Inscription : 01 juin 2019, 01:19

Re: Jeedom OK mais SSH impossible

Message par Salva57 » 23 juin 2019, 17:34

Bonjour,

Je suis débutant donc je sais pas si ma réponse va servir.
J'ai lancé la commande que tu donne, mais je suis déjà connecté en ssh avec putty du coup sa te sert peut-être à rien, mais voilà la réponse que j'ai.

Code : Tout sélectionner

lines 1-17/17 (END)
● ssh.service - OpenBSD Secure Shell server
   Loaded: loaded (/lib/systemd/system/ssh.service; enabled; vendor preset: enabled)
   Active: active (running) since Sun 2019-06-23 15:39:52 CEST; 1h 47min ago
  Process: 513 ExecStartPre=/usr/sbin/sshd -t (code=exited, status=0/SUCCESS)
 Main PID: 578 (sshd)
   CGroup: /system.slice/ssh.service
           └─578 /usr/sbin/sshd -D

Jun 23 15:39:51 raspberrypi systemd[1]: Starting OpenBSD Secure Shell server...
Jun 23 15:39:52 raspberrypi sshd[578]: Server listening on 0.0.0.0 port 22.
Jun 23 15:39:52 raspberrypi sshd[578]: Server listening on :: port 22.
Jun 23 15:39:52 raspberrypi systemd[1]: Started OpenBSD Secure Shell server.
Jun 23 17:23:43 raspberrypi sshd[14533]: Invalid user admin from 192.168.0.1 port 52563
Jun 23 17:23:44 raspberrypi sshd[14533]: input_userauth_request: invalid user admin [preauth]
Jun 23 17:23:54 raspberrypi sshd[14533]: Connection closed by 192.168.0.1 port 52563 [preauth]
Jun 23 17:24:27 raspberrypi sshd[14550]: Accepted password for pi from 192.168.0.1 port 52572 ssh2
Jun 23 17:24:27 raspberrypi sshd[14550]: pam_unix(sshd:session): session opened for user pi by (uid=0)

Code : Tout sélectionner

lines 1-17/17 (END)...skipping...
● ssh.service - OpenBSD Secure Shell server
   Loaded: loaded (/lib/systemd/system/ssh.service; enabled; vendor preset: enabled)
   Active: active (running) since Sun 2019-06-23 15:39:52 CEST; 1h 47min ago
  Process: 513 ExecStartPre=/usr/sbin/sshd -t (code=exited, status=0/SUCCESS)
 Main PID: 578 (sshd)
   CGroup: /system.slice/ssh.service
           └─578 /usr/sbin/sshd -D

Jun 23 15:39:51 raspberrypi systemd[1]: Starting OpenBSD Secure Shell server...
Jun 23 15:39:52 raspberrypi sshd[578]: Server listening on 0.0.0.0 port 22.
Jun 23 15:39:52 raspberrypi sshd[578]: Server listening on :: port 22.
Jun 23 15:39:52 raspberrypi systemd[1]: Started OpenBSD Secure Shell server.
Jun 23 17:23:43 raspberrypi sshd[14533]: Invalid user admin from 192.168.0.1 port 52563
Jun 23 17:23:44 raspberrypi sshd[14533]: input_userauth_request: invalid user admin [preauth]
Jun 23 17:23:54 raspberrypi sshd[14533]: Connection closed by 192.168.0.1 port 52563 [preauth]
Jun 23 17:24:27 raspberrypi sshd[14550]: Accepted password for pi from 192.168.0.1 port 52572 ssh2
Jun 23 17:24:27 raspberrypi sshd[14550]: pam_unix(sshd:session): session opened for user pi by (uid=0)

Salutations.

Avatar de l’utilisateur
Patdec
Actif
Messages : 756
Inscription : 21 janv. 2015, 15:49
Localisation : Tournai

Re: Jeedom OK mais SSH impossible

Message par Patdec » 23 juin 2019, 19:56

mjeanne a écrit : Bonjour,

a la lecture de ce topic entier, je ne comprends pas trop ce que vous cherchez a faire. Si j'ai bien compris, vous voulez un accès SSH depuis l’extérieur de votre réseau, j'ai raison ?
C'est tout à fait exact.
mjeanne a écrit : La question qui se pose déjà, c'est alors de savoir si cela fonctionne en local, depuis votre réseau. Donc que donne une connexion SSH vers l'IP de votre jeedom sur le port 2222 que vous avez choisi ?
Avant mon départ, la connexion ssh en local fonctionnait parfaitement sur le port 22.
De mémoire, ( n'étant pas chez moi ) pour les connexions externes, j'ai réglé ma Bbox sur le port 2222. et cela à déjà fonctionné, mais ne fonctionne plus.
Je vais voir si je peux avoir accès à ma box de l'extérieur pour faire une copie de mes redirections de port.
mjeanne a écrit : Si cela ne fonctionne pas, il faut revoir les paramètre de votre ou vos parefeux et le routage dans votre réseau.
A ce niveau je n'ai rien changé sauf si un hacker est passé par là .....
mjeanne a écrit : Si cela fonctionne, il faut alors vérifier que le port 2222 est bien natté de votre box internet vers votre Jeedom.
Et enfin, il faut tester depuis l'extérieur du réseau via votre domaine. Si vous testez depuis le réseau local, il est peu probable que cela fonctionne, car les box ne gèrent pas de loopback.
De l'extérieur, je me connecte à Jeedom sans aucun problème et tout fonctionne à merveille et j'ai toutes les commandes dans _OS/DB fonctionnelles
mjeanne a écrit : Petit conseil: à la lecture de votre log HTTP, vous avez ouvert votre Jeedom au monde entier et vous avec déjà des attaques de bots. Pensez à maximiser la sécurité ! Perso je vous recommande de ne pas exposer le port 80 et de privilégier un accès via VPN, ou un filtrage d'IP.
Merci du conseil et c'est ce que j'essaie de faire depuis 15 jours en tentant de configurer Fail2ban à l'aide des tutos et commandes trouvées sur différents sites. C'est pour cela que le ssh en extérieur me serait utile plutôt que passer par Jeexplorer pour modifier les fichiers fail2ban.

Pour info, je copie de cat /etc/fail2ban/ * dans un nouveau fichier créé avec Jeexplorer vers /var/www/html puis je modifie le fichier et à partir de _OS/DB je réimporte la copie du fichier modifié avec Jeexplorer.

Fameuse gymnastique .... :roll: :roll:
Débutant Jeedom.
VirtualBox 6.0.10 sur Tablette I Works 12 sous Win 10 - Debian 9.9
Jeedom 3.3.33 - Contrôleur Aeotec ZW 090 C
Modules Fibaro FGR-222

mjeanne
Actif
Messages : 621
Inscription : 11 mars 2017, 18:36

Re: Jeedom OK mais SSH impossible

Message par mjeanne » 23 juin 2019, 20:10

Patdec a écrit :
23 juin 2019, 19:56
Avant mon départ, la connexion ssh en local fonctionnait parfaitement sur le port 22.
De mémoire, ( n'étant pas chez moi ) pour les connexions externes, j'ai réglé ma Bbox sur le port 2222. et cela à déjà fonctionné, mais ne fonctionne plus.
Je vais voir si je peux avoir accès à ma box de l'extérieur pour faire une copie de mes redirections de port.
Votre copie d'écran de ce matin 9h09 indique que SSHD écoute sur le port 2222 sur Jeedom. Donc si sur votre box vous avez mappé le port externe 2222 vers le port 22, ça ne peut pas fonctionner. Il faut soit garder le port 22 sur Jeedom et mapper ext 2222->int 22, soit garder le port 2222 sur Jeedom et mapper ext 2222->int 2222


@LuluDom : votre log indique que soit vous avez fait des erreurs de mot de passe, soit vous subissez une attaque de l'IP 58.242.83.31 (Chine) vers votre service SSH. La personne a fait 2x2 essais de mot de passe en espaçant de 2 minutes, probablement pour ne pas être détecté par fail2ban. (d’où l’intérêt dans sa conf 'jail.local' de monter le temps de détection à 30 ou 60mn)

Avatar de l’utilisateur
Patdec
Actif
Messages : 756
Inscription : 21 janv. 2015, 15:49
Localisation : Tournai

Re: Jeedom OK mais SSH impossible

Message par Patdec » 24 juin 2019, 10:54

Bonjour Mjeanne
mjeanne a écrit :
23 juin 2019, 20:10
Donc si sur votre box vous avez mappé le port externe 2222 vers le port 22, ça ne peut pas fonctionner.
Tu as mis le doigt sur le problème. En plein dans le mille. :D :D
De mémoire ( toujours), j'ai mis en Protocole TCP - Port externe début 2222 - Port externe fin 0 et Port interne 22 avec hôte interne 192.168.1.61 ( L'IP Jeedom chez moi )
mjeanne a écrit : Il faut soit garder le port 22 sur Jeedom et mapper ext 2222->int 22, soit garder le port 2222 sur Jeedom et mapper ext 2222->int 2222
J'ai donc remis le port en 22 dans /etc/ssh/sshd_config et dans /etc/fail2ban/jail.local.
Un petit sudo systemctl restart sshd et un TOUT GRAND MERCI. :D :D

il me reste à comprendre toute cette logique de port et de redirection. Cela reste encore nébuleux pour moi.
Débutant Jeedom.
VirtualBox 6.0.10 sur Tablette I Works 12 sous Win 10 - Debian 9.9
Jeedom 3.3.33 - Contrôleur Aeotec ZW 090 C
Modules Fibaro FGR-222

Avatar de l’utilisateur
Patdec
Actif
Messages : 756
Inscription : 21 janv. 2015, 15:49
Localisation : Tournai

Re: Jeedom OK mais SSH impossible

Message par Patdec » 24 juin 2019, 11:12

LuluDom a écrit :
23 juin 2019, 17:33
Je ne m'y connais pas tant que ça et donc je ne sais pas d'emblée ce que ce log veut dire, mais le voici :
Merci pour ta contribution mais mon problème n'était pas à ce niveau.
Mjeanne l'a trouvé.

Par contre, Mjeanne t'as adressé, dans sa réponse à mon message, un petit conseil.
Pour info, mais tu le sais peut-être déjà, pour augmenter le temps c'est " findtime " en secondes.
Pour 30 mn = findtime = 1800
60 mn = findtime = 3600
Débutant Jeedom.
VirtualBox 6.0.10 sur Tablette I Works 12 sous Win 10 - Debian 9.9
Jeedom 3.3.33 - Contrôleur Aeotec ZW 090 C
Modules Fibaro FGR-222

Avatar de l’utilisateur
LuluDom
Timide
Messages : 111
Inscription : 30 oct. 2017, 12:51

Re: Jeedom OK mais SSH impossible

Message par LuluDom » 29 juin 2019, 17:14

mjeanne a écrit :
23 juin 2019, 20:10
@LuluDom : votre log indique que soit vous avez fait des erreurs de mot de passe, soit vous subissez une attaque de l'IP 58.242.83.31 (Chine) vers votre service SSH. La personne a fait 2x2 essais de mot de passe en espaçant de 2 minutes, probablement pour ne pas être détecté par fail2ban. (d’où l’intérêt dans sa conf 'jail.local' de monter le temps de détection à 30 ou 60mn)

Merci ! En faisant la copie des lignes j'ai vu cette connexion bizarre. J'attendais quelques conseils. Je vais ausculter celà en suivant les vôtres.

J'ai besoin d'aide : je ne trouve pas le fichier jail.local en cherchant dans /etc/ ou dans /etc/fail2ban.

Je prend de la lecture en attendant :
https://blog.swmansion.com/limiting-fai ... da15a2313b

Je viens de refaire la commande. Il y a d'autres apparentes tentatives de connexion et même une déconnexion en première ligne. D'où celà peut venir ? J'ai un Jeedom DIY sur un vieux netbook.

Code : Tout sélectionner

jeedom@Jeedom:~$ sudo systemctl status ssh
[sudo] Mot de passe de jeedom : 
● ssh.service - OpenBSD Secure Shell server
   Loaded: loaded (/lib/systemd/system/ssh.service; enabled; vendor preset: enabled)
   Active: active (running) since Sun 2019-05-19 22:10:42 CEST; 1 months 10 days ago
 Main PID: 568 (sshd)
    Tasks: 1 (limit: 4915)
   CGroup: /system.slice/ssh.service
           └─568 /usr/sbin/sshd -D

juin 29 16:36:30 Jeedom sshd[26548]: Disconnected from 181.220.230.40 port 15115 [preauth]
juin 29 16:46:51 Jeedom sshd[10993]: pam_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh ruser= r
juin 29 16:46:53 Jeedom sshd[10993]: Failed password for root from 222.186.52.123 port 43439 ssh2
juin 29 16:46:55 Jeedom sshd[10993]: Failed password for root from 222.186.52.123 port 43439 ssh2
juin 29 16:46:58 Jeedom sshd[10993]: Failed password for root from 222.186.52.123 port 43439 ssh2
juin 29 16:46:58 Jeedom sshd[10993]: Received disconnect from 222.186.52.123 port 43439:11:  [preauth]
juin 29 16:47:39 Jeedom sshd[11939]: pam_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh ruser= r
juin 29 16:47:41 Jeedom sshd[11939]: Failed password for root from 222.186.52.123 port 50582 ssh2
juin 29 17:16:46 Jeedom sshd[27334]: Accepted password for jeedom from 192.168.0.127 port 53233 ssh2
juin 29 17:16:46 Jeedom sshd[27334]: pam_unix(sshd:session): session opened for user jeedom by (uid=0)
Et quelques minutes plus tard avec une dernière ligne aussi bizarre "Thank you for playing"

Code : Tout sélectionner

juin 29 16:46:55 Jeedom sshd[10993]: Failed password for root from 222.186.52.123 port 43439 ssh2
juin 29 16:46:58 Jeedom sshd[10993]: Failed password for root from 222.186.52.123 port 43439 ssh2
juin 29 16:46:58 Jeedom sshd[10993]: Received disconnect from 222.186.52.123 port 43439:11:  [preauth]
juin 29 16:47:39 Jeedom sshd[11939]: pam_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh ruser= rhost=222.186.52.123  user=root
juin 29 16:47:41 Jeedom sshd[11939]: Failed password for root from 222.186.52.123 port 50582 ssh2
juin 29 17:16:46 Jeedom sshd[27334]: Accepted password for jeedom from 192.168.0.127 port 53233 ssh2
juin 29 17:16:46 Jeedom sshd[27334]: pam_unix(sshd:session): session opened for user jeedom by (uid=0)
juin 29 17:21:51 Jeedom sshd[3434]: pam_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh ruser= rhost=95.77.227.74  user=root
juin 29 17:21:53 Jeedom sshd[3434]: Failed password for root from 95.77.227.74 port 47094 ssh2
juin 29 17:21:53 Jeedom sshd[3434]: Received disconnect from 95.77.227.74 port 47094:11: Normal Shutdown, Thank you for playing [preauth]
Si je comprend bien, il y a eu 113381 tentatives en 1 mois et 10 jours et 17074 bans sur mon ssh !

Code : Tout sélectionner

jeedom@Jeedom:/etc/fail2ban$ sudo systemctl status fail2ban
● fail2ban.service - Fail2Ban Service
   Loaded: loaded (/lib/systemd/system/fail2ban.service; enabled; vendor preset: enabled)
   Active: active (running) since Sun 2019-05-19 22:10:48 CEST; 1 months 10 days ago
     Docs: man:fail2ban(1)
 Main PID: 834 (fail2ban-server)
    Tasks: 3 (limit: 4915)
   CGroup: /system.slice/fail2ban.service
           └─834 /usr/bin/python3 /usr/bin/fail2ban-server -s /var/run/fail2ban/fail2ban.sock -p /var/run/fail2ban/fail2ban.pid -x -b

Warning: Journal has been rotated since unit was started. Log output is incomplete or unavailable.
jeedom@Jeedom:/etc/fail2ban$ sudo fail2ban-client status sshd
Status for the jail: sshd
|- Filter
|  |- Currently failed: 1
|  |- Total failed:     113381
|  `- File list:        /var/log/auth.log
`- Actions
   |- Currently banned: 0
   |- Total banned:     17074
   `- Banned IP list:
jeedom@Jeedom:/etc/fail2ban$

Avatar de l’utilisateur
Patdec
Actif
Messages : 756
Inscription : 21 janv. 2015, 15:49
Localisation : Tournai

Re: Jeedom OK mais SSH impossible

Message par Patdec » 30 juin 2019, 22:21

LuluDom a écrit :
29 juin 2019, 17:14
J'ai besoin d'aide : je ne trouve pas le fichier jail.local en cherchant dans /etc/ ou dans /etc/fail2ban.
C'est normal, le fichier jail.local est un fichier que tu dois créer à partir de jail.conf
sudo cp /etc/fail2ban/jail.conf /etc/fail2ban/jail.local

Ainsi ton jail.conf reste intact et tu ne modifie que jail.local
Lors d'un update tes paramètres jail.local serons conservés puisque l'update ne sera fait que sur le .conf

Sur le lien que tu indiques, ils mentionnent de ne reprendre dans jail.local que les modifications apportées à jail.conf.
Un autre site sur lequel je m'étais basé, ne le mentionnait pas.
Débutant Jeedom.
VirtualBox 6.0.10 sur Tablette I Works 12 sous Win 10 - Debian 9.9
Jeedom 3.3.33 - Contrôleur Aeotec ZW 090 C
Modules Fibaro FGR-222

Avatar de l’utilisateur
LuluDom
Timide
Messages : 111
Inscription : 30 oct. 2017, 12:51

Re: Jeedom OK mais SSH impossible

Message par LuluDom » 01 juil. 2019, 23:52

Patdec a écrit :
30 juin 2019, 22:21
LuluDom a écrit :
29 juin 2019, 17:14
J'ai besoin d'aide : je ne trouve pas le fichier jail.local en cherchant dans /etc/ ou dans /etc/fail2ban.
C'est normal, le fichier jail.local est un fichier que tu dois créer à partir de jail.conf
sudo cp /etc/fail2ban/jail.conf /etc/fail2ban/jail.local

Ainsi ton jail.conf reste intact et tu ne modifie que jail.local
Lors d'un update tes paramètres jail.local serons conservés puisque l'update ne sera fait que sur le .conf

Sur le lien que tu indiques, ils mentionnent de ne reprendre dans jail.local que les modifications apportées à jail.conf.
Un autre site sur lequel je m'étais basé, ne le mentionnait pas.

Merci, c'est ce que je m'étais hasardé à faire avant ton message.

Répondre

Revenir vers « Discussions Générales »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 2 invités