Ce Forum passera en lecture seule en janvier 2020
Image
Merci de vous rendre sur https://community.jeedom.com maintenant pour vos prochains postes ;)

Jeedom/Apache down après installation Conbee/Phoscon

gfx54
Timide
Messages : 5
Inscription : 20 févr. 2018, 21:30

Jeedom/Apache down après installation Conbee/Phoscon

Message par gfx54 » 02 déc. 2019, 23:18

Bonjour à tous,

Je m'adresse à vous après plusieurs heures de recherches, et je suis un peu désespéré.

Je possède un Jeedom sur RPI3 avec RFXCom et dongle Zwave GEN5, le tout sur SSD.
Tout tournait au poil, chauffage(Zwave), Lumière, Guirlande (433MHz) etc.

J'ai fait l'acquisition d'un dongle Zigbee Conbee II et j'ai tenté ce soir de l'installer.
Outre le fait que le plugin Deconz n'existe plus sur le market (j'ai mis du temps à comprendre que je devais utiliser RaspBee).

En cherchant un peu partout, je me rend compte qu'il faut installer un genre de nouveau site web via des lignes de commandes, afin de pouvoir configurer la clé Conbee et les futurs devices Zigbee.

Je me lance donc dans l'install en ligne de commande trouvé quelque part sur Internet.
$ wget http://deconz.dresden-elektronik.de/ras ... t-beta.deb
sudo dpkg -i deconz-latest-beta.deb
sudo apt install -f

et là c'est parti en vrille.

A la fin de l'install, lorsque je tente de retourner dans Jeedom pour paramétrer le plugin RaspBee, je me rends compte que mon Jeedom est injoignable.
Par contre à la place, je parviens bien à joindre l'appli Phoscon App (http://192.168.1.35/pwa/login.html)

Et depuis, c'est un peu panique à bord, parceque j'ai l'impression que l'installation du site web Phoscon App, a remplacé celle de Jeedom.

Etant un débutant en Apache / Linux et cie, je ne sais pas comment dire à Apache que le site web par défaut (Port 80) est Jeedom et non Phoscon.

Je pense avoir trouvé la raison pourquoi Apache ne veut plus se lancer, il semblerait qu'il y ai un autre truc qui écoute sur le port 80.
En bidouillant, j'ai réussi à relancer Apache sur le port 448, mais moi je souhaite qu'il revienne sur le 80.


Dans mon fichier /etc/apache2/ports.conf :
GNU nano 2.7.4 File: /etc/apache2/ports.conf

# If you just change the port or add more ports here, you will likely also
# have to change the VirtualHost statement in
# /etc/apache2/sites-enabled/000-default.conf

#Listen 80
Listen 448
<IfModule ssl_module>
Listen 443
</IfModule>

<IfModule mod_gnutls.c>
Listen 443
</IfModule>

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet


J'ai réussi à retrouver mon Jeedom en ajoutant un autre port d'écoute 448, mais plus rien n'est fonctionnel (Daemon RFXCom NOK et Daemon Zwave NOK).

Dans : /etc/apache2/sites-enabled/000-default.conf j'ai :

<VirtualHost *:80>
ServerAdmin webmaster@localhost
DocumentRoot /var/www/html
ErrorLog /var/www/html/log/http.error
</VirtualHost>

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet



Je pense que mon problème ne se situe pas dans Jeedom, mais dans Apache mais...j'avoue ne pas savoir quoi faire.

Plusieurs remarques :
- J'ai pas de backup du système, j'ai uniquement des backups de Jeedom (Dans mon cas, une restore n'a servi à rien)
- Je vais monter un 2ème RPI avec juste cette m**** de Phoscon à part, comme ça plus de soucis.
- J'espère que mon post est au bon endroit sur le forum.


Merci pour votre aide précieuse,
Pièces jointes
Jeedom-Netstat.PNG
Jeedom-Netstat.PNG (28.41 Kio) Consulté 49 fois

Répondre

Revenir vers « Raspberry Pi »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 0 invité